Ableton 8 und Latenz Probleme

Dieses Thema im Forum "DAW / Komposition" wurde erstellt von Steven Hachel, 11. Mai 2010.

  1. Steven Hachel

    Steven Hachel bin angekommen

    Hallo,

    ich habe mich mal wieder an Ableton Live versucht und wieder nen ganzen tag damit verbracht, ein Latenzfreies Arrangement hin zu bekommen.
    Folgendes habe ich versucht...

    Habe zB. meine Jomox als Externes Instrument eingebunden und spiele darüber zB. eine Bassdrum in nem simplen 4/4 Takt.
    zudem habe ich, keine Ahung ob meine herangehensweise da korrekt ist, eine einfache Midi Spur eröffnet, worüber ich die Snaredrum der Jomox spielen möchte.

    Nun mein Wundern... Sobald ich die Snaredrum über diesen sepparaten Midikanal spiele, ist die nicht gleich von der Sync her zu meiner Basssdrum...?
    Dümpelt immer hinterher. Selten isse genau im takt. Wie kommt sowas? Ich weiss, dass die Noten physikalisch durch das selbe Midikabel müssen, aber dass nicht ein einziger Takt sync zu der Bassdrum spielt ist sehr komisch. hingegen funzt es aber, wenn ich über den Kanal des Extern eingebunden Instruments (Jomox) die Snaredrum spiele korrekt, sowie, wenn ich die Bassdrum halt über die eigene Midi Spur spiele, worin sich die SD befindet. naja.. ab und ann hakelt das.

    Hatt mich damals schon mit Live 7 versucht, aber aufgegeben. Kann es mit dem Mididevice zusammen hängen? nutze da das Midex 8.

    Unter Cubase, wollt ich noch anmerken, habe ich NULL Latenz probleme. Egal wieviele Midikanäle ich nutze und wieviele Noten ich über ein Kabel zu einem Instrument jage.

    Arbeite auf einem Dual Kern System, 4 GB und WinXP 32 Bit und ja, ich weiss, dass WinXP nur 3GB verwalten kann. :)

    Evtl. hat da einer nen Tip für mich oder sagt gleich, dass Ableton für ein Hardware Setup nichts taugt. Das würde mir das ganze gebastel ersparen.

    viele Grüße
    Steven
     
  2. Zolo

    Zolo Tach

    Bei mir läuft das absolut tight in Ableton... Selbst wenn ich Audio im Live und extenere Klangerzeuger nehme.

    Aber du scheinst noch nicht viel Ahnung davon zu haben, denn von den wichtigsten Punkten verlierst du kein Wort: Die Latenzeinstellungen der Soundkarte, Treibereinstellungen der Soundkarte usw.

    Es gibt im Ableton ein inaktives Tutorial wo das erklärt wird. Die Tutorials findet man im Hilfe Menue oben.

    Wenn man MIdi und Soundkarten Output gesynct haben will (bei Cubase lief das nie wirklich tight bei mir) sollte man den tatsächlichen Latenz ausgleich messen lassen - aber das steht alles im Tutorial.

    Ansonsten hätte ein Blick in die Anleitung womöglich geholfen ;-)

    Viel glück
    Zolo
     
  3. Steven Hachel

    Steven Hachel bin angekommen

    Hey Zolo,

    Ahnung hin oder her. Noch zur Info: habe die Jomox jetzt zweimal als externes Instrument angelegt. Einmal für die BD und einmal für die SD. Beide haben jeweils verschiedene Audioausgänge und wurden auch dementsprechen im Multiface geroutet.
    Nun frage ich mich, was ich denn da an dem Programm einstellen soll, damit beide Noten auch gleich zur und von der Jomox gesendet und in der Soundkarte verarbeitet bis zu meinem Ohr gleich ankommen? Da ist doch wat faul, oder irre ich mich da?

    Arbeite mit einer RME Mutliface Karte. Eingestellt auf eine BufferSize von 256(6ms).

    Eingangslatenz der Soundkarte unter ABL ist 6.53 ms und Ausgangslatenz 7.26. Treiberkompension ist demzufolge auf -607 Smp gestellt ergibt folglich eine Globale Latenz von 0.02 ms. Alles sowieso nur theoretisch.

    ABer dieses wird so und so nicht mein Problem lösen, da es ja ein ganz anderes ist, nämlich, wenn ich mich wiederholen darf, dass zwei im gleichen Takt versendete Noten Zeitversetzt auf meinem System ankommen.

    Bitte um Hilfe, wenn es machbar ist und keine Sprüche von, ich hab keine Ahnung und der Gleichen. SOlch Töne bin hier hier nicht gewohnt. ^^

    viele Grüße
    Steven
     
  4. Zolo

    Zolo Tach

    Achsoo dann hab ich dich falsch verstanden. Dachte du wüßtest nicht mal was Latenz ist (kommt ja häufig vor).

    Also wenn 2 gleichzeitig gesendete Noten nicht ankommen, klingt das für mich aber nicht nach einem Latenz Problem sondern ein Problem deines Midi Interfaces ? Aber ich verstehe womöglich nicht genau was dein Problem ist. Vielleicht andere eher als ich...

    Gruß Zolo
     
  5. Steven Hachel

    Steven Hachel bin angekommen

    Jau, du hast es richtig verstanden. habe mich wohl etwas dämlich ausgedrückt und/oder zuviel des guten beschrieben.

    Es kann dann nur an dem Midiinterface liegen, wenn die beiden Noten aus dem selben Gerät unteschiedlich an- und / oder von dem Gerät kommen. Werde die Jomox mal an die RME Karte stecken. Evtl. funzt das besser. Wäre nur Schade, wenn ich das MIDEX aufgeben müsste, da es unter Cubase SX super funzt.

    viele Grüße
    Steven
     
  6. freidimensional

    freidimensional Tastenirrtuose

    Hi steven,

    wie siehts denn aus wenn Du die Snare nicht über nen separaten, sondern gleichzeitig über den gleichen Midichannel wie die BD anspielst? falls das geht? Kenne mich mit Deinem Gerät leider nicht aus, aber viele Drummies können doch z.B. über einen Channel angespielt werden, und haben dann die verschiedenen Instrumente auf verschiedenen Noten liegen...z.B. kick auf C1, Snare auf Cis 1 usw...Du kannst dann ja trotzdem der Snare nen separaten Audioeingang zuweisen im Ableton, um diese dann separat mit EQ oder weiss ich was zu bearbeiten...Dafür bräuchtest Du die dann nicht zweimal als External instrument einzubinden, sondern nur einmal für die Midiansteuerung. Für die Einzelausgänge (Snare, Hihat etc) bräuchtest Du dann nur jeweils neue Audiokanäle aufmachen.
    Ansonsten ist das schon komisch, hatte ausser mit der Machinedrum (und das lag eindeutig am selbigen Gerät) noch nie Probs beim ansteuern externer Hardware.

    grüße & viel Erfolg
     
  7. mokkinger

    mokkinger Tach

    ich wüste auch keinen wirklichen grund warum ich mehrere midiclips haben woltle für ein und den selben drumcomp; pack die noten in einen clip und schau ob es dann tight läuft - falls ja wirds wohl am midiinterface/treiber liegen, auch wenns merkwürdig klingt.

    hast du die einzelnen clips solo getestet? funktioniert das tight zum live-metronom?
    ich hatte auch schon das problem dass ein extra für den zweck angeschafftes midiinterface nicht mit dem midi-out meiner soundcard zusammen spielen wollte, und das obwohl beide von motu sind...

    was du auch noch unbedingt checken solltest ist ob irgendeines deiner externen geräte die mididaten durchschleift und wieder zurück sendet. das hat bei mir mal zu sehr merkwürdigen ergebnissen geführt, da läuft dann irgendwann alles auseinander...
     
  8. Steven Hachel

    Steven Hachel bin angekommen

    Sooo, liebe Leute.
    Habe das eben in einem Clip laufen gehabt, und dort lübbt se synch. Is schon komisch, oder?
    Hmmm... Bei ausgeschalteter Latenzkompensation läuft der in dem seppareten Midichannel fast synch.

    ABL muss das intern irgendwie anderes behandeln, sobald da ne eigen MIDI Spur + Externes Gerät involviert ist, anders kann ichs mir nicht erklären.
    Wie gesagt, ich schaue nochmal zwecks RME Midiinterface. Kam da leider noch nicht zu. Wollt erstmal alles getestet haben. ^^

    Vielen Dank für eure Tipps. Ich denke, ich komme dem ganzen etwas Näher. :) Wäre schön, wenn ich nun auch ABL nutzen könnt, ohne dieses geier.

    viele Grüße
    Steven
     
  9. gourmet

    gourmet Tach

    Hast du auf der snarespur vll ein verzögernden Effekt drauf? :sad: bei mir hat ich mal das gefühl das ein comp verzögerte aber ich red wahrscheinlich wieder mist :)
     
  10. Steven Hachel

    Steven Hachel bin angekommen

    @gourmet

    Nein, ist eine reine MIDI Spur. Werde mich die Tage nochmal davor setzen und alles durch testen.
    Frage mich nur, warum es schlimmer wird, wenn die Latenzkompensation eingeschaltet ist. Da habe ich wohl etwas nicht verstanden. ^^

    viele Grüße und vielen Dank
    Steven
     
  11. Zolo

    Zolo Tach

    Ein Bug ? Welche Version nutzt du überhaupt ?
     
  12. Steven Hachel

    Steven Hachel bin angekommen

    Hey zolo,

    also ich nutze die aktuelle Version. Die 8.1.3. Ich bin hier grad noch ein wenig am optimieren.
    Komplett neues Projekt aufgesetzt. Nutze jetzt nur noch die Midi SPuren und lasse das "Externe Instrumenten" Gedöhns außen vor.

    Es klingt schonmal besser als zuvor. Ich werde die Tage das Ding um einige Spuren erweitern. Mal schauen, wie es sich weiter verhält.

    viele vielen Dank für eure Antworten und Ideen.

    viele Grüße
    Steven
     
  13. also ableton ist ohnehin nicht der kracher:

    Ableton 8 Stereo Spuren bei 24 bit 96 khz Latenz 10 ms 40 % CPU
    Sonar 8,5 32 Stereo Spuren bei 24 bit 48 khz Latenz 5 ms 20 - 30% CPU
    Cubase SX 3 32 Spuren bei 24 bit 96 khz Latenz 10 ms, routing auf mehere ADAT Ausgänge plus 32 MIDI Spuren macht: 15 - 22 % CPU

    Mit einer RME Hammerfall 9652 und ASIO, Rechner: 2x XEON 2,66 Ghz CPU, U320 SCSI Platte und 1 GB RAM

    Also Ableton verbraucht mir einfach zu viel Power, was aber auch sofort aufällt wenn die Oberfläche gestartet wird. Cubase 5 ist vergleichsweise Leistungshungrig. Das beste Program bleibt für mich immernoch Cubase SX 3, super schlank, super schnell und macht was es soll. mehr brauch man nicht, oder?

    OK, Sonar ist eigentlich auch OK, verbraucht aber auch mehr Power als Cubase, ausserdem kackt es manchmal ab und verursacht knackser in der Aufnahme, ausserdem komme ich mit dem MIDI Editor nicht zurecht. Um es freundlich auszudrücken, der MIDI Editor von Sonar kotzt mich an, genauso wie die das Editiren in der Spuransicht. Ableton ist zwar cool weil man schon seine Pattern organisieren kann, aber kommey, das Ding ist mehr ein Spielzeug als ein Werkzeug.

    Ich habe auch unter Linux mit meheren Programmen eine DAW eingerichgetet, funktioniert auch ganz gut... Aber irgendwie klappt der Dual screen unter Linux nicht, deswegen benutze ich doch Cubase SX und Windows.
     
  14. Zolo

    Zolo Tach

    Haha sorry aber das ist doch Bullshit :mrgreen: Versuchs mal mit der Orginalsoftware :roll:
     
  15. was für originalsoftware

    Ich habe von allen Programmen die Trials runter geladen. oder glaubst du etwa im ernst das ich in de laden renne 600 € für ne software hinlege die ich dann nicht mehr zurück geben kann wenn sie mir nicht gefällt. Ich bleibe bei Cubase SX 3 und sobald ich es mit dem Dual Screen mit Linux auf die Reihe bekommen habe benutze ich wieder Ardour, was sogar von der Performance her noch besser als Cubase ist.


    :lol:
     
  16. Steven Hachel

    Steven Hachel bin angekommen

    der war gut, aber ich kann aber auch nur bestätigen, dass Live mehr Ressourcen frist, als mein ORIGINAL Cubase. ^^

    Meine Latenz ist nach einigen Einstellungen etwas besser geworden. Mich nervts halt nur, dass ich für jeden Synth die Latenzen anpassen muss. Jeder reagiert unter Live zeitlich etwas unterschiedlich, was das Abfeuern der Midinoten betrifft.

    Na mal schauen, evtl. gewöhne ich mich ja daran. Nutze es jedenfalls immer öfter, aber weiterhin nutze ich für längere Sessions mein Cubase, da ich damit keine Latenz Probleme habe.
     

Diese Seite empfehlen