Ableton und Midi Clock

Dieses Thema im Forum "mit Sequencer" wurde erstellt von Jones, 12. Juli 2007.

  1. Jones

    Jones Tach

    Erstmal Hi,
    bin neu hier im Forum, hab den Tipp zu dem Forum hier von jemandem im Korg Forum bekommen.

    Natürlich hab ich auch ein Problem :D für das ich keine Lösung finde deswegen wollte ich euch fragen.

    Zuerstmal meine Ausrüstung

    iMac G5 1,9 Ghz, OS 10.4.10
    Korg Electribe R-1 MKII
    Evolution MK- 425C Keyboard
    und meine neueste Erungenschaft ein:
    Alesis IO|2

    Ich nutze Ableton und versuche über das Alesis meine Electribe zu syncen.
    Hab alles soweit eingestellt so das Ableton als Master läuft. Um dann die Latenz des Metronom Clicks von Ableton mit der Synchronisierten Electribe auszugleichen hab ich die Verzögerung der Midi Clock im Ableton Menü eingestellt auf -59 ms. Das ist schon meine erste Frage, dieser Wert ist der normal oder übermässig hoch?
    Wenn ich dann diese Konstelation so laufen lass und mehreremale aufnehme dann seh ich an den Taktstrichen das der Beat manachmal vor dem Takt strich manchmal bisschen dahinter liegt, das muss doch immer 100% exakt passen oder?
    Problem Nr. 3 ist: Wenn ich die Start-Taste von Ableton drück und die Electribe anfängt zu spielen stimmt der aller erste Schlag der Electribe nicht mit dem Metronomklick überein, erst die dahinterfolgenden passen. Woran liegt das?
    und mein letztes Problem ist: Lasse ich Ableton als Slave und die Electribe als Master laufen (mit eingestellter Midi Clock Verzögerung in den Einstellungen von Ableton) und ich schalt mein Keyboard an oder aus schmeissts mir die ganzen Einstellungen der Midi Verzögerung wieder raus, wieso den das nun wieder?

    Sorry wenn ich zum Einstand gleich soviel Fragen mitbring aber mir brennts echt unter den Nägeln, hab nur ne 30 tage Geldzurückgarantie bei Thomann, wenns bis dahin nicht läuft werd ichs wieder abtreten müssen.
    Außer ihr könnt mir sagen was da schief läuft oder obs normal ist.



    Grüße Jones :D
     
  2. die Timingvariation der Beats ist voellig normal - das der erste Beat nicht passt auch - diese grosse Verzoegerung bei dieser Art von Interfaces wohl auch
     
  3. Feinstrom

    Feinstrom aktiv

    Keine Ahnung, aber
    :hallo:

    Schöne Grüße,
    Bert
     
  4. dstroy

    dstroy Tach

    Liegt am Interface, normal habe ich mit meiner M-Audio Karte 12 ms

    Nimm auf alle fälle Ableton als Master, die Electribes haben eine schlechte Midi Clock. (ALLE)

    Hast du vieleicht SWING Einstellungen im tribe oder in Ableton gesetzt ?
     
  5. Jones

    Jones Tach

    Hehe, danke =)

    Swing ist bei Ableton genauso wie an der Electribe aus...

    Also wenn ich Ableton als master nehme und die Electribe zu nem Midi Kanal route und damit n midi schlagzeug ansteuer brauch ich ca. 33 ms verzögerung bis das Ableton metronom ziemlich genau auf den Beat passt.
    Nehm ich die Electribe als Audio spur auf brauch ich bei der Midi Clock verzögerung ca. 66 ms.


    d.h. wenn ich Audio und dann mal wieder Midi aufnehm muss ich andauernd die Einstellungen ändern, das is doch zum kotzen. Mal davon abgesehen das vor zwei drei stunden noch 47 ms verzögerung bei audio perfekt waren, warum zur Hölle ändert sich das laufend, gibts doch nicht...


    Wenns wirklich am Interface liegen sollte muss ich mir wohl um ein neus schauen...

    gruß jon
     
  6. Anonymous

    Anonymous Guest

    drei-vier allgemeine Dinge von mir dazu:

    Die Clock von Ableton scheint bei schnelleren Computern genauer/konstanter zu laufen, das ist meine Erfahrung mit bisher 3 Laptops mit Ableton...

    Electribe mit PC Syncen , von dem hab ich nie was gutes gehört...
    Frag mal Kobayashi

    Ich habe heute mit meiner Machinedrum bzw. der TR 808 3 oder 8ms und v.a (und das ist das wichtigste) passen die Kicks auf jedem Schlag "tupfgenau" überrein, alles andere ist für beatlastige Musik unbrauchbar (ausser man nimmt immer wieder auf und korrigiert dann das Audiofile), da z.B die Snare und der Kick genau passen müssen...

    Und sehr wichtig bei der Ableton Aufnahme, Monitor muss auf OFF sein, nur so wird deine Aufnahme angepasst (das heisst sie wird soviel wie deine Audio-Einganslatenz ist, nach vorne geschoben)
     
  7. genau

    das Dumme daran ist, das man dann bei der Aufname nicht hoert was man da so aufnimmt

    also hab ich mir einen Kanal zum aufnemen erstellt (monitor off) und einen zum hoeren (monitor in)

    via Crossfader kann ich dann zwischen aufgenommener Spur und der aktuellen umschalten/faden
     
  8. Anonymous

    Anonymous Guest

    ich höre da entweder am Mischpult (also bevor es in den Computer geht) ab oder falls das Instrument direkt an meiner Soundkarte ist, schraube ich den gewünschten Eingangs-Kanal am Fireface-Mixer einfach hoch, so geht der Sound auch direkt wieder raus.

    Scheinbar hat da jeder seine Methoden ;-)
     
  9. moondust

    moondust bin angekommen

    ich habe die clocks von ableton mal getestet.
    habe version 4 mit 5 und 6 verglichen
    jehöher die versoin ist desdo mehr diverenzen im timing gibt es . interface ist auch immer ein facktor.
    für ne stabile clock würde ic hdir auf dem mac dieses programm empfehlen
    http://www.grantedsw.com/midiclock/
     
  10. milesahead

    milesahead Tach

    du meinst also ableton live 4 war besser als 5 - und die wieder besser als 6 - das wäre ja der hammer !!
    würde heissen, umsomehr midi-implementationen - umso mehr probleme mit der clock ....

    und zum zweiten:
    funktinoiert das auch mit hard/soft - ware gemischt.

    ich weiss zwar dass midiclock auf dem mac 2 rechner mit midi-software synchen kann,
    aber dass das auch mit hardware funktioniert ...
    muss ich gleich mal ausprobieren.
    denn, wenn ich meine patterns der electribe in ableton live aufzeichnen will, habe ich auch diese verschiebung, egal wie ich die latenz einstelle,
    hingegen - wenn ich beide zusammen laufen lasse , bei meinem live-act hab ich`s so (ableton im slave) dann klappts bestens.
     
  11. moondust

    moondust bin angekommen

    :hallo:
    hier im forum
    wenn du mal noch ne frage hast ich bin ja auch in zürich zuhause . da könne wir ja auch mal testen . ihc bin etwas müde und schnall gerade nicht so was du meinst.
    das mit dem versionen , ist eingendlich klar.
    je höre die version ist ,des do mehr wird warscheinlich im hintergrund laufen, und so kann der rechner die clock nicht so genau wieder geben . hingen das kleine clock programm macht ja nix anderes. als click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. click.. (das waren 500bpm :mrgreen: )
     
  12. e6o5

    e6o5 Tach

    Keine Ahnung wie Ableton programmiert, aber ich habe daran meine Zweifel, ob das stimmt.
     
  13. Anonymous

    Anonymous Guest

    Die Electribes senden MidiClock an Ableton Live, wenn Live im Slave Modus ist!
    Auch alle deine Electribes und deine MPC laufen nur danke MidiClock Synchron...

    Und ja, natürlich muss das Zeugs irgendwie zusammenlaufen mit einer MidiClock, sonst stimmt eine Aufnahme natürlich nie... Das Zeug läuft ja nicht automatisch durch die Luft Synchron?!? Oder was meinst du mit "nicht zusammenlaufen" und dann eine verschobene Aufnahme haben?

    Verschiebungen durch die Einganzslatenz bleiben vorhanden, wenn wie schon oben erwähnt, bei einer Aufnahme Monitor auf ON bzw Auto ist. Das kann je nachdem sogar gewünscht sein. Wenn z.b über Ableton Live abgehört wird, der Sync so eingestellt wurde, dass es so stimmt, dann kann man Monitor auf ON lassen...

    Diese Unterschiede in der Clock zwischen live 4 und 6 bezweifle ich...
     
  14. dest4b

    dest4b Tach

    oooch ich hab auch schon gaaanz furchtbare dinge mit der clock von notebooks festgestellt... obs nun an ableton hing oder nicht .. kann ich nicht sagen .. da wir nur ableton hatten. Es gibt geräte die mit hardware zusammen nur rumeiern, egal welches interface.

    aber selbst bei notebooks bei denen das Timing "stabil" ist, bau ich einmal diesen beatrepeat oder andere delay granulardingens oder so ein und das komplette timing ist nicht mehr zur Hardwaregeräten synchron. ( klaar verzögert ein delay .. aber ich meine unsynchron im bezug auf erst ein 16tel hinten drann .. dann ein achtel vornedran .. usw... )

    iss mir früher nie aufgefallen, da ich noch keine hardware hatte ;-)

    nuja.
     
  15. ist das genau ein 16tel oder 8tel? sonst wuerde ich vermuten das einfach die Midi-Clock durch CPU Last staerker jittert - ein leider normaler Effekt - bei USB/Firewire Midi Interfaces leider viel staerker als bei den guten alten seriellen oder die von PCI-Audiointerfaces
     
  16. dest4b

    dest4b Tach

    ja das jittert.. aber wo ist denn da der sinn des ganzen? ist der sinn von externer midi synchronisation nicht das es extern synchronisiert ?! was bringt uns die ganze technik ? !

    ob es sich genau um ne sechzentel hanelt .. es läuft halt von offbeat bis tight alles mal durch. dann einmal stopp und es passt nicht ganz dann passts und 5 takte später wieder offbeat.

    kommt aber auf das notebook an .. ich denk mal auch rechenleistung. aber bestimmt auch auf das interface. mit seriell kann ich nicht viel zu sagen.
    ich verwende das edirol fa101 mit firewire. und da sind es wie gesagt sogar eigentlich nur die ableton internen dinger wie beatrepeat die mein notebook dann echt ausm sync hauen. satndalone mert man das gar nicht wirklich.
     
  17. achso dein Notebook wird von externer Hardware gesynct

    damit hab ich wenig Erfahrung und bisher war mir ein versatz nicht aufgefallen - hab aber auch nicht drauf geachtet

    aber ich hab mit dem Firewire Interface am Notebook auch extreme Probleme - koennte mir schon vorstellen das System in stocken geraet

    daher setz ich auch weiterhin auf meinen desktop Rechner mit PCI
     
  18. dest4b

    dest4b Tach

    wobei die richtung egal ist... exrtern -> notebook oder notebook -> extern.
    mir sind beim multrack recording via ADAT an meinem grossen rechner auch schon so sachen aufgefallen an einem tag passte es mit 7ms midi latenz .. an m nächsten tag waren es -3 ms latenz...

    es scheint für mich wirklich was mit der internen latenzkompensation von ableton zu tun zu haben. Wie gesagt es kommt ganz arg auf die plugins an ..
    wenn ich zb "glitch" verwende ( freeware beatzerpflücker ) dann habe ich keine probleme nehme ich jedoch beatrepeat ( der ja eigentlich nichts im vergleich mit glitch macht ) ist es unsynchron.
    aber auch nicht immer.. naja ..
    Ein freund hatte sein notebook mal dabei und hat in ableton als sync ausgänge das audiointerface und alles andere angehakt. Da ging dann gar nichts, denn da war das Microsoft virtual Midi GM dingens auch dabei.
    und sobald dieses nicht mehr ausgewählt war lief sein notebook recht ok .. bis zum ersten beatrepeat. Ich denke auch gerade diese sache mit dem virtual midi teil .. weist für mich auf die interne latenzkompensation hin.
    und die scheint echt nur bei interner verwendung zu funktionieren bei externem gear scheint sie nur zu schlimzuverbessern.

    r.
     
  19. ja die interne latenzkompensation ist mir auch schon negativ aufgefallen bei verwendung von UAD plugins arbeitet die auch wenn sie ausgeschaltet sind :evil:
     
  20. Anonymous

    Anonymous Guest

    Zu diesem Beatrepeat Zeugs kann ich leider auch nichts gross sagen, ich benutze den zwar, aber zu dem Zeitpunkt habe ich meine Hardware meist wieder weg und schon zu Audio verwandelt...
    Das werd ich mal testen!!!

    Versätze hatte ich auch schon, Stop und wieder Start und dann stimmts, wieso ich die Versätze hatte weiss ich jetzt auch nicht... Live wäre sowas ziemlich übel... Aber bspw. Rob Acid hat es auch geschafft, dass seine TB 303 und seine Machinedrum mit Ableton Live während 1.5 Studen Perfekt im Sync waren...

    Zur Konstantheit bzw rumeiern der Clock: die MD im Slave Modus, hat ja eine Beat-Anzeige(es zeigt mir die externe reinkommende MidiClock Geschwindigkeit an), mit meinen zwei alten Laptops schwankte das schon sehr, mit meinem neueren Laptop schwankt das nur noch um 10tel oder so... Ich kann ehrlich nicht genau sagen, an was es liegt, aber nach meiner Vermutung liegt es an der Geschwindigkeit der Laptops.
    Durch das schwanken konnte ich dann eigentlich nicht wirklich gleichzeitig Perkussionen vom Laptop und von der Machinedrum spielen, heute kann ich das...
     
  21. dest4b

    dest4b Tach

    ja genau das hab ich auch festgestellt.. mein notebook P4 2,66 Ghz 1Gb ram AtiRadeon 7500 und firewire FA101 .. da läuft es recht gut..
    bis auf einige plugins die nichtmal wirklich CPu ziehen .. aber die bremsen die clock. bei "noch" langsameren notebooks ist das noch viel schlimmer.
    ein schnelleres hab ich leider nicht ;-)
     
  22. an meinem Desktop PC mit seriellem Midi Interface eiert die clock so im bereich von -0.2 bis 0.2 - finde ich eigentlcih recht heftig - aber hoeren tue ichs nicht
     
  23. von meinem Laptop fang ich gar nicht an - ist'n ziemlich langsames
     
  24. Anonymous

    Anonymous Guest

    Problem, Problem:

    = Die clock von ableton hat "gerumpelt " ....... ????




    folgendes:
    habe mit ACA ne Jam gemacht,
    und dabei ableton eigentlich das erste mal benutzt.


    Ableton 5 auf Notebook mit 2,5Ghz Gericom ( das alte von Scaff ) und RME Multiface I.
    Auch midi raus über die RME. ( auch die quasi das erste mal benutzt ( vor allem Midi ))

    In ableton haben wir das Audio auf ner stereo spur aufgenommen,
    und es liefen 4 einfache midi spuren um 4 gate/ clock spuren zu erzeugen über das MCV24.
    D.h. man kann sich die Mididaten wie 4x nen Metronomtrack vorstellen.
    Sonst lief nichts !
    Kein Plugin, keine Audio spur.
    Systemauslastung war bei 1%.


    Problem:
    Die Aufnahme "rumpelt" teilweise im Timing.
    D.h. es gibt da ziwischendurch stellen wo einfach Schläge massiv verzögert kommen,
    und zwar auf allen spuren.


    Hat jemand ne Idee worans liegen kann :?:




    Wenn ich den Thread hier und andere zuvor revue passieren lasse,
    dann scheinen einige Leute Probleme mit ableton auf'm notebook zu haben.
    Speziell bezüglich clock und knacksern.
    Im weitern musste ich die Latenz auf 2048 Samples stellen um keine knackser zu haben.
    D.h. ich habe den Käse auch noch.........

    ( ach ja: ACA hat ableton bedient.
    Er ist erfahren damit, hats aber selber auf dem Mac )
     
  25. Anonymous

    Anonymous Guest

    Ich kann deine Erfahrungen nicht bestätigen. Ich hatte noch nie Probleme mit der Clock von Live. An deiner Stelle wende dich doch einfach an den Support von Ableton. Die helfen sehr gut!
     
  26. Bernett

    Bernett Tach

    also ich muß sagen auf meinem desktop hab ich keine probleme nur wenn ich dies mit dem labi laufen lass gibts große probleme. da stell ich dann z.b. meine tribe auf master und lass ableton als slave laufen.
     
  27. mops

    mops Tach

    zum syncen von life mit externer hardware mußt du bei live in die midisettings, danach den midi-input (mit dem gesynct wird) in live wählen, das kleine dreieck daneben öffnen (WIRD SEHR OFT ÜBERSEHEN, habe schon 2 jahre mit live gearbeitet, ohne davon zu wissen...)
    da kannst du dann die latenz ausgleichen in ms...

    ich synce die mpc1k mit live so:
    gesynct per midiclock, beide geräte im playmodus mit jeweils dem metronom an. danach in die midiclock einstellung und ms-latenz anpassen, bis beide metronom sounds übereinander liegen

    macht bei mir mit einem lifebook (1,7ghz centrino)+rme multiface in etwa 26ms aus.

    danach perfekt in sync!
     
  28. x-deio

    x-deio Tach

    Hallo,


    ich habe Timingschwankungen (Ableton Live) in Verbindung mit einem externem Hardware Step-Sequenzer (Döpfer MAQ 16/3).
    Live ist Master. Der MAQ 16/3 startet auch gleichzeitig, aber die Noten kommen irgendwie leicht versetzt.
    Man hört es, und bei der Aufnahme sieht man das gut im Matrix/Noten-Editor.
    Wenn ich das ganze in Logic aufnehme, dann sitzen die Noten perfekt !?

    Liegt das nun an Live oder am Interface oder an Lives Clock ?

    Ableton Support sagen es läge am MIDI-Interface.
    Ich meine hier nicht die Audio-Latenz, sondern wirklich nur die in Live eintreffenden MIDI-Noten.

    Logic Pro 7.1.1
    Ableton Live 6.0.10
    Power Mac G 5 - OS X 10.4.10 - Dual 2 GHz / 2,5 GB RAM
    MIDI-Interface: Emagic Unitor 8 MKII
    Audio-Interface: Digidesign DIGI RACK 002
     
  29. Anonymous

    Anonymous Guest

    Hi, normalerweise kann man in den Einstellungen von Live die Midiclocksignale einzelner Ports des Midiinterfaces gegeneinander verschieben. So, dass am Ende die Geräte an den Ports auch synchron laufen.
    Leider funktioniert das mit den Emagic Unitor Interfaces nicht, was lt. Auskunft von Abletons Support an den Treibern vom Unitor liegt. Ich habe selbst Unitors am Mac hängen und es klappt nicht, wie es soll.

    Mit einem anderen Interface würde das klappen. Habe das mit einem Midiman Midisport 2x2 probiert, da gabs keine Probleme.

    Falls Du nur das MAQ 16 mit Midiclock versorgen musst und sonst nichts, kannst Du in den Live-Einstellungen aber wenigstens die Midiclock aller Ports gemeinsam verschieben, bis die Noten sitzen. Schau mal unter " Voreinstellungen--->Midi/Sync" nach, dort musst du einen kleinen Pfeil, der links bei den Out-Ports ist, anklicken und die "Midiclock-Sync-Verzögerung" einstellen.
     
  30. Anonymous

    Anonymous Guest

    ich habe Live nun auf dem PC am laufen:

    als ich gestern 2 Geräte zu live synchronisieren wollte,
    musste ich feststellen dass die Clock schubweise schneller wurde.

    D.h. z Bsp. 4 Viertelnoten normal, dann 1ne viertelnote in deutlich höherem speed. ( so als Beispiel, was aber der sache recht nahe kommt )

    kennt jemand dies Problem ?
    hab ich was falsch eingestellt ?


    edit: shit, ist ja das umgekehrte Problem wie beim notebook ;-)
     

Diese Seite empfehlen