*Gelöst* Einsteigerverzweiflung Synthesizer Ableton Setup

C

Carekoala

.
Guten Abend zusammen,

kleine Vorwarnung - ich bin absoluter Einsteiger was Synthesizer angeht, insbesondere DAWs, daher entschuldigt vorab meine Unwissenheit.

Soeben habe ich "erfolgreich" meinen Roland JD-XI mit Ableton live 10 via USB verbinden können.
Signal kommt an und mit dem Setup der MIDI Spuren habe ich bisher keine Probleme gehabt.
Folgende Herausforderung stellt sich mir dennoch:
Wenn ich den Output über den Roland JD-XI laufen lasse, höre ich die auf dem Synthesizer gespielten Sounds. Passt also! Läuft der Output jedoch über meinen Computer (Microsoft GS Wavetable Synth) höre ich plötzlich andere Töne als auf dem JD-XI angezeigt. Schalte ich auf meinem Synthesizer durch die Sounds, ändern sie sich zwar, es wird aber nie der Sound wiedergegeben wie ausgewählt.

Ich hoffe ich konnte mein Problem verständlich beschreiben. Anbei noch einige Screenshots.

Danke und beste Grüße,
Carekoala
 

Anhänge

  • Annotation 2020-02-11 192524.png
    Annotation 2020-02-11 192524.png
    63,7 KB · Aufrufe: 18
  • Annotation 2020-02-11 192610.png
    Annotation 2020-02-11 192610.png
    49 KB · Aufrufe: 18
  • Annotation 2020-02-11 192839.png
    Annotation 2020-02-11 192839.png
    112,1 KB · Aufrufe: 17
Sonosphere

Sonosphere

.....
Hallo Carekoala

Frage 1: Welche MIDI Kanäle hast du beim Roland eingestellt? Läuft es im Multi Modus? KAnnst du also mehrere Kanäle gleichzeitig anspielen? Du hast da ja mehrere Spuren.

Frage 2: Wieviel Outputs hat dein Roland? Kann es sein, dass du beim dem einen Programm den falschen Output gewählt hast?

Und kennst du Abletons Funktion mit "External Instrument"?

PS: Kannst du bei den Ableton Einstellungen mal Input / Output Configs screenshoten und posten?

Eventuell kannst du "Track" deaktivieren bei den Midi einstellungen dafür aber "Sync" aktivieren. Dann ist wenigstens mal BPM gesynced.


Ausserdem musst du beim dritten Bild nicht die "MIDI From" einstellen. Oder erhältst du MIDI Befehle vom Roland? Du willst ja nur MIDI rausschicken oder nicht?

Gruss
Sonosphere
 
Zuletzt bearbeitet:
unse Jung

unse Jung

...
Hallo,
Ich glaube du musst noch einen Audiokanal hinzufügen und Audio von extern einstellen. Habe auf den Screenshots nur Midikanäle gesehen.
Grüße
 
Sonosphere

Sonosphere

.....
Hallo,
Ich glaube du musst noch einen Audiokanal hinzufügen und Audio von extern einstellen. Habe auf den Screenshots nur Midikanäle gesehen.
Grüße


Du hast völlig recht, daran hab ich nicht gedacht, als ich die Screenshots angeschaut habe. Oder eben "External Instrument" wählen beim MIDI-Kanal. Dann gehts auch.
 
C

Carekoala

.
Hi Sonosphere,

Zu Frage 1) Der JD-XI hat zwei Digital-Synth, eine Analog-Synth und eine Drum Spur. Es kann aber immer nur ein Kanal gleichzeitig angespielt werden.

Zu Frage 2) Der Roland hat zwei Klinke-, einen MIDI- und einen USB-Output. Verbunden habe ihn via USB direkt zum CMP, ohne Audio Interface zwischengeschaltet. Ich denke den richtigen Output habe ich gewählt, denn er sendet ja an Ableton wenn tasten gespielt werden.

Von der Ableton External Instruments Funktion habe ich gelesen, ist in der Trial Version aber leider nicht enthalten. Upgraden will ich eigentlich erst sobald ich das Gefühl habe mit Ableton zurecht zu kommen und vorher gerne noch FL Studio und Logic antesten.

Input und Output Config ist bei mir nada, siehe Screenshot.

Mein Plan ist es das auf dem Roland gespielte in Ableton aufnehmen zu können.

Vielleicht eine hilfreiche Ergänzung: Die Filter auf dem JD-XI funktionieren auch nicht wenn der Output über den PC läuft.


Danke schonmal für deine schnelle Antwort!
 

Anhänge

  • Annotation 2020-02-11 202113.png
    Annotation 2020-02-11 202113.png
    19,9 KB · Aufrufe: 13
Mr. Roboto

Mr. Roboto

positiv eingestellt
Du darfst natürlich nicht den MS GS Wavetable Synth einstellen. :lol: Dann hörst Du ja nur die Tröte.
Wenn Du die Midispuren wiedergeben willst, musst Du als Ausgang auch den JSxi definieren.
 
Sonosphere

Sonosphere

.....
öhm... du solltest aber einen Input haben? Sonst kannst du gar keinen Sound empfangen?

Also wenn du beim Roland USB Out (für Audio!) eingestellt hast, dann müsstest du den Roland wohl als USB-Soundcard auf deinem PC sehen.

Andere Frage: Hast du beim ersten Screenshot beim Input statt Realtek Mikrofon auch Roland zum auswählen?
 
C

Carekoala

.
Die External Instrument Version gibt es doch. Hat das Problem aber leider nicht behoben, es sei denn meine Einstellungen stimmen nicht.

@Mr. Robot Wenn ich den JD-XI als Output wähle und die Kopfhörer in den Synth stecke läuft auch alles top. Besteht denn nicht die Möglicheit die selben Signale/Sounds über die Kopfhörer-Klinke am Computer zu empfangen? Ich würde gerne noch ein MIDI Pad mit Ableton verbinden und die Möglichkeit haben beide Instrumente gleichzeitig anzuspielen und logischerweise über ein Output zu hören.
 

Anhänge

  • Annotation 2020-02-11 203345.png
    Annotation 2020-02-11 203345.png
    154,4 KB · Aufrufe: 11
C

Carekoala

.
@Sonosphere Nein die Auswahlmöglichkeit hatte ich nicht. Bedeutet das mir fehlt ein Treiber?
 
Sonosphere

Sonosphere

.....
hmmm scheint so... komisch. Was sagen dir die Audioeinstellungen des Computers? Wird der Roland als Soundcard erkannt? Oder nicht? (wahrscheinlich nicht)

edit: zwar du kannst ja direkt über den roland senden. Okay andere Frage. Kannst du bei "Output Audio Device" Roland einstellen?
 
C

Carekoala

.
Die Treiber scheinen installiert zu sein. Ob der Roland als Soundkarte erkannt wird weiß ich nicht, ich schaue ob ich es finde.

Auch beim Output nicht, siehe Screenshots.
 

Anhänge

  • Annotation 2020-02-11 204312.png
    Annotation 2020-02-11 204312.png
    74 KB · Aufrufe: 13
  • Annotation 2020-02-11 2043122.png
    Annotation 2020-02-11 2043122.png
    77,5 KB · Aufrufe: 14
Sonosphere

Sonosphere

.....
Welche Auswahl hast du bei "Driver Type"? Vielleicht musste ja ASIO installieren...?
 
unse Jung

unse Jung

...
Du brauchst noch die Treiber vom jd xi von der Roland Website. Dann kannst Du den Synthesizer direkt in Ableton verwenden.
 

Anhänge

  • 15814503144023053325108530772319.jpg
    15814503144023053325108530772319.jpg
    1,8 MB · Aufrufe: 18
Mr. Roboto

Mr. Roboto

positiv eingestellt
Hat der Roland denn überhaupt Audio über USB?
Ansonsten musst Du das Audiosignal vom Roland noch in Deine Soundkarte geben.
Um Latenzprobleme zu vermeiden würde ich dann als Audiotreiber noch Asio4All installieren.
 
Sonosphere

Sonosphere

.....
schau mal nach was unse Jung gesagt hat. Von wegen Roland Treiber auf der Website.
 
C

Carekoala

.
@Sonosphere Wenn ich ASIO wähle bekomme ich auch als Audio Device den JD-XI vorgeschlagen. Bei der Auswahl aber Fehlermeldung siehe Screenshot.

@unseJung Treiber ist installiert. Installieren die sich nicht idR direkt bei der ersten Verbindung mit dem Gerät?

@Mr Robot Jo USB wird unterstützt. Könnte die Zwischenschaltung über ein Audio Interface das Problem lösen?

Da es ja problemlos läuft wenn der Output über den JD-XI läuft, denke ich dass ich etwas falsch in den Einstellungen in Ableton habe. Kann es z.B. sein, dass ich eine falsche Bedienoberfläche ausgewählt habe (aktuell Launch Control, da es keine passende für den JD-XI gibt). Oder würde ein Audio Interface zwischen Roland und CMP das Problem lösen?
 

Anhänge

  • Annotation 2020-02-11 2043122.png
    Annotation 2020-02-11 2043122.png
    126,7 KB · Aufrufe: 17
  • Annotation 2020-02-11 210024.png
    Annotation 2020-02-11 210024.png
    25,6 KB · Aufrufe: 16
unse Jung

unse Jung

...
eventuell bei driver type core audio probieren. Und in der Sessionansicht das Monitoring für den entsprechenden Audiokanal auf in Stellen.
 
Sonosphere

Sonosphere

.....
genau probier mal core Audio. Und Jain.. also die treiber müssen sich nicht unbedingt selber installieren. Kann gut sein, dass man die manuell installieren muss.

Ein AUdio Interface würde das Problem lösen. Dann kannst du beim Roland über die Audio Ausgänge raus.
 
C

Carekoala

.
Danke euch allen für die Hilfe!
Leider funktioniert es immer noch nicht, werde eure Vorschläge morgen nochmal in Ruhe durchgehen. Außerdem habe ich eben bemerkt, dass selbst wenn ich den Output über den Roland laufen lasse ich beim Aufnehmen extreme Aussetzer und Stocker habe. Sogar eine Fehlermeldung auf dem Roland Display mit "Record Overload". Anscheinend habe ich mich mit dem Plan das "mal eben" an einem Abend einzurichten überschätzt. Ich werde mich die nächsten Tage einfach weiter reinarbeiten und mit der Zeit wird das schon ?
 
unse Jung

unse Jung

...
nicht aufgeben.....
Hab mir z.Bsp grad meine Projekte aufm Octratrack zerschossen. Machen was halt nochmal alles neu
 
GeoTeknique

GeoTeknique

|||||
Leider funktioniert es immer noch nicht, werde eure Vorschläge morgen nochmal in Ruhe durchgehen. Außerdem habe ich eben bemerkt, dass selbst wenn ich den Output über den Roland laufen lasse ich beim Aufnehmen extreme Aussetzer und Stocker habe.
Ja das Problem hatte ich auch. Ich habs folgendermaßen gelöst: Wechsel von Ableton auf Presonus StudioOne
Genau das ist das Problem, wenn man MIDI-Notensignale sendet und gleichzeitig über die selbe Schnittstelle Audio-Signale empfängt. MIDI will möglichst kleine Buffer und schnelle Kommunikation, während Audio nach einer höheren Pufferung verlangt. Das beißt sich fundamental. Kommt dann noch eine nicht saubere MIDI-Implementierung wie bei Ableton hinzu (Ableton ist kein MIDI-Spezialist, sondern eigentlich eine Audio-Loop-Software) ist das Chaos perfekt und die erlebst die beschriebenen Probleme.
So generell würde ich dir aber zu einem halbwegs vernünftigen, sprich semi-professionellen, Sound-Interface raten. So teuer sind die nicht. Dann kannst du dein Roland auch mit Ableton halbwegs stabil absteuern.
 
Mr. Roboto

Mr. Roboto

positiv eingestellt
Die DAW wechseln und ein Audiointerface kaufen empfinde ich nicht unbedingt also so sinnvollen Tip, wenn man es mit ein paar simplen Einstellungen in weniger als einer Minute lösen kann. Gibt genug Konfigurationen mit Ableton Live und USB-Geräten, mit denen es funktioniert.
Würde mal behaupten, ich bräuchte keine drei Minuten um es zu fixen, wenn ich davor sitzen würde.
 
everNoob

everNoob

|||
Erstmal ignoriere Alles was vorher im Thread gepostet wurde ist durch die Bank halbwahr oder gar Schwachsinn.

Deaktiviere sicherheitshalber mal Alle Audio Ein und Ausgänge inkl. der des Jd xi in den Windoof AudioGeräte Einstellungen und starte den Pc neu. Warte nach dem Hochfahren 2 Minuten bis Windoof auch wirklich Alle Hintergrunddienste und Hintergrundprogramme geladen hat.
Dann öffne Ableton geh in die Voreinstellungen wähle bei Audio Drivertype Asio und als Audio Device den jd xi, wie du es ja schonmal probiert hast.
Falss du wieder eine Fehlermeldung bekommst dann bitte nochmal Posten, dann helf ich dir beim troubleshooting.

Falls es jetzt keine Fehlermeldung mehr anzeigt dann aktiviere mal unten den Testton, jetzt solltest du über die Ausgänge und Kopfhörerbuchse des jd xi einen 440 hz Sinuston hören falls nicht auch Posten.

Falls du den Sinuston hörst dann kannst du ihn wieder ausschalten.
Gehe als Nächstes zu den Link MIDI Einstellungen wähle als Control surface none als Input none und Output none. Der jd xi hat in diesen oberen Teil der MIDI Einstellungen, nämlich nix verloren.
Jetzt sollte sich der untere Teil verändert haben. Falls nicht, dann starte Ableton einmal neu.
Beim jd xi Output wählst du Track und Sync an.
Beim jd xi Input nur track und schaust mal ins Handbuch des jd xi auf Seite 12 wie du dass keyboard des jd xi auf Local Switch off einstellst falls du den jd xi wieder Standalone ohne Ableton betreiben möchtest musst du das Jd xi Keyboard wieder auf Local Switch on einstellen.
Nun kannst du die Voreinstellungen schließen.
Schau mal beim Master Track ob die Ausgänge passen, sollte jd xi 1/2 oder ähnlich sein.
Als nächstes erstellst du einen Audio Track und benennst ihn am besten mal in jd xi Audio um.
In diesem Track wählst du bei Audio from Ext In. aus, untendrunter 1/2 und stellst Monitor auf In.
Audio to sollte ja schon auf Master stehen.

Als nächstes erstellst du einen neuen Midi Track benennst diesen in jd xi MIDI um und wählst bei MIDI to jd xi Output oder ähnlich aus und als MIDI ch erstmal 1 .
Nun erstellst du in dem MIDI Track einen MIDI Clip clickst über die Pianorolle paar Noten ein und startest diesen, du solltest nun was hören.
Als nächstes stoppst du den Clip wieder, stellst den Track auf record arm und Spielst paar Noten auf dem Keyboard des jd xi Falls du diese wieder hörst dann wünsche ich viel Spaß.
In Zukunft wirst du dich noch mit so Sachen wie Multitimbralität und Latenzkompensation auseinandersetzen müssen, aber dass wäre jetzt Zuviel des guten.

Edit: Schau dir mal Seite 14 im Handbuch an zwecks MIDI Channels und du kannst am Gerät selbst nochmal einstellen ob du den Roland oder Class Compliant Treiber verwenden willst, vorher aber USB Kabel abziehen.
Hab oben noch paar Kleinigkeiten editiert
 
Zuletzt bearbeitet:
C

Carekoala

.
@everNoob danke für die step by step Erklärung!

Der erste Fehler lag schon mal darin, dass ich auf dem JDXI in den Systemeinstellungen bei USB Drive "Generic" ausgewählt hatte. Auf der Roland Website steht man soll "Vendor" auswählen. Mich würde interessieren worin der Unterschied liegt.

Ich bin anschließend deinen Schritten gefolgt und es hat alles ganz genau so geklappt wie du es beschrieben hast. Sehr geil!

Trotzdem habe ich noch ein paar Fragen:

1. Wenn ich etwas über meinen JDXI in Ableton aufgenommen habe und es wiedergeben möchte, dann sendet Ableton das Signal aber leider nicht zurück in den JDXI und durch dessen Output in meine Kopfhörer. Ist das überhaupt möglich oder muss ich um das Aufgenommene zu hören über PC Output gehen? Siehe Screenshot!

2. Da mein JDXI vier Spuren hat würde ich auch gerne alle Spuren in Ableton recorden können. Hierzu habe ich drei weitere MIDI Tracks erstellt und jeweils den entsprechenden Channel ausgewählt. Ist das so wie im Screenshot korrekt?

3. Wieso ist der Reverb so stark obwohl auf JDXI ausgestellt?

4. Wie wäre es nun wenn ich ein MIDI Pad via USB mit dem PC verbinden würde? Gibt es eine Möglichkeit den Output des MIDI Pads auch über den JDXI Output zu empfangen?
 

Anhänge

  • Annotation 2020-02-12 193448.png
    Annotation 2020-02-12 193448.png
    128,1 KB · Aufrufe: 7
  • Annotation 2020-02-12 193607.png
    Annotation 2020-02-12 193607.png
    156,6 KB · Aufrufe: 9
  • Annotation 2020-02-12 19360724.png
    Annotation 2020-02-12 19360724.png
    121,5 KB · Aufrufe: 8
 


Neueste Beiträge

News

Oben