hilfe reparatur microQ

Dieses Thema im Forum "Reparatur, Pflege, Modifikation" wurde erstellt von comboy, 23. Februar 2017.

  1. comboy

    comboy ......

    Hab hier grad nen micro Q in der werkstatt.
    Kam hier mit datenmüll auf dem display und nur einer leuchtenden LED an.
    Nachdem ich einen arg misshandelten D-Flipflop und einen losen SMD transistor getauscht habe gibt er wieder lebenszeichen von sich.

    display tut, waldorf begrüßung, OS 2.20, dann seh ich instr.1 und preset name.
    Daraufhin leuchten auch "Play" , "Inst.1" und "OSC1" LED auf.

    Allerding reagiert er auf keinerlei tastendruck oder das drehen am encoder.

    Geh ich jedoch beim booten auf die factory test page kann ich alle tests erfolgreich abschließen.
    Hier reagieren sämtliche knöpfe, encoder und LEDs wie sie sollen.

    jemand ne idee?

    muss dazu sagen das es mein erster Q ist. Also keine ahnung von der bedienung. ;-)
    Da aber nichtmal der Powerknopf oder inst.2-4 eine wirkung zeigen vermute ich da stimmt noch was nicht.

    gibt es einen factory reset?
     
  2. comboy

    comboy ......

    hmmm vermutlich ein DSP problem. Ich denke mal der DSP test sollte nicht die ganze zeit nur "Reboot" melden... :heul:
     
  3. swissdoc

    swissdoc back on duty

    Bedienung ist echt super im Handbuch beschrieben :)
    Kannst Du die Demos abspielen?
    Kommt was, wenn über Midi Noten auf verschiedenen Kanälen gesendet werden?

    Was passiert bei:
    How to reset the mQ CPU clock?
    How to enter the factory test mode?
    Anybody know what 'watchdog timeout' means on a microQ screen?
    How to get into the mircoQ's factory test, service, erease data mode?
    Is there a microQ easter egg?
    http://faq.waldorfian.info/faq-browse.php?product=mq#16

    Demo Sequenzen
    Der microQ ist mit vier Demo-Sequenzen ausgestattet, die Ihnen die Möglichkeit geben, auch ohne Spielen der MIDI-Tastatur einen Klangeindruck zu bekommen.

    Wiedergabe einer Demo-Sequenz:
    Drücken Sie Peek und einen der vier Instrumenten-Taster gleichzeitig, um eine Demo-Sequenz mit dem angewählten Sound wiederzugeben.
    Drücken Sie einen anderen Instrument-Taster, um eine andere Sequenz auszuwählen.
    Durch Drehen des Auswahlrades können Sie das Soundprogramm wechseln.
    Drücken Sie den Power-Taster, um die Demo-Sequenz-Wiedergabe zu stoppen. Der microQ kehrt in den normalen Modus zurück.
     
  4. comboy

    comboy ......

    Naja ich dachte da eher an sowas spezielleres.
    Vielleicht gibts ja sowas wie "local off" für die bedienoberfläche oder sonstige stolpersteine. ;-)

    Das funktioniert bei mir leider genausowenig wie die Service Page auf der man die clock angeblich ändern kann.
    Gibts aber im netz noch mehr leute bei denen das keine funktion hat.
    Oder es liegt an meinem DSP hardware problem.
    wie oben beschrieben alle test OK, außer dem DSP test. => REBOOT DSP!


    Mittlerweile hab ich noch gemerkt das die Ladungspumpe für die -8V der ausgangs OpAmps nicht tut.
    Die hat aber wohl eher weniger mit dem DSP problem zu tun. Vermutlich die Mosfets.

    Werd jetzt wohl mal etwas abstand gewinnen und dann mit frischen augen nochmal genauer den DSP und Flash begutachten.

    Ansonsten: Quarz läuft, takt kommt am DSP an, 5V und 3.3V sind vorhanden und stabil. Flash und SRAM liefern an den Datenpins auch fröhlichers binärgeflacker, auch wenn die Flanken echt Sch**** aussehen.

    schwere geburt :heul:
     
  5. swissdoc

    swissdoc back on duty

    Ich hatte übersehen, dass beide Postings von Dir waren, der DSP Test sollte natürlich keine Fehlermeldung liefern.
    Wenn ich es recht erinnere, so hat der microQ einen Host-Prozessor und DSP(s), beim Blofeld wurde dann einiges vom Host in den DSP verschoben -> billiger.
    Die Tasten werden vom Host-Prozessor abgefragt, wenn dort also nichts passiert, ist es etwas merkwürdig. Einen Local OFF des Panels gibt es meines Wissens nicht.
    Die Tasten werden aber abgefragt, sonst würdest Du ja nicht in den Test-Modus kommen.

    Ich bilde mir ein, dass mein mQ das mit dem CPU Clock konnte, aber das ist nun alles echt Jahre her.

    Preise sind ja doch noch recht signifikant, also einfach einen anderen bei eBay schiessen, ist wohl keine Lösung.
     
  6. comboy

    comboy ......

    Außerdem macht das ja auch keinen spaß ;-)

    Ich bin mittlerweile auch mit waldorf in kontakt.
    An dieser stelle Daumen hoch. Erstaunlich guter support für so ne alte kiste. :supi:
    Auf der SDIY mailingliste gabs auch schon ein paar Ideen.

    Mittlerweile glaube ich der DSP läuft, jedenfalls erzeugt er erfolgreich die master clock für den codec.
    Also vielleicht ein SRAM problem.
    Nach dem booten scheint der microcontroller einzufrieren beim versuch die daten in den SRAM zu laden bzw den DSP zu booten.
    Das firmware update schreibt wohl auch zuerst die daten in den SRAM bevor sie dann nach erfolgreicher übertragung in den flash geschrieben werden.

    Mal sehen. Vielleicht versuche ich es mal mit einem SRAM tausch.
    Gestern abend habe ich auch noch bemerkt das in meiner kiste früher wohl mal die voice extension verbaut war, aber wohl wieder entfernt wurde.
    Vielleicht liegt auch da der hund begraben.

    Auf jeden fall schon wieder viel gelernt bei der autopsie der kuh.