Latenz Ableton Live

Dieses Thema im Forum "DAW / Komposition" wurde erstellt von Henning, 30. April 2008.

  1. Henning

    Henning Tach

    Hallo, ich arbeite schon einige Zeit mit Ableton Live und habe eine Frage zum Thema Latenz.

    Ich nehme mit einer Echo Indigo PCMCIA Karte auf, Ableton läuft mittels eines Motu Fastlane Midi Interface synchron zu meinem MPC.

    Ich nehme beim Produzieren meist Spur für Spur auf und mische dann in Ableton ab etc...

    Dabei komme ich um gewisse Latenzzeiten natürlich nicht rum, was eigentlich auch nicht weiter schlimm ist, da ja alle Spuren mit der gleichen Latenz aufgenommen wurden. Problematisch wirds nur dann, wenn ich in Ableton noch weitere Tracks mit internem Sequencer und internen VSTs aufnehme laufen die halt nicht perfekt synchron.

    Meine Frage: da Ableton ja die Latenzzeiten kennt, die bei den Aufnahmen entstehen, kann das Programm die wieder "rausrechnen"? Also nach der Aufnahme die jeweiligen Tracks einfach um die Paar Millisekunden nach vorne ziehen die auf Grund der Latenz entstanden sind?

    lg Henning
     
  2. klar du kannst z.B. einen negativen wert in der Spur der du die MPC aufnimmst eintragen - oder einen positiven in der VST Spur

    in 7 gibt es auch einbindung von ext. Instrumenten - das funzt gut solang man die auch vom Ableton Sequencer steuert

    was ich noch nie ausprobiert habe sind die externen Effekte - evtl kann man darueber auch einen synth der sich selbst sequenced (also der nur Clock von Live erhaelt) einbinden
     
  3. Anonymous

    Anonymous Guest

    also wenn die Spur auf Monitor off gestellt ist, verschiebt Ableton das Aufegohmene automatisch um deine Latenz nach vorne!
     
  4. aber dann hoert man nichts :roll: ausserdem sollte die Latncy Error Compensation richtig eingestellt sein

    ich benutz zwei SPuren - eine zum hoeren und eine zum aufnehmen
     
  5. Anonymous

    Anonymous Guest

    nein da muss man nichts einstellen, das ist automatisch richtig eingestellt (also falls dein exernes Zeug synchron mit deinem Internen läuft, was aber natürlich sowieso eine Voraussetzung ist).

    Ich höre externes sowieso über mein Mischpult ab oder alternativ über den Totalmix vom Fireface!

    Wenn ich externe instrumente aber in Live reinroute um das ganze noch simultan mit Effekt-PlugIns bearbeite (also nur über live selber abhören kann), dann Stelle ich die Spur oder den Midi-Sync von hand ein, so wie du es empfohlen hast.
     
  6. also wenn ich die Latency Error Compensation nicht richtig einstelle sind die Aufnahmen nicht auf'm Beat

    keine Ahnung wie du das machst, das es passt
     
  7. Anonymous

    Anonymous Guest

    meinst du auf Deutsch die Treiberfehler-Kompensation im Menu Voreinstellungen?

    also falls du die meinst, die war und ist bei mir immer auf Null, habe scheinbar keine Treiberfehler...
     
  8. gourmet

    gourmet Tach

    ahh warum wurde dieser threat nicht etwas weitergeführt wie z.b.
    wie ist der optimale weg die treiberfehler kompensation zu ermitteln
    welche kabel ?welchen weg? im live workshop find ich das für einen laien unzureichend erklärt
    ich habs auch auf null und ich denke das die leistung schnell auf 50% is
     
  9. mokkinger

    mokkinger Tach

    Also eigentlich ists in der Live Hilfe recht gut erläutert:

    1. hardware-treiberfehler rausfinden, indem man out 1 des interfaces mit in1 verbindet, das setup-liveset aufruft, und dort in der sessionansicht einfach auf record klickt. anschl. reinzoomen in die aufnahme, und die ms ablesen. diese dort eintrage. (mein Motu 828 mk II FW hat zb 1,3 ms Treiberfehler-Latenz)

    2. eine externe maschine über midi ansteuern, das interne sowie das externe metronom (oder ein perkussiven sound, klick oder so) synchronisieren, indem man in den voreinstellungen / midi / sync den jeweiligen Versatz in ms erhöht (hier habe ich 4 ms verzögerung); DAS ist dann die Latenz, um die sich eine Aufnahme bei eingeschaltetem Monitoring verschiebt, da salopp gesagt "der Sound genau diese zeit benötigt um vom ext. HW via Interface ins Live" zu gelangen; bei deaktiviertem Monitoring rechnet Live diese Latenz wieder raus - Vorrausgesetzt man hat die "Automatische Latenzkompensation" aktiviert. die findet man im Menü (wo genau hab ich grad nicht im Kopf:)

    ich hab auch recht lange gebraucht bis ich ein stabiles setup zusammen hatte - kann an vielen dingen liegen, unsauber programmierte treiber, unterschiede in der midi-hardware etc... aber wenn du diese beiden punkte durchspielst dann solltest du ziemlich sicher zu einer latenzfreien aufnahme gelangen.

    trotzallem mache ich, bevor ich ein längeres projekt beginne oder aber bevor ich eine recording session mache IMMER kurz den metronom-check, um sicherzu gehen dass alles tight läuft - ich habe keine Lust nachträglich mit track delays oder gar von hand die dinge zurecht zu rücken;

    hoffe das hilft dir weiter,
    gruss mark
     
  10. Anonymous

    Anonymous Guest

    Re:

    habe jetzt gerade gesehen das die treiberfehlerkompensation nur für ein Direct Monitoring Szenario relevant ist, also wenn man das signal durch den rechner abhört, deswegen hatte ich da wohl auch nie einen fehler....

    @gourmet
    mach am besten einfach den enstprechenden live kurs durch, besser und bildlicher wie da kann man es eigentlich nicht erklären
     
  11. gourmet

    gourmet Tach

    danke das hilft schon weiter Mokkinger
    aber um die ungenauigkeit bei ableton anzusprechen is mit welchem kabel
    nach längerer überlegung bin auch darauf gekommen das es wohl egal wäre ob mono oder stereo klinke
    kann doch auch meine adat i/o´s nehmen oder? dann routen und so derspar mir mir des rumstecken ,fein
     
  12. mokkinger

    mokkinger Tach

    hmm, da bin ich mir nicht sicher, da es ja dann keine da-ad-wandlung ist, wenn du über adat routest, oder? aber eigentlich sollte es auch gehen. mach halt mal den vergleichstest. stereo klinke sollte auch gehen, es geht halt darum mindestens einen kanal raus und direkt wieder rein zu routen;
     
  13. gourmet

    gourmet Tach

    warum fängt der Anfang nicht gleichlaut an wie der rest?
    kann ich sagen daß das etwa 0,03 millisec sind oder wie darf ich das sehen ?
    ich musste bei meinen rme settings auch mit der eingangs lautstärke regeln (steht jetzt auf 40 Volt) damit ich den pegel gleich dem der ersten spur
    hinbekomme ,weil wenn mit der masterspur geregelt , stell ich auf +3 db und komm nur auf die hälfte?!
    ahh ich seh grad das auf der zweiten spur ein fade eingestellt ist?!?Das erklärt wohl den kleinen anfangs sinus :P
    aber sollte ich jetzt die eingänge auf 48 v stellen und die Masterspur wieder runterregeln (steht jetzt auf 0.3 db)?
    soory bild kommt gleich :D

    [​IMG]
     
  14. mokkinger

    mokkinger Tach

    ich seh da ziemlich genau 2ms. die kurve fängt ja nach 2ms genau da an wo sie im original auch anfängt.

    die pegel kannst du eigentlich ignorieren, das passt schon so. es geht ja nicht um die lautstärke, sondern um die zeitverschiebung.
    dass das signal anfangs etwas leiser ist liegt einfah am originalsignal - hat auch ncihts zu sagen. wenn du die wellenformen übereinander legen würdest sollten sie ca. deckungsgleich sein, leichte unterscheide mal aussen vorgelassen;
     
  15. gourmet

    gourmet Tach

    merci so können wir das thema nun abschließen- klappt jetzt reibungslos :cool:
     
  16. mokkinger

    mokkinger Tach

    prima, freut mich!
     

Diese Seite empfehlen