MKS-50 vergisst seine Presets, kopfkratz

interruptor

interruptor

..
Guten Tag miteinander

Mein liebster MKS-50 hat eine frische Stützbatterie für das statische RAM. Trotzdem vergisst er, sobald man ihn länger als ein paar Sekunden ausschaltet, alle Presets und meldet sich mit einer Fehlermeldung (Check Battery) wieder. Solange er läuft, kann man Presets aber ohne Probleme verändern, speichern und wieder aufrufen.

Ich habe etwas allgemeines Elektronikwissen aber überhaupt keine konkrete Erfahrung mit der Reparatur von Synths. Ich wäre deshalb sehr glücklich über Tipps von euch :)

Ein erster Check mit einem Multimeter ergab, dass die Versorgungsspannung des RAMs eingeschaltet bei 5V und ausgeschaltet bei 3V liegt. Laut Datenblatt reichen ca. 2V um den RAM-Inhalt zu halten, soweit scheint also alles i.O.

Um der Sache auf den Grund zu gehen, habe ich mir ein Oszilloskop zugelegt und kontrolliert, ob die Versorgung des RAMs auch während des Ein- und Ausschaltvorgangs stabil bleibt. Und siehe da: Insbesondere beim Einschalten treten eine ganze Reihe von Spikes auf, die beim RAM dass Vdd kurzzeitig sehr weit herunterziehen. Siehe dazu den Oszilloskop-Plot im Anhang und den Schaltplan, wo ich die gemessenen Punkte A und B eingezeichnet habe. Man sieht schön, wie beim Einschalten die Logikversorgung von 0 auf 5 Volt ansteigt, während der Versorgungspin Vdd des RAMs von der Batteriespannung 3V auf knapp 5V steigt.

Ist das ein Fall, wo ein Tausch der Elkos im Netzteil helfen kann? Oder suche ich da ganz am falschen Ort? Ganz kapputt können die wohl nicht sein, sonst würde das Gerät wohl überhaupt nichts mehr machen..

herzliche Grüsse
Daniel / interruptor
 

Anhänge

  • mks-50_ON3.jpg
    mks-50_ON3.jpg
    183,5 KB · Aufrufe: 270
  • mks-50_ON3_schematic.jpg
    mks-50_ON3_schematic.jpg
    207,6 KB · Aufrufe: 270
fanwander

fanwander

*****
Hallo

ohne es überprüfen zu können, behaupte ich mal, dass der C22 der ja direkt an der VDD des SRAMs hängt den Spike mit seinen 100nF abfangen sollte. Schau mal, ob der wirklich noch dranhängt, oder ob da eventuell eine Lötstelle kaltgeworden ist, oder die Leiterbahn beim Batterietausch einen Riss bekommen hat.

Gruß
Florian
 
swissdoc

swissdoc

back on duty
interruptor schrieb:
Trotzdem vergisst er, sobald man ihn länger als ein paar Sekunden ausschaltet, alle Presets und meldet sich mit einer Fehlermeldung (Check Battery) wieder.
Wie sieht denn das Bild der beiden Spannungen aus, wenn Du den MKS50 kürzer als ein paar Sekunden ausschaltest? Dein Satz impliziert ja, dass dann der Speicher erhalten bleibt.
Die Spikes beim Ein- und Ausschalten sollten aber gleich sein, egal, wie lange dazwischen gewartet wird.

Irritiert mich gerade etwas, aber wahrscheinlich liegt es an dem Kondensator, den Florian identifiziert hat.
 
interruptor

interruptor

..
Vielen Dank für eure hilfreichen Antworten! Ich habe die Kurven noch einmal mit gleicher Skalierung aufgenommen nach kurzem Ausschalten (ca. 3 sec).
Es sind wesentlich weniger heftige Spikes zu sehen, und der Memoryinhalt blieb tatsächlich erhalten.
Interessant auch, wie die beiden Kurven schneller bei 5V ankommen, als im ersten BIld. Ich vermute, die Kapazitäten waren noch nicht vollständig entladen.
Ich werde als nächstes die Verbindungen des C22 zu den benachbarten Bauteilen prüfen und nocheinmal berichten..
 

Anhänge

  • mks-50_ON4_nur_kurz_ausgeschaltet.jpg
    mks-50_ON4_nur_kurz_ausgeschaltet.jpg
    174,9 KB · Aufrufe: 237
interruptor

interruptor

..
OK.. Ich habe an C22 mit dem Multimeter den Widerstand der Verbindungen zu Erde und zum Vdd-pin am RAM gemessen und jeweils fast 0 Ohm erhalten. Da scheint das Problem also nicht zu liegen.

C22 <--> VDD von SRAM: OK
C22 <--> Ground (VSS von SRAM): OK

Es gibt noch weitere Kapazitäten in dieser Grössenordnung, wenn man den Pfad bis zum Gleichrichter zurückverfolgt. Ich such mal da weiter..
 
swissdoc

swissdoc

back on duty
Ich würde einfach alle Elkos im Netzteil tauschen, vor allem im 5V Teil. Das sind dann

C103 47/16
Cxxx 1/50
C108 3300/16

Dann IC28 und C102/C107, wenn es nicht besser wird.

Das sind alles kleine Fische.

Vorraussetzung ist natürlich, dass ab Trafo und Gleichrichter alles sauber kommt. Das kannst Du ja mit dem Osci nachmessen. Evtl. hat ja auch der Gleichrichter einen Hau.

Das Teil hier kann es allerdings auch sein: EMI SUPPRESSION FILTER COMPACT DISC-TYPE DSS310-55D223S, zum Test evtl. auslöten und brücken?
 
interruptor

interruptor

..
Danke für die Tipps! Ich werde nocheinmal mit dem Oszi messen und mir dann Ersatzteile beschaffen.
Wohin gehst du in Zürich für deine Bauteile? Kann man bei Pusterla immer noch mit einer Stückliste antraben und die Komponenten gleich mitnehmen? Ich wohne seit 10 Jahren in Basel. Da gab es mal die Firma Grieder Bauteile. Leider haben die aber ihren Laden zugemacht. :sad:
Herzlicher Gruss
Daniel / interruptor
 
swissdoc

swissdoc

back on duty
Pusterla habe ich ein oder zweimal besucht, ist lange her. Liegt für mich blöd. Ich gehe banal zu Conrad, die haben sich günstig in Dietlikon niedergelassen. Basiskrams haben die da, sonst bestellt man es kostenlos in die Filiale. Dann gibt es noch Distrelec in Nänikon, dort kann man auch abholen nach Vorbestellung. War aber länger nicht mehr nötig. Den Rest dann per Mailorder aus D oder weltweit, wenn es sein muss.
 
interruptor

interruptor

..
Das ist ein guter Tipp mit dem Conrad-Laden. :) Ich wusste nicht, dass es einen solchen gibt in Dietlikon. Ich habe auch noch gesehen, dass Grieder Bauteile weiterhin Versand macht und auch Abholung in Sissach möglich ist. Das liegt für mich ziemlich gut.
Noch eine Anfängerfrage: Die Radial-Elkos 46uF/16V, von denen es mehrere gibt im MKS-50, scheinen nicht mehr gebräuchlich zu sein. Ich vermute, es spricht nichts dagegen, diese mit Elkos von grösserer Spannungsfestigkeit zu ersetzen? 47uF/63V sehe ich bei Konrad im Onlieshop. Grieder hat 47uF/35V.
herzlicher Gruss
Daniel/interruptor
 
bionyx

bionyx

...
das sollte easy funktionieren...haben kürzlich auch ein paar kondensatoren 35v mit 100v ersetzt... :) läuft alles bestens..
 
Starkstrom

Starkstrom

|
Die Volt-Angabe beschreibt die maximale Spannungsfestigkeit - mehr geht da eigentlich immer, nur kleinere Werte sollte man da nicht einsetzen... Wichtig ist aber, dass die Kapazität genau stimmt ;-)

:peace:
 
interruptor

interruptor

..
Besten Dank für eure Tipps. :) Ich war gestern bei Pusterla in Zürich und habe mir die Bauteile besorgt. Der Laden ist noch genau so, wie ich ihn von vor 20 Jahren in Erinnerung hatte. Inklusive freundlicher Bedienung und Gratisratschläge für weniger bewanderte Lötfreunde wie mich.. Vor mir war ein Lehrer dran, der für eine Projektwoche ein Fahrrad zum Stromgenerator aufpimpen wollte. Er bekam gleich einen Schaltungsvorschlag auf Notizpapier gekritzelt. Toll, dass es den Laden noch gibt!
 
interruptor

interruptor

..
Nach einigen Stunden basteln, das Resultat:
- Alle Elkos (C103, C108, C101) und Keramikkondensatoren (C22, C104, C102, C107) im +5V Zweig ausgewechselt.
- Das Gerät läuft immer noch, Juhuu..
- Leider hat sich das Verhalten des RAMs nicht verbessert. Der Inhalt geht immer noch verloren, sobald man das Gerät länger als ein paar Sekunden ausschaltet.

Aufgefallen ist mir, dass die Spikes während des Einschaltens mindestens zum Teil vermutlich "drahtlos" eingekoppelt werden. Sogar wenn der Netzschalter des Geräts auf OFF war, sah ich feine Spikes beim Anstecken des Netzkabels! Den Effekt konnte ich mininieren, indem ich die Tastköpfe direkt auf der Platine anhänge. Zuerst hatte ich diese mit feinen Drähten verlängert, da mir die "Klauen" an den Tastköpfen zu grob erschienen um die Beinchen der Chips zu greifen.
Unten Bilder des Einschaltvorgangs im aktuellen Zustand. Einmal nach langer, und einmal nach kurzer Auszeit.

Der Gleichrichter D19 und der Spannungsregler IC28 scheinen gut zu funktionieren (siehe das 3. Bild)

Ich frage mich, ob ich das Problem überhaupt am falschen Ort suche.. :?

@swissdoc: Du hast erwähnt die Drossel FL1 könnte defekt sein. Mit Ausbauen und überbrücken, würde man das Problem aber wohl nur schlimmer machen? Gibt es einen Weg zu prüfen, ob die Drossel das Problem ist? Direkt hinter dem Netzschalter ist noch so ein Teil.

herzliche Grüsse
Daniel / interruptor
 

Anhänge

  • mks-50__A_5Vdc__B_D19Gleichr_12V+ripple_m.jpg
    mks-50__A_5Vdc__B_D19Gleichr_12V+ripple_m.jpg
    173,3 KB · Aufrufe: 128
  • mks-50_ON12_after_short_offcycle_memory_OK.jpg
    mks-50_ON12_after_short_offcycle_memory_OK.jpg
    171,4 KB · Aufrufe: 127
  • mks-50_ON14_after_long_offcycle_memory_lost_m.jpg
    mks-50_ON14_after_long_offcycle_memory_lost_m.jpg
    174 KB · Aufrufe: 127
swissdoc

swissdoc

back on duty
interruptor schrieb:
@swissdoc: Du hast erwähnt die Drossel FL1 könnte defekt sein. Mit Ausbauen und überbrücken, würde man das Problem aber wohl nur schlimmer machen? Gibt es einen Weg zu prüfen, ob die Drossel das Problem ist? Direkt hinter dem Netzschalter ist noch so ein Teil.
Ich denke, die kannst Du testweise ohne Ausbau einfach mal brücken. Die Dioden D1 und D2 kann man auch tauschen. Ein neues RAM löst das Problem evtl. auch.
Viel mehr bleibt dann ja nicht...
 
interruptor

interruptor

..
Das stimmt, viel mehr kann man dann gar nicht mehr auswechseln..
Angenommen die Drossel funktioniert noch und ich überbrücke sie: Besteht da nicht die Gefahr, dass danach starke Impulse bis zu den ICs vordringen und diese kaputtschiessen?
 
swissdoc

swissdoc

back on duty
Alternative:
- baue eine neue Drossel ein oder
- löte die Diode ab, lege die 5 Volt über eine Last (Widerstand mit entsprechender Leistung oder Glühlampe) auf Masse und miss dann mit Drossel und mit gebrückter Drossel, je nachdem -> baue neue Drossel ein

Oder alles weglassen, die Tests und den Rest wie beschrieben tauschen. Mehr fällt mir da auch nicht ein.
 
interruptor

interruptor

..
Danke für deine Tipps. Das mit der abgelöteten Diode wird ich probieren. Vor dem RAM-auslöten hab ich etwas Respekt. Das Teil hat schon arg viele Beinchen.. Den Spannungsteiler hab ich bei Mouser gefunden, evtl. bestell ich mir dort auch gleich ein neues RAM und Dioden. Muss mal in mich gehen.. :)
 
interruptor

interruptor

..
Spannungsregler hab ich natürlich gemeint. War wohl schon etwas spät.. :)
 
swissdoc

swissdoc

back on duty
interruptor schrieb:
Spannungsregler hab ich natürlich gemeint. War wohl schon etwas spät.. :)
Alles klar, wobei die 5 Volt recht OK aussehen, kann man bei Deinem Bild aber nicht so genau sehen. Du könntest mal auf AC schalten und den Messbereich zoomen. Das sollte dann eigentlich glatt sein, zumindest ist das bei den LM78xx so der Fall.
 
interruptor

interruptor

..
Re: MKS-50 vergisst seine Presets, kopfkra

Das mit dem ranzoomen werd ich machen, bin allerdings die nächsten Tage weg vom Studio. Es dauert also noch ein bisschen..
 
interruptor

interruptor

..
Ich habe den Ausgang des Spannungsreglers (IC 28) nochmals gemessen mit AC-Kopplung und rangezoomt soweit möglich. Das sieht für mich OK aus:

A: Ausgang Spannungsregler (Pin5 von IC28), AC-Kopplung
- vertikal: 200mV je grobe Linie
- horizontal: 200ns je grobe Linie

B: Vdd von RAM, DC-Kopplung
- vertikal: 5V je grobe Linie
 

Anhänge

  • mks-50_ON15_Output@IC28_ACcoupled.jpg
    mks-50_ON15_Output@IC28_ACcoupled.jpg
    185,9 KB · Aufrufe: 62
interruptor

interruptor

..
Hier das Resultat eines weiteren Versuchs: Ich habe die 3V Stützbatterie probeweise ersetzt durch ein separates Netzteil, welches knapp 5Vdc liefert. (Wandwarze, aktuelles Schaltnetzteil) Ich hatte den Verdacht, dass das RAM im Stromsparmodus (Vdd=3V) nicht mehr funktioniert, aber bei vollen 5V zuverlässig ist. Leider Fehlanzeige.. Schaltet man die Hauptversorgung des Synths aus und hält die 5V-Versorgung des RAMs aufrecht, gehen die Presets trotzdem verloren, wenn man länger als ein paar Sekunden wartet.

Im Anhang zwei Bilder:
1.: Einschalten des externen Netzteils
==> Kanal B: Vdd des RAM steigt von 0V auf knapp 5V an
2.: Anschliessendes Einschalten der Netzschalters am Synth:
==> Kanal A: Ausgangs des Spannungsreglers steigt von 0 auf 5V
==> Kanal B: Vdd des RAM steigt wenig an

Interessant, dass die Spikes beim Einschalten des externen Netzteils viel geringer ausfallen, als beim Netzteil des Synths. Ich habe das mehrmals probiert, und dabei das externe Netzteil auch bewusst in die Nähe der Tastköpfe gehalten. Das Resultat war immer in etwa dasselbe.

Nachdem ich die Kondensatoren im Netzteil getauscht habe, und der Spannungsregler ebenfalls gut aussieht, sieht es so aus, als sollte ich tatsächlich die Drossel FL1 in Augenschein nehmen. Ich frage mich allerdings was an einer Drossel kaputtgehen soll, es ist ja nichts weiter als ein gewickelter Draht.. Da ein Unterbruch nicht sein kann, müsste sie einen Kurzschluss haben.
Auf der Primärseite des Netzteils sehe ich eine weitere Drossel FL1 und einen weiteren Kondensator C1. Könnten die evtl. schuld sein?

Das Problem scheint beim MKS-50 häufiger vorzukommen: Auf Gearslutz habe ich einen Thread gefunden, wo zwei weitere Leute an ihrem MKS-50 nach dem Batteriewechsel dasselbe beobachten:
https://www.gearslutz.com/board/electro ... ement.html
 

Anhänge

  • mks-50_ON16 - 3Vbattery replaced by 5Vdc - mainsON.jpg
    mks-50_ON16 - 3Vbattery replaced by 5Vdc - mainsON.jpg
    172,3 KB · Aufrufe: 57
  • mks-50_ON16 - 3Vbattery replaced by 5Vdc - batteryon.jpg
    mks-50_ON16 - 3Vbattery replaced by 5Vdc - batteryon.jpg
    169,1 KB · Aufrufe: 57
swissdoc

swissdoc

back on duty
Gemäss Plan ist in FL1 auch ein Kondensator drinnen, ausserdem können auch Spulen über den Jordan gehen. Das RAM selbst könnte es am Ende auch sein.
Als letzte Verzweiflungstat könnte man einfach alles, was noch alt ist, also die restliche Cs und Dioden etc. tauschen und alle Lötstellen mit frischem Lot nachlöten.
Einen anderen MKS50 als Vergleich heranziehen und Messungen vergleichen wäre auch noch eine Variante, nur dann die richtigen Schlüsse zu ziehen...
 
interruptor

interruptor

..
An einen Vergleich mit einem funktionierenden MKS-50 hab ich auch schon gedacht. Dazu müsste man allerdings erstmal Zugriff auf einen haben.. Für die Drossel war ich nocheinmal bei Pusterla, wurde dort aber nicht fündig. Sieht also nach Bestellung aus dem Internet aus - da könnte ich auch gleich das RAM mitbestellen.
Beim Stöbern im Internet habe ich noch den Hinweis gefunden, dass statische RAMs empfindlich auf negative Spikes in der Versorgung reagieren können. Insbesondere falls VDD bis unter -1V abfällt. Um dies zu verhindern, wäre die Diode D17 vorhanden. Ein genauer Blick an der Stelle könnte helfen, wenn auch die letzten aufgenommen KO-Bilder keine so tiefen Spikes mehr zeigen. Ich werde da noch einmal näher ranzoomen.
Ansonsten habe ich herausgefunden, dass es ein frei Verfügbares CTRLR-Panel für den MKS-50 gibt. Mit CTRLR als VST im Sequenzer konnte ich damit bequem Sounds editieren und sogar die Einstellungen zusammen mit dem Song abspeichern und erneut aufrufen. Eventuell sollte ich besser mit dieser Behelfs-Lösung leben, als das Instrument beim RAM-löten noch komplett zu himmeln.. :-/
 
interruptor

interruptor

..
Ich habe es nun doch gewagt und das RAM auch noch ausgetauscht. Es funktioniert nun alles wunderbar! :huepfling:
Vielen Dank an die lieben Mitglieder, die mir geduldig mit Ratschlägen geholfen haben!
Beim Auslöten hat eine Vakuumpinzette gute Dienste geleistet. Da der identische RAM-Chip schwer zu bekommen ist, habe ich den etwas neueren und schnelleren TC5564APL-15 eingebaut.
 
 


News

Oben