Nonome, Max4Live und 7up – Problem

Dieses Thema im Forum "DAW / Komposition" wurde erstellt von colectivo_triangular, 2. Dezember 2009.

  1. Hallo an alle,

    ich wollte gerade bzw. gestern Abend 5 Stunden lang das Launchpad über nonome dazu verwenden, die 7up Applikation in Ableton Live zu steuern. Das Launchpad funktioniert problemlos als monome-Ersatz, wenn ich beispielsweise genomé oder mlVr starte. Auch die Ansteuerung von Live mit dem Launchpad klappt, sofern ich den genomé Ausgang zur Steuerung bspw. des Operators verwende.
    Habe schon eine Menge probiert und ich vermute, dass es kein großer Akt ist, aber als absoluter MAX-Neuling sind viele Parameter noch böhmische Dörfer für mich.

    Was ich bislang probierte:
    1. Starten von Nonome und Verbindungstest (=funktioniert)
    1 a) Aktivieren des Launchpads in nonome, Aktivieren des session 2 Buttons, die Max4Live Inputs sind in Ableton unter den Preferences aktiviert.
    2. Hereinladen der 7up core anwendung. (=keine Statusänderung, weder beim Launchpad, noch bei der nonome Oberfläche
    3. Manuelles Eintragen der Anwendung „7up“ im OSC-prefix Fenster von nonome. Dort steht \7up. Möglicherweise muss ich etwas anderes eintragen?
    4. In der 7up core Anwendung bleibt alles wie gehabt, lediglich der monome 64 wurde selektiert.
    5. Ein Klick auf „verbinden“ bringt keinen Erfolg, die Lichter des Launchpads bleiben aus.
    6. Als monome seriennummer in der core anwendung ist die vorgegebene 127.0.0.1 (in etwa, sitze gerade nicht vor meinem Musikrechner) eingestellt. Muss ich hier etwas ändern?

    Wäre genial, wenn mir hier jemand weiterhelfen könnte. Über jeden Tipp bin ich dankbar.
     
  2. Servus,
    bist du da weitergekommen?
    Die monome-apps laufen einwandfrei unter nonome, aber die midiclock bei der einbindung in Live ist nicht tight.
    Hab mir grad max4live gezogen und werde es mal probieren...wäre echt toll wenn das sauber läuft.

    mfg
     
  3. bin zumindest einen schritt weiter... Die Kommunikation zwischen 7up und der nonome Software geht jetzt. Dafür kann ich nun nicht mehr das Launchpad aktivieren, sobald ich über Live gehe. Mit anderen Worten: in der Max MSP Runtime Version scheint es zu gehen, innerhalb von Ableton geht es nicht mehr, da ich keinen Treiber (Launchpad) in nonome aktivieren kann.
    Eigenartigerweise fällt der Zeitpunkt in etwa mit dem Ablauf der 30Tage Trial von Max/MSP zusammen. Wohl gemerkt: Max4Live habe ich gekauft. Stand alone funktioniert MAX/MSP allerdings jetzt nicht mehr, da die Downloadversion von MAX ja eine Demoversion ist, auf deren Engine Ableton dann wiederum zurückzugreifen scheint (nur eine Vermutung). Innerhalb Abletons ist alles wie gehabt, nur, dass ich jetzt nicht mehr auf das Launchpad zugreifen kann... Und nonome wiederum öffnet man ja als Patch direkt über MAX/MSP.
    So richtig viel Spaß macht mir das momentan nicht gerade...
     
  4. sushiluv

    sushiluv bin angekommen

    Den nonome patch kannst Du ja miter Max runtime öffnen, da besteht kein grund eine vollversion zu starten.

    dein prefix mit 7up ist schon korrekt, bei mir sind die ports vertauscht, also up war 8000 und down war 8080, oder irgendwie so, deine ip stimmt auch, 127.0.0.1, soweit müsste alles funktionieren.

    lies nochmal die installationsanleitung durch, hast du das projekt exportiert so wie es da steht? externals in die javal lib ordner kopiert?

    was die midiclock angeht, es gibt ein 2.0.1 update das hier recht tight läuft, man muss aber den stopbutton zweimal drücken ordentlich in sync zu starten.

    bei nonome kann ich leider nicht weiterhelfen, hab ein 40h hier.

    die jungs basteln gerade an einer mlr-artigen erweiterung für 7up und die stretta suite solltest du unbedingt mal antesten, es bleibt spannend.
     
  5. Nun mein kleiner workaround:
    Als erstes startet man Ableton Live und zieht 7up in einen freien Midikanal. Danach wird die MAX Runtime geöffnet, nonome geladen und das Launchpad ausgewählt. Hier trägt man als OSCprefix 7up (ohne Slash) ein. Ein doppelter Klick auf Session, zeigt, ob das Launchpad mit nonome kommuniziert (die ersten vier Navigationspfeile leuchten).
    Als nächstes folgt die Konfiguration von 7up. Dort wird monome 64 ausgewählt und die Ports - wie schon beschrieben - eingestellt. Ein letzter Klick auf "connect" und die Anwendung läuft.

    Folgende Punkte sollten beachtet werden:
    1. Einsatz von MAX 5 Runtime, also nicht die MAX/MSP Version aus Ableton Live heraus starten.
    2. Verschieben sämtlicher externals in die Java lib (hatte ich als erstes vergessen). Das steht ausführlich beschrieben in der read me Datei, direkt im 7up File.
    3. Um Verzögerungen zu vermeiden, wie sushiluv bereits schrieb, doppelt auf Stop gehen. Ansonsten kann man die Delayzeit auch im entsprechenden Kanal vorziehen.

    Scheint nun alles zu laufen.

    Danke
     
  6. okay da liegt der hund begraben... :supi:
    habe MAX/MSP Version aus Ableton Live heraus genutzt.
    Hab schon gedacht ich bin einfach zu blöd...(wird sich noch zeigen)
    Mein sonst immer stabiles Live ist gestern sogar gleich drei mal abgekackt...grummel

    ..werd es gleich mal antesten....

    ein dickes Dankeschön !!!
     
  7. heureka-es läuft !!!
    und sogar tight mit midiclock...
    leider schmiert mir live beim speichern eines sets dann ab...stabil ist was anderes...liegt wohl am nonome-app
    bin schon ganz gespannt auf updates und berichte...
     
  8. Anonymous

    Anonymous Guest

    grüsst euch=)

    auch bei mir funzt das launchpad nicht mehr in live nachdem ich nonome etc gebraucht hab... kennt jemand ne lösung?

    lg=)
     

Diese Seite empfehlen