Nvidia Treiber / KVM-Switch Problem

Dieses Thema im Forum "PC" wurde erstellt von sinot, 6. November 2009.

  1. sinot

    sinot Tach

    Ich benutze einen 2x DVI KVM Switch der unter Vista mit Nvidia-Windows-7-BETA Treibern einwandfrei funktionierte. Ich konnte zwischen den beiden Rechner (der zweite hat ebenfalls eine Nvidia Karte aber etwas älter und XP Pro) beliebig hin und herschalten. Mit den Original Nvidia Vista Treibern war das nicht möglich. Da half umstecken, alles raus und wieder anstöpseln, aktuelle Treiber installieren usw. nichts. Mit Windows 7 habe ich nun das gleiche Problem. Ohne installierte Nvidia Treiber funktioniert es, mit installiertem Treiber nicht, ich bekomme kein Signal. Während PC1 hochfährt kann ich auch umschalten, erst wenn die ganzen Treiber geladen werden (sowie meine Vermutung des Schuldigen -> Nvidia Treiber) geht es nicht mehr.

    Die Suche nach einer Lösung hat sich als äusserst schwierig rausgestellt, googeln half mir nicht. Hat jemand auch ein ähnliches oder gleiches Problem gehabt und kann mir vielleicht helfen. Ideen oder Lösungsvorschläge sind selbstverständlich auch willkommen.

    mfg sinot
     
  2. Summa

    Summa wibbly wobbly timey wimey

    Hast du mal probiert die PCs hintereinander hochzufahren, erst PC1 mit aktiviertem Monitor, danach die selbe Prozedur mit PC2. Ich gehe (bisher ungetestet) davon aus dass der Treiber die Monitordaten ausliest und dann nix findet und vielleicht auf 'nen sekundaeren VGA oder HDMI Ausgang umschaltet. Das Problem (allerdings mit ATI-Treiber) hab ich hier auch mit einem manuellen DVI-Switch, wenn ich beim hochfahren mal vergesse den richtigen Monitor auszuwaehlen hilft es meist in den Standby-Modus zu gehen und den Rechner danach wieder aufzuwecken, unter Umstaenden funktioniert das bei dir ja auch.
     
  3. sinot

    sinot Tach

    @summa
    Das hab ich auch schon gemacht, leider läuft nur der PC worauf der Switch von Anfang zugeschaltet war abgesehen vom PC2 wo ich XP Pro drauf hatte. Ich habe aus Neugier auch auf dem zweiten PC Windows 7 installiert und den selben aktuellen Treiber für eine ältere Nvidia Karte. Ich das Umschaltproblem bei beiden Rechner und jetzt bin ich mir sicher das es die Treiber sind so dass ich nach ein Tweak suche womit ich dieses Verhalten von den Treibern ändern kann. Man muss doch so hinkriegen das bei beiden Anschlüssen beständige Signale liegen denn wenn ich umschalte und einen schwarzen Bildschirm vor mir habe heisst das es ist kein Signal da oder wird nicht gefunden, wenn ich allerdings das dazugehörige hintere Kabel am Switch oder das vordere abziehe und wieder anstöpsle, bekomme ich ein Signal so das ich wieder ein Bild habe. Da wird man noch wahnsinnig.....

    mfg sinot
     
  4. sinot

    sinot Tach

    Nach einem ungleichen Kampf der mich zig Stunden gegen die Übermacht an Nvidia-Treiber gekostet hat, gebe ich meine Kapitulation bekannt. Eine Lösung fand ich zwar in Form der Treiber 182.50 (letzte Version der eigenständigen Vista Treiber OHNE die Verschmelzung mit der Windows 7 Kompatibilität aber für Windows 7 benutzt), jedoch waren dieser und alle anderen älteren Treiber geplagt von Latenzproblemen. Ich habe mit einem Latenzcheckprogramm festgestellt das dieser Treiber Soundknackser verursacht haben aber mein Switch funktionierte einwandfrei. Jetzt habe ich die aktuellen Nvidia-Treiber drauf (Bezeichnungszusatz ION) und es läuft mit Musik und Sound alles perfekt nur mein Switch nicht mehr. :?:

    Das einzige was mir bleibt und ich bis jetzt aus dem Internet rausfischen konnte, allerdings weiss ich nicht ob das Teil anderweitig Probleme bereiten könnte:
    http://www.al-kabelshop.de/cgi-bin/...eferer=si_neu&PKEY=050E&Hauptseite=detail.htm

    Es ist wahrlich wie ein elender Fluch der meiner Person ausgesprochen wurde und noch immer anhält.

    mfg sinot
     
  5. Summa

    Summa wibbly wobbly timey wimey

    Wie lange sind denn die Kabel, durch den Switch verringert sich die moegliche Kabellaenge (uebergangswiderstaende etc.), das wuerde erklaeren warum es funktioniert wenn du die Kabel direkt in den Monitor steckst, obwohl dann wuerde es zumindest bei niedrigeren Aufloesungen funktionieren.
     
  6. sinot

    sinot Tach

    Du meinst die DVI-Kabel vom Switch an die GPU, 1,5m aber ob es an den Kabeln liegt wenn ich die älteren Treiber benutze? Mit den neuen Treiber funktioniert es ja ohne das ich da was ändere.

    mfg sinot
     
  7. Phil999

    Phil999 Tach

    double- bzw. erst nach 2 Tagen veröffentlichtes Posting.
     
  8. Phil999

    Phil999 Tach

    das ist eine etwas leidige Geschichte. Ich habe zwei Rechner mit Nvidia-Karten, die beide Dual-Screen haben. Der eine Monitor schalte ich manuell (VGA/DVI), den anderen mit KVM-Switch. Das funktioniert nie so richtig glatt, die Nvidia-Treiber schalten oft auf Single-Screen während des Wechselns. Mit dem letzten Switch gab es noch gröbere Probleme, so musste ich den Switch auswechseln. Keine billige Sache. Also der Avocent KVM-Switch, den ich heute habe, kann ich nicht uneingeschränkt empfehlen, aber er funktioniert immerhin. Wenn Du also nur einen Monitor schaltest, sollte er einwandfrei funktionieren. Mit W7 habe ich allerdings keine Erfahrung, ich war jedoch der Meinung, dass es dasselbe wie Vista ist bezüglich Treiber.
     
  9. sinot

    sinot Tach

    @Phil999
    Das es an den Treibern liegt weiss ich ja, naja das erwähnte ist für mich auch keine 100%ige Lösung, es muss klappen. Wegen so einer Kleinigkeit wird man auch schnell Geld los weil dies oder jenes nicht geht. Auch wenn ich dafür irgendwelche Hardware ausprobiere. Den DVI Detective schau ich mir auf jeden Fall an zumal das Problem bekannt ist und dieses Teil bewusst dafür entickelt wurde. Ich bin nun mal darauf angewiesen da ich nicht alles (Hardware) über einen Rechner machen kann. Alles nur weil eine Firma names Nvidia, etwas funktionierendes aus den Treibern nimmt bzw. weglässt. Aber dafür bin ich jetzt schlauer und weiss, dass es keinen einzigen Treiber von Nvidia gibt, der einwandfrei ohne andere Probleme zu verursachen, funktioniert. ;-)

    Hab den Lindy KVM Switch Lite (dank eines Vorschlags von jemandem hier) der bis jetzt hervorragend funktionierte wo ich noch Vista "Nvidia Windows 7 Beta Treiber" gehabt habe aber Vista mach ich mir auf keinen Fall drauf und XP ist veraltet sowie zu langsam (aber mit XP geht alles). Suchen und testen...... es geht immer weiter :-x

    Also Windows 7 ist nicht dasselbe wie Vista, zwar wurden durch die Service Packs viele mir bekannte Fehler ausgebügelt aber W7 ist da wirklich runder und stabiler. Sidebar ist und man kann Gadgets frei positionieren (wer keine Gadgets benutzt verpasst was). Ich hatte bis jetzt nur 1 Bluescreen im Laufe meiner Treiberexperimente :mrgreen:
    Nur eines MUSS endlich aufhören, das ständige neustarten nach irgendwelchen Installationen sowie das Anwendungen das System einfrieren können.

    mfg sinot
     
  10. Summa

    Summa wibbly wobbly timey wimey

    Hmmm... ist bei mir unter Vista als erstes rausgeflogen, genau wie Aero Glass. Verpasse ich da was wichtiges?
    Bin was die Benutzeroberflaeche betrifft nur wenig verspielt, schliesslich will ich mit dem Geraet arbeiten, da saugt jedes im Hintergrund laufende Programm unnoetig Speicher und Prozessorleistung, die ich im Zweifelsfall zum Musik machen oder Soundbau brauchen koennte.
     
  11. Phil999

    Phil999 Tach

    leider kann ich Dir da nur viel Glück wünschen. Wo ich wohne gibt es öfters mal Stromunterbrüche, und ich kenne das mit dem Abschalten und Ausstecken, bis die Sache wieder läuft. Ekelhaft.
     
  12. sinot

    sinot Tach

    In Windows 7 sieht man die Sidebar nicht mehr, der ganze Desktop ist die Sidebar und das Programm läuft im Hintergrund.
    Es gibt ein Gadget was sich Application Launcher nennt, sehr praktisch da man dort die Symbole (.exe) sprich alle möglichen Anwendunge ablegen kann und bequem sowie platzsparend irgend wo auf dem Desktop positionieren kann, finde ich unerlässlich. Desweiteren ein Gadget womit man mit einem Klick auf ein Symbol Neustarten, Herunterfahren, Ausführen usw. starten kann, man spart sich Zeit und Klicks. Oder der Notizblock. beim hochfahren gleich ersichtlich um Dinge nicht zu vergessen die man nicht vergessen möchte. Gibt aber noch viel mehr und dürfte für jeden was dabei sein was er gut finden wird, sofern man mal etwas rumschaut und probiert. Ist irgendwo auch ne Übersichtssache. Kann ich nur empfehlen! :nihao:

    USB-Stick als Readyboost und schon hast du Speicher. :mrgreen:

    mfg sinot
     
  13. Summa

    Summa wibbly wobbly timey wimey

    Ich bin mit meinem System oft genutzte Programme zu starten, bei dem ich einfach Links in Ordner (Audio, Internet, Tools etc.) auf dem Desktop packe, an sich recht zufrieden und wenn ich noch mehr Zeit sparen will kopier ich denk Link in die Schnellstartleiste oder leg den Start auf 'ne F-Taste.

    Ich glaub das mit dem Readyboost hast du nicht ganz verstanden, das bringt dir unter Umstaenden schnelleren Zugriff auf den Cache, trotzdem bleibt swappen langsamer als die Nutzung von freiem Arbeitsspeicher.

    http://de.wikipedia.org/wiki/ReadyBoost
     

Diese Seite empfehlen