Studio One - Midi to Audio - Latenz

rolandos
rolandos
..
Hallo Zusammen,

uff also aktuell raufe ich mir die Haare und komme mit dem Thema Latenz und DAW auf keinen grünen Zweig.
Das Problem ist schnell erklärt - ich möchte meine externen Synths bzw. Midi Spuren bouncen und mit Audio Tracks weiter arbeiten.
Dabei habe ich ständig mit Abweichungen zwischen Midi und Audio zu kämpfen.

Gerade wenns um Timing relevante Themen innerhalb des Tracks geht, laufen mir die Spuren total auseinander.
Ziel ist es, dass ich den Midi Track einfache bounce und gleich damit weiterarbeiten kann, ohne nochmal das Timing anzupassen etc.

Ich arbeite mit Studio One 5.5. Nach etwas hin und her, hat mir der Presonus Support den Tipp gegeben mit dem Midi Offset zu arbeiten.
Also pro Midi Spur/Synth den Offset ermitteln und dann den Verzögerungswert in den Spursettings hinterlegen.
Da verschiede Synths unterschiedliche Midi „Laufzeiten“ haben, sei das notwendig und sollte im DAW Template entsprechend hinterlegt werden.

Erste Frage – ist das generell richtig so? Ehrlich gesagt hatte ich mir da noch nie so detailliert Gedanken gemacht.
Leider ist es so, dass bei einem DAW Neustart das Ganze wieder von vorne losgeht. Die Offsets passen plötzlich wieder nicht, obwohl vorher alles kalibriert hatte.

Ich tippe mal auf die Initialisierung des Midi Interface – wenn das geschieht wird anscheinend das Timing neu „gewürfelt“.

Setup (Win11, i7 12700k, 32GB / Midi Interface ESI M8U xe 16 / Audiointerface Focusrite Clarett8+)

Bin ich mit dieser Idealvorstellung, dass alles schön im Timing ist aufm Holzweg oder sollte nach dem Bouncen immer nochmal manuell im Audiotrack alles angepasst werden?
Oder passt hier mit meinem Setup grundsätzlich was nicht? Ein anderer Ansatzpunkt wäre der Audio Offset, hier spielt aber dann das Thema Buffersize noch mit bzw. wrids dann richtig tricky.

Danke im Voraus…

Grüße
Roland

1653037686680.png
 
starcorp
starcorp
||||||||
also, ich würd immer ein Midi interface im Audio Interface vorziehen. Gerade wegen des Timings (Jitter).
Aber nun hast du zwei Usb Interface die vom Betriebssystem unterschiedlich eingetaktet (timestamp) werden.
Bist du denn auch sicher das diese zwei Geräte jeweils einen eigenen unabhängingen USB Port im Rechner bekommen haben?
Leider wird es immer so sein, mit jedem Start verändert sich die Prioisierung der beiden USB Geräte.
Also jede Session neu kalibrieren.
 
Zuletzt bearbeitet:
verstaerker
verstaerker
*****
also, ich würd immer ein Midi interface im Audio Interface vorziehen. Gerade wegen des Timings.
Aber nun hast du zwei Usb Interface die vom Betriebssystem unterschiedlich eingetaktet werden.
Bist du denn sicher das diese zwei Geräte jeweils einen unabhängingen USB Port im Rechner bekommen haben?
Leider wird es immer so sein, mit jedem Start verändert sich die Prioisierung der beiden USB Geräte.
Also jede Session neu kalibrieren.
ich glaub das ist der so ziemlich größte Unfug den ich jeh dazu gelesen habe .
Warum das mit Studio One problematisch ist, kann ich allerdings nicht beantworten, ich kenne das Programm nicht.
 
starcorp
starcorp
||||||||
Du könntest auch versuchen im Taskmanager den Tasks der Interface per Hand (mit rechtem Mausklick)
eine höhere Priorität zu zuweisen.
Aber ob es bei deinem Problem hilft weiß ich nicht.
Die Latentz in deinen externen Synths ist immer gleich, daher macht das abspeichern für das jeweilige Template
eigentlich auch Sinn.

Hast du die externen Synths per USB an den Hub vom Esi angeschlossen oder per midi Din?

Ein älterer Tread, aber müsste dein Problem sein:

 
Zuletzt bearbeitet:
rolandos
rolandos
..
OK, Danke für die Anregung. Die Prio Einstellung checke ich mal. Ansonsten habe ich m. PC schon Audio optimiert und die Hinweise von Steinberg oder Focusrite berücksicht.
Also USB Energiespar Optionen deaktivieren usw.

Mich wunderts eigentl. dass nicht der Rest der Welt auch damit zu kämpfen hat. Alle haben Synths und irgendwann wird’s ja recorded und sollte voll im Grid sein, z.B. mit den Drum Spuren.
Technisch gesehen ist eine Laufzeit ja verständlich. Wie arbeitet ihr eigentlich damit? wenns ans Mixen geht?

Die Latenz scheint auch bei den Synths unterschiedlich zu sein und daher gibt’s wohl auch einen Offset pro Spur. Ich würde auch sagen dass das Thema DAW Hersteller unabhängig ist, der Sachverhalt ist ja immer der gleiche.

Das ESI Interface ist per USB 3 am PC angeschlossen und die Synths sind quasi über DIN sternverkabelt. Also keine Thru Ketten etc.

Ich denke dass mein Mainboard nur einen USB Controller hat, so wie die meisten PCs. Hatte auch schon im BIOS USB Legacy deaktiviert und hier getestet. Keine Besserung etc…
 
verstaerker
verstaerker
*****
Die Latenz scheint auch bei den Synths unterschiedlich zu sein und daher gibt’s wohl auch einen Offset pro Spur. Ich würde auch sagen dass das Thema DAW Hersteller unabhängig ist, der Sachverhalt ist ja immer der gleiche.
Ja das ist völlig korrekt. Wieso das in Studio One immer zurück gesetzt wird scheint mir ein Bedienungsfehler der Software zu sein oder vielleicht irgendein blöder bug.
Schreib doch mal dem Support?
 
verstaerker
verstaerker
*****
Mich wunderts eigentl. dass nicht der Rest der Welt auch damit zu kämpfen hat. Alle haben Synths und irgendwann wird’s ja recorded und sollte voll im Grid sein, z.B. mit den Drum Spuren.
Technisch gesehen ist eine Laufzeit ja verständlich. Wie arbeitet ihr eigentlich damit? wenns ans Mixen geht?
mal davon abgesehen das ich alles nur als eine fertig gemixte Stereospur aufnehme... kann man ja in der DAW auf die eine oder andere Weise mit externen Synths u Effekten arbeiten und deren Latenz einstellen.
In Ableton Live würde ich mich wohl eine Template-Projekt mit allen Synths inkl der korrekten Latenz speichern .
 
rolandos
rolandos
..
:) schon gemacht und warte auf Antwort. Den Midi Interface Hersteller habe ich auch schon angeschrieben und warte auf Feedback. Hast du beim Mixdown auch eine Latenz? wie löst du das z.B. in Cubase oder Ableton..
 
starcorp
starcorp
||||||||
da bist du nicht der einzige!
User @offebaescher hatte es glaube ich dann mit einer ERM Clock als Master für alle gelöst.
Ich umgehe das so, ich sequence mit der Force, alles hängt als Slave an dieser.
Synths, Digitakt, ein macbook (Mainstage), Modular Kram...
Erst wenn ein Arragement steht, nehme ich alles in S/one auf Einzelspuren auf und arbeite mit denen weiter.
Wir hatten es damals auch mit der Einbindung von S/one versucht, aber es war ein einziges rumgeeiere.
Wenn wenigsten die Versätze immer gleich bleiben würden ... Aber nee.
 
Zuletzt bearbeitet:
offebaescher
offebaescher
neu hier
schwieriges thema.. multiclock macht es aber wirklich einfacher ;-)
 
verstaerker
verstaerker
*****
Hast du beim Mixdown auch eine Latenz? wie löst du das z.B. in Cubase oder Ableton..
ja Midi->Synth->Audiointerface->Daw .. diverse Stellen wo Latenz aus verschiedenen Gründen entsteht.

meine Lösung ist eine Mischung am Pult.. unterschiedliche Latenzen verschiedener Synths und Sequencer werden mit 2 Multiclocks ausgeglichen.
 
rolandos
rolandos
..
hmm das Hobby wird immer teurer - ich dachte eigentlich dass ich keine Multiclock brauch. Hmm muss mich da mal einlesen was das für die Midi Verkabelung heißt. Wie ist das dann mit meinem Midi USB Interface was m. Midiverteiler darstellt. Wie schaut dann die Verkabelung aus? ERM - da gibts ja ein kleine + große Variante....
 
verstaerker
verstaerker
*****
hmm das Hobby wird immer teurer - ich dachte eigentlich dass ich keine Multiclock brauch. Hmm muss mich da mal einlesen was das für die Midi Verkabelung heißt. Wie ist das dann mit meinem Midi USB Interface was m. Midiverteiler darstellt. Wie schaut dann die Verkabelung aus? ERM - da gibts ja ein kleine + große Variante....
nein du brauchts keine Multiclock um ein brauchbares Setup hinzubekommen. Damit machst du ein ganz neues Faß auf.
Dein Setup müsste eigentlich funktionieren. Versuche bitte die Lösung zu finden warum sie die Latenz immer wieder verstellt. Ich bin der Meinung das muss ein Studio One Problem sein.
 
microbug
microbug
MIDI Inquisator
Wie wärs denn mit einem MIO XM oder XL und MIDI über Ethernet statt USB? Das vermeidet zumindest bei MIDI die USB Problematik.

Die ESI Interfaces sind vom Timing her ansonsten absolut sauber, natürlich sollte man unter Windows den Treiber installiert haben (auch wenn man nicht muß, aber alleine schon wegen Multiclient und so).

Ob Dein Mainboard nur einen USB Controller hat, kannst Du mit Hardware-Infotools wie Aida64/EverestHome von Lavalys oder "System Information for Windows" (SIW) bzw "Belarc Advisor".

Denk auch dran, daß Du das gespeicherte Template in Studio One auch laden mußt (bei neuer Song, Reiter "User"), das passiert nicht automatisch.

Ich setze Studio One nur selten unter Windows ein. Hier könnte evtl @Synthmill helfen, der hat Studio One auf Windows bzw es lange auf dieser Plattform genutzt.
 
Zuletzt bearbeitet:
DefSteph
DefSteph
||
hmm das Hobby wird immer teurer - ich dachte eigentlich dass ich keine Multiclock brauch. Hmm muss mich da mal einlesen was das für die Midi Verkabelung heißt. Wie ist das dann mit meinem Midi USB Interface was m. Midiverteiler darstellt. Wie schaut dann die Verkabelung aus? ERM - da gibts ja ein kleine + große Variante....
Die ERM hilft eigentlich nur, wenn man Hardwaresequencer zur DAW synchronisieren möchte. Werden die Noten von der DAW getriggert verhält sich die Multiclock wie ein schnödes USB-Midi-Interface - wenn auch ein gutes. Man kann DAW Controllerdaten und Noten zwar mit dem Clocksignal mischen, aber das bringt gar nichts bezüglich der Tightness der Noten. Der einzige Vorteil des Mischens hat man nur, wenn die Noten im Sequencer des jeweiligen Hardwaregerätes befinden und von der DAW z.B. MIDI-CCs zugemischt werden sollen.
Vielleicht verhält sich die Multiclock beim durchschleusen der MIDInoten von der DAW besser als manch anderes MIDI Interface, aber eine Garantie gibt es nicht.
Einen konstanten Versatz zu kompensieren ist auch ohne Multiclock möglich. Bei Ableton funktioniert das wunderbar über das External Instrument. Aber Jitter (Schwankungen die nicht vorhersehbar sind) kann auch die Midi-Interface-Funktion der Multiclock nicht beseitigen. USB-Midi ist ein graus. Wahrscheinlich ist eine alte PCI-Karte mit MIDI tighter als das schwammige USB-MIDI. Das ist der bereits genannten Priosierung von MIDI auf WIN und MAC geschuldet.
Also Multiclock nur, wenn Du vor hast Hardwaresequencer, Drummachines oder Grooveboxen, wo die Noten im eigenen Sequencer programmiert sind, zur DAW synchronieren willst.
Wie microbug oben vorschlägt: Weg von USB-MIDI... MIDI-Interfaces mit Ethernet-Protokoll könnte Abhilfe schaffen.
 
Perry Staltic
Perry Staltic
||||||||||||
Früher habe ich auch mal mit negativer Spurverzögerung gearbeitet, mittlerweile stelle ich vor der Aufnahme einfach die Latenz bzw. die Puffergröße des Audiointerfaces soweit runter, dass es noch nicht knackst (eventuell im Projekt geladene Plugins temporär deaktivieren!), der Synth aber ohne hörbare Verzögerung aufgenommen wird.
 
verstaerker
verstaerker
*****
Früher habe ich auch mal mit negativer Spurverzögerung gearbeitet, mittlerweile stelle ich vor der Aufnahme einfach die Latenz bzw. die Puffergröße des Audiointerfaces soweit runter, dass es noch nicht knackst (eventuell im Projekt geladene Plugins temporär deaktivieren!), der Synth aber ohne hörbare Verzögerung aufgenommen wird.
und was ändert das an der Latenz die die Synths selbst haben? Also von Eintreffen Midinote bis Ausgabe Ton.
 
Perry Staltic
Perry Staltic
||||||||||||
Die scheint zumindest bei meinen Geräten vernachlässigbar zu sein, denn sonst würde ich mit der oben genannten Methode ja nicht zu brauchbaren Ergebnissen kommen...
 
TopperHarley
TopperHarley
as himself
nur mal zur Grundlagenforschung: du hast schon den richtigen Audio-Treiber ausgewählt und die Buffergröße angepasst?
 
rolandos
rolandos
..
…so das WE habe ich nochmal Stunden damit verbracht die Sachlage zu checken. Danke nochmal an DefSteph dass die ERM hier keine Abhilfe schafft.
Der Presonus Support hat sich mittlerweile gemeldet.
Hier wurde auf Midi Jitter hingewiesen bzw. dass ich mit der Transienten Erkennung arbeiten soll, um den Versatz zu kompensieren.
Hmm nicht so prall bzw. weiß ich jetzt schon dass ich mir darin dann verliere.

Mein Mainboard habe ich auch schon unter die Lupe genommen und mit ein paar BIOS Settings gespielt. Keine Änderung.
Wie es aussieht hat mein ASRock z690 pro rs nur einen USB Controller on Board – ggfs. hilft hier eine separate USB Karte, ist aber eine reine Vermutung.

Ansonsten…
  • In Studio One bleiben im Projekt die vorher ermittelten Offsets abgespeichert - hier muss ich mit -21ms arbeiten damit ich einen Synch habe..uff ganz schön viel
  • Nach einem DAW Neustart passen die vorher eingestellten Offsets gar nicht mehr.
  • Mein Test Synth ist ein Waldorf Pulse

  • Zum Thema Buffer Settings / hier gibt es ja zwei Schräubchen, einmal die Einstellungen (Audio Device) hier hatte ich schon bis auf 16 Sampels / ~2,5ms getestet und der Midi/Audio Versatz wird kaum bzw. minimal besser. Wenn ich die (Processing – Dropout Protection) Settings ändere, also da wo die Audio Roundtrip Time ermittelt wird, sieht es schon anders aus. Je niedriger die Dropout Protection eingestellt wird z.B. von high auf -> medium, wird der Versatz Midi/Audio deutlich höher.
  • -> Öhmm Frage ist das in dem Zusammenhang logisch? Eigentl. nehme ich ja nicht das von der DAW verarbeitete Audiosignal auf, sondern das was vom Interface rein kommt. Mithören ist aber deaktiviert…

  • Die Tatsache dass sich der Offset immer dann verstellt wenn die DAW neu gestartet wird, bleibt aber erhalten. Glaube dass das definitiv mit dem USB Windows Priorisierung zu tun hat.

Leider ist das Setup relativ neu und eine neues Midi Interface mit Netzwerkanschluss ist budgetmäßig nicht mehr drin…..evtl. muss ich damit leben und die Audiospur manuell korrigieren.. :-/
 
Perry Staltic
Perry Staltic
||||||||||||
  • In Studio One bleiben im Projekt die vorher ermittelten Offsets abgespeichert - hier muss ich mit -21ms arbeiten damit ich einen Synch habe..uff ganz schön viel
  • Nach einem DAW Neustart passen die vorher eingestellten Offsets gar nicht mehr.
Das heißt, wenn Du das entsprechende Projekt lädst, dann werden auch Deine ermittelten Offsets mitgeladen? Dann leg Dir doch ein leeres Template mit eben diesen Offsets an. Dieses lädsts Du, wenn Du einen neuen Song beginnst. Oder habe ich Dich falsch verstanden?
 
starcorp
starcorp
||||||||
  • Zum Thema Buffer Settings / hier gibt es ja zwei Schräubchen, einmal die Einstellungen (Audio Device) hier hatte ich schon bis auf 16 Sampels / ~2,5ms getestet und der Midi/Audio Versatz wird kaum bzw. minimal besser. Wenn ich die (Processing – Dropout Protection) Settings ändere, also da wo die Audio Roundtrip Time ermittelt wird, sieht es schon anders aus. Je niedriger die Dropout Protection eingestellt wird z.B. von high auf -> medium, wird der Versatz Midi/Audio deutlich höher.
  • -> Öhmm Frage ist das in dem Zusammenhang logisch? Eigentl. nehme ich ja nicht das von der DAW verarbeitete Audiosignal auf, sondern das was vom Interface rein kommt. Mithören ist aber deaktiviert…
ist schon logisch, da wird sich S/one mehr Ressourcen im Systhem sichern, dadurch geht natürlich auch die CPU Belastung hoch.
Probier doch mal ne USB PCI/e, kostet ja nicht die Welt. Vielleicht muss dann das Systhem nicht so mit der variablen USB Bandbreite jonglieren.
Gibt ja durchaus Interfaces die zickig darauf reagieren keinen USB Host nur für sich zu haben. (Maschine MK3 zB.)
 
rolandos
rolandos
..
Das heißt, wenn Du das entsprechende Projekt lädst, dann werden auch Deine ermittelten Offsets mitgeladen? Dann leg Dir doch ein leeres Template mit eben diesen Offsets an. Dieses lädsts Du, wenn Du einen neuen Song beginnst. Oder habe ich Dich falsch verstanden?
hast du schon richtig verstanden, nur ist es so dass die ermittelten Offsets beim nächsten Öffnen des Projektes nicht mehr passen. Das Ganze ist dermaßen instabil dass die ermittelten Offsets nur während einer laufenden Session stimmen.
Wenn ich das Projekt speichere und dann wieder öffne, muss der Offset neu gemacht werden da die letzten ermittelten Werte wieder daneben liegen.... - saunervig!
Mittlerweile hat sich ESI gemeldet und hier auf die Latenzen des Audio Interface hingewiesen... :) wenn ich Focusrite noch mit einschalte, verweisen die wahrscheinlich dann auf ESI :)))
Also das mit der PCIexpress USB Karte werde ich mal testen....
 
aliced25
aliced25
0x7F6990 & 0xFFEF
Die Latenz summiert sich für gewöhnlich an drei Stellen. Als erstes kommt es bei Midi protokollbedingt zu einer Verzögerung von min. 1ms. Solange braucht ein Midi Befehl 3 Byte (u.U. 2 Byte) bei 31250 Baud um versendet zu werden. Für gewöhnlich kann Jitter im Bereich von Noten Informationen vernachlässigt werden, da sich dieser nicht wie bei einem Midi Clock Signal auf Dauer aufsummiert. Auch wenn USB nicht die Ideale Schnittstelle ist, würde ich den Fehler hier eher nicht vermuten.
Der Synthesizer selber, hat auch eine gewisse Latenz (manche sogar erheblich, vgl. Litmus test).
Mit einem relativ simplen Test kannst Du diese beide Quellen ausschließen, indem Du einen Lautsprecher in unmittelbarer nähe am Synthesizer anschließt und laut auf ein Midikeyboard klickst (Ein entsprechend kurz gehaltener Klicksound eignet sich im Synthesizer am besten). nimm das Szenario mit dem Mobiltelefon auf und vergleiche, ob es dort eine Latenz gibt (Die Abstände der Geräte sollten so nah wie möglich sein, um Schalllaufzeiten so gering wie möglich zu halten).
Falls hier keine nennenswerte Latenz auftritt wird es vermutlich am Audiointerface liegen bzw. an der Kombination aus DAW, Interface und Computerschnittstelle.
 
 


Neueste Beiträge

News

Oben