Sync Problem Virus B mit Live 6.05

Dieses Thema im Forum "DAW / Komposition" wurde erstellt von axens, 23. April 2007.

  1. axens

    axens Tach

    Ich habe mir einen Virus B zugelegt und habe nun ein seltsames sync Problem in live. Die Latenzkompensation funktioniert nicht, wenn ich den Virus von Ableton aus ansteuere. Bei meinen anderen Geräten funktioniert die globale Latenzkompensation jedoch einwandfrei. Nur beim Virus reagiert sie überhaupt nicht und die Noten hinken ca 140 ms hinterher, wie ich durch das Trackdelay feststellen konnte. Habe schon unterschiedliche Midiinterfaces ausprobiert, jedoch auch da funktioniert es nicht.
    Steuere ich hingegen den Virus direkt mit der Machinedrum an, so ist alles 100 Prozent tight.

    Bestimmt ist es mal wieder nur eine Kleinigkeit, aber ich komm einfach nicht drauf. Hab bei Ableton alles überprüft. Haken bei Latenzkompensation, das richtige Midiinterface, und bei output an der globalen Latenz geschraubt...

    Habt ihr eine Idee?

    P.S. Mit dem Microkorg am selben Interface lief alles!
     
  2. Anonymous

    Anonymous Guest

    Hm, die Globale Latenz hat nur mit Audio zu tun...

    Du schreibst hier aber nur über Midi. Versteh ich dich da richtig?
    Da musst du es über das Trackdelay einstellen, so wie du es schon getan hast, warum allerdings 140 ms ist mir schleierhaft?! :?:

    Theoretisch ist es nicht möglich, dass dein Microkorg das gleiche Signal sync spielt und der Virus 140 ms verspätung hat!!!

    Ich habe bei Midi 0-3 ms Latenz

    Und die Globale Latenzkompensation kommt eigentlich erst zum Spiel wenn du das Audiosignal vom Virus direkt in dein Interface und somit in Ableton reinroutest(z.B für effekte von Ableton), dann müstet du den Midikanal um die Einganslatenz nach vorne schieben und das geht wieder über das Trackdelay..
     
  3. axens

    axens Tach

    Ah ok mein Denkfehler war, dass die Latenzkompensation sich ja nur auf die Clock auswirkt.
    Ich hab es grad nochmal im direkten Vergleich probiert mit Microkorg und Virus, über das Multiface. Habe bei beiden die gleiche üble Latenz beim anspielen der synths mit einer midispur.

    Ja, bei mir läuft alles direkt in die Soundkarte und wird über live abgehört. Dieser hohe Wert von 140 ms ist echt komisch. woher kann das bloss kommen. Meine Buffersize steht auf 256, aber selbst wenn ich sie auf 32 runterschraube bekomme ich keine brauchbare latenz...
     
  4. dns370

    dns370 Tach

    Mal ne andere Frage: hast du irgendetwas anderes am Rechner laufen was sehr ressourcenintensiv ist?
     
  5. axens

    axens Tach

    Hm ne nichts besonderes, hab auch schon gerebootet, aber es ist immer das selbe
     
  6. dns370

    dns370 Tach

    und wie hast du die MIDI-Clock eingestellt -- ich verwende beispielsweise FL-Studio und da kannst du unter Midi-Options den Synchronisationstyp einstellen: MTC 29,97 fps ... das synchronisiert bei mir ordentlich

    ich hatte ursprünglich mit der normalen MIDI-Clock gearbeitet mit dem Ergebnis: Schwankungsbreite von +/- 5 BPM ...da hat überhaupt nichts synchron geklungen
     
  7. escii

    escii Tach

    Midiproblme ggf. mit midiox mal monitoren.
    Wegen Porgrammenim Hintergrund, einfach mal Windows +r drücken und dann msconfig eingeben. Dann mal alles unnötige deaktivieren und den Rechner neu starten.
     
  8. axens

    axens Tach

    ok, von dem midiox hab ich schonmal was gehört, das werd ich nachher mal ausprobieren. Aber was Sachen im Hintergrund angeht, da ist mein Rechner eigentlich ganz gut auf Audio abgestimmt. Die Probleme habe ich auch erst seit kurzem. Ein Gedanke wäre noch das es vielleicht an dem neuen Treiber vom Multiface liegen könnte, weil ich seit dessen installation vor ca einem monat, nichts mehr mit externen synths gemacht habe...

    @dns: Also bei Ableton ist das etwas anders, wüsste nicht was ich da noch umstellen könnte... Habe da aber auch nichts verändert und bis dato liefs ja auch

    Thx an alle schonmal. Mal schauen was Midiox bringt!
     
  9. axens

    axens Tach

    Also, hab mir jetzt mal reaper gezogen als shareware um zu sehen ob es vielleicht an live liegt. und siehe da, es funktioniert mit reaper einwandfrei. die latenz verändert sich je nach buffersize und ist bei kleinem buffer auch unter 3 ms. Arg also liegts mal wieder an live...

    EDIT:

    Hab im Live Forum gelesen und festgestellt, es liegt daran, dass wenn man durchschleift, also die audiospur auf auto oder in steht, dann hat man die fiese latenz. nimmt man allerdings auf und hat es während dessen auf off stehen, dann ist das aufgenommene perfekt im sync...
     
  10. Anonymous

    Anonymous Guest

    Hier werden viele verschiedene Sachen vermischt!!!

    MidiClockSync

    Globale Latenz

    Trackdelay

    Sind 3 Unterschiedliche Sachen und haben alle nur indirekt miteinander zu tun, müssen aber alle richtig eingestellt werden für ein funktinierendes Setup...

    Monitor Off stellt man ein wenn man eine Aufnahme von einem mit Midi synchroniserten oder angesteuerten Instrument machen möchte, diese Aufnahme wird dann automatisch um deine Einganslatenz nach vorne geschoben.
    Um die Aufnahme trotzdem abzuhören solltest du sie über deine Soundkarte oder über deinen Mixer abhören.
    Wieso? weil man bei einer Aufnahem von einem direkt (live)eingespielten (und reingerouteten) Instrument automatisch zu früh spielt und so keine Verschiebung nötig ist.
    Hast du diese Latenz nur bei Aunahmen? dann ist Monitor Off die Lösung, 140ms ist trotzdem komisch, denn das enstpricht nicht 256 samples.

    Mit der MidiClock in Live hab ich die Erfahrung gemacht, dass diese erst ab einem System mit einer Buffersize von ca < 800 (vielleicht auch 512?)samples tight und ohne Schwankungen läuft.
    hatte mehrere Laptops und hab jeweils mit einer MachineDrum ausgemessen und gemerkt, dass ab etwa dieser Einstellung die Clock jeweils ohne (bzw nur mit minimen) Schwankungen läuft...
     

Diese Seite empfehlen