Wie funktioniert die Envl Schaltung der TB303?

Dieses Thema im Forum "Lötkunst" wurde erstellt von intercorni, 9. September 2009.

  1. Hallo,

    ich habe hier einen Nachbau der Roland TB303 in Form der ML303, welche bis auf den Sequencer
    auf den originalen Schaltungen der TB303 basiert.
    Leider läßt sich bei meinem Modell nicht die Decay Zeit einstellen, es wird also ein fester
    Decay Wert ausgegeben, auch wenn ich dabei fleißig am Decay Poti drehe.
    Nun bin ich kein Elektronik-Schaltungs-Experte. Darum meine Frage: die Envelope Schaltung
    sieht recht simpel aus und eigentlich kann der Grund für das nicht reagierende Decay Poti
    nichts kompliziertes sein. Wie funktioniert also die Schaltung genau? Und was sollte in der
    Schaltung das Decay Poti bewirken? Sicherlich das Entladen des Kondensators?
    Am Prüfpunkt zischen Q40 und Q39 sehe ich auf dem Oszi einen Impuls, welcher sich
    jedoch nicht ändert, wenn ich am Decay Poti drehe :sad:
    Wie kann ich die Fehlfunktion weiter eingränzen? Freue mich über jegliche Tipps.

    Danke :)

    [​IMG]

    [​IMG]
     
  2. kobayashi

    kobayashi aktiviert

    r123 (1,2m müsste das sein) gegen 1m poti tauschen. damit hast du dann nen vca decay!

    der decay ist bei der tb303, ml303, acidlab und sonstigen clones nur für den vcf, nicht für den env.

    klingt bescheuert, is aber so! :nihao:
     
  3. Da verstehst Du etwas falsch! Mit Decay steuert man eine rudimentäre Hüllkurve. Und genau diese läßt sich
    bei mir nicht einstellen. Ich muss beim Aufbau also einen Fehler gemacht haben und genau diesen versuche ich,
    einzugrenzen. Und genau darum muss ich wissen, was genau in dieser Schaltung passieren sollte.
    Wenn ich also am Poti drehe und den Impuls auf dem Oszi betrachte, sollte sich dieser auch verändern lassen.
    Doch leider zeigt das Decay Poti keinerlei Einfluss auf die Hüllkurve, das Decay bleibt also immer gleich lang.
    Was kann das sein?
     
  4. Hat keiner einen Tipp für mich?
     
  5. Anonymous

    Anonymous Guest

    Hängt das am langsamen oder am schnellen Ende?

    Das Poti wird vom Decay CMOS-Schalter (IC12 Pin 3 und4) für den Accent überbrückt.
    (Pin 3 von IC12 aus der Fassung biegen, geht es dann?)
     
  6. Hallo Fetz,

    ich habe Pin3 von IC12 aus der Fassung gebogen und noch einmal den Oszi angeschlossen.
    Regel ich nun das Decay Poti von Null auf den maximalen Wert, so verändert sich lediglich
    die Amplitude des Impulses, nicht aber die die Ausschwingzeit, welche laut Schaltplan bei
    max. 2,5 sec liegen soll. Das Decay sollte einen minimalen Wert von 200ms bei zugedrehten
    Poti und max 2,5 Sekunden bei aufgedrehten Decay Poti haben. Aber wie gesagt ändert
    sich bei ausgehebelten Pin 3 lediglich die Amplitude der Hüllkurve.
     
  7. IC12 ist bei mir übrigens ein HEF4066BP - hoffentlich der richtige Typ?
     
  8. Bin immer noch nicht weiter gekommen. Freue mich über jede Hilfe!
     
  9. Anonymous

    Anonymous Guest

    HEF4066 ist richtig. (Es darf nur kein 74HC4066 sein.)

    Wie lang ist deine Hüllkurve denn jetzt?
    Ich erwarte am ehesten, das sie an einem der beiden extrem klebt - 200ms oder 2,5sec, dort aber 'richtig' aussieht. Stimmt das?
     
  10. Hallo Fetz,

    da bin ich schon einmal beruhigt, dass der IC Typ stimmt.
    Und ja, die Hüllkurve ist auf den kleinsten Wert, lässt sich nicht vergrößern.
    Momentan sollten das ca. 200ms sein.
     
  11. Wenn du 200ms misst, dann entlädt sich C62 wohl nicht durch das Poti. Hast du den Widerstand vom Poti gemessen? Vielleicht ist da drin was kurzgeschlossen?
    Ich mag mich nicht mehr so ganz daran erinnern, aber: Wir hatten mal Probleme mit den Potis in der V6 und deren Masseverbindung am Potigehäuse. Da hatten manche Probleme damit. Wenn die nicht schön in der Platine sitzen kann das zu Kurzschlüssen führen...
     
  12. Das ist eine gute Idee, dann werde ich als nächstes mal das Poti ausmessen.
     
  13. Ich habe das Decay Poti einmal ausgelötet. Laut Aufdruck hat es 1M jedoch zeigt mein Messgerät gerade mal 800K an. Kann das hinkommen?
     
  14. Jup, des kommt (leider) hin. Bei Potis kannst du schon mit 20% (manchmal sogar 30%) Toleranz rechnen...
    Interessant is jetzt nur, ob der Poti kaputt - i.S.v. "stecken geblieben" is (vielleicht is ja der Schleifer abgefallen oder was weiss ich) - oder ob es zumindest von 0 auf 800k schleift. Dann hätt ich das Gefühl, dass es auch nicht am Poti liegt...
     
  15. Das Poti regelt ok, daher von 0 auf ca. 800K. Also kann es dann leider nicht am Poti liegen.
    Dann werde ich als nächstes wohl mal die Widerstände auslöten und nachmessen müssen.
     
  16. Anonymous

    Anonymous Guest

    Sowas kann gerne auch mal ein Lötklecks zwischen zwei Beinchen sein.
    (Ist einer der häufigsten Fehler, wenn man sorgfältig arbeitet, d.h. keine vertauschen Teile & Kabel produziert hat. )
     
  17. Danke Fetz, bevor ich weitere Bauteile auslöte werde ich erst einmal schauen, ob irgendwo etwas Überbrückt ist.
     
  18. redled

    redled -

    Was spricht denn das Oszi an der Basis von Q41 (C62+) gegen Masse? Tut sich da was bei Änderungen des Wertes vom Decay-Poti? Mein Verdächtiger ist der 2Sk30. Den 4066 solltest Du einmal austauschen.

     
  19. Hallo,

    ist Dir klar, dass die Decay-Zeit auf Minimum geht wenn, der CMOS-Switch in IC-12 (pins 3/4/5) durchlässt? Dann wirkt der Regler nicht. Wenn Du also zB den CMOS-Switch ueber ein MIDI/CV-Interface mit zB der Velocity ansteuerst und der Switch oberhalb eines bestimmten Vel-Wertes durchlässt, dann kann sich am Decay-poti nix tun...

    (Darauf bin ich mal bei der MB303 reingefallen, weil ich sie mit einem undynamischen MIDI-Keyboard angesteuert hab).

    Florian
    Florian
     
  20. Anhand dieser Aussage kann man das Velocity-Problem ausschliessen. Leider. Wäre zu einfach gewesen ;-)

    Dass sich aber bei heraus gebogenem Pin3 vom 4066 die Amplitude ändert, wenn du am Poti drehst, finde ich leicht merkwürdig.
     
  21. Was bewirkt denn herausziehen des pin3? Wenn der 4066 kaputt ist, kann die Schaltspannung oder die Versorgungsspannung auch auf den Pin 4 durchschlagen.

    Das könnte man dadurch erklären, dass die Decayzeit kürzer als die Abklingzeit des Sägezahn wäre (was bei positiver Spannung am pin4 des 4066 wohl der Fall wäre). Es würde bedeuten, dass das Poti durchaus noch arbeitet (und wirkt) nur, dass das der Zeitwert des (summarisch gedachten) RC-Gliedes viel zu niedrig ist.

    Ich würd den 4066 tauschen.
     
  22. Danke für die Tipps, dann sollte ich wirklich den 4066 einmal austauschen, bevor ich anfange, die Widerstände
    auszulöten. Übrigens steuere ich die ML mit dem internen Sequencer und nicht extern an.
     
  23. Brother303

    Brother303 aktiviert

    Hallo,

    hier mal ein Link fürs troubleshooting :

    http://forums.adafruit.com/viewtopic.php?f=12&t=5964

    (x0x-Forum/Making x0x/Troubleshooting FAQ)

    Geht zwar um die x0x,aber da die Basics ja die selben sind,sollten da schon einige gute Hinweise dabei sein.

    Zur Decay/Env-Problematik gibts da auch Infos!
     

Diese Seite empfehlen