Win10 / USB-Midi hat sich verschluckt / Geräte-Reset?

Dieses Thema im Forum "PC" wurde erstellt von Jan_B, 16. Dezember 2016.

  1. Jan_B

    Jan_B Ist_OK

    Hallo Leute,

    ich habe eine Frage zu USB-Midi Geräten unter Windows, genauer geht es bei mir um Windows 10.

    Und zwar habe ich das Problem, dass ich zur Zeit zwei Geräte über Midi-USB nicht zum laufen bekommen, ein M-Audio 4x4 Midi-Interface und ein Korg Kaosspad 3+.

    Das 4x4 lief ohne Murren und Knurren, das KP3 ebenfalls. Ich habe vor einiger Zeit öfter mal neu verkabelt und die USB-Ports der Geräte häufiger gewechselt, ab und zu war auch mal ein USB3-Hub dazwischen - lief alles tutti. Gefühlt laufen die beiden Geräte seit einer der letzten Umsteckorgien nicht mehr - an keinem Port. Das 4x4 wird im Gerätemanager sogar noch als korrekt installiert angezeit, lässt sich aber z.B. mit MidiOX nicht ansprechen, das KP3 wird nicht angezeigt und das KP3-Configurations-Programm findet es auch nicht. Ein anderes, kleines M-Audio Midiinterface (welches glaube ich den gleichen Treiber wie das 4x4 nutzt) läuft perfekt.

    Ich habe mal aufgeschnappt, dass unter Windows ggf. alte Midi-Geräte neue Midi-Geräte in der Registry blockieren können, kann es sein, dass ich da was machen kann? Hat jemand einen Link, welche Registry-Einträge ich säubern muss, so eine Art Midi-Reset?

    Andere USB-Midi-Geräte wie z.B. die Elektrons/Roland-Boutique/Microbrute/Masterkeyboard verbinden sich ohne Probleme.

    Danke und Gruß JAN
     
  2. MacroDX

    MacroDX Hat ein Bild mit Robotern wo aufm Mond rumlaufen

    Hallo Jan,
    ich würde dir folgendes raten: Deinstallier die USB Treiber der Geräte, die sich nicht richtig verhalten und installier diese dann nochmal neu, ggf. aktuellere Versionen (wenn man schon dabei ist...).
    Mir hat dann dieses Programm hier geholfen, meine Geräte richtig auf die USB Ports zu verteilen:
    http://www.uwe-sieber.de/usbtreeview_e.html
    Ich möchte Wetten, dass die wenigsten wissen, zu welchem Bus die jeweiligen Anschlüsse gehören. Das kann aber durchaus Sinn machen, wenn man seine USB Geräte sinnvoll verteilt. So habe ich z.B. mein USB Audiointerface an einem einzigen Hub (im Software-Treiber Sinne) hängen, und die übrigen Geräte an einem anderen Hub, an dem dann noch ein 7-Port Hardware Hub hängt.
     
  3. tholan

    tholan ......

    das stammt zwar noch von XP her, aber vlt. gehts ja noch:
    Es gibt ein kleines Progrämmchen, das nennt sich "usbdeview".
    Windows merkt sich jedes USB-Gerät, das jemals an den Rechner angeschlossen war.
    Mit "usbdeview" kannst Du das sehen und Löschen, vlt. besinnt sich der Rechner dann wieder.
    Die vorhandenen Treiber bleiben erhalten und installieren sich dann neu,
    wenn Du die Geräte wieder ansteckst.
     
  4. swissdoc

    swissdoc back on duty

  5. Jan_B

    Jan_B Ist_OK

    Danke für die Ansätze! Ich werde mich die Tage dransetzen und dann berichten.
     
  6. Jan_B

    Jan_B Ist_OK

    Perfekt. Mit dem KP3 hab ich noch nicht ausprobiert, aber der 4x4 war ca. 10 mal installiert. Alles deinstalliert, 4x4 reingesteckt, läuft.

    Super Tool. Danke!