yusynth saw animator

Dieses Thema im Forum "Lötkunst" wurde erstellt von Widy75, 16. April 2014.

  1. Widy75

    Widy75 aktiviert

    hi
    das Teil mach mich fertig :sad:
    Problem:
    Ich hab mir einen Yusynth Saw Animator in meine ASM-2 Synth mitverbaut ..so weit so gut
    Wenn der Saw Animator Power hat, fangen meine VCO's des ASM leicht zu schwanken an
    ( Die Frequenz/Faktor bestimmt der LFO vom SAW Animator )
    Das ist nicht gut :sad:

    Mir kommt vor, wenn ich die led des SAW Animators wegnehme wird es besser !?
    Wenn ich andere Module abstecke ( Zusätzlicher extra VCA + Mixer , wirds es nicht nicht besser, war nur mal so grob der Test ob genug Power vorhanden )

    Kennt das Problem jemand ?
    lg Widy
     
  2. Nоrdcore

    Nоrdcore deaktiviert

    Löte mal R5/R20 (1k) aus. (= Die LED gehen dann gar nicht mehr, da kommen wir dann später zu... )
    Ist es dann weg?
     
  3. Widy75

    Widy75 aktiviert

    ohne r5/20 gehts super
    was sagt uns das :) !?
    lg widy

    ps danke für die rasche hilfe
     
  4. Nоrdcore

    Nоrdcore deaktiviert

    Die LED brauchen (mit 1k5) knapp 10mA Strom, durch R5 fließen knapp 10mA Strom, Summe 25mA. Die werden mit LFO-Frequenz geschaltet.
    Dieser Strom fließt aus den 15V in die Masse. In mindestens einem der beiden Pfade entsteht dabei ein Spannungsabfall, der den VCO moduliert.

    Wirklich Abhilfe schafft leider nur eine ziemlich andere LED Ansteuerung. Die Schaltung muss konstant Strom verbrauchen, unabhängig davon, ob die LED an oder aus ist.
    (Ist beim TTSH mit der LFO-LED übrigens auch ein Problem ... da(gegen) hab ich schon eine kleine SMD-Platine im Eagle angefangen... )

    Kannst du einfache Schaltungen nach Schaltplan auf Lochraster aufbauen?

    Edit: Ansonsten bau das auf superhelle LEDs um, die mit sehr wenig Strom auskommen (blau, true green). Dann kannst du die Ströme *viel* kleiner machen und das Problem wird proportional kleiner.
    R5/R20 = 100k oder 220k Ohm. R6,R21 = 22k Ohm - oder größer. Bei blauen/echt-grünen LEDs dürftest du da auch mit 68k (oder so) noch ausreichende Helligkeit bekommen.
     
  5. Widy75

    Widy75 aktiviert

    hi ja super danke für die info
    klar kann ich lochraster schaltungen bauen :)
    bitte an link auf a schaltung :)
    lg widy
     
  6. Nоrdcore

    Nоrdcore deaktiviert

    Wenns nur der Link wäre hätte ich den schon gepostet ... die muss ich erst mal malen, und *das* muss ich mir nicht geben, wenn es eh nicht hilft...
     
  7. Widy75

    Widy75 aktiviert

    würd doch helfen, ohne led tuts ja schon super, nur die led wär halt auch noch fein zu haben :)
    ich versuch mal diese eine led durch eine normale blinkschaltung mit 2 leds zu ersetzen
    eine geht dann nach außen eine bleibt auf der pcb. Wenn immer a LED leuchtet sollte ja die Stomaufnahme konstant sein

    bissi hack ..aber mal testen
    lg widy
     
  8. Nоrdcore

    Nоrdcore deaktiviert

    So....
    Das ganze ist etwas verdreht, damit die LEDs genauso an sind wie vorher (also wenn der OP-Ausgang positiv ist)

    Q3 arbeitet als Konstant-Stromquelle
    Mit R42 wird der Strom eingestellt. Dieser Strom fliesst immer, entweder durch die LED oder Q1/Q2 die die LED *abschalten* wenn sie durchgesteuert werden. Das passiert immer dann, wenn der OP-Ausgang negativ wird (das ist ja ein Rechteck mit ca. +/-13V bzw. dem was die OPs halt maximal so raushauen).



    Beachte, dass die Dioden anders rum sind und PNP statt NPN Transistoren verwendet werden.
    Die Dioden verhindern übrigens, dass die Basis-Spannung falsch rum wird: die Basis-Emitter Diode dabei zwar gesperrt, hat aber nur rund 5V Durchbruchspannung.
     

    Anhänge:

  9. Widy75

    Widy75 aktiviert

    wow dank dir :)
    inzwischen kurz die Rs wie beschrieben getauscht und das vco schanken ist kaum noch zu hören
    werd als nächstes deine schaltung testen
    lg widy
     
  10. Nоrdcore

    Nоrdcore deaktiviert

    Wenn du mit relativ wenig LED-Strom auskommst (so dass der OP ihn auch liefern kann...) dann gibt es noch eine Spar-Lösung:
    Einfach ein Widerstand vom OP-Ausgang nach +15V. (Wert *etwa* das doppelt des LED-Vorwiderstandes. )
    Der zieht dann den Strom, wenn der Ausgang negativ ist und die LED ihn nicht zieht.
     
  11. Widy75

    Widy75 aktiviert

    hi danke nochmal ...die spar lösung tut mal so weit super bis perfekt....

    hier nochaml die zusammenfassung
    R6/R21 auf ~50K geändert ...VorWiderstand LED.
    R5/520auf 120K geändert ... Damit über die Basis nicht zu viel Strom kommt ( wenn ich das richtig verstanden habe )
    Und von OP PIN 7/8 je einen 120K auf +15V ...für Stromaufnahme bei negativem Puls vom LFO gernerator
    bin zufrieden .
    danke nochmal recht herzlich für die hilfe
    lg widy
     
  12. Feedback

    Feedback Individueller Benutzer

    Wow, na das ist doch mal Elektronik guit erklärt!
    Leider ist die Schaltung nicht mehr da...
     
  13. Widy75

    Widy75 aktiviert

    welche ...
    yusynth saw animator: [​IMG]
    lg w
     
  14. Feedback

    Feedback Individueller Benutzer

    nee, der LED-Driver. Im Gegensatz zur Saw-Animator-Schaltung wird die nicht angezeigt...
     
  15. Nоrdcore

    Nоrdcore deaktiviert

    Bei den fixen Rückmeldungen und der sinnvollen Mitarbeit macht helfen ja richtig Spaß.

    Der Basisvorwiderstand ist schlichtweg völlig schwachsinnig dimensioniert gewesen - und ja, der deshalb unsinnig große Basisstrom macht dann (auch) Ärger.
    So ein Transistor (BC5xxC) hat eine Stromverstärkung über 400. Wenn ich da 20mA für die Leuchtdiode brauche, dann braucht das 0,05mA Basistrom. Der Op liefert 13,5V, UBE=0,65V => (13,5 - 0.65)V/0,05mA= 415kOhm!
    Selbst wenn man da den Bastler einplant, der einen anderen Transitor nimmt, ist alles unter 100kOhm nur schwer motivierbar.

    Der Haken an der Sparlösung ist übrigens, dass die sehr von der LED (Durchlassspannung=Farbe) und der Versorgungsspannung abhängt. Für ein geschlossenes System kein Problem, aber für "Modular" ist das eher nix.
     
  16. Nоrdcore

    Nоrdcore deaktiviert

    Ich wars nicht ... bei mir ist die noch da.
    (Ist aber im Forum hochgeladen = nur zu sehen, wenn man angemeldet ist. )

    Ist übrigens echt witzig: vor ein paar Tagen überlege ich mir, wie man beim ADSR die Masse sauber hält, dann ist bei MUFF ein Thread dazu ... und gestern erwischt das Widy
     
  17. Widy75

    Widy75 aktiviert

    @nordcore ...ja ich bau eh auch noch die Led Driver mit Konstant I Quelle ..
    brauch nur die richtigen T's dafür ...(liegt da leider nix herum)

    Mein ASM-2 ist soweiso ein Sorgenkind
    damals das Filter dass mit deiner Hilfe gerichtet wurde und jetzt der Saw Animator ... naja der erster Analoge Synth halt den ich gebaut hab
    ich schraub den so ungern auf ....zu viele kabel :sad: würde vieles anders machen :)
    ...aber ich hab dem jetzt noch ein Audio -> CV/Gate spendiert ( Expert Sleepers ES-1 nachbau mit 2 Kanälen ) und kann das über meine Scope und Luna IO box super betreiben.


    @feedback
    ich seh die schaltung..komisch
    lg widy
     
  18. Feedback

    Feedback Individueller Benutzer

    na das ist jetzt komisch: ich bin angemeldet (sonst könnte ich ja auch nix schreiben... :nihao: ),
    - die Yusynth-Schaltung sehe ich :supi:
    - von der anderen nur ein rotes X und den Dateinamen in einem Rahmen, den ich anklicken kann, dann wird er größer :doof:

    Ist aber der IE von den doofen Kleinweichs, mal heute abend sehen, wie's mit Firefox ist
     
  19. Widy75

    Widy75 aktiviert

    hi
    hab noch schnell an lochraster entwurf ( falls jemand benötigt )
    also so würd ich die bauteile anordnen um nicht zu viele leiterbahnen zu haben
    !!noch nicht getestet!!
     

    Anhänge:

  20. Synlog

    Synlog -


    Bei mir gehts(Safari).
     
  21. Nоrdcore

    Nоrdcore deaktiviert

    Dioden D1/D3 und Widerstand R5/R20 kannst du auch auf der Original-Platine bestücken. (Dioden halt umdrehen, und mit BC5xxC kannst du für R5/R20 auch die 120k drin lassen, die jetzt drin sind. )

    Der "Stromwiderstand" R2 lässt sich gut anpassen, der ist in einem weiten Bereich einfach proportional zum Strom, der durch die LED fließt. Unabhängig von der LED-Farbe.
    Für z.B. 2mA wird er dann 470 Ohm. ( 1V/2mA = 500 Ohm; nächster Normwert 470, so genau ist das eh alles nicht... )
    (Nur dass blaue LEDs natürlich bei 2mA schon echt hell sind, während Standard-LEDs da eher erst anfangen, sinnvoll zu leuchten. )
     
  22. Nоrdcore

    Nоrdcore deaktiviert

    Noch was:
    wenn du eh nur 2..5mA für die LEDs willst, kann ich dir die Sparschaltung auch umdimensionieren.
    Dazu muss du nur verraten, was für LEDs du nehmen willst, deren Schwellenspannung geht ziemlich in die Rechnung ein.
    (Und natürlich den Strom - den kann man da ja nicht so leicht "mal eben" anpassen. )
     
  23. Widy75

    Widy75 aktiviert

    Gelb 2ma stand am sackerl der LED's
    aber ich werd auf alle Fälle die Schaltung aufbauen .. auf der jetzigen pcb will ich gar nix mehr herumbastel, zumal sich schon die leiterbahnen lösen ( dort wo ich mit der saugpumpe drann war, wurden auch die leiterbahnen bzw lötpads mitabgesaugt ...mag ich gar nicht )

    ausserdem schaut mir die schaltung nach einer relativ leichten schaltung aus und auch für andere zwecke einsetzbare ( adsr leds zb )
    muss echt nur die T's besorgen .. und das ist kein stress ... fahr eh jeden tag am conrad vorbei

    lg widy
     
  24. Die LED-konstantstromquelle (CCS) scheint mir doch etwas mit Kanonen auf Spatzen geschossen. Wäre nicht der 1. Schritt,die Ursache für den Spannungsabfall an der VCO-Betriebsspg. zu beseitigen ? Also die Zusatzschaltung direkt an saubere +-15V zu hängen, also zB direkt an den Spannungsreglern ? Nordcore hat Recht wenn er niedrigere LED-ströme empfielt; ich gehe auf 1..2mA runter - mit modernen ultrahell LEDs kein Problem. Statt CCS kann auch die simple Stromumschaltung s. Bild verwendet werden : schaltet der OPamp auf -Vmax ( je nach OPamp 0..2,5V oberhalb der - Betriebsspg. , fliesst der Strom durch die Diode in den OPamp statt durch die LED; schaltet der OPamp nach + sperrt die Diode und der (fast identische Strom) fliesst durch die LED. Hat man rote LEDs und/oder einen OPamp der nicht nah genug an - Ub rankommt, kann man die rechts gezeigte Trans.schaltung verwenden ( die sich in der Orig.schaltung evt. leicht so abändern liese)
     

    Anhänge:

Diese Seite empfehlen