Bräuchte mal Hilfe bei einem Reaktor Ensemble

Dieses Thema im Forum "Softsynth" wurde erstellt von Crabman, 1. August 2010.

  1. Crabman

    Crabman aktiviert

    Tach zusammen,

    habe folgendes Problem(e):Bastel da grad an einem polyphonem Synth Patch aber wenn man (im mono mode)mehrmals hintereinander eine Taste drückt (zwischen 3-6 mal) verschwindet die Release Phase und der Ton hört abruppt auf.Erst mit drücken einer neuen Taste ist wieder alles ok.Solange ich den Ton halt nicht mehrmals spiele.Ist aber auch nicht in allen Kombinationen so:

    Poly=ok
    poly Legato=ok
    poly Glide=ok
    mono=überhaupt keine Releasephase :!: (stört mich aber nicht unbedingt,vielleicht lass ich Glide zum Schluss auch immer an)
    mono Legato=fail
    mono glide=fail
    mono ST*=ok (!)
    mono ST Legato=fail
    mono ST Glide= fail

    ( *Single Trigger )

    Nun muss ich sagen,das dies hier meine bisher komplexeste Arbeit ist und ich damit meine persönlichen Grenzen -vorrübergehend- erreicht habe.Kenne mich auch auf der Core Ebene nicht aus.


    2.Ich habe mehrere Modquellen,die man zu bestimmten Zielen routen kann.Sowohl positiv als auch negativ.Nun ist mir das Modulationssignal in beide Richtungen zu stark und ich weiss leider nicht wie ich das eingrenzen kann.Wenn`s nur positiv wäre,kein Problem aber der"Trick"mit der constant value funktioniert hier nicht.Zumindest hab ich`s noch nicht gerafft.Wenn da jemand einen Tip hat,bitte sehr :)


    3.Das Teil ist recht hungrig,gibt es irgendwelche Tips wie man noch Leistung sparen kann ohne das ganze Teil umzubauen?Ist bislang auch nur 4-stimmig. (etwa zwischen 17-28% auf`nem Macbook C2D und 2,4Ghz).Diverse Module lassen sich bereits ganz ausschalten um Strom zu sparen.


    Für den Fall das jemand `nen Blick draufwerfen will hab ich`s mal angehängt.Aber Achtung:Reaktor 5.5 only (das war halt die Motivation,das ich mich überhaupt wieder vorgesetzt habe).Leider `n Tick zu gross um`s hier hochzuladen:

    http://www.sendspace.com/file/qgeust

    Im Hintergrund isses auch noch etwas chaotisch.Funktioniert aber (endlich fast) alles,braucht halt noch etwas finetuning.
     
  2. Crabman

    Crabman aktiviert

    Alles nur Preset User hier oder wat? :fawk: ;-)
     
  3. CS1x

    CS1x Tach

    weiss nicht ob ich das problemm richtig verstanden habe.
    wen das ding nur 4voices hat dan ist doch klart das die release irgendwan abreisst.Teste mall mit mehr voices
    reaktor ist ein CPU fresser das ist sein nachteil,vorteil nix ist unmöglich deswegen ist reaktor ein CPU fresser
    mein synth frisst bei manchen Presets bis 90% AMD Athlon 6000+ x2
    es kommt immer drauf an wie geschickt man ein synth zusammen bastelt
     
  4. CS1x

    CS1x Tach

    wen ein Modulationssignal zu sterk ist kanst du es mit einem Multiply schwächer machen
    ist aber schon lanmge her wo ich mit reaktor gebaut habe habe schon bissel was vergessen
     
  5. CS1x

    CS1x Tach

    achja we du mit Audio Core Cell arbeitest dan musst du aufpassen das die inputs nicht immer ein audio signal sind. denn man kann ja noch ein event signal verwenden und der braucht weniger CPU last zmb ein steur signal der den Cutoff steurt muss nich ein audio signal sein sonder besser wäre da ein event signal
     
  6. Crabman

    Crabman aktiviert

    Ne,das ist es nicht.Nach den 3-4 gespielten Noten (und Ausfall der Relasephase) überlappen sich die ja nicht.Ausserdem hab ich das Problem im polyphonen Modus ja nichtmal,nur im monophonen.Also ich hau ein paar mal auf die gleiche Taste sodass die monophonen Noten,dank langem Release,einander"berühren" und danach ist`s Release einfach weg.Also auch nur eine Note spielen hat den gleichen Effekt.Und das-wie gesagt- auch nur bei einstimmigem Spiel.Erst mit Anschlag einer neuen Taste geht`s dann -vorläufig- wieder.

    Multiply...mmmh,schau ich mir mal an.

    Von Core hab ich leider keinen Plan,verwende aber weitgehend wo`s geht A/E Converter.Da bastel ich aber grad noch."Leider" hab ich gern auch viel FM Rotz dabei,da hilft das dann nur bedingt^^


    Danke trotzdem schonmal :supi:
     

    Anhänge:

  7. CS1x

    CS1x Tach

    hm einem A/E Converter habe ich niee verwendet habe da schlechte erfahrung zbs ein Core Envelope knakst und hackt wen der ein event signal bekommt der zuerst audio war
     
  8. CS1x

    CS1x Tach

    ich habe das so gemacht beim beuen meinem Synth.immer wen ich eine keinen fortschritt hatte habe ich alle funktionen ausprobiert und mehrmals auf dem keyboard gespielt ob alles in ordnung ist nur so kommst du
    ohne fehler ans ziel
     
  9. Crabman

    Crabman aktiviert


    Das mache ich natürlich auch aber mein Fehler war das ich nie mehrmals die gleiche Taste angeschlagen habe bzw.mir`s nicht aufgefallen ist.Wann genau der Fehler auftrat kann ich somit erstmal nicht nachvollziehen.Mir ist allerdings jetzt aufgefallen das der Fehler auch im"Vorgänger" (das Ensemble ist eine deutlich"aufgebohrte"Version eines älteren von mir) vorhanden ist.
     

Diese Seite empfehlen