Firmware Versionen des Emagic amt8

Dieses Thema im Forum "Controller & MIDI" wurde erstellt von tux, 3. Dezember 2014.

  1. tux

    tux aktiviert

    Hallo, ich hab mal meinen amt8 aufgemacht und dabei entdeckt, das der anscheinend relativ neu ist, auf dem Firmware Eprom klebt ein gelber Aufkleber mit der Aufschrift: EES(c)2005 amt8 U 204

    Die Platine selbst hat ein 9912 Datum Code (sollte 12. Woche 1999 bedeuten), also gibt es wohl nur eine Version der Platine, aber es sieht so aus, als ob es mehrere Firmware Versionen geben könnte.

    Der Firmware Eprom ist ein ST M27C256B-10F1 und ist gesockelt, also sollte es kein Problem sein den auszulesen und eventuell mit einer neueren Version zu beschreiben (Eprom Programmiergerät vorausgesetzt).
    (der amt8 kann nicht über MIDI oder USB vom PC aus updated werden wie der Unitor:cool:.

    Was interessant wäre ist was für Firmware Versionen ihr hier habt.

    Ich werde meine Firmware mit einem Eprom Programmiergerät auslesen, falls meine die neuste sein sollte kann ich das binary image gerne weitergeben.
     
  2. Ron Dell

    Ron Dell Kiosk hat zu ¯\_(ツ)_/¯

    Etwas mehr als 2 Jahre später hole ich mal hier diese Threadleiche hoch.

    Weil ich mich gerade auch mit dem Thema beschäftige. Ich habe hier aktuell zwei amt8 und das Dritte ist unterwegs. Ich habe mal gerade eines geöffnet, weil ich im Unitor Control Panel (OSX) gesehen habe, dass eines mit Firmware 2.0.4 und das andere mit 2.0.2 läuft, na da kuck ich doch mal nach :)
    Als erstes werd ich mal das 2.0.4 EPROM auslesen und das andere amt8 aktualisieren.

    Auffällig ist, dass es scheinbar Unitors mK2 und amt8 das gleiche Board benutzen. Beim amt fehlen natürlich die zusätzlichen Anschlüsse, LED's, Kondensatoren und aber auch etliche IC's. Schade eigentlich ;-)

    Abschliessend schliesse ich mich der Frage des Threadstarters an: Ist eine aktueller Firmware fürs amt8 als 2.0.4 bekannt?
     
  3. satchy

    satchy aktiviert

    Hallo allerseits,

    meine beiden AMT8 hatten auch zwei verschiedene Versionen.
    Einmal U2.02 und einmal U2.04.
    Hab auch die Daten von beiden ausgelesen und beide auf die Version U2.04 gebrannt.

    Ob eine noch neuere Version als die U2.04 im Umlauf ist, kann ich nicht beantworten.
    Ist auf jedenfall spannend zu wissen, dass beide Geräte auf derselben Firmwareversion laufen. :D

    Beim Unitor 8 ist die Firmware ja per MIDI aufspielbar.
    Da hab ich nur die Version 1.3.1 die es im Netz zu finden gibt.
    Jedoch kein Unitor 8 Gerät :sad:
     
  4. Ron Dell

    Ron Dell Kiosk hat zu ¯\_(ツ)_/¯

    Mein dritter amt8 ist hier und war auch nur auf 2.02. Das update auf 2.04 ging auch hier ohne Probleme. Ich habe auch etwas gestöbert im Netz und keine Angaben zu neueren Versionen als 2.04 gefunden. Spricht wohl dafür, dass es sich hier wirklich um die neueste Version handelt.

    Ich hab mir jetzt auch ein Windows XP Laptop mit USB und RS232 Schnittstelle besorgt. Wenn ich die amt8 über USB anschließe funktioniert alles. Bei RS232 wird nicht erkannt, dass ein unbekanntes Gerät angeschlossen wurde. Deshalb kann ich auch keine Treiber installieren. In der Anleitung vom amt8 ist lediglich die Prozedur bei Windows 2000 beschrieben. Diese ist aber im Vergleich zu XP gänzlich anders. Irgendwie steh ich auf dem Schlauch.
     
  5. swissdoc

    swissdoc back on duty

    Das Interesse hat gesiegt und ein paar Schrauben später ist klar: Es ist 1999 EES U202 bei meiner AMT8. Muss ich mich nun sorgen, dass ich etwas verpasse? Midi-Kanal 17 oder Treiber Support bis Windows 99 und 128 Bit? Im Ernst, was unterscheidet U202 von U204?

    Mit Seriell geht Plug and Play (PnP) nicht, man muss also manuell installieren, das ist hier [1] unter Lösung 1 beschrieben. Der Win2000 Treiber ist wohl der für Windows XP passende.

    http://www.pcwelt.de/ratgeber/Installat ... 08253.html
     
  6. satchy

    satchy aktiviert

    Hallo woolie,

    hatte anfänglich auch so meine Probleme, bis meine AMT8 unter Windows XP richtig liefen... :?
    Aber nach langem Hin und Her hat es dann endlich mal geklappt. :selfhammer:

    - Hier in der angehängten Datei findest Du die Anleitung zur korreten Treiberinstallation, auch für Windows XP...
    - Sofern Du dir das Treiberpaket "unidrv227" heruntergeladen hast, sollte die Datei als "unitor liesmich.htm" im Paket vorhanden sein.
    - Die AMT8 laufen sowohl unter USB als auch Seriell.

    Viel Glück beim Installieren...

    @swissdoc
    Den Unterschied zwischen 202 und 204 habe ich nicht herausfinden können, aber wenn schon denn schon,
    irgend etwas wird schon Anders sein.... hab auf jedenfall 2x dieselbe Version... (inkl. gleicher bug's). ;-)
     

    Anhänge:

  7. Ron Dell

    Ron Dell Kiosk hat zu ¯\_(ツ)_/¯

    Danke für den Hinweis auf die liesmich.htm. Das war die für mich fehlende notwendige Info. Weil die manuelle Treiberinstallation bei Win XP anders funktioniert als bei Win 2k und die Prozedur nur für letzteres im Handbuch beschrieben ist. Jetzt gehts auch hier bei mir mit COM-Port und Windows XP, fabelhaft!! :nihao:

    Ich habe die amt noch nicht im Einsatz und kann deshalb auch nichts sagen zu den Firmware-Versionen. Anfänglich hatte ich auch noch nicht geupdatet und die 2.02 verhielten sich genau so wie die mit 2.04. Aber wenn man eh die Möglichkeit hat, weil ein EPROM programmer im Hause ist, dann kann man das ja machen.

    Wie macht ihr das eigentlich mit der Kabelführung? Ich werde wohl auf mindestens 4 amt kommen, das sind 4 x 7 in und 4 x 7 out ports, also insgesamt 56 Midikabel. Ich glaub ich opfere obendrüber 1 HE mit einer Rackwanne als Zugentlastung. Also Löcher reingebohrt und Kabelbinder dran...

    Noch eine Frage an die Miditrix-user: Ich habe keine Einstellungsmöglichkeit gefunden, wie man die Footswitch-Buchse eines Unitors damit nutzen könnte. Übersehe ich da was?
     
  8. swissdoc

    swissdoc back on duty

    Alles klar, danke. Ich dachte, Du hättest evtl. irgendwelche Releasenotes oder so. Meine AMT macht mit U202 soweit keine Probleme, einzig Vista hat ein Problem mit der AMT nun, aber das generell, da geht gar nichts mehr. Unter XP ist alles beste Bohne.
     
  9. Ron Dell

    Ron Dell Kiosk hat zu ¯\_(ツ)_/¯

    Achtung, kaum Erkenntnisgewinn -> nur fürs Protokoll:
    Ich habe inzwischen auch ein Unitor 8 MK2 hier. Ich war etwas erstaunt, als ich nach dem Anschliessen gesehen habe, dass es mit Firmware Version 2.0.4 läuft. Das letzte Firmwareupdate, das man im Internet herunterladen kann und die Versionsnummer 1.3.1 trägt, scheint wohl nur für das alte Unitor ohne USB zu sein.
    Naja, jedenfalls lag für mich die Idee nahe, dass es sich bei v2.0.4 aus dem Unitor MK2 um die gleiche Firmware handeln könnte wie die v2.0.4 vom amt8. Also hab ichs aufgeschraubt und das EPROM ausgelesen. Was tut man nicht alles für die Wissenschaft :) Ergebnis: Die Firmwares von amt8 und U8 MK2 sind unterschiedlich, es gibt aber auch Gemeinsamkeiten:
    [​IMG]

    Somit hätten wir das auch für zukünftige Generationen dokumentiert ;-)
     
  10. Hallo, hab mir letzte Woche ein AMT8 gekauft um meinem alten Unitor8 wieder Leben einzuhauchen. In der DAW hat alles gut geklappt. Bei dem Versuch die Unitor Control Software ans laufen zu bringen, um mir Patches zu erstellen, hab ich mir das AMT8 leider abgeschossen! Ätzend. Nun absolviert er den Einschaltest nicht mehr korrekt. Er läuft bis sieben, um dann starr bei In 1 und Out 1 zu verweilen... Ist schwer abzuschätzen wann er wirklich den Test verweigert, der Ablauf geht ziemlich flott.

    Meine Frage: Kann es sein, dass ich den Eprom zerschossen habe? Wenn ja, wäre einer von Ihnen bereit mir diesen neu zu beschrieben? Danke!

    Gruß Volker

    Self-test:
    1 - Processor working
    2 - RAM o.k.
    3 - SMPTE initialized (skipped by AMT:cool:
    4 - Click Input o.k. (skipped by AMT:cool:
    5 - EEPROM o.k.
    6 - UART MIDI o.k.
    7 - Computer communication o.k.
    8 - unused
     
  11. Summa

    Summa wibbly wobbly timey wimey

    Ist mir zum Glück bisher noch nicht passiert, hab' 1x Unitor8 MK2 und 2x AMT8, ist das Netzteil das Richtige afair muss es ein Wechselstrom Netzteil sein?
     
  12. Ja, ist das originale Netzteil.
     
  13. Ron Dell

    Ron Dell Kiosk hat zu ¯\_(ツ)_/¯

    Wie darf ich mir das vorstellen? Du hattest ein defektes Unitor8 und hast das EPROM vom amt8 in das Unitor eingesetzt? Oder wie?
     
  14. Hallo, danke für die Antwort! Nein, ich hatte das AMT8 gekauft um es über RS422 mit dem Unitor8(mk1) zu verbinden. Geöffnet wurde keines der Interface. Bei dem Versuch mit der Control Software ein Patch zu erstellen, um es auch ohne Sequenzer nutzen zu können, hat sich das AMT8 "aufgehängt". Keine serielle Verbindung wurde "heiß" getrennt. Leider finde ich keinen Weg es zu initialisieren. Denke nicht das es ein Hardwaredefekt ist.
     
    Zuletzt bearbeitet: 22. November 2017 um 16:51 Uhr
  15. Es läuft wieder! Puh, eine Sorge weniger :) Danke für die Anteilnahme...
     
    Zuletzt bearbeitet: 22. November 2017 um 17:24 Uhr

Diese Seite empfehlen