Hilfe mit State Variable Vactrol Filter

Dieses Thema im Forum "Lötkunst" wurde erstellt von a_guy_called_tom, 2. Januar 2011.

  1. Hallo zusammen,

    Ich hab, basierend auf dem Neutron Projekt (Mutron III Filter Clone), ein Platinen Layout gebastelt und möchte dieses jetzt gerne ein oder zweimal fertigen lassen (hab da an platinenbelichter gedacht). Im Unterschied zum Neutron soll der Filter aber nicht nur über den eingebauten Envelope Follower (Autowah) gesteuert werden, sondern auch über einen normalen CV Eingang und Cutoff Regler.

    Da ich aber vom Layouten und auch von der Elektronik selber nicht so viel Ahnung hab, wäre es toll wenn jemand von den Erfahrenen kurz einen Blick auf die Eagle Files werfen könnte, vielleicht fliegen dabei noch einige offensichtliche Fehler auf oder jemand hat noch ein paar Verbesserungsmöglichkeiten (Ich wollte eigentlich ein einseitiges Layout, hab das aber nicht hingekriegt und beim zweiseitigen Layout hat der Autorouter kräftig mitgeholfen...). In etwa hab ich den Filter aber so schon auf dem Breadboard und er funktioniert grundsätzlich.

    Für Tips bin ich dankbar,

    Grüsse,
    Tom
     

    Anhänge:

  2. Schupf doch mal PDFs oder PNGs von deinen Sachen rein, nicht jeder hat Eagle... :supi:
     
  3. Guter Punkt.
     

    Anhänge:

    • brd.png
      brd.png
      Dateigröße:
      40,8 KB
      Aufrufe:
      78
    • schema.png
      schema.png
      Dateigröße:
      20,1 KB
      Aufrufe:
      78
  4. Heinz Schnackensiel

    Heinz Schnackensiel ACCOUNT INAKTIV

    Die Ansteuerschaltung um T1 steuert die LEDs in den Vactrols sehr plötzlich an, das ist wohl wenig schön einzustellen. (Es passiert alles auf einem kleinen Bereich der Potis - und ist auch recht temperaturabhängig. )
    Wenn du (im Prinzip) den 560 Ohm Widerstand auf die Emitterseite vom Transistor setzt, dann wird daraus (übern Daumen) eine spannungsgesteuerte Stromquelle. Und die Helligkeit der LED hängt ja vom Strom ab = sinnvollere Ansteuerung.
    Die Funktionsweise ist dann überschlägig:
    Die Basisspannung gibt die Emitterspannung vor (ca.: UEmitter = UBasis - 0.6V).
    Der Emitterwiderstand (560 Ohm) macht daraus den Strom (U=R * I bzw. hier I=U/R) - der notgedrungen vom Kollektor kommen muss (Basisstrom vernachlässigen wir mal)
    => Kollektorstrom ist proportional der Basisspannung.

    Zum Testen würde ich erst mal ein der beiden Vactrol-LEDs durch eine normale rote ersetzen, dann siehst du, was du da treibst.

    Deine 100 k an der Basis werden dann allerdings (zu) hochohmig - der Transistor verstärkt den Strom "nur" um ein paar hundert. Da wir jetzt ja eine (Basis-) Eingangsspannung haben (wollen) sollten die Widerstände im Eingang so klein sein, das der Basisstrom kaum eine Rolle spielt.

    Die Dimensionierung musst du nachrechnen, wenn du da Probleme hast helfe ich auch gerne weiter. (Ich mag nur nicht so blind beim Dreisatz anfangen, das ist dann so viel getippsel ;-) )
     
  5. Hallo Heinz,

    vielen herzlichen Dank für deine Ausführungen! Ich hab die Ansteuerung der Vactrols in etwa wie in der angehängten Datei beschrieben gemacht. Ich hab 'deine Version' jetzt auch mal noch aufm breadboard ausprobiert, bin mir aber noch nicht schlüssig ob ich da rein subjektiv einen Unterschied feststelle. Ich muss erst noch einige konkrete Messungen machen und wie du sagst noch etwas mit dem 100k Widerstand spielen bis ich einen optimalen Bereich abdecken kann.

    Danke und viele Grüsse,
    tom
     

    Anhänge:

    • VtoR.jpg
      VtoR.jpg
      Dateigröße:
      97,8 KB
      Aufrufe:
      50
  6. Heinz Schnackensiel

    Heinz Schnackensiel ACCOUNT INAKTIV

    "Meine" Lösung hat auch "nur" den Vorteil, das der Arbeitspunkt der Schaltung unabhängig von der Stromverstärkung des Transistors ist.
    Für "deine" Lösung:
    Hat der Transistor eine Stromverstärkung von z.B. 117 (für einen 2N3904 realistisch), dann brauchst du für 10mA LED-Strom 10mA/117=85µA Basisstrom. Die Basisspannung ist dabei ca. 0.72V (aus Transistor Datenblatt), der 100k von Basis gegen Masse "klaut" dir also 7,2µA. Damit fließen durch den 100kBasis(reihen)widerstand 92,2µA, an ihm müssen also 92,2µA*100kOhm= 9,22V abfallen. (Was rund 10V Eingangsspannung für 10mA LED-Strom macht. )
    Der 560Ohm Widerstand kommt hier praktisch nicht vor, der tritt erst dann ernsthaft in Erscheinung, wenn der Transistor voll durchgeschaltet hat. (D.h. die Kollektor-Emitterspannung unter ca. 0.5V sinkt) Vorher verschiebt er den Arbeitspunkt kaum.
    (10mA * 560 Ohm = 5.6V, - 2 *1,7V (LEDs) sind 9V, je nachdem, ob du 12 oder 15V Versorgung hast bleiben 3V oder 6V als Kollektor-Emitterspannung über. Damit geht meine Annahme (=linearer Verstärker-Betrieb) auf, denn in dem Bereich arbeitet der Transistor tatsächlich ganz gut als "ideale Stromquelle", sprich der (Kollektor-)Strom ist unabhängig von der (Kollektor-Emitter-)Spannung. )

    Die nötige Eingangsspannung für einen bestimmten LED-Strom ist hier direkt von der Transistor-Stromverstärkung abhängig. Und die ist vom Transistortyp abhängig und streut relativ stark. Wenn du das für deinen Transistor passend ausgetüftelt hast, dann funktioniert das durchaus. (Mein Rechenbeispiel zeigt ja auch, das es hinkommen kann, denn mit den von mir angenommenen Werten arbeitet das ja sinnvoll. )
     
  7. Hallo Heinz,

    Danke für die ausführliche Erklärung, sehr interessant. Klingt logisch wenns einem jemand vorrechnet, ich muss allerdings da nochmal in drüber nachdenken um die wesentlichen Unterschieder der beiden Varianten zu verstehen. Ich hab den 560Ohm Widerstand jetzt auf die Emitterseite genommen und das ganze Layout nochmal gründlich überarbeitet. Ist jetzt unterwegs zum Platinenbelichter und ich werd dann den Post auch nochmals updaten wenn ich Erfolg hab mit der Platine.

    Grüsse,
    Thomas
     

Diese Seite empfehlen