ibook & powerbook performance ... UPDATE

Dieses Thema im Forum "Apple MacOS" wurde erstellt von opt.X, 18. Dezember 2005.

  1. opt.X

    opt.X Tach

    hallo leute,

    für alle zufriedenen mac oder pc nutzer sicher zum lachen, aber ich finds echt ma richtig sch**se ...

    hat dafür jemand ne erklärung

    live 4/5 auf
    ibook 1,2ghz 1,25gb 10.4.3
    vs.
    powerbook 1,67ghz 1,5gb 10.4.3

    und das powerbook ist LAnGSAMER !!!! ich krieg nen anfall.

    gleich: live setup, plugins, latency, interfaces, usw.

    den 50%testton über internal audio kriegt das ibook mit 48 samples crackle-free hin, das powerbook braucht 80 ...

    wenn ich hier nicht noch DEN tipp krieg schick ich das pbook morgen zurück ... und hol mir ein 1,33 ibook oder nen pc ...

    m.

    mitleid oder hämische bemerkungen bitte erst ab dem 100. reply ;-) danke
     
  2. Ed Solo

    Ed Solo Tach

    also ich wei

    also ich weiß nicht woran das in deinem speziellen fall liegt, aber normal ist das sicherlich nicht.

    check mal die latenzeinstellungen der audiokarte.
     
  3. opt.X

    opt.X Tach

    danke ...
    also audio interface ist das emi26 latenz (in sam


    danke ...
    also audio interface ist das emi26 latenz (in samples) war z.b. jeweils 512
    gleiche in/out configuration ...
    aber auch mit dem internen audio der gleiche effekt ...
     
  4. Sehr seltsam !

    Du hast nicht zuf


    Sehr seltsam !

    Du hast nicht zufällig ausversehen beim Powerbook die Energiespar Einstellungen verstellt ?

    Ansonsten kann ich dir nur raten mal im Ableton Forum unter den Performance Tests nachzuschauen. Dort kannst du mittels Testsong mal vergleichen ob dein IBook / PBook ähnliche Leistungen wie andere I/PBooks bringt.
     
  5. Anonymous

    Anonymous Guest

    48/80 Samples ist in einem Bereich wo evtl. eklige Hrdwareei

    48/80 Samples ist in einem Bereich wo evtl. eklige Hrdwareeigenschaften zuschlagen, die im Normalbetrieb nicht stören.
    Stell dir eine minimale (PCI-)Bus(burst)übertragung von a)512 b)2048 vor. Bei b) fällt da der vierfache Overhead an - keine Ahnung, was da wirklich im System los ist, aber ich würde Audiopuffer so für um 5ms Latenz auslegen, damit muß es richtig laufen, 1ms oder 2ms stellen doch eher nur eine unnötige Systemlast dar. (Der PCI-Bus hat hohe Latenzzeiten und dafür einen hohen Durchsatz = günstig für Multimedia.)
     
  6. opt.X

    opt.X Tach

    @ koffein...
    ja, danke, energiespar einstellung steht auf m


    @ koffein...
    ja, danke, energiespar einstellung steht auf maximale leistung
    den performance test song aus dem forum Live5PerformanceTest.als
    (alle einstellungen beachtet) hab ich getestet
    ibook ca 75%
    powerbook ca 62%
    also hier alles in ordnung
    aber dann der original ableton demo song (hat ja verschiedene belastungen)
    bei vergleichbarer latenz z.b. 128 oder 256 samples
    ist das ibook 1-2% besser und hat auch keine störungen bei 128 samples

    @fetz
    ja danke, ich liebe technisch fundiert unterstützte antworten. wirklich!
    also vermutlich denkst du an ca. 5ms einfach (also instgesamt 10ms) was ja ca 160 samples sind. würde mir reichen aber:

    mal kurz details zu meinem live setup
    6 midispuren (ms20LC, polysixLC, 2xsimpler, 2ximpuls) 2returns (simpledeleay+resonator, graindelay)
    da bringt bei 160samples das
    ibook 45-50% (ohne störungen)
    powerbook 50-60% (mit störungen)
    prozessorlast (wird übrigens in der aktivitätsanzeige von osx bestätigt)

    und das ist nun mal frustrierend ...
    aber vielen dank für die bisherigen tipps ...
    vielleicht hab ich ja noch was übersehen ... ich würde es hoffen
    mir scheint es aber so als ob das core-audio beim PB schlechter ist ...
    das verhalten gilt übrigens auch für externe audio HW (emi 26)
     
  7. tomcat

    tomcat Tach

    Normal ist das definitiv nicht. Hab auf PBs 17, 12 und ibook

    Normal ist das definitiv nicht. Hab auf PBs 17, 12 und ibooks geaarbeitet und die PBs waren immer schneller (solange die Taktrate schneller war). Die Prozessoren sind ja dieselben. Merkwürdig jedenfalls....

    Kann dir aber auch nicht weiterhelfen da ich mit Live nix mache.
     
  8. Moogulator

    Moogulator Admin

    [quote:b7d89301dc=*multidiletant*]danke ...
    also audio inte


    usb interfaces, besonders das emi sind wirklich das unidealste, was man haben kann..

    zumal es auch nebengeräusche hat (brummsurren)..

    habe selbst ein PB, allerdings das kleinere 1.5er und das ist deutlich schneller als das ibook..

    ich empfehle in jedem falle ein vernünftiges interface, bevorzugt pcmcia oder firewire.. aber sicher nicht usb.. das bremst ordentlich aus.. meiner ansicht nach, einer der schlimmsten emagic produkte, die es je gab..
     
  9. opt.X

    opt.X Tach

    @moogulator:
    also, da es sowohl mit internem audio also auc


    @moogulator:
    also, da es sowohl mit internem audio also auch mit externem (emi26) so ist, liegts wohl kaum am interface (ich weiss schon dass du es nicht magst ;-) aber mir reichts ... nebengeräusche hats bei mir nur bei usbstromversorgung, hab mir ne externe gebastelt da hör ich live nix)

    mir kommst so vor, als ob es definitiv am audio-daten pfad liegt, egal ob mir internem audio oder mit interface ...
    selbst die ruhelast ("song auf stop") meines live-setups ist beim ibook niedriger als beim powerbook
     
  10. Moogulator

    Moogulator Admin

    doch, bei solchen interfaces kann das durchaus sein, das es

    doch, bei solchen interfaces kann das durchaus sein, das es da saftprobleme gibt (im sinne von DSP saft)..
     
  11. opt.X

    opt.X Tach

    und warum dann bei internem audio der gleiche effekt ?

    und warum dann bei internem audio der gleiche effekt ?
     
  12. tomcat

    tomcat Tach

    R

    Räum mal das System beim PB auf, vielleicht ist da irgendein unseliger Treiber übriggeblieben. Die Basishardware ist ja dieselbe, die tests die ich kenne sind auch beinahe identisch, solange die Taktfrequenz gleich ist.

    Du hast schon die letzten EMI Treiber installiert?
     
  13. Moogulator

    Moogulator Admin

    das kann ich nicht erkl

    das kann ich nicht erklären.. nichtmal bestätigen..
    seltsam..

    meckern an apple muss helfen, obwohl deren service leider nicht direkt gut ist (musste ich leider auch schon erfahren)..
     
  14. opt.X

    opt.X Tach

    das pb system ist nagelneu ...
    neuesten emi-treiber nochmal


    das pb system ist nagelneu ...
    neuesten emi-treiber nochmal tagesaktuell runtergeladen. passt also auch.

    ja, vielleicht sollte ich mich mal bei apple beschweren, vielleicht können die das ja erklären ...

    an den ableton support hab ich auch schon geschrieben, mal sehen ob die was davon wissen.
     
  15. Moogulator

    Moogulator Admin

    ja, das ist das beste.. auch wenn ich bef

    ja, das ist das beste.. auch wenn ich befürchte, das sie alle sich die kompetenz in die schuhe schieben werden..
    aber usb generation 1 zeug war immer sehr intensivzeug..
     
  16. opt.X

    opt.X Tach

    update:

    ableton ist nichts bekannt über dieses verhalten


    update:

    ableton ist nichts bekannt über dieses verhalten ...

    apple ist nichts bekannt (die üblichen tipps: PRAM reset, PMU reset, system neu installieren ... klasse ...) die ersten 2 hab ich schon durch dem dritten punkt räum ich keine chance ein, war eh ein neues system ... aber vielleicht hab ich ja noch die nerven dazu

    hab noch eine bitte an andere powerbook/abletonlive user. gerne auch ibook 1,33 oder 1,42 ...
    könnt ihr bitte mit dem internen audio mal den 50%-testton fahren und mir sagen bis zu wieviel samples ihr die latenz runterstellenkönnt ohne das es hakt .... gerne auch als pm ...
    bei mir gehen 79 noch bei 78 fängts an ...
    ich weiss das ist für reale anwendungen nicht unbedingt relevant, sagt aber trotzdem was über den datendurchsatz aus ...
    danke schonmal ....

    muss das pb notfalls diese woche noch zurückschicken ...
     
  17. opt.X

    opt.X Tach

    nur zur info, ich bin nicht allein ...

    http://www.ableton


    nur zur info, ich bin nicht allein ...

    http://www.ableton.com/forum/viewtopic.php?t=31263

    daher muss das pb wieder gehen :sad: es wär so schön gewesen ...

    jetzt ist wieder alles offen, sogar wintel :twisted:
     
  18. Anonymous

    Anonymous Guest

    Ich kann mich dunkel erinnern, das PB und iB unterschiedliche Chipsätze haben...Board Design ist sowieso unterschiedlich, vielleicht ist das des Pudel´s Kern?
     
  19. opt.X

    opt.X Tach

    Oh, es geht weiter ;-)
    Hi Monokit,
    Du meinst vermutlich nicht, dass die beiden (IB und PB) verschiedene interne Audio-Chipsätze haben, oder? Aber das ist ja eh klar ... V.a. weil das PB ja noch die tollen optical in/outs hat.
    Eher meinst Du mit Chipsätze den IC-Kram direkt um den Prozessor rum, oder?
    Na ja ehrlich gesagt hilfts ja nix, egal ob es das eine oder andere ist, selbst wenn es sich durch SW bzw. Treiber beheben ließe, wer weiss wann usw. ...
    Ich hab es ja, wie gesagt, schon wieder zurück geschickt.

    Aber der erste Punkt interne AudioHW könnte (rein spekulativ) schon mit schuldig sein, mir ist irgendwo (OSX-AudioMidiSetup?) aufgefallen, dass es da jetzt eine Auswahl für interne/externe Audio Clock gibt. Mal angenommen, es steckt keine externe (optische) Clock dran, und die intern erzeugt würde nicht künstlich über den Prozessor erzeugt, sondern sagen wir mal von einem anderen nicht synchronisierten internen Oszillator, dann wäre der Rechner vermutlich etwas mehr beschäfftigt, die Audiodaten auf dieses leicht zum Prozessortakt schwebenden Takt umzurechnen.
    Das Verhalten trat ja auch bei ner externen Soundkarte auf, was diese These etwas relativiert, es sei den der OSX-Audiotreiber versucht auch die extrene Karte softwaretechnisch auf diese Clock zu zwingen. Achtung alles rein spekulativ !!! (ich krieg wohl trotzdem Haue von Leuten die von der Audio HW und SW die volle Ahnung haben ... na egal)
     
  20. Anonymous

    Anonymous Guest

    Ohauerha an die Audiochips hatte ich noch gar net gedacht. Wie auch immer finde ich es von BEIDEN Firmen einfach frech, sich nicht um dieses Problem zu kümmern. Vor allem Ableton sollte ein Interesse daran haben. Aber die Jungs haben sich bisher immer ziemlich resistent gegen Kritik gezeigt. In Live wurden ja damals MIDI Sequencer Funktionen integriert. Mein Partner und ich hatten damals leider feststellen müßen, das man Live damit zwar gut mit den internen Softsynths benutzen kann, das es bei der externen Ansteuerung von Hardwaresynths zu einem Synchro Lag mit einigen ms Verzögerung kommt (damals noch auf Windows PC gemessen)hat die Kollegen nicht interessiert. Wir haben dann die Finger von Live gelassen, und uns je eine MPC4k und 1k für MIDI-<a href="https://www.sequencer.de/specials/sequencer.html">Sequencer</a>uencing gegönnt.

    Meiner Meinung nach ist Live völlig überbewertet. Und die Klangqualität bei Nutzung des internen Mixers läßt auch zu wünschen übrig.

    Meiner Meinung nach. Und jetzt schlagt mich.
    :cool:
     
  21. Nein, wir schlagen dich nicht.
    Ich halte Live für den intuitivsten Seqeuncer wenn man denn schon mit dem Computer arbeitet, aber das Synclag kenne ich. Das ist einer der Gründe, warum ich immernoch zögere auf Live 5 zu wechseln. Dort gibt es zwar einen Latenzausgleich pro Port, aber dieser musste bei mir in der Demo nach jedem Neustart neu kalibriert werden, obwohl die alten Werte zu sehen waren.
     
  22. Anonymous

    Anonymous Guest

    Na dann hoffen wir mal, daß Ableton in der Version 5.5 oder 6 in den Griff kriegt. Alternativ als Sequencer, allerdings eher an die klassischen Software Sequencer angelehnt mit der Oberfläche ähnlich Live ist Tracktion 2 von Mackie. Sehr intuitiv und schnell zu bedienen. Und läuft stabil. ;-)

    Ansonsten MPC und G2 in Kombination. Unschlagbar.
     
  23. opt.X

    opt.X Tach

    nur noch mal ein update, nach dem ja inzwischen einige ableton und apple (auch core audio) updates raus sind:

    heute hatte ich mal das letzte 17" g4 1,67 mit 2gb ram zur verfügung.
    kurzen test gemacht gegen mein altes ibook 12" g4 1,2 mit 1,25gb ram. beide tiger mit neuesten updates, internes audio 16bit 44,1khz

    z.b. unter 5.03 50%-cpu-last-teston
    ibook 48 samples krachfrei, powerbook ca. 80

    das gleiche bei einem einfachen song mit 2x simpler 2x impuls je 256 sample latenz
    prozessor last ibook 14% powerpook 22%

    klar bei vielen effekten und mit dem standarddemosong bekommt man auch zu erwartendes verhalten hin, aber für mich isses leider nix, ich muss wohl bei meim alten schrott bleiben ... oder demnächst mal gegen mactels testen.

    schade, ich dachte es wäre ein treiber problem gewesen und evtl inzwischen behoben ...

    schöne grüße

    m.
     
  24. Anonymous

    Anonymous Guest

    Mal ehrlich. Das ist doch echt voll ätzend! :sad:
     

Diese Seite empfehlen