TR 808 SYSEX Daten - Mapping ändern beim CHD Midi Kit

Dieses Thema im Forum "mit Sequencer" wurde erstellt von KingCAZAL, 13. Oktober 2015.

  1. KingCAZAL

    KingCAZAL Tach

    Hallo liebes Forum und ein herzliches Hallo

    vor ein paar Monaten habe ich mir von CHD das Midikit für die TR808 gekauft und erfolgreich installiert. Alle 11 Sounds werden brav angetriggert gemäß dem Factory Mapping (GM Standard *würg*). Läuft auch prinzipiell wunderbar. Aber genau um das Mapping geht es. Nun wollte ich aber die letzten Tage per SYSEX das Mapping änern und andere Parameter (Midikanal, LED Message on,..). Das mit dem Midikanal ändern und die LED Message an und aus Schalten geht ohne Probleme. Schicke ich jedoch einen Hexadezimalcode (vom Codegenerator) der einen Sound auf eine andere Taste legen soll tut sich einfach nichts und das Original Mapping bleibt bestehen. Da die anderen Sachen funktionieren (Midikanal ändern und LED Message an und aus) ist davon auszugehen, dass alles richtig angeschlossen ist. Habe alles probiert. Anderen Hex Editor, anderen Sysex Versender und und und. Ich nutze einen Mac und zum übertragen SYSEX LIBRARIAN was ein Standardprogramm für solche Zwecke ist. Ich glaube langsam, dass mit der Hardware irgendwas nicht stimmt, aber bin natürlich für jeden Tip froh und hoffe auf schnelle Hilfe.

    Ach ja. Mir ist bewusst, dass ein 3 maliges blinken lediglich einen Factory Reset quittiert. Ich merke es einfach daran, dass sich nicht verändert hat. Auch ein Aus- une Einschalten der 808 bewirkt nichts. Die LED Helligkeit kann ich auch nicht verändern. Lediglich Midikanal Veränderung und die LED Message werden sofort übernommen.

    LG
    KingCAZAL
     
  2. sähkö

    sähkö Tach

    Die LED Helligkeit zu verändern ist MWN gar nicht implementiert (oder doch? Kläre uns auf!). Bei Anomalien generell (hatte mal eine heftige MIDI Panic im Studio) würde ich auch einen Factory Reset in Betracht ziehen, danach müsste evtl. die DAC Kalibration ausgeführt werden, um Doppeltrigger (zwei Instrumente bei einer Note) auszumerzen. Zu deinem Problem: Du generierst die Sysex Strings per CHD Sysex Generator, aber nur jene, die die 808 Instrumente auf andere MIDI Noten mappen, funktionieren nicht? Hast du mittels MIDI Monitor überprüft, ob die Sysex Messages rausgehen und dein MIDI Noten-Sender auch das am CHD Kit eingestellte entsenden? Im Hex-Editor deiner Wahl sind die Sysex Strings plausibel aufgebaut?

    Ich nutze Hex Fiend, die Strings schaue ich mir unter View als Single Bytes an, so sehe ich z.B. mein BD Mapping auf MIDI Note #35/A01 als:
    F0 00 20 21 7F 62 50 23 01 00 7F 2B F7
    Funzt nachweislich. Teste das. Wenn es nicht geht, Factory Reset und dann wieder von vorne. Im Anhang findest du die Hex Datei zu meinem BD Mapping, die du direkt mit Sysex Librarian aussenden kannst.

    Ich hatte keine Probleme, den String via Verona DRM1, TR-9090, Akai S950, an meine 808 zu schicken. Vielleicht probierst du es mal mit der 808 direkt an deinem MIDI Sequencer/MIDI Interface. Kannst du generell mit anderen Geräten problemlos via Sysex kommunizieren?
     

    Anhänge:

  3. KingCAZAL

    KingCAZAL Tach

    Also ich habe die Version 3.30 und in meinem Code Generator ist explizit die Helligkeit einstellbar. Lad Dir mal den Codegenerator runter und Du wirst es sehen.

    Also habe das gnaze jetzt mal vom PC ausprobiert mit MIDIOX und dasselbe verhalten. Setup ist definitiv richtig. Zur Probe ob alles richtig verkabelt ist schicke ich per Software den Reset raus und anhand des blinken der LED am Midi Kit sehe ich ja, dass alles richtig rausgeht. Der Generator bringt schon plausible Daten raus. Ich kann Dir ja auch mal im Anhang eine Datei schicken wo das Mapping der Rimshot auf dem mittleren C (60) gemappt werden soll. Es bleibt immer wieder die Tom.

    DAC kalibrieren braucht meine 808 nicht. Jeder Sound wird sauber einzeln brav angetriggert.

    Also eine Sache macht mich stutzig. In meinem Codegenerator kommt das hier raus wenn ich die BD auf die 35 legen möchte.

    F0 00 20 21 7F 62 50 23 01 00 7F 2A F7

    Ist der Codegenerator vielleicht Mist? Habe es auf PC und Mac getestet.

    Hex Fiend und Sysex Librarian waren auch meine Wahl. Nutze sogar noch den Midimonitor, der mir brav zeigt, dass Sysex Daten rausgehen.

    Factory Reset habe ich ja schon 10000mal gemacht.

    So ein Mist. Ich muss das ummappen!!

    Habe Dir mal meine Sysex angehangen. Kannst Du die vielleicht testen?


    LG
    KingCAZAL
     

    Anhänge:

  4. sähkö

    sähkö Tach

    Scheint also einen neuen Generator zu geben. Hast du dich erkundigt, ob der zu deiner Firmwareversion passt? Mein Setup steht und während einer laufenden Produktion lade ich nichts fremdes. Wenn du mein .syx nicht testen willst und sonst nicht mehr weiterkommst, bleibt der Top-Support via E-Mailvon CHD :supi:
     
  5. swissdoc

    swissdoc back on duty

    Sieht so aus, als würde der neue Codegenerator die Prüfsumme falsch berechnen. Details im alten Thread zum Thema:
    viewtopic.php?t=103421
     
  6. KingCAZAL

    KingCAZAL Tach

    Bäm. Exakt der Verdacht ist mir gerade in den Sinn gekommen. Ich habe mal folgendes überprüft. Meine Version habe ich im Mai 2015 gekauft. Laut der Musikhaus Korn Seite von wo ich das Kit habe war das die Version 3.2. Die aktuellste Version laut CHD ist 3.3 und der Codegenerator sagt auch 3.3. Auf der Seite gibt es wohl den 3.2 Codegenerator, aber der Link verweist zur Version 3.3.

    Hat jemand die 3.2 Version für mich? Das könnte durchaus das Problem sein. Ist aber sehr unschön, dass das nirgends bei CHD erwähnt wird und geantwortet haben die mir auch nicht. Das ist kein guter Support!!!

    Ich vermute mal, dass ich die korrekte Version auf der CD habe, aber finde die nicht mehr obwohl ich die garantiert noch habe.


    LG
    KingCAZAL
     
  7. KingCAZAL

    KingCAZAL Tach

    Ich glaube schicken braucht es mir erst mal keiner. Habe im anderen Thread den 3.2 Codegenerator gefunden. Werde es heute Abend mal überprüfen und sofort berichten.

    Schon mal Danke mich auf die richtige Spur gebracht zu haben!!!

    LG
    KingCAZAL
     
  8. KingCAZAL

    KingCAZAL Tach

    Auf jeden Fall schon mal Danke vorab an SÄHKÖ und SWISSDOC :phat: :phat: :phat: :adore: :adore: :adore:
     
  9. KingCAZAL

    KingCAZAL Tach

    So. Hier das versprochene Update. Das Problem ist gelöst! Schuld war tatsächlich die Nutzung vom Codegenerator 3.3 für eine 3.2er Hardwareversion.

    Vielen Dank für eure Hilfe.

    Wad bleibt ist die große Enttäuschung des Support aus Tschechien. Noch nicht einmal eine Antwort!!!!!! Auch kein Hinweis über die neue Version o.ä. Sehr sehr schlecht. Aber das Kit selbst ist perfekt.

    LG
    KINGCAZAL
     
  10. swissdoc

    swissdoc back on duty

    Fein, vielleicht haben die gerade Ferien? Ansonsten glaube ich nicht, dass die Methode zur Prüfsummenberechnung von Version 3.2 zu 3.3 geändert wurde. Aber genau dort waren die SysEx Strings unterschiedlich. Aber ist ja auch egal. Es klappt ja nun...
     
  11. KingCAZAL

    KingCAZAL Tach

    Naja. Auch wenn die Ferien haben kann man doch einen Autoresponder installieren, der einem das mitteilt. Dafür habe ich ja Verständnis. Aber die User im Regen stehen lassen ist definitiv keine gute Werbung. Musikhaus Korn dagegen war super. Die haben mir sofort angeboten das Teil zurück zu schicken und zu ersetzen. Schreibe denen gleich, dass alles i.O. ist.

    Also es hat sich ja definitiv etwas geändert. Und sobald auch nur 1 Zeichen falsch ist akzeptiert die Kiste es nicht. Ich als User kann das auch gar nicht sehen und ich will ja Musik machen und nicht nebenbei Mathematik studieren :lol:

    Freun können sich über diesen thread die nächsten, die vielleicht dieses Problem haben werden. Wenn man bei Google "Mapping" "CHD" und "808" landet man hier :phat:

    LG
    KingCAZAL
     
  12. sähkö

    sähkö Tach

    Mein Kontakt zum Entwickler war :supi: der hat mir bereits zwei mal freundlich und ausführlich geholfen. Swissdoc ist eh 'ne sichere Bank, wie noch ein paar weitere Spezis in dieser Klapsmühle. Im Supermarkt an der Kasse wird mann/frau auch täglich anders bedient, der Meister wird das — branchenüblich — nicht hauptberuflich machen, also ruhig Blut.

    Ende gut, alles gut :opa:
     
  13. KingCAZAL

    KingCAZAL Tach

    Ist mir schon klar, dass das freaks sind. Aber eine kurze Mail kann man doch irgendwie schon erwarten. Habe übrigens noch immer keine Antwort. Egal. Läuft ja :)


    Wie kann ich hier übrigens einstellen, dass ich eine Email bekomme wenn hier eine Antwort gepostet wird?

    LG
    KingCAZAL
     
  14. sähkö

    sähkö Tach

    Bei deinem nächsten Beitrag die Option "Mich benachrichtigen, sobald eine Antwort geschrieben wurde" aktivieren. Geht in den Einstellungen auch als Standard zu setzen, dünkt mir.
     
  15. KingCAZAL

    KingCAZAL Tach

    ah ok. gefunden. unten ganz versteckt :)

    thx und schönes wochenende

    KingCAZAL
     
  16. swissdoc

    swissdoc back on duty

    Wenn man den Codegenerator 3.2 und 3.30 vergleicht, so fällt auf, dass die Prüfsumme anders gerechnet wird. In einem Fall (bei Programs in 3.30) ist die Prüfsumme sogar immer 00. Eher merkwürdig das alles, vermutlich eher ein Fehler im Codegenerator 3.30, warum sollte man die Methode zur Prüfsummenberechnung auch ändern. Welcher Controller soll das denn dann noch unterstützen?
     
  17. KingCAZAL

    KingCAZAL Tach

    Dann wundert es mich umso mehr, dass ich keine Antwort bekomme. Da müssten doch viel mehr mit dem Problem konfrontiert sein.
     

Diese Seite empfehlen