Bitwig! (Tips & Tricks, Austausch unter Usern)

Bernd@PDX
Bernd@PDX
..
@moss hast Du zufaellig in Deiner DrivenByMoss Roadmap Korg NanoKey Studio irgendwann zu unterstuetzen? Weiss nicht wie weit das verbreitet ist, dass es sich lohnen wuerde...
 
arsc
arsc
....
Kann mir vielleicht jemand sagen, wie man in dem DrivenByMoss Flexi Script einen CC-Wert bzw Funktion unabhängig vom MIDI-Kanal zuweisen kann? Also das quasi eine Zuordnung für alle MIDI-Kanäle gilt. Ich habe ein Keyboard mit 16 MIDI Kanälen und möchte jetzt nicht jeden Regler und jeden Button für jeden MIDI-Kanal einzeln mappen. Ich hatte mir gedacht, dass ich z.B. acht Regler fest auf die Device-Makros lege und ich den MIDI-Kanal am Keyboard ändere und somit dann das Device mit dem entsprechendem MIDI-Kanal in Bitwig steuern kann.
 
moss
moss
||
Kann mir vielleicht jemand sagen, wie man in dem DrivenByMoss Flexi Script einen CC-Wert bzw Funktion unabhängig vom MIDI-Kanal zuweisen kann? Also das quasi eine Zuordnung für alle MIDI-Kanäle gilt. Ich habe ein Keyboard mit 16 MIDI Kanälen und möchte jetzt nicht jeden Regler und jeden Button für jeden MIDI-Kanal einzeln mappen. Ich hatte mir gedacht, dass ich z.B. acht Regler fest auf die Device-Makros lege und ich den MIDI-Kanal am Keyboard ändere und somit dann das Device mit dem entsprechendem MIDI-Kanal in Bitwig steuern kann.
Nein, das geht momentan nicht. Ich nehm es mal auf die Wunschliste.
Ich bin mir aber nicht ganz sicher ob ich deinen Anwendungsfall verstanden habe. Wenn der MIDI-Kanal ignoriert wird musst du trotzdem das jeweilige Device selektiert haben das du steuern möchtest.
 
arsc
arsc
....
Eigentlich gibt es folgende zwei Fälle die ich abdecken möchte:

  • Die Transporttasten (Play, Record, Stop, usw) meines Keyboards senden CC + den eingestellten MIDI-Kanal. Ich möchte damit die entsprechenden Funktionen in Bitwig steuern, egal welcher MIDI-Kanal am Keyboard eingestellt ist. Im Flexi Script müsste ich jetzt jede Taste 16x für jeden MIDI-Kanal zuweisen. Es wäre toll, wenn ich das nur einmal machen müsste.
  • Die Regler + Taster senden ebenfalls CC + MIDI-Kanal und ich möchte diese auf die Device-Makros legen. Auch hier wäre es toll, wenn ich das nicht für jeden MIDI-Kanal einzeln konfigurieren müsste. Die Zuweisung von Device zum MIDI-Kanal kann ich bei dem jeweiligen Device in Bitwig machen. Ich möchte, unabhängig welches Device in Bitwig gerade selektiert ist, ein Device über den MIDI-Kanal spielen und steuern.
Vielleicht denke ich jetzt auch viel zu kompliziert und man kann das irgendwie anders und viel einfacher lösen.
 
arsc
arsc
....
Ich hätte mal eine Frage zu Automationen in Clips. Also entweder bin ich zu blöd dazu oder es geht in Bitwig einfach nicht. Ich kenne das vom Elektron Sequenzer und Ableton Live so, wenn man in einem Clip eine Automation aufnimmt und der Clip-Loop geht wieder an den Anfang, dann bleibt die aufgenommene Automation erhalten und wird nicht durch die aktuelle Reglerstellung überschrieben. Ich habe dazu verschiedene MIDI-Controller entweder als Standardgerät oder mit dem moss-Script gemappt und egal ob ich Overdub aktiviere oder deaktiviert habe, die Automation wird im Loop immer wieder überschrieben. Gibt es hier irgendeine versteckte Einstellung oder ähnliches damit das nicht passiert?
 
moss
moss
||
Ich hätte mal eine Frage zu Automationen in Clips. Also entweder bin ich zu blöd dazu oder es geht in Bitwig einfach nicht. Ich kenne das vom Elektron Sequenzer und Ableton Live so, wenn man in einem Clip eine Automation aufnimmt und der Clip-Loop geht wieder an den Anfang, dann bleibt die aufgenommene Automation erhalten und wird nicht durch die aktuelle Reglerstellung überschrieben. Ich habe dazu verschiedene MIDI-Controller entweder als Standardgerät oder mit dem moss-Script gemappt und egal ob ich Overdub aktiviere oder deaktiviert habe, die Automation wird im Loop immer wieder überschrieben. Gibt es hier irgendeine versteckte Einstellung oder ähnliches damit das nicht passiert?
Du musst "Write Clip Launcher Automation" ausschalten, das ist unabhängig von "Overdub".
 
arsc
arsc
....
Aber dann kann ich ja gar keine Automation mehr in einen Clip aufnehmen. Oder ich müsste das ganz schnell bevor der Clip wieder von vorne beginnt ausschalten. Finde ich jetzt nicht sehr komfortabel. Vor allem weil es bei Elektron und Ableton sehr viel besser gelöst ist und einfach so funktioniert.
 
OdoSendaidokai
OdoSendaidokai
𝄞 ぶ ぷ 옺 웃 유 ♫
Aber dann kann ich ja gar keine Automation mehr in einen Clip aufnehmen. Oder ich müsste das ganz schnell bevor der Clip wieder von vorne beginnt ausschalten. Finde ich jetzt nicht sehr komfortabel. Vor allem weil es bei Elektron und Ableton sehr viel besser gelöst ist und einfach so funktioniert.
Bitte mich nicht privat für eine Lösung anfragen, wenn für ein Problem das hier im Forum besprochen wird eine Lösung gesucht wird. Das führt so ein tolles Forum ad absurdum.

Ich habe das hier mal ein wenig ausprobiert, bei mir wird die Automation nicht wieder überschrieben. Es könnte eventuell einen Unterschied machen, ob du direkt auf den Playknopf des Clips drückst, oder auf den Playknopf des Transportfeldes. Hat es bei mir, wenn ich zusätzlich das Automation Write für den Arranger an hatte. Weiss nicht, ob das ein Bug oder ein Feature ist?

Ansonsten hatte ich nur den Clip Automation Knopf und den Clip Overdub gedrückt . Da ging das einwandfrei.
1631652257531.png


Zum Punkt Tutorials findest du in diesem Tutorial unter Latch/Touch/Write die Erklärung dazu.
https://www.youtube.com/watch?v=6jiieu0L9BM&list=PLdIGJzeTcaAfmug7E2WJgie9yJ93k8l_z&index=4
 
arsc
arsc
....
Bitte mich nicht privat für eine Lösung anfragen, wenn für ein Problem das hier im Forum besprochen wird eine Lösung gesucht wird. Das führt so ein tolles Forum ad absurdum.
Ja das stimmt natürlich. Da war ich wohl etwas zu ungeduldig.

Ich habe das hier mal ein wenig ausprobiert, bei mir wird die Automation nicht wieder überschrieben. Es könnte eventuell einen Unterschied machen, ob du direkt auf den Playknopf des Clips drückst, oder auf den Playknopf des Transportfeldes. Hat es bei mir, wenn ich zusätzlich das Automation Write für den Arranger an hatte. Weiss nicht, ob das ein Bug oder ein Feature ist?
Vielen Dank fürs Ausprobieren und für das Video. Bei mir verhält es sich immer so wie im Write-Modus. Egal welcher Modus, egal ob Clip-Automation/Overdub an oder aus und egal welcher Playknopf, die Automation wird im Loop immer überschrieben. Das stört mich schon sehr.
 
polysix
polysix
|||
@moss Hallo lieber Jürgen,
wäre es möglich die Displayanzeige etwas zu verkängern wenn ich beim PUSH 1

  • Oktave up / down
  • Select+Clip (bei der Anzeige des Clip Namens im Session view)
jeweils benutze. Die Anzeige ist ziemlich flott für meine alten augen :)

....und ich trau mich fast garnicht nochmal dich ganz lieb zu fragen ..schluck...würde es nicht doch gehen bei NOTE die beiden zeilen zu vertauschen? Ich glaube nur da wird über die obere zeile die untere ausgewählt. Bei "MASTER" z.b wähle ich die obere zeile im Display über die obere Reihe Buttons aus .. und bei SCALES genau so ..nur bei NOTE scheint es vertauscht zu sein, ich klick da oft falsch. Möchte Play und krieg den Sequencer .. der zwar ja auch sehr schön ist ...aber na ja... sorry für mein generve... aber der push 1 mit deinem script lässt sooooo intutiv bedienen nur an der stelle muss ich mich konzentrieren und nachdenken :)
 
Zuletzt bearbeitet:
moss
moss
||
@moss Hallo lieber Jürgen,
wäre es möglich die Displayanzeige etwas zu verkängern wenn ich beim PUSH 1

  • Oktave up / down
  • Select+Clip (bei der Anzeige des Clip Namens im Session view)
jeweils benutze. Die Anzeige ist ziemlich flott für meine alten augen :)

....und ich trau mich fast garnicht nochmal dich ganz lieb zu fragen ..schluck...würde es nicht doch gehen bei NOTE die beiden zeilen zu vertauschen? Ich glaube nur da wird über die obere zeile die untere ausgewählt. Bei "MASTER" z.b wähle ich die obere zeile im Display über die obere Reihe Buttons aus .. und bei SCALES genau so ..nur bei NOTE scheint es vertauscht zu sein, ich klick da oft falsch. Möchte Play und krieg den Sequencer .. der zwar ja auch sehr schön ist ...aber na ja... sorry für mein generve... aber der push 1 mit deinem script lässt sooooo intutiv bedienen nur an der stelle muss ich mich konzentrieren und nachdenken :)
Ich hab's mir mal notiert, habe aber momentan einige andere Baustellen :)
 
 


News

Oben