Der große RENOISE - Thread

stefko303

||||||||||
der Laptop? nope...das wundert mich nämlich! nur ein paar %, bis in erratischen abständen über 50% hochschiesst, was dann zu den knackser führt
 

said

|||||
Läuft da noch was anderes im Hintergrund? Auge auf den Monitor werfen, ob da noch ein anderes Programm ungefragt seinen Dienst verrichtet.
 

stefko303

||||||||||
Sollte man auf Performance stellen, d.h. CPU sollte immer mit max. Frequenz laufen. Macht es einen Unterschied ob er auf Netz oder Akku läuft?
mit akku betreibe ich den laptop nicht. der akku ist innherlab von 15 minuten leer und das im idle. liegt also daran ncht. ansonsten ist alles auf oerformance im Netzbetrieb.

said
ja natürlich...mit der betonung auf "einiges". habe nämlich alles was ich nicht brauche, darunter Netzwerk tools u.s.w. deaktiviert um die laufenen prozesse auf dem minimum zu halten. ganz blöd bin ich nämlich nicht ;-)
 

C0r€

|||||||||||
Netzwerk am besten komplett abstellen (flugmodus oder Treiber deaktivieren), das führt gerne zu spikes.
Absolut kein Humbuk, ich hab Latenzmessungen gemacht, 10000 Midi Events mit Wifi on vs off. Auf einem 2007er IBM X61!
ca. 3ms jitter (davon extrem wenige Ausreißer) bei midi wenn wifi off ist (output to input mit ALSA)
>9ms jitter wenn wifi on ist
Ein großer Anteil vom Jitter kommt von der allerersten Note, da die komischerweise 1ms schneller durchgeht, ich vermute einen Fehler in der Messung, also effektiv ca. 2ms max Jitter.
Den Prozessor im Bios auf max hat vorher schon ca. ein paar ms weniger jitter gebracht.
Wichtig ist auch nen USB Port zu nehmen, auf dem nichts anderes los ist (irgendwelche Interrupts), kann man ja nachschauen und merkt man auch bei den Messungen.
So läuft midi in Renoise superstabil. RT Kernel hab ich mit ein paar extra settings kompiliert, hat allerdings kaum etwas gebracht im Vergleich, da die neuen Kernels schon gut abgestimmt sind.

Supersimpler Test im Sequencer:
Einfach 300bpm einstellen und 16tel noten im Sequencer abspielen über MIDI (quasi ein schneller Snare Roll). In Renoise unter Linux bei mir kein Problem und kein Jitter zu hören.
Man glaubt gar nicht, wie viele Sequencer (inklusive Hardware) daran scheitern und es nicht gleichmäßig klingt! Manche stottern schon ab 130bpm und 16teln.

Bei einem neueren Laptop wird es wahrscheinlich anders aussehen, hoffentlich noch deutlich besser. Wobei da potentiell mehr Komponenten mit Interrupts dazwischenfunken könnten und damit ggf. die höhere Taktrate usw. zunichte machen könnten. Da hilft nur ausprobieren und messen.
 
Zuletzt bearbeitet:

stefko303

||||||||||
was ist das für ein tool? nur zum testen oder zum verbessern der Latenz?

und die eingebaute WLAN Netzwerkkarte schalte ich am gehäuse eh über nen schalter auf OFF. Treiberseitig stelle ich nur den onboard sound ab im Geräte Manager bzw BIOS.
mehr will ich da nicht machen, nicht das ich nachher schwierigkeiten kriege das wieder in gang zu bekommen.
 

C0r€

|||||||||||
Das Tool ist nur zum Messen.
Ich schalte WLAN auch per Schalter aus, mehr nicht. Wichtig ist, dass WLAN aus ist und nicht nur nicht verbunden. Ansonsten sucht die Karte ständig nach neuen möglichen Verbindungen usw.
 


News

Oben