DIY Midi Splitter

Hallo,
ich habe mir in den Kopf gesetzt einen Midi Splitter zu basteln.
Wenn er funktioniert, würde ich gerne hier ne Anleitung schreiben, zum nachbauen.
Mit einem ordentlichen Metallgehäuse liegt der Splitter kostentechnisch knapp über 10€, da finde ich die Preise im "Musikfachgeschäft" doch etwas hoch angesetzt.

Dafür hab ich die erste Schaltung aus dem Netzt genommen, die ich finden konnte.
Problem:
Leider kommt bei meinem Aufbau hinten kein Midi Signal wieder raus.



Ansich passiert da soweit ich verstanden habe auch nichts aufwändiges.
Midi Signal -> optokoppler ->hex inverter -> 4 Midi raus

Das ganze sieht jetzt bei mir wie folgt aus:


meine Vermutung ist, dass einer der Chips eine leicht andere Spezifikation hat, als benötigt.
aber vielleicht liegt es auch nur an meinem unvermögen .


Hab es mit verschiedenen Netzteilen probiert.
5V liegen an, hab noch einen verpolungsschutz extern drangebastelt, damit ich mir nicht die Chips zerschieße.
Pin 3; 5; 11; und 13 sind unterm Sockel zusammen gelegt.

Hat jemand von euch schon mal einen Splitter in der art gebaut und/oder kann mir einen anderen Chip empfehlen?
Den HD74LS14P und 6N139 habe ich von Reichelt,
ich kann bei bedarf auch noch mal die Datenblätter heraussuchen.

lg
Bunterhund
 

Anhänge

mink99

*****
Bei meinem experimentier Midi Board ist der 6n139 anders beschaltet.

Pin8 : 5v
Pin7 : gnd über 10k
Pin6 : 5v über 470
Pin5 : gnd

........

Wenn ich den pin6 nicht beschalte, tuts nicht.
Wenn ich einen 6n138 nehme, brauche ich pin6 nicht zu beschalten

.......

Ich weiss aber nicht wirklich, was ich da tue, aber so funktionierts bei mir....
 
Danke für die schnellen Antworten!
Hast du mal geprüft, ob du an IC2/6 überhaupt Signal hast?
Ich hab gerade kein osci da, was sollte denn da anliegen? 5v wie viel Hz?
Bekomme ich das auch mit einem Multimeter hin? (Messbereich max. 10Mhz)

Pin7 : gnd über 10k
Pin6 : 5v über 470
Pin5 : gnd
Werd ich mal morgen ausprobieren, hab gerade keinen 470k mehr da.

.......
Wenn ich den pin6 nicht beschalte, tuts nicht.
Wenn ich einen 6n138 nehme, brauche ich pin6 nicht zu beschalten
So wie ich verstanden habe muss an Pin 6 das Midi Signal.
an welchem Pin hängt denn stattdessen das Midi Signal?

Ich weiss aber nicht wirklich, was ich da tue
dito
 

mink99

*****
Sorry, soll heissen : pin6 über 5v/470k und rx

Problem ist : es gibt 831 verschiedene Schaltpläne , bei jedem ist der optokoppler entweder ein anderer oder anders beschaltet. Es gibt Pläne für devices mit 3.3 v Ports , welche mit 5v Ports ,( Midi ist immer 5 Volt .)

Ich hab am breadboard solange ausprobiert, bis tat,
 

Heinz Schnackensiel

Schaltplan- Versteher
Pin 6 muss einen Widerstand nach +5V habe, sonst ist die Funktion zufällig.
Mit 1k8 ist der relativ hochohmig, in einem Splitter würde ich den kleiner machen (1k).

Pin 7 lässt man üblicherweise offen.

Der "richtige" Optokoppler ist 6N138, der 6N139 ist unnötig empfindlicher (weniger Eingangsstrom nötig, der ist aber konstant und fest vorgegeben) dafür aber auch langsamer, und das stört etwas. Funktionieren sollten allerdings beide.

Der 6N137 ist übrigens noch schneller, kommt aber mit den 5mA Eingangsstrom gerade so nicht aus: neu und im Labor reicht das, alt (-50%) und bei 70° reicht es nicht mehr.
Langsam wäre übrigens gar nicht so schlimm, wenn es nicht beide Signalflanken unterschiedlich beträfe....

Schaltungen mit anderen billigen Optokopplern (CNY-17 und Co. ..) sind Murks. PC900 (das war mal *der* Midi-Optokoppler) gibt es schon lange nicht mehr zu kaufen, der 6N138 ist auch noch besser.
 

MacroDX

Hat ein Bild mit Robotern wo aufm Mond rumlaufen
bunterhund schrieb:
Danke für die schnellen Antworten!
Hast du mal geprüft, ob du an IC2/6 überhaupt Signal hast?
Ich hab gerade kein osci da, was sollte denn da anliegen? 5v wie viel Hz?
Bekomme ich das auch mit einem Multimeter hin? (Messbereich max. 10Mhz)
Ich bin kein Messtechniker, aber ein Multimeter würde ich da als denkbar ungeeignet erachten. An Pin6 kommt das übetragene MIDI Signal raus. Siehe hier, schön dargestellt: http://mitat.tuu.fi/?p=22
 

FNT

....
Wenn du kein Oszilloskop hast, könntest Du auch mit einer LED testen. Zwischen Optokoppler und Inverter, zwischen Inverter und Inverter und am Ausgang. Da sollte dann zumindest mal was flackern. Pin 4 und 5 an den DIN-Buchsen vielleicht verdreht? Der von Dir referenzierte Schaltplan macht keine Angabe ob Front- oder Rückansicht der Buchse gemeint ist...
 

mink99

*****
Informatiker frage :

Wenn an den angeschlossenen Geräten an den jeweiligen Midi-in Ports bereits optokoppler verbaut sind, braucht man doch im Splitter eigentlich keinen ?
 

MacroDX

Hat ein Bild mit Robotern wo aufm Mond rumlaufen
Mit Informatik hat das zwar nicht allzuviel zu tun, aber ich sag mal nein. Du hast zwischen der Aus- und Eingangsseite keine Masseverbindung und somit kein definiertes Potential zwischen Ausgangs- und Eingangsinverter. Die MIDI Kopplung basiert darauf, dass die Senderseite Strom durch die LED im Optokoppler schickt. Dadurch sind die Geräte entkoppelt. Man sollte die LED im Optokoppler auch eher als der Senderseite zugehörig betrachten, welche Lichtsignale zum Empfänger rüberschickt.
 

microbug

*****
mink99 schrieb:
Danke auch von mir, das Problem sind nicht fehlende Schaltpläne sondern zu viele .....
832....
Nehmen wir doch einfach mal einen, der wirklich funktioniert, also auch in der Praxis seit Jahren erprobt ist, und da fallen mir sowohl midibox als auch Mutable Instruments ein.

Schaut man sich den Schaltplan des Shruthi-1 an, so verwendet dieser einen 6N137, ohne Widerstand nach 5V, aber mit einem 10k zwischen Ausgang (Pin 6) und +5V, also ein Pullup. Pin 7 bleibt frei. Die gleiche Schaltung wird auch im Ambika verwendet.

Kann man sich hier anschauen:

http://mutable-instruments.net/static/s ... al-v07.pdf
http://mutable-instruments.net/static/s ... bo-v08.pdf (auf Seite 2)

Den 6N137 hab ich jedenfalls schon in etlichen kommerziellen Geräten gesehen.
 


Neueste Beiträge

Sequencer-News

Oben