iConnect MIDI4+ MIDI2+, MIO2/4/10, MIO XM und XL

lowcust
lowcust
|||||
Ich nutze bisher ein MIDI 4+ im Homestudio, das funktioniert so wie es sein soll.
Nun habe ich von einem Kollegen ein zweites MIDI 4+ bekommen das er nicht mehr braucht.
Durch einen Wechsel des Audio Interface von RME UC auf Digiface USB fehlen mir nun MIDI Ports.

Daher die Frage:
Kann man zwei MIDI 4+ in einem System problemlos betreiben?
Ich hab 2X MioXl und zuvor 2x Mio10 geht per USB ohne Probleme am Windows10/11 PC
 
Soundwise unlike
Soundwise unlike
advanced beginner
Besten Dank erstmal, bei mir wird sich das auf Mac beschränken.

Ich werde dann nachher mal beide per USB an den Hub anschließen und auch mal in der Kette von device zu device.

Bisher habe ich für die Konfiguration die alte Software benutzt.
Wenn das einmal passt muss man ja nicht ständig da ran.
 
M
Mr.Pink
|||||
Ich versuche gerade, mein aktuelles PC-System mit meinem Altbetandsystem (Mac) zu verbinden. Meine Synths hängen am Mac an 2x Unitor8. Für den PC habe ich zunächst mal mit mioXM angefangen.
Die Rechner hängen am gemeinsamen Switch und das mio XM auch.
Die mioXM Ports werden vom Mac erkannt, aber am PC sind die RTP Ports des Interface nicht zu gebrauchen. Sowohl in Reaper als auch Live11 werden sie nicht zuverlässig gelistet.

Deshalb habe ich jetxt erstmal RTP im mioXM ausgeschaltet und benutze rtpMIDI von Tobias Erichsen, was einwandfrei funktioniert.

Benutzt hier jemand ein iConnectivity Interface an Mac und PC?
Wenn man das Interface per Ethernet verbindet, sollte man am Mac alle Ports sehen können (Host, DIN)? Ich sehe in AMS nur die RTP Ports und sonst gar nichts.
Ich hatte gehofft, dass ich mit Hilfe des mioXM die Synths an den Unitors direkt ansprechen könnte. Moentan muss ich dazu aber auf dem Mac in der DAW das MIDI Routing machen.
 
offebaescher
offebaescher
neu hier
aloso am PC gehts doch nur mit dem RTP Midi von Herrn Erichsen ... oder verwechsl ich da was ?

ich hab mit dem Tool zumindest keinerlei probleme !
 
M
Mr.Pink
|||||
aloso am PC gehts doch nur mit dem RTP Midi von Herrn Erichsen ... oder verwechsl ich da was ?

ich hab mit dem Tool zumindest keinerlei probleme !
Ja, mit rtpMIDI klappt es. Aber die RTL Ports des XM sind bei mir am PC nicht zu gebrauchen.
Zusätzlich hätte ich gerne gehabt, daß ich die Synths am Mac/Unitor direkt von PC/Reaper ais ansprechen kann. Aber das geht nicht. Es geht nur über den Umweg DAW-Routing am Mac zu machen.

CoreMIDI ist so ziemlich das Einzige, was ich nach dem Wechsel auf PC vermisse.
 
P
PSR60
..
Hallo zusammen, ich habe eine Frage bzw. ein Problem in meinem Setup - vielleicht kann mir ja ein Midi-Profi hier weiterhelfen.

Ich möchte via Midi-Keyboard die Synthies auf meinem iPad spielen. Mein Setup besteht aus iConnect Audio 2+ / iPad / Mac mit Live / Midi-Keyboard

Leider kann ich auf dem iPad keinen Eingang eines Midi-Signals verzeichnen. Um die Midi-Funktionsweise des Keyboards generell zu testen, habe ich das Keyboard über folgende Verkabelung an meinen Mac/iPad angeschlossen:

Midi-Keyboard Midi-out in Audio 2+ DIN Midi-in
Ipad via Lightning in Audio 2+ USB-iPad Anschluss

Leider kommt hier kein Midi-Signal (weder in Live/Mac noch auf dem iPad) an. Generell funktioniert der Midi-Signal-Weg des Keyboards - habe das Keyboard über ein Esi-MidiInterface am Mac angeschlossen => hier blinkt dann die Midi-Anzeige in Live.

Nur über das iConnect kann ich leider keine Midi-Verbindung herstellen. Hat jemand einen Tipp wie man das Setup realisieren könnte bzw. wie man über das Audio 2+ ein Midi-Signal vom Keyboard auf das iPad/Mac herstellt/routet ?
 
microbug
microbug
MIDI Inquisator
Das Audio2+ ist zwar hier nicht Thema, aber das Routing sollte dort genauso wie bei den Anderen funktionieren.

  • Lade Dir mal die App "Protokol" von Hexler.net runter, das ist ein MIDI Monitor, dann siehst Du, ob was amkommt, ohne Rätselraten.
  • Finde heraus, wie der Port an dem das iPad hängt im Audio2+ heißt (Handbuch, MIDI Monitor)
  • benenne den Port in der Software (Auracle for X) "iPad"
  • route den MIDI IN auf den USB Port an dem das iPad hängt

Wenn man mit MIDI arbeitet, sollte man immer einen MIDI Monitor auf dem Rechner haben, auf dem Mac wäre das "MIDI Monitor" von Snoize. Spart einem Gerätsel, zumal dort Channels und Ports im Klartext angezeigt werden, die manchmal kryptische Bezeichnungen haben.
 
  • Daumen hoch
Reaktionen: 0x1
0x1
0x1
|
"USB Device Jack2" lautet der Name für die (schlitz förmige) iPad Buchse, "Din In/Out" für das Midikeyboard. Diese Verbindung sollte geroutet werden im Midi Port Routing. Zumindest heisst es so im "alten" iConfig. Im (eckigen) USB Port direkt neben dem iPad Port darf dann aber nichts stecken, es geht nur entweder oder !
 
microbug
microbug
MIDI Inquisator
Wird beim Audio2+ das ipad mit dem Lightning-Kabel an den Hostport angeschlossen? Das funktionierte bisher nicht, man mußte es immer mit dem USB Lightning Camera Adaptor und USB Kabel an einen der Deviceports anschließen, bei MIDI2+ und 4+ gab es dazu ein Spezialkabel, welches auch laden konnte. Dieses Kabel wurde allerdings mit den MIOs abgeschafft und ich meine auch beim Audio2+.

In Auracle X heißt der Deviceport IIRC "USB DAW".
 
P
PSR60
..
Großes Dankeschön an @microbug & @0x1 für eure Kompetenz !!!

@microbug
Endlich hab ich feine Monitoring Tools - Haben mir sehr geholfen.

@0x1
Dank dir für den Tipp mit der iPad-Port-Benamung - Hätte ich so nicht rausgefunden

Es funktioniert auch jetzt. Das Midi Signal kommt auf dem iPad & in Live/Mac an.
Wer es nachbauen möchte - das Midi-Routing sieht bei mir so aus

Auracle for X-Series Version 1.9.0

Monosnap 2022-04-05 09-36-37.png

Computer/DAW (Jack1) => geht rein in Live / dort dann iConnectAUDIO2+ DIN als Input wählen
Computer/DAW (Jack2) => geht auf's iPad / dort dann iConnectAUDIO2+ DIN als Input wählen


Alternativ geht es auch über das alte Konfiguration-Tool
iConnectivity iConfig Version:4.2.7
iConnectivity iConfig 2022-04-05 09-43-07.png
 
Onimat
Onimat
...
Hey, vllt kann mir hier wer helfen: also folgendes Problem: ich benutze das mio xl via lan auf einem Windows10-pc, Daw ist Ableton 10. Bis vor kurzem hat auch alles prima funktioniert. Dann jedoch hab ich hardwaremäßig etwas aufgerüstet(vom komplete s25 zum s49mk2 und zusätzlich ein expander Synthesizer), deswegen wollte ich mal das ganze routing optimieren, Dumme Idee. Jetzt funzt nix mehr.

Folgendes genauer beschrieben:

Rtpmidi App zeigt alles normal an

Auracle for x zeigt alles normal an

(Beide lassen sich normal programmieren, die ip erscheint, alles super)
Ableton midi, keine diesbezüglichen Ports sind anwählbar. Das mio xl erscheint auch nicht.

Probiert habe ich schon:

Auf laptop: mioxl wird erkannt Ports können zugewiesen werden alles super. Also es ist ein Software Problem vom pc.

Pc: iconfig von Ableton wurde gelöscht, also eventuell fehlerhafte presets, bringt nix, außer das ich das audiorouting neu machen kann, anstrengend.

Auracle for x und rtp midi neu installieren + Interface zurück setzen brachte auch nix.

Achso, verbinde ich das Interface via usb, wird’s erkannt. Auch in Ableton. Sonst nix. Seltsam. …. Na, vllt weiß wer von euch was neues, hat ne andere Idee. Ich würde mich freuen.

Grüße,

Tamino
 
markus.schloesser
markus.schloesser
...
hat sich evtl die IP Adresse geändert und deswegen erkennt windows das als neues gerät und Live entsprechend nicht mehr?
 
Onimat
Onimat
...
Hey Marcus, dann dürfte Auracle und rtmmidi ja auch das Interface nich mehr finden, oder? Achso, und per usb funktioniert das wie es soll, nur via lan halt nicht…..
 
microbug
microbug
MIDI Inquisator
Schau Dir mal in Deinem Router die Vergabe der IP Adressen an, evtl ist da eine doppelt vergeben, zB vom neuen Rechner. Oder der RTP MIDI Treiber (unter Windows) findet die neue Netzwerkhardware nicht, vielleicht muß der neu konfiguriert bzw installiert werden, da kenne ich mich aber grad nicht aus. Wenns am Mac auch nicht geht, spricht es eher für einen IP Konflikt.

Bei fest im LAN installierten Komponenten empfiehlt sich folgende Vorgehensweise:

  • DHCP Adreßbereich so einstellen, daß dieser erst 10 Adressen später beginnt, also bei 192.168.0.1 (Router) dann bei 192.168.0.10 (oder 11) anfangen
  • feste IP Adressen für alle fest am LAN hängende Geräte vergeben und diese auch entsprechend beschriften bzw sich eine Liste machen
So arbeite ich hier seit vielen Jahren. Die Geräte am WLAN und temporäre Geräte nutzen dann den DHCP Bereich.

Das mit den festen Adressen braucht es für Portfreigaben, zB für Online-Sessiontools wie Sonobus etc.
 
Zuletzt bearbeitet:
Onimat
Onimat
...
Ok, vllt liegt’s ja doch dran, ich probiere das später aus. Danke erstmal😊
 
0x1
0x1
|
Bei mir hats mal nach einer Änderung die IP : Ports im Interface durcheinander gebracht. Musste dann vergleichen zwischen dem Interface und die Ports beim rtpMidi neu zuweisen . Vielleicht ja das ?
 
Onimat
Onimat
...
Hm, ich stehe auf dem Schlauch und muss gestehen, dass ich auch nur die Hälfte von all dem verstehe.

Hab aber trotzdem heute noch mal Bonjour/rtpmidi/Auracle for x deinstalliert, Netzwerk und mio xl resettet alles wieder neu installiert, aber hat nix gebracht.

Bei rtp-midi wird die gleiche ip angezeigt wie bei im rtp Netzwerk.

Glaube ich versteh aber tatsächlich eure Lösungsvorschläge nur halb…gib’s da irgendwo ne Anleitung für dumme😉?
 

Anhänge

  • image.jpg
    image.jpg
    4,6 MB · Aufrufe: 6
Onimat
Onimat
...
Ok, etwas weiter bei der Fehlersuche bin ich. Habe jetzt mal mit dem Hexler Protol nach den erstellten „rtp Ports“? Gesucht, wird auf dem pc nicht gefunden. Aber aufm Laptop schon.
 
2bit
2bit
||||||||||
Ich hab hier ebenfalls Mio XL und FB 7530.

Eine der allerersten Sachen, die ich für den reibungslosen Betrieb im eigenen Netzwerk eingestellt habe, war das hier:

1653413624033.png


Dahin kommst du so:

1653414191635.png


Ferner hab ich meinen angeschlossenen Midi-Devices folgende Konfiguration verpasst:

1653414501715.png

Die Auflösung über "Name" hat unter Windows 10 nicht zuverlässig funktioniert. Die 192.168.178.31 ist mein PC (dieser wurde ebenfalls von mir per fritz!box-config mit permanenter IPv4-Adresse ausgestatten; s.o)
 
Zuletzt bearbeitet:
Onimat
Onimat
...
Hm, danke für den Versuch, hab das genau wie beschrieben eingestellt, aber es wird immer noch nicht in Ableton/hexlerprotokol gefunden.
 
2bit
2bit
||||||||||
Das mioXL ist zusammen mit Windows 10 wirklich sehr störrisch. Ich weiß nicht mehr, genau woran es letztendlich lag, aber es waren einige Neustarts von mioXL und Windows 10 vonnöten. Ich meine mich dunkel zu erinnern, dass es generell besser war, zu erst den PC und erst danach, nach vollendetem Bootvorgang von Windows, das mioXL zu starten.
 
lowcust
lowcust
|||||
Blockiert eventuell deine Windows Firewall die Session, schalt sie zum Testen einfach mal für paar Minuten aus.
Ansonst hab ich die Erfahrung gemacht, das ein Reset und frische Konfiguration die beste Lösung darstellt und spart dir ggf. sogar Zeit.
 
Onimat
Onimat
...
Mit der Firewall hab ich auch schon gedacht und gerade noch mal probiert, brachte nix. Resettet hab ich alles schon mehrmals. Vllt is das Windows irgendwie bisschen weitgehender futschgegangen.
 
lowcust
lowcust
|||||
Mit der Firewall hab ich auch schon gedacht und gerade noch mal probiert, brachte nix. Resettet hab ich alles schon mehrmals. Vllt is das Windows irgendwie bisschen weitgehender futschgegangen.
rtpMIDI von Tobias Erichsen macht Einträge in denn Windows Registry. Google mal wie man das eventuell zurücksetzten kann, gut möglich das es sich hier beißt.
 
Onimat
Onimat
...
Hui, das wird ja immer komplizierter😃 hab mir jetzt son registry-cleaner runtergeladen, vllt hilft das schon….nö, hilft nicht. Muss da noch mal genauer suchen, aber mitm Editor in der Registrierung rumzufuschen…. Huihuihui. Da würde ich Muffensausen bekommen. Achso, interessant ist noch, das der pc zumindest beim hexlerprotokol das Interface erkennt, sobald ich Auracle starte.
 
Kristallprinz
Kristallprinz
||
Das mioXL ist zusammen mit Windows 10 wirklich sehr störrisch. Ich weiß nicht mehr, genau woran es letztendlich lag, aber es waren einige Neustarts von mioXL und Windows 10 vonnöten. Ich meine mich dunkel zu erinnern, dass es generell besser war, zu erst den PC und erst danach, nach vollendetem Bootvorgang von Windows, das mioXL zu starten.
Nein , bei mir nicht !
Ich starte immer meine beiden Mio XL's zuerst , dann Windows 10 ... Ich hatte noch nie Probleme mit den Mio's !!!
Mio's über USB mit Computer verbunden ... Kommunikation mit etwa 15 Midi Geräten nur über Midi DIN .
Funktioniert alles für meine Verhältnisse perfekt !
 
microbug
microbug
MIDI Inquisator
hab mir jetzt son registry-cleaner runtergeladen, vllt hilft das schon….nö, hilft nicht.
Warum sollte es auch? Ein Gerätelimit gibts nur bei USB, und von solchen Registry-"cleanern" läßt man besser die Finger, und manuell drin rumpfuschen auf keinen Fall, außer man ist langjähriger Windows-Entwickler und weiß was man tut. Das ist gefährlicher Aktionismus.

Das einzige empfehlenswerte Registry-Tool ist USB Deview, damit kann man die ganzen USB Geräteleichen gefahrlos entsorgen, und das muß man von Zeit zu Zeit mal machen.
 
 


News

Oben