Latenz, Latenz, Latenz.. Midi beim Mac

Dieses Thema im Forum "DAW / Komposition" wurde erstellt von bratze, 27. Juni 2011.

  1. bratze

    bratze -

    Hallo Forum,
    Ich befasse mich grad mal wieder mit dem Thema.

    Folgendes Szenario:
    USB-Midikeyboard, MacbookPro 2,4er - 4GB, Ableton

    Mich nervt einfach die Latenz wenn ich VSTs anspiele. Wie sich das verhält mit Puffer und ms ist mir schon klar, aber mir ist die Latenz einfach noch zu gross. Bei einem Puffer con ca. 250 Samples habe ich eine Latenz von etwa 13ms, dies ist aber um etwas einigermaßen in time einzuspielen einfach zu viel. Ob ich nun ein AudioInterface (CoreAudio) dran habe oder die internen Speaker des Books verwende, das Resultat ist das gleiche. Weiter runter möchte/will/kann ich mit dem Samplepuffer nicht gehen, sonst fängt's an zu knacken wenn ich Szenen durchschalte.

    Gibt's nen Trick :agent:
    Ich wäre dankbar
    Markus
     
  2. Anonymous

    Anonymous Guest

    eigentlich nein und würde jetzt auch nicht sagen, dass 250 samples viel sind... ausserdem hörst du da nur die ausgangslatenz von 6.5 ms, eingangslatenz spielt bei deinem beispiel mit dem vst keine rolle.

    die lösungen sind da eher teurer, entweder ein hardware instrument für direktes live spiel (monitoring über mixer) oder ein imac/mac pro, da wird man wohl noch einiges runtergehen können mit dem puffer :dunno:
     
  3. also mein MBP läuft mit 256ms 96kHz knackserfrei - das sind 3ms latenz ... das ist mehr als super

    wie groß die Midilatenz über USB ist, weiß ich nicht - da könnte aber je nach Treiber evtl. noch ein Problem sein

    einige VSTs können übrigens noch zusätzliche Latenz verursachen - da kannste ja den Ableton Simpler mit dem VSTs deiner Wahl vergleichen
     
  4. fab

    fab -

    hm, die "250 samples" (256?) werden dir als audio buffer vom interface angezeigt? irgendwo in der kette midi/host/vst/audio-treiber scheint der wurm drin - denn mit 256 samples sollte man bei guten komponenten tight einspielen können. ich verwende für live meist sicherheitshalber 128 samples, aber bin nicht sicher, dass ich das blind von 256 unterscheiden könnte. das ist aber nur der buffer, die reale latenz ist treiberabhängig. seltsam auch, dass es bei 256 samples schon knackt.

    am ehesten hätte ich das usb interface in verdacht, mehr latenz zu produzieren als nötig. bastel doch einfach mal eine klickspur in midi und audio und nimm die das ganze in schleife über midi in /out auf. dann kannst du die abweichung sehen.
     
  5. bratze

    bratze -

    Also Audiomäßig läuft alles gut. Route z.B. meine komplette 909 über 8Ins via Audiointerface in Ableton und muß selbst an der Latenzkorrektur nichts einstellen, nur eben das Anspielen per Midi bzw. USB nervt.

    Nur zur Klarstellung: Die Latenz die mich stört, also Einspielkeyboard.. Hat das denn generell etwas mit dem Audiointerface (Qualität bzw Treiber.) zu tun??
     
  6. nein die Latenz hat vermutlich nichts mit dem audiointerface zu tun - vllcht gibts da n Treiberproblem?
    Ich bin kein Profi - abe rmit ist mit meinem USB-Keyboard noch keine nennenswerte Latenz aufgefallen
     
  7. fab

    fab -

    kann schon sein, denn wenn du audio einspielst, rückt die DAW es automatisch an den richtigen platz. das geht natürlich nicht wenn du live einspielst und abhörst.
    wie gesagt, mach den oben beschriebenen schleifentest mit midi in/out und schau dir deinen versatz an.

    weiterer test: was ist denn, wenn du über das audioface, über das du deine sounds beim keyboardspielen abhörst, audio live einspielst und software monitoring aktivierst? auch latenz?
     
  8. fab

    fab -

    welches audiointerface nutzt du eigentlich? die reale (nicht angezeigte!) latenz der treiber variiert ganz schön.
     
  9. benutzt man z.B. ein RME Ff400 entspricht die reale der angezeigten latenz - das hat aber dennoch nichts mit der Midilatenz zu tun


    ist die Latenz denn bei allen vsts gleich schlimm?
     
  10. bratze

    bratze -

    @fab.. Teste ich heute abend mal. Zudem teste ich auch mal wie's ist wenn ich mit einem anderen Keyboard per MIDI-In (ganz klassisch) einspiele..

    Die Latenz ist bei allen VSTs gleich schlimm. Nutze sehr gerne die TALs und den Predator. Selbst wenn ich die 909 per Keyboard ansspiele (einzelsounds) tritt die Latenz auf. >> Ich muss aber zugeben das die Latenz noch nicht immer so schlimm war! Kann natürlich auch am System liegen.

    Audiointerface ist ein Presonus Firestudio (FW) mobile.

    :invader2:
     
  11. fab

    fab -

    OK, also deine kette ist:

    usb midi interface vom keyboard (welches?) --> Ableton Live (software monitoring im kanal aktiviert) --> VST ----> Presonus Firebox mit 250 samples als buffer (nur ein buffer, oder?)

    hast du noch ein anderes VST host programm außer Live? wie ist es da? könntest du dir die MAC-beta-version von reaper runterladen (http://www.reaper.fm) und es damit probieren?
     
  12. Hallo,

    sorry wenn ich dazwischen funke, aber ich habe auch ein Problem in diese Richtung. Ich habe Cubase 5.5 und ein Toneport UX8 Interface ( USB 2.0 ). Ich stelle ebenfalls auf 256 Samples und habe dann so in etwa 7-8 ms Eingangslatenz bei ca 15ms Ausgangslatenz.
    Soweit so gut, ich kann damit wohl oder übel leben. Wenn ich aber nun ein VST ansteuere und eine Melodie aufnehme ( benutze das Korg Microkey ) dann sind die aufgenommenen Noten alle nach vorne hin verschoben. Ich muss eine aufgenommene Melodie immer nachträglich per Hand nach hinten verschieben ( Einspielfehler außen vor :) ).
    Ich würde jetzt eher erwarten, das ich die melodie nach vorne ziehen muss aufgrund der Latenz. Ich werd auf jeden Fall das gefühl nicht los das da irgendwas bei mir nicht stimmt.
    Und 2te Frage: Wenn ich den Virus TI anspreche habe ich gleich eine viel höhere Latenz. Leuchtet mir aufgrund des zusätzlichen Audiostroms auch ein. Aber gibts da nicht einen Trick oder so dagegen?
     
  13. Beim Ti gibt es im Plugin unten links einen Button mit der Aufschrift "Live". Es empfiehlt sich, diesen beim Einspielen zu betätigen. Das senkt die Latenz beim einzuspielenden Midi-Part. Beim Abspielen sollte der aus sein.
     
  14. Ok danke. Ich Depp. Kenne doch den Button und weiß auch was er macht. Manchmal hab ich echt n Brett vorm Kopf :selfhammer:
     
  15. Hm. Hab mal gegeuckt. Der Live Button ist bei mir gar nicht klickbar sondern disabled :-|
     
  16. Summa

    Summa wibbly wobbly timey wimey

    Ich hab' zwar im Moment nicht die aktuelle Version der TI Software Installiert, denn die aktuellen Erweiterungen betreffen fast nur die Effekt Sektion, aber probier mal den D (Direct) Button unter dem Mute Button, der sorgt dafuer dass das Signal nicht nochmal durch den Rechner geschickt wird, falls der in der aktuellen Version noch existiert.
     
  17. Auch, wenn der Sequenzer gestoppt ist?
     
  18. microbug

    microbug |||

    Jein. Ableton live war hier bei MIDI das problemloseste, aber ich hab auch keine VSTis genutzt. Billige Mac-Midiinterfaces haben scheinbar keinerlei Pufferspeicher etc, ich hab meine MIDI-Timingprobleme hier mit dem Kauf eines gebrauchten AMT8 (MT4 geht auch) gelöst - Treiber beachten, ich hab eine Übersicht im MacOS-Bereich gemacht.
     

Diese Seite empfehlen