Microwave (1) versteht kein Realtime-Sysex mehr - why?

Dieses Thema im Forum "Analog" wurde erstellt von micromoog, 9. Oktober 2010.

  1. Mein Microwave (Rev. B - Soft 2.0) will sich nichts mehr von Sysex-Realtime Steuerungen sagen lassen, woran kann das liegen?
    Vor ein paar Wochen/Monaten hat alles noch funktioniert, es wurde auch sehr lange nichts mehr gedumped.

    Bereits probiert wurde:
    - Regelwerk an Microwave mit entsprechenden Sysex-Parameter-Befehlen (entsprechen 1:1 dem Access-Programmer)
    - alternative Probe mit Rees C16 Faderbox und kleinem Microwave-(Werks-)Preset -> wird ebenfalls ignoriert, auch dort alle Kanäle und ID's probiert.
    - CCs und Note-Befehle werden vom Waldi absolut problemlos empfangen.
    - MW in div. Modes betrieben -> nüscht
    - Regelwerk und Rees zum Gegencheck mit entsprechenden Parameter-Presets an den MKS-50 geroutet, dort läuft alles rund.

    am Waldi:
    - Alle Kanäle probiert Omni-16 -nix
    - Alle externen MIDI-Ansteuerungen sind zugelassen
    - Device ID von "000" bis über "126" probiert
    alles nüscht.

    Bei Device "000" blinkt zwar bei reglerbewegungen die MIDI-LED, Paremeteränderungen werden jedoch nicht ausgeführt (auf allen Kanälen nicht)

    Edititieren am Gerät selbst geht, sonst scheint auch alles andere Tip Top aus!

    Habe ich irgendwo in den tiefen Analen was übersehen, was versehentlich deaktiviert wurde?

    Oder sonst noch Tipps?
    Gibts irgend einen Reset-"Affengriff" im Waldi?
     
  2. swissdoc

    swissdoc back on duty

    Interessantes Fehlerbild. Mein original MW hat sich vor einiger Zeit einfach komplett verabschiedet. Muss den mal aufschrauben. Gut dass ich noch einen 2. habe und den WAVE...

    Wie alt ist Deine Batterie? Jemals gewechselt? Gibt es komische Zeichen im Display? Könnten evtl. korrupte Daten im Speicher sein.

    Die Device ID hast Du ja schon probiert. Das sollte aber ja im Regelwerk auch zu regeln sein. Versuch es mal mit der generischen Checksumme 7F bei den SysEx Strings. Hast Du wohl eh schon drinnen.

    Es gibt keinen Reset. Einfach einen KNOWN GOOD Dump in den MW jagen.
    Es gibt keinen SysEx enable/disable Schalter. Der Parameter slow/fast im Midi Menu ist nur für das Senden.
    Schau was mit dem Link Parameter ist.

    Es gibt noch einen Test Mode, da kannst Du einiges Testen oder auch zerstören
    http://faq.waldorfian.info/faq-browse.php?product=mw#69
     
  3. Danke für den Tipp mit dem "Guten Dump"!

    Also er "frisst" die Daten immernoch.
    Jedoch nur die, welche ich damals vom Access Programmer in den C-LAB Creator recordete.
    Evtl. hängt es doch mit dem Speicherverlust vom Regelwerk vor ein paar Tagen zusammen. Komisch nur, das die MKS80 und MKS50 Presets tadelos funktionieren, aber das gleiche Back-Up mit dem Microwave Preset nichts tut, obwohl die Daten gesendet werden - Strange!

    Im Rees Controller ist übrigens das MW-ROM (!!!) Preset grottenfalsch :shock: :roll: . Midi-OX und Atari zeigen im Vergleich mit den Access-Daten einen völlig anderen String. Komisch das die das nie ausprobiert haben...wahr wohl ein "Blind Date"!
     
  4. swissdoc

    swissdoc back on duty

    Ich meinte einen Dump vom Typ CRTR (IDM: 14h (Cartridge Dump Request)) an den MicroWave zu schicken, dann ist im MicroWave alles auf grün, wenn der Dump eben KNOWN GOOD ist.

    Wenn natürlich Dein Regelwerk falsche SysEx Daten sendet, wird es nicht klappen...

    Hier findest Du die SysEx Specs vom MicroWave für V2.0:
    http://www.waldorfmusic.de/de/archiv/mi ... nload.html

    Schau nach RTBP (IDM: 60h (Real Time BPR Edit)), nimm jeweils 7F für die SysEx ID und die Checksum, nur wenn Du mehrere MicroWaves getrennt steuern willst, musst Du Dir Gedanken machen...
     
  5. Denke ein kleines Missverständnis:
    Meine selbstertellten Regelwerk-Daten haben bis zum RW-Speicherverlust funktioniert, das identische Back-up sendet den "vermeintlich" richtigen String, nur der MW reagiert nicht darauf.
    Wie gesagt der gleiche String vom Atari funktioniert, da muss noch irgendein "Querolant" in der Strecke RW-MW sein ;-)

    Die ROM-Preset Daten für den MW der Philipp Rees C16 Fader-Box sind ab Werk falsch.
     

Diese Seite empfehlen