NI Maschine Mk3 - Midi-Probleme - die Lösung ist irgendwie krass!

H

HorstBlond

||||
Moin moin,

meine Maschine Mk 3 verliert die Midi-Connection nach kurzer Zeit.

Setup: Win 10, neueste NI Software-Versionen installiert. Rechner ist überhaupt gerade frisch neu aufgesetzt.
Midi über RTP (iConnectivity MioXM, Firmware 1.10)

Innerhalb der Maschine Software, mit VSTs läuft es so weit stabil. Wenn ich aber einen Sound über Midi ansteuere, klappt das nur kurz. Nach kurzer Zeit (spielen, Mod Wheel, AT oder Soundwechsel am Midi Gerät) hängt sich die Midi-Verbindung auf. Manchmal mit Noten-Hänger, manchmal kommt einfach nichts mehr. Es hilft nur: Maschine Software schliessen und neu starten, dann passiert es nach ca. 30 sec (ohne erkennbaren Grund oder das es genau reprodizierbar wäre) wieder.

Die Midi-Verbindung über RTP scheint stabil: wenn ich das gleiche in Live mache (ohne Maschine) bleibt die Midi-Vernindung stabil. Daher vermute ich das Problem bei der Maschine. Richtig?

Habt ihr Ideen? Danke.

P.S. ich bin, sagen wir es diplomatisch, erstaunt über die Qualität der NI Software: anderes Beispiel: beim Neuaufsetzen hatte ich, wie auch bei NI empfohlen, den NI Content und die VST Locations geändert, um alle VSTs, auch von anderen Herstellern in einem Ordner zentral zu haben (im NI Access-Tool). Ergebnis in der NI Software: Erstens: wenn ich dann z.B. einen FM8 standalone starte kommt der ohne Soundbänke hoch... und wenn ich dann zweitens einen Sound in der Maschine laden will heisst es: FM8 (z.B.) kann nicht geladen werden. Usache: in den Plugin Settings sucht Maschine nur in den Standard-Ordnern, aber nicht in denen, die ich im Native Access angegeben habe... Ich mein... das ist so basic... Das sollte die Software bei der installation doch merken... Ich nutze ja Version 2. irgendwas und nicht die v.0.9 beta....
 
Zuletzt bearbeitet:
H

HorstBlond

||||
P.S. in dem Zusammenhang - Stichwort: VST Ordner. Ich wollte dafür keinen eigenen Thread aufmachen.

Welche Ordner-Struktur ist da richtig?
-VST2 mit Unterordner VST2-32bit und VST2-64 bit
- VST3 - Unterordner?

In der NI-Welt gibt es nur VST2? Bei Ableton Live VST2 und VST3.
 
H

HorstBlond

||||
Nachtrag: man kann das schon provozieren: Wenn ich am Novation SL61Mk3 über Midi CC Changes mache (z.B. Cutoff) dann passierts beinahe sofort und mit Sicherheit. Wenn ich nur spiele geht das meist lange gut - aber auch nicht immer
 
H

HorstBlond

||||
UPDATE: das eigentliche Problem ist "gelöst": Ich glaube, dass das Problem der instabilen Midi-Verbindung ein sehr altes NI Problem ist. Kurz: es gibt einen (Windows) Registry Hack dafür (man muss einen Wert hinzufügen; in dem gleich verlinkten Thread wird ein Patch angeboten, der wohl nichts anderes macht; mir war es aber lieber, dass ich den Eintrag per Hand vornehme).

Im NI- Forum wurde das heiss diskutiert, über Jahre... z.B. hier. Auf der verlinkten Seite gibt der Moderator dann bekannt, dass NI das Problem nicht lösen will. Immerhin eine klare Aussage.

Bei mir läufts erstmal, ich verstehe aber nicht wirklich, was ich mir mit dem Reg-Hack antue; immerhin wirkt der Hack nur in der NI-Welt und mischt nicht das System irgendwo auf. Ich weiss nicht, ob mein Problem wirklich das beschriebene war - aber seit dem Reg Hack läuft es.

Ehrlich gesagt habe ich mir noch nicht die Mühe gemacht genau zu verstehen, was das Problem für NI ist und was der Nachteil für mich mit dem Hack ist. Warum implementiert NI nocht einfach den von ihnen bekanntgegebenen Hack? Ich finde das - mit nur 10 Min lesen - krass: Ein Key-Feature (Midi-Sequencing) wird nur über einen (einfachen) Hack möglich. Und ich muss dazu irgendwas mit Sync abschalten?? Leider für mich ein weitere Grund (neben der fehlenden Integration bzw. Nutzung als Midi-Controller zB in Live) von NI Abstand zu nehmen auf andere Controller und Systeme zu schielen.

Hat noch jemand eine Meinung zu dem VST-Ordnern oder rechtfertigt das einen eigenen Thread?
 
Zuletzt bearbeitet:
betadecay

betadecay

Dronemaster Flash
Das kenne ich (bei der alten MK 2) - den Link zu dem Registry-Hack hatte ich hier auch schon vor Kurzem gepostet, aber so, dass ihn dort sicher niemand suchen würde.

Bei mir hat das immer zu Notenhängern geführt, so dass ich irgendwann aufgegeben habe, Hardware über Maschine anzusteuern (DIN-Kabel war übrigens genau so doof wie USB-MIDI - das Problem tritt bei beiden auf). Abhilfe: entweder aus- und wieder anschalten oder Patch wechseln, andernfalls trötet das Blech endlos weiter. Beim "Nerdlich der Mitte" mussten VSTis den Job übernehmen, das war mir sicherer. Mit dem Hack läuft jetzt aber alles wunderbar und verlässlich.

Der Hack bezieht sich nur auf den MASCHINE-Teil der Registry, von daher dürfte der woanders nicht stören (und hat es bei mir bisher auch nicht getan).
 
H

HorstBlond

||||
hier auch schon vor Kurzem gepostet, aber so, dass ihn dort sicher niemand suchen würde.
:) stimmt, gelesen hatte ich das ;-) Aber den Link nicht hergestellt... Bei mir ist / war es ein Abbruch, definitiv ein Abbruch, der manchmal Notenhänger verursachte. Wie bei Dir half nur ein Neustart der Software. Und permanent bis jetzt der Registry-Hack. Gestern gemacht, auch heute kein Abbruch bisher.

Weisst Du / jemand, was der Hack an vlt gewünschter Funktionalität abschaltet?
 
betadecay

betadecay

Dronemaster Flash
Ne, keine Ahnung. Wenn gar der nichts böses tut, warum ist er dann nicht gleich in der Setup-Routine für Maschine integriert? Anderserseits: ich hab bisher nichts nachteilges bemerkt oder irgendwo gelesen.

Wobei ich nicht die MASCHINE ausmachen musste, sonden den Synth. Oder Programmwechsel, das ging auch. Maschine lief dabei munter weiter, die Software hat sich nicht dafür interesseiert, dass da ein Synth um Hilfe rief....
 
 


Neueste Beiträge

News

Oben