ASIO4ALL - Reihenfolge der Devices ?

Dieses Thema im Forum "PC" wurde erstellt von bellarossa, 3. März 2017.

  1. Hi,

    habe jetzt schon kreuz und quer gegooglet aber irgendwie nichts gefunden, das mir weiterhilft.

    Es geht um die Einbindung mehrerer USB "Soundkarten" (also Roland Boutiques, MX, TR usw) in Ableton via ASIO4ALL. Prinzipiell werden alle Karten erkannt und es funktioniert, aber wenn ich sie nach und nach alle anstecke, dann werden sie nicht in der gleichen Reihenfolge in ASIO4ALL abgebildet und es würfelt mir alle Einstellung in Abelton durcheinander.

    Beispiel: Am Anfang ist nix angeschlossen und das erste USB Interface wird angesteckt:
    USB PORT 1, TB-03 -> ASIO Device 1, Ableton Channel 1+2

    Dann kommt das MX dazu und wird, wie erwartet, einsortiert:
    USB PORT 1, TB-03 -> ASIO Device 1, Ableton Channel 1+2
    USB PORT 2, MX -> ASIO Device 2, Ableton Channels 3-20

    Jetzt würde man ja erwarten, ich stöpsel die TR8 an Port 3 und die wird dann als Device 3 erkannt und kriegt die Kanäle 21 usw

    Aber nein, die TR8 wird jetzt zwischen die TB und das MX geschoben, also sind alle Kanalzuweisungen aus Ableton für das MX1 für die Katz.
    USB PORT 1, TB-03 -> ASIO Device 1, Ableton Channel 1+2
    USB PORT 2, MX -> ASIO Device 3, Ableton Channels 15-33
    USB PORT 3, TR -> ASIO Device 2, Ableton Channels 3-14

    Und so geht´s weiter, wenn ich weitere Boutiques oder auch ein RME Babyface dazuschalte (ist also kein Roland Problem !). Es ist irgendwie keine Logik erkennbar, in welcher Reihenfolge ASIO4ALL die angeschlossenen Geräte auflistet und immer wenn etwas neues dazu gekommt, wird wieder bunt neu gewürfelt.

    Das ist ja alles noch ok, wenn ich ein festes Setup habe im Studio. Aber wenn ich mal mit Laptop und 1-2 Geräten unterwegs bin, geht alles wieder von vorne los.

    Weiß jemand, wie das bei ASIO4ALL funktioniert und wie man die Reihenfolge steuern kann?
     
  2. darkstar679

    darkstar679 |||||

    ich habe immer alle geräte angeschlossen.
    sobald ich die geräte einschalte, werden nacheinander alle USB geräte angemeldet.
    danach fahre ich erst die DAW hoch und der ASIO4ALL registriert die ports.

    die sind aber immer alle in der gleichen reihenfolge.
     
  3. Hm, das ist ja seltsam. Kannst Du mal probehalber die USB Ports von zwei Geräten tauschen und kucken, ob sich an der Reihenfolge was ändert ? Aber bitte nur, wenn Du die Zeit hast, potentiell verwürfelt es Dir sonst auch Deine Config....

    Es gibt nicht zufällig irgendeine config oder .ini Datei bei ASIO4ALL, in der man da ein bißchen steuern könnte ?
     
  4. Summa

    Summa hate is always foolish…and love, is always wise...

    USB Ports tauschen unter Windows funktioniert eigentlich nur bei Maus und Tastatur halbwegs problemlos, am besten Foto machen und wieder genauso in den Rechner stecken ;-)
     
  5. Ich hab mir jetzt einen powered USB Hub geholt und alle Ports schön sauber gelabelt.

    Das mit dem Geräte verwürfeln passiert immer noch, sobald mal eins fehlt - heißt also: Immer schön alles anschalten, auch wenn man nur 2 benutzt.

    Ich könnte mir natürlich ein separates Ableton Template bauen für die typischen Szenarien, also template 1 für "alles an" und template 2 für "alles ohne TR8" usw, aber da glaub ich zahl ich lieber ein bisi Strom und hab´s dafür einfach :nihao: