Display Umbau Emu-EIV - Cool Blue fertig!

Dieses Thema im Forum "Digital" wurde erstellt von eisbaerlin, 26. April 2012.

  1. Hallo zusammen,

    gestern hab ich es geschafft. Der Umbau meines EIV mit einem neuen blauen Display ist vollbracht. Das sage ich mit etwas Stolz :lol:

    Ein riesen Dank nochmal an Dietmar :phat:

    Wie bereits geschrieben, habe ich noch ein nagelneues Display übrig + Kleinteile. Wer Interesse hat kann sich per PN bei mir melden. Ich verkaufe die Teile zum Selbstkostenpreis von 45,- +Porto.
    Für alle, die ähnliches vorhaben, habe ich eine Anleitung mit Fotos erstellt. Anregungen und Kritik nehme ich gern entgegen.

    Vielen Dank!
     

    Anhänge:

  2. 7f_ff

    7f_ff aktiviert

    Herzlichen Glückwunsch - klasse Sache, auch das mit der detailierten Anleitung :!: :supi:


    Gruss
     
  3. :supi: + klasse Anleitung!

    Ein neues Display würde meinem EIII auch gut stehen.
     
  4. vds242

    vds242 -

    ...und warum tust Du es dann nicht?

    Es dürfte bei Deinem EIII doch sehr wahrscheinlich nur die Hintergrundfolie sein.

    War bei meinem EIII, EIIIXP und ESI 32 genauso.

    Habe die Folien über Midi-Rakete bestellt.

    Es kann aber etwas Bastelei sein, wenn die alte Folie noch auf der "Platine" klebt. Das wurde wohl so gemacht, damit sie nicht verrutscht.
    Dann muss man halt mit etwas Geduld, die alte Folie von dem Kleber befreien.

    Ist also nicht soo schwer. Ich als absoluter Löt-Laie habe das jedes Mal ohne Probleme hinbekommen.

    Gruß,
    Chris
     
  5. microbug

    microbug |||

    Well done!

    Ok, 2 Sachen wissen wir also jetzt:

    1. Es muß auf jedem Fall eine gerade Pfostenfeldleiste auf das Display gelötet werden
    2. Es braucht eine Anpassung des Kongrastregelbereichs, zumindest bei diesem Displaytyp.

    @admin: das gehört doch eigentlich eher nach Lötkunst, vielleicht dorthin verschieben?

    Bei den E5000 Ultra, auf denen schon EMU-Ensoniq steht, ist so ein Wechsel viel einfacher, die haben keine Zusatzboards und bereits ein LED-Display drin, allerdings auch nur ein schwaches Grünes.

    Und fürs Wiki wäre das auch was.
     
  6. cleanX

    cleanX -

    Ich hab mal ne Frage, weil ich das selbe gerade bei einem e64 vor habe. Du hast die 5V genommen für die LED-Beleuchtung ohne Vorwiderstand? Bin gerade ein bissel verunsichert, wenn ich so einige Elektronik-Foren zum Thema LED-LCD-Display quer lese.

    Ich habe das ebay-Display für 15E bestellt, hat ebenfalls den T6963C als Controller, Kontrast funktioniert im e64 ebenfalls nicht out of the box. Bei der Hintergrundbeleuchtung habe ich ein bisschen Angst da 5V ohne Widerstand drauf zu geben.

    bei dem Anbieter steht zum Beispiel unbedingt Vorwiderstand einsetzen:
    http://www.lcd-module.de/pdf/grafik/w240-6.pdf

    oder in diesem Forum wird diskutiert, wo der Fehler liegt und ob es eine LED- oder CL-Hintergrundbeleuchtung ist. Dem Foto nach, kann es m.E. nur eine LED-Hintergundbeleuchtung sein. Leider erfährt man nicht, wie es am Ende ausgegangen ist.

    http://www.mikrocontroller.net/topic/110647
     
  7. rauschwerk

    rauschwerk pure energy noise

    Super Anleitung !
     
  8. microbug

    microbug |||

    OMG. Vergiß das bitte ganz schnell wieder, der Autor des letzten Beitrages hat völlig recht: dem OP wurde Blödsinn erzählt, der Thread ist völlig nutzlos. Zum Einen, weil der OP nicht alle Infos liefert und sich darauf der Rest was zusammenreimt.

    Wenn Du den Inverter ausbaust und dessen 5V-Zufuhr ans Display führst, bist Du schon hinter dem Kontrastregler, der ja nichts Anderes als ein regelbarer Vorwiderstand darstellt. Nur reicht offenbar der Regelbereich nicht für jedes Display aus. Manche haben einen eingebauten Zusatzwiderstand, wahrscheinlich genau aus Gründen der Kompatibilität zu den Displays mit Folie, um den Austausch einfacher zu gestalten. Löte daher einfach mal ein Trimmpoti dazwischen und probiere, bei welchem Wert der Regelbereich paßt.
     
  9. cleanX

    cleanX -

    Moment. Grundsätzlich müssen wir doch zwei Sachen unterscheiden, die Spannung für den Kontrast und die Spannung für die LED-Hintergrundbeleuchtung. Um letzteres geht es mir im Augenblick. Alles was ich bisher zusammengelesen hab, geht in Richtung unbedingt Vorwiderstand wegen Strombegrenzung in die 5Volt-Leitung für das LED-Backlight, wenn die LEDs ne Weile halten sollen.

    Mein Problem ist die Widerstandsberechnung, weil es für mein Display keine Anleitung mit den notwendigen Daten gibt.

    Die Spannung für den Kontrast wird innerhalb des 20poligen Anschlussblocks gehandelt. Das hat doch mit den 5V aus dem Mainboards, die für das Backlight genutz werden, gar nichts zu tun.

    Die helleren weiss-grauen Dislays der späteren E-mu-Modelle, egal ob Classic oder Ultra dürften m.E. eine CCFL-Hintergrundbeleuchtung haben und benötigen daher auch einen Inverter. Einzige Ausnahme ist der E5000 Ultra mit dem grünen Display, das ist eine LED-Beleuchtung.
    Nur der das Ur-Modell EIV und der e64 haben anscheindend diese EL-Folie.
     
  10. microbug

    microbug |||

    Die Kontrastregelung erfolgte zumindest beim SY99 über die Spannung für die Folie, oder ich habe mich massiv im Schaltplan verguckt. Ich hab da jedenfalls keinen Vorwiderstand eingebaut, sondern direkt die 5V angeschlossen, dafür war dieses Display auch gedacht. Wenn Du mal den Thread, der diesem hier vorausging, anschaust, so findest Du dort Links zu ex5tech, wo es um einen Zusatzwiderstand in der Spannungszuführung der Beleuchtung geht.

    Wenn das Datenblatt des Displays 5V an der Versorgung für die LED-Beleuchtung vorsieht, dann geht da auch 5V, ohne irgendein gebastel mit Vorwiderstand. Wäre ja auch ein wenig Blödsinn, dem Kunden das aufzubürden, denn zur Berechnung müßte er die exakte Menge der verwendeten LEDs und deren Stromverbrauch kennen.

    Die späteren Modelle, wo EMU-Ensoniq draufstand, hatten alle ein LED-Display, zumindest die Geräte, die ich schon von innen sehen konnte. Nur deren Mainboard ist auch für beides vorgesehen, und die Mainboards sind ja bei allen Ultras identisch.
     
  11. vds242

    vds242 -

    Hallo Dietmar!

    E-Synth Ultra, E6400 Ultra, E4XT Ultra und der E4 Platinum haben alle CFFL Displays.

    Lediglich der E5000 Ultra hat ein LED Display.

    Gruß,
    Chris
     
  12. microbug

    microbug |||

    Hm, also ich hatte hier neulich mindestens einen E6400 mit LED-Display, das war nicht nachgerüstet. Hab extra aufs Typenschild geschaut, da stand schon EMU-Ensoniq, so wie bei meinem E5000 Ultra.
     
  13. vds242

    vds242 -

    Ultra oder none Ultra?

    Die Ultravorgänger hatten noch LED Displays, der original EIV und der e64 hatten noch EL Folie.
    Wie das bei den Keyboardvarianten war, weiß ich nicht mehr genau.

    Gruß,
    Chris
     
  14. microbug

    microbug |||

    Müßte ein Ultra gewesen sein. Beim non-Ultra sieht der Schriftzug auf dem Frontpanel deutlich anders aus.
     
  15. vds242

    vds242 -

    Hmm, das wundert mich jetzt wirklich.
    Ok, eine Möglichkeit ist noch, das Du da ein Mischgerät hattest. Also durch einen Engpass ein anderes Display eingebaut wurde.

    Ähnliches ist zumindest definitiv beim Übergang von Classic zur Ultrareihe passiert.
    Z.B. beim Gehäuse. Bei Ebay ist zur Zeit ein E4X drin, der auf der Rückseite ersichtlich, das Ultragehäuse hat, auch schon mit dem Ultra DWAM Board ausgerüstet.

    Da frage ich mich z.B. wie das funzen soll? Der E4X hatte ein anderes Gehäuse, und keine Wordclock-Anschlüsse......

    Na ja, egal.

    Hauptsache, die Displays leuchten schön......ähem, das macht mein E5000 nur noch recht schwach.... :floet:

    Gruß,
    chris
     
  16. microbug

    microbug |||

    Das wäre doch ein schöner Einsatz für das Display, welches der TE noch über hat :)
     
  17. vds242

    vds242 -

    Keine Ahnung, ob der das noch übrig hat......

    Ich frage Ihn mal....

    Danke für die Erinnerung!

    Gruß,

    Chris
     
  18. cleanX

    cleanX -

    http://forum.electronicwerkstatt.de/phpBB/faq/led/

    Die Erklärung des Users Zabex hat mir ganz gut geholfen:

    http://f3.webmart.de/f.cfm?id=1663923&r ... 781&pg=118


    @microbug

    Der SY99 hatte doch bestimmt auch original eine EL-Folie. Mit der hochfrequenten Spannung wird bestimmt nicht der Kontrast eingestellt, oder?

    Bei den Yamaha-Bastlern hat irgendwie niemand einen Vorwiderstand für das LED-Backlight eingebaut. Die haben alle den Widerstand für den Kontrast geändert. Aber das sind wie gesagt ja zwei verschiedene Sachen.
    Und so richtig ausgefuchste Elektroniker tummeln sich in dem Yamaha-Thread eben nicht.

    Ja, genau das steht in den Datenblättern. Der Kunde ist ja kein Endverbraucher aus dem Mediamarkt, sondern ein Elektronikbastler. Und die Hersteller der Displays haben bestimmt nicht den unbedarften Bastler als Kunden im Visier.

    Ich habe mittlerweile ein halbes Duzend solcher Datenblätter angesehen, und da stehen die relevanten Daten drinn. Und die sind von Display z Display ganz schön unterschiedlich, auch wenn die übrigen masse alle gleich sind. Leider habe ich eben für mein Display keins bekommen.

    Die Formel zur Berechnung lautet:

    R = U Speisespannung - U LED-Flussspannung / max. LED-Strom

    Die Speisespannung sind die 5 Volt. Bei der LED-Flussspannungen gibt es schon arge Unterschiede. Manche Hersteller haben z.b. Modelle mit LED-Array oder mit LED-Edge.

    "EA P240-6K2LED ist mit einer gelb/grünen LED-Hintergrundbeleuchtung ausgestattet. Die
    Anzeige erscheint gelb/grün leuchtend mit schwarzen Zeichen. Die LED-Beleuchtung benötigt
    typ. 500mA bei einer Flußspannung von typ. 4,1V. Ein Vorwiderstand zur Anpassung des Stroms
    ist unbedingt erforderlich (z.B. bei 5V Versorgung: R = (5V-4,1V) / 0,5A = 1,8Ω). Dieser
    Vorwiderstand kann als SMD Widerstand vom Typ 1206 direkt auf das Modul gelötet werden (R17
    und R1:cool:. Ist die Lötbrücke J16 geschlossen, kann aber auch über die 20-pol. Lötaugenleiste und
    den Pins 3 (VDD) und 20 (Kathode LED) die LED-Beleuchtung versorgt werden. 100.000 Stunden.
    ...

    EA P240-6K2LW ist mit einer weissen LED-Beleuchtung ausgestattet. Die Anzeige erscheint blau
    mit weiss leuchtenden Zeichen (Negativ). Die LED-Beleuchtung benötigt zum Betrieb eine
    Stromquelle oder einen externen Vorwiderstand bei max. 60mA (25°C). Die Flußspannung liegt
    zwischen 3,0V und 3,6V. Bitte berücksichtigen Sie ien entsprechendes Derating für Temperaturen
    über 25°C."
    http://www.lcd-module.de/pdf/grafik/p240-6.pdf

    Alleine der Unterschied bei diesem Hersteller zwischem gelb/grün typ. 500mA und dem blau/weissen, max. 60mA.


    Beim folgenden Datenblatt sind die Daten:

    LED-array: Flussspannung 4,2V
    LED-edge: Flussspannung 2,1V
    LED-Strom max. 660mA

    http://www.google.de/url?sa=t&rct=j&q=& ... -Efa0K3FJA


    in dem Kurzweil K2000 Displaywechsel-Thread wird das Thema Vor-Widerstand diskutiert und berechnet:

    http://www.gearslutz.com/board/electron ... l-lcd.html

    Und nu?
     
  19. microbug

    microbug |||

    Der SY99 hatte eine EL-Folie, ja. Wie das genau angeschlossen ist, muß ich nachschauen, Kontrastregelung hat da jedenfalls gepasst. Die blauen LCDs von zinguy waren jedenfalls auf direkten 5V-Betrieb ausgelegt.

    Display ohne Datenblatt ist natürlich Mist, ist da wirklich keins aufzutreiben? Wäre ja Stochern im Nebel. Letztlich müßtest Du das aber am Display aber auch messen können, ob da ein Vorwiderstand drin ist oder nicht. Den haben selbst die billigen LED-Matrixfelder, die mit Adapter für Mini-Glühlampen geliefert werden, eingebaut.

    Beim Tinsharp-LCD von Maritex steht nichts von einem Vorwiderstand im Datenblatt, bei den Displays von EA ist dieser auch nicht bei allen Typen nötig, hab gerade mal ins Heftchen zu meinem Display geschaut.
     
  20. cleanX

    cleanX -

    Leider nein. Habe schon alles abgesucht. Der Anbieter hat mir eins von einem früheren Modell geschickt, das ist aber von einem anderen Hersteller.


    Hast du einen link dazu?

    Wenn man z.b. dieses kleine Display von maritex anschaut, dann stehen dort 5V als LED-Spannung. Rechnerisch kommt man damit logischerweise auf 0 ohm, wenn man 5 Volt als Betriebsspannung anlegt. Das Problem ist aber die Strombegrenzung, die dort mit 50mA typ und 100mA max. angegeben ist. Ich denke mittlerweile, dass man selbst da einen 1,8 ohm Widerstand für die Strombegrenzung zur Sicherheit einbauen solte.

    http://download.maritex.com.pl/pdfs/op/TC0802A.pdf
     
  21. microbug

    microbug |||

  22. cleanX

    cleanX -

    Auf der Leiterplatte ist PS-24065G2 Rev.1 aufgedruckt. Daneben ein kleiner weisser Aufkleber mit der Bezeichnung
    MG24065G-SBLWU
    5044

    Controller ist der übliche T6963C plus ein Sanyo LC3564Bm-10. Als Besonderheit sind die sonst zu findenden zusätzlichen SMD-IC (z.b. LC7940N beim EW50340BMW) viel kleiner und komplett mit Vergussmasse abgedeckt, wie es früher teilweise bei RAMs üblich war.

    Und das Datenblatt wurde mir auf Anfrage zugesendet, jedoch mit dem Hinweis, es wäre für ein anderen Display gewesen.
    http://www.gme.cz/dokumentace/513/513-2 ... -207.1.pdf
    Da steht, was die Buchstaben SBLWU bedeuten und auf der letzten Seite sind schöne schematics fürs Backlight.


    Das Datenbaltt ist wirklich unglaublich umfangreich, inkl. Fluxempfehlung. Nur beim Backlight ein bissel dünne. Auf Seite 10 die kleine Tabelle darunter mit ELECTRICAL –OPTICAL CHARACTERISTICS(Ta=25℃) verstehe ich nicht.
    Dort stehen 3,2V und 120mA. Soll das Sapnnung und Strom sein, damit die Zeichen weiss leuchten?
     
  23. microbug

    microbug |||

    Das ist wahrscheinlich die Betriebsspannung der weißen LEDs, zumindest hab ich das so verstanden - würde durchaus passen. Somit wäre da wohl auch ein Vorwiderstand drin.

    Der weiße Aufkleber ist die Displaybezeichnung. Es handelt sich dabei um ein Display des taiwanesischen Herstellers Everbouquet, das Datenblatt konnte ich auf auftreiben:

    http://www.datasheetarchive.com/mg24065g-datasheet.html (auf pdf-Symbol rechts klicken, läßt sich leider nicht direkt verlinken).
     
  24. Hallo liebe Leute,

    ich war ein Weile Off und bin (positiv) erstaut, dass mein Thread doch immer mal wieder Leser findet mit eigenen Problemen.

    APROPOS Problem :stop:
    Nach meiner anfänglichen Euphorie macht sich etwas Skepsis breit was mein Display Umbau angeht. Gestern ist mir aufgefallen, dass die Hintergrundbeleuchtung von rechts oben her langsam anfängt lila (?) zu leuchten. Nach dem Umbau war alles schick. Schrift weiß und Hintergrund tief blau. Ich habe jetzt den Kontrast Softwareseitig jetzt auf +8 geregelt, so dass der Effekt erstmal nicht auffällt. Wenn man den Kontrast langsam runter regelt (Hintergrund wird insgesamt heller), kann man den Effekt schon recht gut sehen. Ich habe leider gerade keine Digicam zur Hand, werde aber mal versuchen demnächst Fotos zu machen.

    Zu meiner Frage und der vorangegangenen Diskussion zum Thema Vorwiderstand.
    A) Ich habe keinen Vorwiderstand verwendet, da wie Dietmar ja auch geschrieben hat wenn auf dem Datenblatt +5V Betriebsspanung stehen, gehe ich davon aus, dass das stimmt. Ich hatte die Spannung auf dem Mainboard selber auch nochmal kontrolliert: Exakt +5V

    B) Problem Kontrast: Out of the Box hatte bei mir das Display ja nicht funktioniert. Ich habe einen Spannungsteiler direkt auf dem Display für den Kontrast eingelötet. Allerdings Festwiderstände (3 und 9k glaube ich) und nicht das vorgeschlagen Poti von 25k bis 50k. Der Vorschlag stammte jedoch aus einem anderen Datenblatt. Egal - hat ja funktioniert.

    Schlussfolgerung: Wenn ich etwas flasch gemacht habe (Widerstand für den Kontrast), müsste dann jetzt nicht komplett die Hintergrundbeleuchtung "rumzicken" und nicht ein Fade-Effekt einsetzen? Ich Beschreibe diesen Effekt noch mal genauer: Rechts oben in der Ecke fängt die Hintergrundbeleuchtung nun scheinbar langsam heller leuchten als der Rest. Es können aber auch direkt Pixel sein, die eine (mini?) Spannung kriegen und in Form eines Dreiecks (geschätzt 1*1*3cm) anfangen zu leuchten. Macht für mich aber keinen Sinn, die müssten aj irgendwie angesteuert werden.
    Ich weiß, beschissen beschrieben, schwer vorzustellen - Foto folgt demnächst. Aber vielleicht hat ja jemand eine Idee, was da los ist.

    Ich meine, das Ding ist doch digital? Also, entweder alle Pixel gleich hell oder aus. Gleiches für die Hintergrundbeleuchtung - oder sehe ich das falsch?

    Danke schon mal :kaffee:

    PS: Das 2. Display ist schon weg! Sorry!
     
  25. So, um mir selber mal zu antworten und anderen ebenfalls irreführende Informationen aufzuhellen kommt nach etlicher Recherche ein "mini-Update" zum Thema Displays.

    1. Das Datenblatt des Displays von Maritex sagt ganz eindeutig:
    Backlight: A= +5.0V; K= 0V --> Diese 5 Volt habe ich dort abgegriffen, wo vorher der Inverter auf dem Mainboard saß. Sollte also passen. Da braucht kein Widerstand rein. Achtung bei anderen Herstellern! Bei dem von cleanX geposteten Modell ist die Sache nicht 100%ig eindeutig, bzw. doch, da hier im Text darauf hingewiesen wird, dass die LED Hintergrundbeleuchtung "nur" 4,1V benötigt und somit bei 5V Bordspannung ein Vorwiderstand rein muss. Das gilt aber nur für die die Hintergrundbeleuchtung und nicht für das eigentliche Display, das sollte mit standard +5V arbeiten, wobei das wiederum nirgends steht. Ich würde die Finger von diesem Display lassen. Ohne Datenblatt kann man nur mutmaßen.

    So, ok aber das es nicht am Backlight liegt hatte ich mir schon fast gedacht. Bleibt nur noch das Display an sich und damit der Kontrast. Leider kann ich nicht mehr sagen, ob der Kontrast von Anfang an gleichmäßig war, sprich alle Pixel gleich hell. Ich habe mir bei rs-online jetz doch mal die besagten 25k, bzw. 50k Potis bestellt und werde die mal einbauen. Vielleicht sind meine Widerstände einfach "zu knapp" bemessen.
    Bleibt trozdem die Frage, warum ist das Display nur an der rechten oberen Seite etwas heller (schimmert irgwend lila) als der Rest?
    Als letzte Vermutung habe ich noch, dass meine eigentlichen +5V für das Display (also dem Controller) nicht stimmen (an Pin 3 Vdd). Wobei auch hier wiederum alles bisher ohne Probleme läuft. Das werde ich alles zusammen mal überprüfen, wenn die anderen Teile da sind.

    Wenn hier ein E-techik Spezi unterwegs ist, lass ich mich gern aufklären. Dumm sterben ist doof!

    Gibt es inzwischen noch mehr Leute, die Ihre Display getauscht haben und Erfahrungen einbringen können - merci
     
  26. Hi,
    genau das Gleich möchte ich auch an meinem e5000 machen. ist die Pin Belegung des Displays
    denn genau dieselbe wie beim SY99 oder Kawai5000?

    Danke und viele Grüsse
     

Diese Seite empfehlen