iconnectMIDI4+ verursacht Stummschaltung

Dieses Thema im Forum "Controller & MIDI" wurde erstellt von musikus56, 20. März 2017.

  1. musikus56

    musikus56 Tach

    High!
    Als Neuling im Bereich Forum/Diskussionen/Fragen/Antworten ersuche ich erstmal um Nachsicht und nehme Kritik und (ver-)Besserungswünsche gerne entgegen. Ich bin 60 und spiele seit 45 Jahren nur Live (Austro-, Pop,......) und habe die Schlepperei satt.
    Zum Thema:
    Ich will meine Hardware-Patchbay (Yamaha MEP4 und Akai me25s) durch iMIDIPatchbay ersetzen. Es sollen hardwaremäßig NumaCompact als Masterkeyboard1, und NumaOrgan2 als Master2 angeschlossen werden. Als Sound-Expander sollen auf gleichem iPad4 die Apps KorgModule und SampleTank (soll die Roland Hardware XV2020 ersetzen) Verwendung finden. Das alles über iConnectMIDI4+ (in weiterer Folge als iCM4+). über die implementierte Set-List am iMIDIPatchbay soll umgeschalten werden.
    Die Apps funktionieren (jede über ein 1-faches Midi-Interface mit Camera-Kit (Lightning) getestet) einwandfrei.
    Bei Betrieb über die Bildschirm-Tastaturen alles o.k. Stecke ich das iCM4+ per Lightning an das iPad an während die Bildschirm-Tastatur gespielt wird, verstummt nach ca. 2 Sekunden die Audio-Wiedergabe, per Kopfhörer-Ausgang über die Anlage wiedergegeben.
    Bei Versuchen in der iPad-Einstellungen-Ebene unter "Kontrollzentrum" wird durch Änderung des Kopfhörer-Symbols auf iConnectMIDI4+ erkennbar, dass das iCM4+ nach oben erwähnten 2 Sekunden die Steuerung übernimmt.
    MIDI-Daten werden an die jeweilige App übermittelt. LEDs zeigen dies an der iMIDIPatchbay, an den parallel laufenden Apps KorgModule und Sampletank laufen die Bildschirm-Tastaturen syncron zum Masterkeyboard mit.
    Irgend eine Idee warum das iCM4+ die Audio-Durchschaltung unterbricht und wo ich Änderungen (über App iConfig etwa) vornehmen muss?
    Danke für die Anteilnahme an der -meines Erachtens- kniffligen Problemstellung.
    Bei offenen Fragen werde ich -mit meinem vorhandenen Wissen und Verständnis- diese schnellstens beantworten.
    musikalische Grüße
    musikus56
     
  2. Drumfix

    Drumfix bin angekommen

    In der iConnectivity iOS App kann man doch unter Audio Info -> iOS Audio Enabled = off setzen.

    Hilft das ?
     
  3. musikus56

    musikus56 Tach

    Danke für Antwort, Drumfix.

    Hilft aber nicht. alle 3 möglichen USB-Deivces auf disabled gesetzt (bin auf USB-Device 1 mit USB-B-Stecker) -> keine Änderung. Die Lautstärke-Tasten am iPad reagieren nicht, d.h., es erscheint bei Betätigung der Tasten +/- kein Symbol am Screen so wie es bei gleicher Situation ohne angeschlossenem Lightning-Kabel wäre. Irgend eine Einstellung, von derer Funktion bzw. Existenz ich keine Ahnung habe, setzt die Audio-Ausgabe auf Null und nimmt den +/- Tasten die Lautstärke-Einstellfunktion.
     
  4. Ich hatte darüber iirc schonmal geschrieben, muß ich aber selbst suchen. Ursache dürfte das Audio Passthru Feature sein, das muß man einfach im Steuerprogramm im Audio-Reiter deaktivieren (und auch im Gerät speichern), dann sollte es gehen.
     
  5. musikus56

    musikus56 Tach

    Danke Dietmar, alias microbug !!!!! :phat:

    Habe nach dem Begriff "Audio Passthru" gegooglt und nach ca. 1/2 Stunde fündig geworden!!!

    hab dann im iConfig nach dem Audio-Routing gesucht. War schwer, da die Abbildungen auf Youtube eine alte Darstellung der iConfig-App auf dem Mac gezeigt hatte. Letztendlich hab ich dann auf "gut Glück" die Idee des PassThru ins neue Erscheinungsbild der App interprtiert, abgespeichert........und es funktionierte!!!!!
    Bei Tagesanbruch (ca. 9:00) werd ich dann im Proberaum mit den tatsächlichen Masterkeyboards nochmals alles durch-checken und -für jene, die auch mal ein solches Problem haben könnten- den Vorgang mit den korrekten Wortlauten (wie in der iConfig-App) niederschreiben.
    Danke !!!
    musikalische grüße und lange Nachtruhe
    musikus56
     
  6. musikus56

    musikus56 Tach

    zu Thread-Titel
    Grund des Verhaltens:
    iConnectMIDI4+ (in Folge: iCM4+)hat eine „AUDIO PassThru“ Funktion, was so viel bedeutet wie: Geräte (Devices), welche über USB an das iCM4+ angeschlossen sind, übertragen untereinander auch Audio-Signale. So ist das Interface iCM4+ werksseitig voreingestellt. Mit der App iConfig kann man am Mac/PC/iPad das Routing von iMC4+ verwalten. Da alle Audiosignale von einem USB-Anschluss an die beiden anderen USB-Anschlüsse geroutet sind soll eine parallele Übertragung (z.B. vom Kopfhörer-Ausgang ins Aufnahmegerät=Sequenzer am PC/Mac über Audio-Interface) verhindert werden. Und genau das macht das iCM4+ -interne Routing => kein Audio-Signal am Kopfhörer-Ausgang.
    Im Fall einer Verwendung des iCM4+ zusammen mit einem Patchbay für den Live-Betrieb, wo neben Hardware-Klangerzeugern auch Software-Klangerzeuger Verwendung finden und geroutet werden sollen, ist ein Audio-Signal am Software-Klangerzeuger (z.B am iPad) aber unerlässlich (am Köpfhörer-Ausgang).
    Lösung:
    Mit Hilfe der oben beschriebenen App“ iConfig“ kann im iCM4+ das Routing von USB 1/2/3 jeweils von Eingang 1&2 des einen USB auf die Ausgänge der beiden anderen USB (1&2 weil meist stereo) auf „nothing“ gesetzt werden. Wichtig: das Abspeichern am iCM4+ nicht vergessen. Jetzt verhindert iCM4+ die Audio-Ausgabe am Köpfhörer-Ausgang nicht mehr.

    Da ich kein Fachmann bin und dieses Set-Up für meinen Fall beschrieben ist, kann ich nur empfehlen, die in eurem Fall gewünschten Signalwege vorerst in einer Skizze festzuhalten und die verschiedenen Versuche zu kommentieren.

    Durch funktionierende Sound-Wiedergabe auf neues Problem gestoßen: iMIDIPatchbay routet die Hardware und die KorgModule App korrekt. Sampletank über iMIDIPitchbay vom NumaCopact angesteuert bleibt aber stumm, in Stand-alone-Betrieb aber o.k. Mache einen neuen Thread.

    Dank und Gruß an die Beteiligten.
    musikus56
     
  7. Skizze ist eh sinnvoll, wenns ums Routing geht, siehe mein MIDI-Patchbay-Thread. Nix für Planungsallergiker, die ihre spontaneität dadurch gefährdet sehen ...

    Ich habe auch meinen Text zu Deinem Problem wieder gefunden, war im Hauptthread zum iconnect MIDI4+:

    viewtopic.php?p=1032455#p1032455

    Was Dein Routingproblem angeht, so mußt Du Dich entscheiden, ob Du das Routing im MIDI4+ oder in iMIDIPatchbay machen willst, außerdem vielleicht mal dessen Entwickler, Johannes, kontaktieren. Das MIDI4+ kann halt nur ein Routing speichern.

    Diese App soll ja die alten Hardware-MIDIpatchbays ersetzen, das kann sie allerdings nicht wirklich leisten, vor allem nicht eine MIDITemp MP88/PMM-8E, denn es gehen ja alle Datenströme über das USB-Nadelöhr, während man bei einer MIDItemp wirklich parallel im Gerät arbeitet.
     

Diese Seite empfehlen