Roland PG 10 funktioniert nicht am D 110

M
MC 500
.
Mein PG 10 funktioniert leider nicht an meinem D 110. Der Programmer zeigt nach dem Einschalten im D 110 Modus keinerlei Sysex-Aktivitäten. Am D 110 ist auch nicht zu erkennen, das irgendeine Steuerung durch den Programmer erfolgt. Die Verbindungen via MIDI habe ich nach Vorgabe der Manuals der beiden Geräte auch schon alle ausprobiert. Leider ohne Erfolg.

Hat vielleicht hier jemand einen Tip, woran es liegen könnte ?
 
fanwander
fanwander
*****
Wie überprüfst Du dass er "keine SysEx-Aktivitäten zeigt"? Ich nehme an MIDI-Monitoring? Bist Du sicher, dass das Monitoring überhaupt SysEx erfasst?
 
M
MC 500
.
Ich habe mich an dem MIDI LED über der Einschalttaste des D 110 orientiert. Die zeigt keinerlei MIDI Verkehr. Ich habe auch keine Informationen im Manual bzgl. spezieller Einstellungen im D 110 zur Nutzung des PG 10 gefunden (z.B. spezielle Aktivierung der SYSEX Funktionalität).
 
FlorianH
FlorianH
|||
Meiner hat mal vom Masterkeyboard keine Midi Daten mehr empfangen, bis ich drauf gekommen bin, dass der Midi-Empfangskanal falsch gewählt war. Hast du da schon geschaut?
 
M
MC 500
.
Habe ich auch schon ausprobiert. Alles auf Kanal 01. Hat aber leider auch nicht funktioniert.
 
fanwander
fanwander
*****
Ich habe mich an dem MIDI LED über der Einschalttaste des D 110 orientiert.
Die sagt garnix. Die wird von der CPU angesteuert. Wenn der D-110 so eingestellt ist, dass er kein SysEx empfängt, dann leuchtet die nicht.

Besorg Dir eine MIDI-Monitor Software für Deinen Rechner und schau, ob was aus dem PG10 rauskommt.
 
Miks
Miks
Ich kann auch bald nich mehr...
Ich weiß, doofe Frage - aber sicherheitshalber: die MIDI-Strippen hast Du korrekt angeschlossen, oder?

PG 10: MIDI-Out -> D 110: MIDI-In
PG 10: MIDI-In -> D 110: MIDI-Out
 
M
MC 500
.
Berechtigte Frage. Ich habe den PG 10 so wie von Dir beschrieben am D 110 angeschlossen.
Meinen MIDI Controller (Arturia Keystep) habe ich zusätzlich mit dem PARAMETER IN des PG 10 verbunden. Das soll ja ein zusätzlicher MIDI IN Anschluss am PG 10 sein. Leider ohne Erfolg.
 
MacroDX
MacroDX
Hat ein Bild mit Robotern wo aufm Mond rumlaufen
Das soll ja ein zusätzlicher MIDI IN Anschluss am PG 10 sein
Nein, Parameter in muss der MIDI Out vom D-110 sein.
- IN am PG-10: Da kommt DAW/Sequencer/Masterkeyboard dran. Also dass, was letztendendes den D-110 steuern soll. Was da rein kommt wird dann zum Synth hin mit den Daten vom PG-10 gemerged.
- OUT am PG-10: Geht auf den IN am D-110
- Parameter IN am PG-10: OUT vom D-110

Edit: Steht übrigens auf Seite 4 im Handbuch
 
Zuletzt bearbeitet:
M
MC 500
.
Habe ich noch einmal so ausprobiert. Leider erfolglos. MIDI-Fehlermeldungen gibt es keine, aber der PG 10 scheint sich nach kurzer Zeit "aufzuhängen" und akzeptiert keine Tasten oder Fader mehr. Er zeigt auch die Roland ID #17 nicht mehr an. Sehr merkwürdig.
 
MacroDX
MacroDX
Hat ein Bild mit Robotern wo aufm Mond rumlaufen
Achso, ok... Bin jetzt davon ausgegangen dass es Kanalanhängig ist, ich hab damit noch nie gearbeitet.
Indirekt ... Für SysEx ist in der Nachricht eine Device ID definiert. Oftmals entspricht diese dem im Gerät eingestellten Empfangskanal. Das Gerät ignoriert dann Nachrichten, die als Device ID diesen Kanal nicht enthalten. Bei manchen Geräten, meines Wissens auch Roland, kann man aber explizit noch eine Geräte ID im Gerät selbst einstellen, welche in der Regel ab 17 anfängt, um nicht mit dem MIDI Kanal Wertebereich zu kollidieren. Dann reagiert das Gerät nur auf die SysEx Nachricht, wenn die DeviceID übereinstimmt.

Habe ich noch einmal so ausprobiert. Leider erfolglos. MIDI-Fehlermeldungen gibt es keine, aber der PG 10 scheint sich nach kurzer Zeit "aufzuhängen" und akzeptiert keine Tasten oder Fader mehr. Er zeigt auch die Roland ID #17 nicht mehr an. Sehr merkwürdig.
Evtl. hast du dir in irgendeiner Form eine MIDI-Schleife gebaut und die Buffer der Geräte laufen dadurch über. Das ist aber anhand der Beschreibung nur schwierig zu analysieren.
Wie fanwander schon geraten hat, baue mal einen MID Monitor wie z.B. MIDI OX an den OUT vom PG-10 um zu sehen, was sich da tut.
 
MacroDX
MacroDX
Hat ein Bild mit Robotern wo aufm Mond rumlaufen
Ja das ist natürlich sinnvoll. Erstmal prüfen ob die direkte Anbindung der beiden Geräte funktioniert.
 
M
MC 500
.
Ich habs noch einmal wie oben von Florian beschrieben ausprobiert. Der PG10 startet normal im D110 Modus. Sobald man via Edit (z.B. TIMBRE Edit) etwas an den Fadern auswählt, hängt sich der Programmer auf.
 
qwave
qwave
KnopfVerDreher
...
Oftmals entspricht diese dem im Gerät eingestellten Empfangskanal. Das Gerät ignoriert dann Nachrichten, die als Device ID diesen Kanal nicht enthalten.
...
Kannst du mir da mal Beispiele nennen, bei denen das so sein soll? Ich habe hier mehr als 30 Geräte die dieses alle definitiv nicht so machen. Und ich habe noch nie davon gehört.

Wäre ja sau blöd, wenn man seine bei MIDI Kanaleinstellung #1 exportierten Klänge dann nach Umstellen auf Kanal #9 nicht mehr zurückspielen könnte, ohne die SysEx Daten zu editieren oder blind zu hoffen den richtigen Kanal wieder ausgewählt zu haben.

Die SysEx Device ID ist eigentlich ursprünglich dafür gedacht Ordnung und Eindeutigkeiten zu schaffen, wenn man ein Gerät mehr als einmal in seinem MIDI Setup hat. Also das man nicht versehentlich Daten die an einen Blofeld Desktop gehen sollten nicht parallel auch vom Blofeld Keyboard empfangen werden. Eigentlich sollte diese ID ansonsten immer auf dem Standardwert sein. Und das ist immer der kleinste Wert. Je nach Gerät wird der als 0 oder 1 angezeigt. Bei manchen ist der höchst mögliche Wert dann so was wie ein Omni-Mode ("Broadcast ID") für SysEx mit beliebiger ID. Aber einige können diese besondere ID nur empfangen und nicht senden.
 
MacroDX
MacroDX
Hat ein Bild mit Robotern wo aufm Mond rumlaufen
Wäre ja sau blöd, wenn man seine bei MIDI Kanaleinstellung #1 exportierten Klänge dann nach Umstellen auf Kanal #9 nicht mehr zurückspielen könnte, ohne die SysEx Daten zu editieren oder blind zu hoffen den richtigen Kanal wieder ausgewählt zu haben.
Du redest hier offenbar von Bulk Dumps. Da ist das nicht unbedingt sinnvoll, aber auch nicht ausgeschlossen.
Kannst du mir da mal Beispiele nennen, bei denen das so sein soll? Ich habe hier mehr als 30 Geräte die dieses alle definitiv nicht so machen. Und ich habe noch nie davon gehört.
Es geht dabei um Data Entry Messages, also Parameterwertänderungen über SysEx. Spontan fällt mir da jetzt mein DW-8000 ein. Schau mal auf Seite 65 im Owners Manual. Die Parameter Change Message hat da für Byte 3 die Definition:
0011 nnnn => 3*H (* = ch).
Edit: und dann wird noch auf (Note 5) verwiesen, was keine musikalische Note ist, sondern die Anmerkung Nummer 5:
"Messages with channel numbers different from those specified by parameter 84 are ignored."
Sprich, der Kanal in der SysEx Message muss dem eingestellten Empfangskanal entsprechen. Und das kann man nichtmal mit dem Omni Mode aushebeln.
 
Zuletzt bearbeitet:
vogel
vogel
Lebensform, fortgeschritten
Keine Ahnung ob ich zum Thema beitragen kann. Ich hatte mir zwei Mal den Programmer für meinen damaligen D20 besorgt, und beide zeigten denselben Effekt wie bei dir. Konnektion funktionierte, aber beim Editieren haben sie sich aufgehangen. Ich hab daher beide Gebrauchtkäufe zurückgehen lassen....
 
 


Neueste Beiträge

News

Oben