ASIO-Treiber hängt

Dieses Thema im Forum "PC" wurde erstellt von Nils, 16. Oktober 2006.

  1. Nils

    Nils -

    Hallöchen,

    habe hier Probleme mit allen Hosts, die ASIO-Treiber unterstützen. Wenn ein VST-Plugin abstürzt und der Host dann mit crasht, entfernt sich der Task nicht aus dem Task-Manager. Abschießen geht auch nicht, der bleibt einfach drin. Er verbraucht auch weiterhin den gesamten von ihm angeforderten Speicher, also es wird quasi absolut nichts aufgeräumt, nur das Fenster ist weg. Wenn ich Glück habe entfernt sich der Task dann nach ca 5-10Min, aber das klappt auch nur einmal, Regelfall ist eigentlich, dass der Rechner dann nach 5-10 Min neustartet.

    Im Prinzip kein Problem, da ein Host ja nicht allzu oft abstürzt. Aber wenn man selber Plugins programmiert, und da geht mal was schief (oder ich beende den Host aus Gewohnheit einfach hart indem ich den Debug-Lauf beende) dann darf ich direkt wieder neustarten.

    Hat sonst noch jemand das Problem und evtl. eine Lösung? Kennt jemand einen billigen Host, der keine ASIO-Treiber unterstützt und sich somit normal abschießen lässt? MME im "VSTHost" zu wählen reicht leider nicht, trotzdem das selbe Phänomen.

    EDIT: Achso Entschuldigung es geht um einen PC mit WinXP/Service Pack 2

    Danke,

    Nils
     
  2. Das Problem liegt nicht direkt im Host begründet (übrigens hab' ich gestern eine neue VSTHost-Beta hochgeladen, die im Absturzfall theoretisch besser "auf die Füße fällt" und den ASIO-Treiber korrekt beendet, sofern das möglich ist); das liegt auch an den verwendeten ASIO-Treibern. Ich hab' diesbezüglich schon recht unterschiedliche Erfahrungen gemacht - die M-Audio-Treiber sind z.B. echte Sensibelchen, wohingegen z.B. die Terratec DMX 6fire - Treiber relativ gutmütig reagieren und im Normalfall ohne Neustart auskommen.
     
  3. dest4b

    dest4b aktiviert

    joa .. meine edirol Fa101 muss ich auch wenn überhaupt mal raus und rein stöpseln dann gehts wieder.
     
  4. Nils

    Nils -

    Schon klar das der Host daran nicht schuld ist. Aber das ist es ja gerade, egal welchen ASIO-Treiber ich wähle, das Problem hab ich immer. Egal ob DirectX, Asio4all über meine Onboard-Soundkarte oder der Treiber für meine M-Audio USB-Karte, es ist immer das selbe. Und das wundert mich halt.
     
  5. marv42dp

    marv42dp aktiviert

    Da kann pskill von sysinternals.com helfen.
     
  6. Nils

    Nils -

    Habe es gerade mit pskill ausprobiert, der meldet mir zwar, dass er die exe angeblich gekillt hat, stimmt aber nicht, sie verweilt weiterhin im Taskmanager.... :roll:
     

Diese Seite empfehlen