Fehlermeldung "microKORG didn't respond"

Dieses Thema im Forum "Digital" wurde erstellt von brainstorm, 8. November 2012.

  1. brainstorm

    brainstorm Tach

    Hallo!

    Bin neu hier...
    ...und habe folgendes Problem:

    Habe den microKORG über die MBox2 an den IMac angeschlossen. Funktioniert soweit alles wunderbar, nur wenn ich die "microKORG SoundEditor"-Software verwende und Daten vom microKORG empfangen möchte (Receive selected), kommt nach etwa 10 Sekunden diese Fehlermeldung:
    " MIDI Error
    microKORG didn't respond."
    Irgendeine Kommunikation findet statt, denn der microKORG zeigt Sendeaktivität im Display.
    Verkabelt ist alles richtig. Alle MIDI-Filter im microKORG sind wohl richtig eingestellt. Wenn ich eine andere Software verwende, um SysEx-Daten zu empfangen und zu senden, ist das kein Problem.

    Leider bringt die Google-Suche kein Glück. Ich hab den Eindruck, dass nur ein Bruchteil all der unzähligen micoKORG-Besitzern mit der SoundEditor-Software arbeitet... aber vielleicht gibts ja hier Hilfe! ;o)

    LG
    flo
     
  2. mink99

    mink99 bin angekommen

    Ist im midi Filter Enable system exklusive eingeschaltet ?
    Ist Write Protection ausgeschaltet ?
     
  3. brainstorm

    brainstorm Tach

    Danke erstmal!
    Beides ist richtig eingestellt. Wie gesagt, mit dem Programm "SysEx Librarian" funktioniert der Datenaustausch.
     
  4. mink99

    mink99 bin angekommen

    Ach so
    :hallo:

    Mehr weiss ich auch nicht, hab den Editor immer am pc benutzt , Sorry
     
  5. brainstorm

    brainstorm Tach

    Hmm... benutzt jemand dieses Setup? (microKORG + Imac + microKORG SoundEditor)
    Ich glaube nicht, dass es an der MBox2 liegt - mit nem anderen MIDI-Interface (welches allerdings auch über USB läuft) gibts das gleiche Problem.
    Software und Treiber sind auch alle aktuell....
     
  6. brainstorm

    brainstorm Tach

    Hey,

    ...habe das ganze gerade auch an meinem laptop (PC) ausprobiert, wieder mit der MBox2. Gleiches Problem.
    keiner ne Ahnung, was da helfen könnte?

    LG
    flo
     
  7. toxictobi

    toxictobi bin angekommen

    hallo brainstorm
    :hallo:
    ...klink mich ma mit ein, hab ein ähnliches Problem, mit dem 10 Jahre alten PC-Editor!!!
    Mittlerweile bin ich so angenervt, dass ich beim mK einen Factory-Reset gmacht hab, und ihn wieder nur als Preset-Schleuder nutze(mit den guten).
    Ich kann mit dem PC-Editor und Win 7 zwar einzelne Patches raufladen, wenn ich alllerdings das komplette Set sichern möchte, krieg ich ne message à la:
    "ERROR: Can't receive MIDI Message from the Device" der mK kann also scheinbar Sys-Ex empfangen aber nicht senden...
    Hab 2 AI mit MIDI ausprobiert, gleiche Meldung, ein reines USB Midi-Interface hab ich nicht und nur für diesen steinalten Editor Geld für eins ausgeben, ohne Garantie, dass es dann funzt, bin ich nicht gewillt.
    It breaks me on! :twisted:
     
  8. brainstorm

    brainstorm Tach

    Gibt es denn Infos darüber, mit welchen MIDI-Interfaces die Übertragung in beide Richtungen funktioniert? (Muss ja kein reines MIDI-Interface sein)
    Vielleicht sogar eine offizielle Kompatibilitätsliste seitens Korg? (Nicht, dass ich auf deren Seite schon nachgeguckt hätte...)
     
  9. Wozu das denn? Das hat mit jedem stinknormalem MIDI-Interface zu gehen. Das Problem liegt offenbar an anderer Stelle.

    Diese Fehlermeldung ist ein Timeout-Error der Software, weil die eine bestimmte Bytefolge nicht innerhalb einer bestimmten Zeit bekommt.

    MIDI-Kabel sind hoffentlich alle korrekt angeschlossen? MIDI Out vom Interface an MIDI IN des mK, MIDI IN des Interface an MIDI Out des MIDI Out des mK. So, wie im Handbuch beschrieben.
    Außerdem muß der Kanal, den es auch bei Sysex gibt, der dort aber Device ID heißt, am Gerät und im Editor gleich eingestellt sein. Dieser Kanal ist auch beim microKorg vorhanden und wichtig (das 3. Byte des Sysex-Strings: F0 42 3n n=Kanal-1 (0-F für 0-15 entspricht 1-16).

    Dann darf der Filter für Sysex nicht gesetzt sein (muß E-E sein), siehe Handbuch.

    Du kannst die Kommunikation ja überprüfen, zB genau mit der Software SyexLibrarian oder MIDI Monitor für den Mac. Da siehst Du auch die Zeitstempel. MIDI Monitor (Snoize.com, wie auch der Librarian) kannst Du zwischen Editor und dem MIDI-Port schnüffeln lassen, einfach dazu die entsprechenden Häkchen im Programm setzen.

    Es sollten die Daten, die der Editor und der mK schicken, zu sehen sein.

    Löse doch einfach mal einen Dump am Gerät aus und schaue Dir in Sysex Librarian bzw MIDI Monitor den Header an, wie oben beschrieben, achte auf das 3. Byte mit dem Kanal. Wenn dieser nicht korrekt gesetzt ist, kann keine Kommunikation stattfinden.

    Ich fürchte mal, daß das Ganze ein klassiches MIDI-Grundlagenproblem ist, und zwar von beiden Fragestellern.
     
  10. brainstorm

    brainstorm Tach

    Hey microbug,

    danke für die ausführliche Antwort!
    Ich find auch, dass es mit jedem MIDI-Interface klappen sollte ;o)
    ...und ich würd mich riesig freuen, wenn Du nochmal ein paar Minuten Zeit hättest....


    MIDI-Kabel sind richtig angeschlossen.
    Filter sind richtig eingestellt.

    Mit SysEx Librarian hatte ich die Kommunikation auch schon getestet. Ergebnis: Die Kommunikation ist scheinbar ein Ordnung (keine Fehlermeldungen), funktioniert in Wirklichkeit aber nur in eine Richtung: vom Rechner zum microKORG.
    (Ich kann fremde programs auf den mK senden. wenn ich meine programs vom mK zum Rechner sende und in SysEx Librarian aufzeiche, scheint das zwar zu klappen - wenn ich sie aber nach einem Werkseinstellungsreset des mK wieder zurücksenden will, geht das nicht.)

    MIDI Monitor hängt jetzt auch dran. In Beiden Richtungen steht im dritten Byte: 30. Wenn ich das richtig verstehe, ist der Kanal also: 1 (n=1-1)

    nicht erfolgreicher Datendump vom mK zum Rechner, 1. Zeile:
    0000 F0 42 30 58 50 00 20 20 20 20 20 20 20 00 20 20 | B0XP |

    erfolgreiche SysEy-Sendung vom Rechner zum mK, via SysEy Librarian, 1. Zeile:
    0000 F0 42 30 58 50 00 42 61 73 73 20 5A 69 00 6C 63 | B0XP Bass Zi lc|

    Jetzt hab ich 3 Fragen:
    - Wenn die SysEx-Kanäle (bzw. Device ID) übereinstimmen müssen: Wo kann ich sie einstellen? Im mK ist das vermutlich ein fixer Wert, aber in der Mbox2? bzw. bei den Treibern?
    - Obwohl ich nicht weiß, ob Du nen Mac hast: im Audio-MIDI-Setup wird gefragt nach: "Systemexklusiver Wert", man kann eine Zahl zwischen 0 und 127 eingeben. Was ist damit gemeint?
    - Wo könnt der Hund bagraben sein? Ich bin am verzweifeln.
    :sad:
     
  11. 30 im dritten Byte bedeutet Kanal 1, wenns Kanal sein soll, bei Device ID wäre das die 0 oder 1, je nach Hersteller.

    Der mK ist ja monotimbral, und eine Einstellmöglichkeit für die Sysex Device ID habe ich keine gesehen. Demnach wird der Sende/Empfangskanal des Synths als DeviceID genutzt. Steht auch so in der Beschreibung der Sysex-Daten beim 3. Byte: MIDI-Kanal. Kannst ja ausprobieren: Stelle am mK einen anderen MIDI-Kanal ein und das 3. Byte sollte einen anderen Wert als 30 zeigen, wenn Du einen Dump am Gerät auslöst.

    Es gibt auch nur eine Kanaleinstellung beim mK, für Senden und Empfangen gleich.

    Diesen Kanal stellst Du am mK ein und auch im Editor, in diesem Fall beides mal 1.

    Ich bin zwar Mac-User, aber diese Einstellung mit dem systemexklusiven Wert habe ich bei keinem meiner Interfaces aktuell, gerade nochmal nachgesehen. Wo genau taucht dieser denn bei Dir auf? Im Interface stellst Du da nichts ein, Kanäle und IDs sind Sache zwischen Geräten und der Software.

    Gehen wir mal ins Detail. Dazu hab ich mir mal die MIDI-Implememtation des mK besorgt.

    Ein Dump des mK sieht so aus: F0 42 3n 58 <cc> <data> F7

    cc ist das Kommando zum mK oder ein Statusbyte vom mK, falls ein Fehler gemeldet wird.

    Bei Deinen Dumps steht als Kommando 50, also ein All Data Dump. Sowas ist immer problematisch. Probier erstmal einzelne Patches vom Gerät manuell zu senden.

    Leider kann man am Mac mit keiner mir bekannten aktuellen Software Sysex-Dumps und Requests via Einzelbytes eingeben, früher habe ich dazu MIDI (Atari) und später Hearmaster (Mac-Nachfolgepogramm von Emagic) benutzt, die es beide nimmer gibt.

    Ich hab gesehen, daß Du noch einen PC hast. Dort gibts MIDI Ox, und damit geht sowas, also byteweise Eingabe von MIDI-Daten.

    Mittels der Sequenz F0 42 30 58 10 F7 solltest Du einen Dump des aktuellen Programs bekommen.

    Wichtig bei dem ganzen Bytegeschubse: Man muß sich im Klaren darüber sein, daß Request und Dump 2 verschiedene Dinge sind.

    Request bedeutet: Der Befehl an ein Gerät oder Software, etwas bestimmtest zu senden, zB einen Patch bzw Program
    Dump ist entweder die Antwort auf einen solchen Request oder er wird manuell am Gerät ausgelöst.

    Korg ist auch ordentlich und unterstützt die Universalanfrage, also Universal Device Inqury:
    F0 7E 00 06 01 F7

    Wenn Du diese Sequenz (alles in HEX, BTW) von MIDI OX aus an den mK schickst, solltest Du auch eine entsprechende Antwort bekommen, die zeigt Dir meist sogar die Firmwareversion an.

    Wenn ich mir die beiden Dump-Auszüge so ansehe, fällt mir eins auf: Nach dem Header und dem Kommando "50" für den all Data Dump beginnt ja der Name des Programs. Das Nullbyte zu Beginn ist ein Sammelbyte, in dem die 7. Bits der nachfolgenden 7 Bytes gespeichert sind - eins der vielen Varianten, 8 Bit in nur 7 Bytes zu übertragen.
    Nun ist der Name des Programs beim nicht erfolgreichen Dump leer, also aus Leerzeichen bestehend (20h). Das sollte nicht sein.

    Löse doch mal am mK einen Einzeldump aus.

    Du solltest außerden in den Hilfsprogrammen sehen können, was der Editor an Kommandos an den mK rausschickt. Bei MIDI Ox und MIDI Monitor kann man das entsprechend einstellen.

    Es ist leider schwer, sowas aus der Ferne zu lösen, aber vielleicht bringts ja bissl Licht ins Dunkel.
     
  12. toxictobi

    toxictobi bin angekommen

    von mir auch! :)
    Kann ich unterschreiben, genau dasselbe hier, mit dem Unterschied, dass ich MIDI-OX (für Win) verwendet hab.
    einzelne Programme kann ich auf den mK senden, sogar komplette sets (128sounds, global-daten, etc.), die ich vor Jahren mit einem anderen Audio/Midi-Interface und Win XP erstellt hab, will ich nun ein komplettes Set oder auch nur einzelne Sounds vom mK an den PC-Editor im Rechner schicken, krieg ich die besagte Nachricht "ERROR: Can't receive MIDI Message from the Device"
    wenn ich einen komplette SysEx-Dump vom mK mit allen Daten mache, sollten lt.manual 37386 Bytes ankommen, es sind aber nur um die 35000


    me too!

    edit: coole sache microbug, hast ja schon geantwortet! :)
    hab im englischen korgforum was gelesen, dass der PC-Editor bei Win 7 64bit Probleme machen soll...
    mich ärgert, dass Korg den PC-Editor nicht aktualisiert, obwohl der mK noch verkauft wird.
     
  13. Mal ganz dumm gefragt: habt ihr denn Euer MIDI-Interface in den Einstellungen des Editors überhaupt angewählt? Auf dem PC ist das meist ein USB-Audiogerät, auf dem Mac erscheint es mit Namen.

    Möglicherweise hilft aber auch dieser Trick hier:

    http://www.gearslutz.com/board/electron ... oblem.html

    Wobei: auf dem Mac ist der Editor aktuell, sollte also laufen.
     
  14. brainstorm

    brainstorm Tach

    hey,

    ja, das MIDI-Interface ist ausgewählt.
    ....und weiter erstmal kurz und knapp (werde leider erst nächste Woche wieder die Zeit haben, all Deine Vorschläge auszuprobieren):
    ich kann einzelne Programme hin- und herschicken, auch die globalen Einstellungen lassen sich in beide Richtungen übertragen. Nur der komplette Datendump (Global und alle Programme) und die Übertragung aller Programme gleichzeitig schlägt fehl.

    Melde mich nächste Woche wieder!

    LG
     
  15. brainstorm

    brainstorm Tach

    Hallo!

    einzelne Patches senden funktioniert... warum ist ein All Data Dump problematisch, wenn es einzeln geht? Wie auch immer, langsam gewöhne ich mich an die Vorstellung, alles einzeln senden zu müssen... weil ich wirklich schon so viel rumprobiert hab...

    Aber noch zu Deiner Frage:
    Diesen Wert kann man im Audio-Midi-Setup am Mac einstellen, bei den Dienstprogrammen. Wenn ich dort im MIDI-Studio ein Gerät hinzufüge (microKORG), dann taucht dieses Eingabefeld auf.

    Danke nochmal!
    LG
     
  16. Re: Fehlermeldung "microKORG didn't respond"

    Alldata-Dumps sind vor allem der Datenmenge her problematisch, weil moderne MIDI-Interfaces von Feld-Wald-Wiesenfirmen nur die Standardfunktionen abdecken und sowohl bei Pufferspeicher als auch beim Timing schlampen.
     
  17. Alchemist

    Alchemist In Space

    Hat jemand den Microkorg Sound-Editor auf Windows 7 64bit eigentlich zum funktionieren gebracht?
     
  18. toxictobi

    toxictobi bin angekommen

    Würd den thread gern noch mal aus der Versenkung holen. Hab leider immer noch keinen Erfolg mit Win 7 64bit und dem PC-Editor für den microKorg.
    Time out - Problematik bleibt bestehen. Nun hab ich grad einen Riesen-Spaß den mK vom OT zu sequenzen und die Kirmes-Techno-Presets würde ich gern mit anderen sounds ersetzen, ich weiß noch "von früher", als der Editor lief, dass bei den konverierten MS2000 Sounds ein paar echte Perlen dabei sind und selber programmieren macht keinen Spaß, da ich durch den nicht funzenden Editor eh keine sounds backuppen kann.
    Läuft bei irgendwem von euch der microKorg PC-Editor auf Win 7 64 bit? Wenn ja, würd ich mich über infos über euer Setup (v. a. Midi-Interface) freuen.
    Gracias und schöne Restweihnachten!
     
  19. gh0stless

    gh0stless Tach

    Wie es scheint ich, nachdem ich die MIDI-Clock am µKorg auf extern gestellt habe, kommt die Fehlermeldung nicht mehr, und alle Presets werden auf einmal eingelesen. Habe leider im Augenblick nicht die Zeit alles zu testen. Habe Windows 7, 64Bit. Die Version des Editors ist 1.04.

    Gruß,
    Andreas
     
  20. toxictobi

    toxictobi bin angekommen

    Jetzt funzt es endlich. Yeah! :D
    Midi-Filter am mK für SysEx auf E-E einstellen is ja klar,
    habe dann den Midi-Kanal beim mK von 16 auf 1 zum Übertragen der Sounds gestellt, evt. war 16 zu hoch...
    Clock am mK auf extern statt auto oder intern und zu guter Letzt, wie in diesem Video bei Win Vista empfohlen,
    zuvor noch mal das Preload.set aus dem Editor auf das mK-Symbol gezogen. Der mK hängt am Midi-Interface der
    NI Maschine und ich kann sowohl ganze Sets als auch einzelne Sounds in beide Richtungen übertragen.
    Besten Dank für die Hilfe! :supi:
     

Diese Seite empfehlen