Midi-Timing-Probleme in Cubase

D
Despistado
|
Nur kurz als Vorwort: Ich verwende hier die leicht angestaubte Version Cubase SX2 und ein M-Audio Midisport 2x2 Interface.
Das erste Problem (das ich aber im Moment nicht reproduzieren kann - möglicherweise ist es gelöst) war, dass ich bei der Aufnahme von Mididaten erhebliche Timing-Probleme hatte, sprich, manche Noten wurden erst mit merklicher Verzögerung aufgenommen, andere Noten wiederum korrekt.
Auch abhängig davon wieviele andere Midispuren gleichzeitig während der Aufnahme abgespielt wurden (nein, Sysex-Orgien waren nirgends dabei)
Das kann wohl durch Probleme mti den zig Midi-Ports in Cubase zu tun haben, da dort ja DirectMusic und Windows Midi und emulierte DirectMusic Ports vorhanden sind.
Da habe ich alle möglichen Fehlerquellen durch und im Moment tritt das Problem auch nicht auf (die möglichen Vorschläge zur Fehlerbehebung beziehen sich darauf entweder die DirectMusic midi Ports oder die Windows Midiports oder gar auch die emulierten oder eine Kombination aus allen dreien zu verwenden, plus noch der Option "Use system timestamp")
Dieses Problem liegt im Moment scheinbar nicht vor, ich weiß allerdings nicht ob es gelöst ist oder nur sporadisch mal mehr und mal weniger auftritt.

Das Problem das aber auch zur Zeit auftritt ist, dass Cubase direkt nach dem der Song geladen ist, manche Midispuren deutlich verzögert abspielt.
Wartet man dann eine Minute oder so, klappt's auch mit der synchronen Wiedergabe.

Ein weiterer Punkt wo mir das schräge Miditiming aufgefallen ist, war als ich eine Midi und eine Audiospur gleichzeitig wiedergegeben habe (auf der Audiospur wurde die Midispur aufgenommen).
Am Anfang laufen die beiden hörbar auseinander, es sind also deutlich zwei nacheinanderfolgende Sounds zu hören, nach ein paar Takten legt sich das aber und die beiden Aufnahmen (eben Midi +Audio) klingen gleichzeitig.

Irgendwie komm ich mir hier vor wie mit einem Pentium I und Windows 95, ist es aber nicht (Windows 7 und Intel Core i3).
 
G
Glgralkhges23535615573
Guest
Ich hatte unter SX2 mal ein Midisport 4x4 am laufen und kann mich an ähnliche Probleme erinnern, das ist verdammt lange her.

Das 4x4 hatte bei mir damals grundsätzlich Probleme bereitet, weshalb ich es irgendwann gegen ein großes Motu tauschte.
Hingegen habe ich jetzt ein neueres Midisport 2x2, welches einwandfrei funzelt unter Win10 und Cubase 10pro,
es könnte also ein Revisions- oder Treiberproblem sein ?

Dann war noch was mit den emulierten Ports, aber soweit bist du ja auch schon.

So kleines Midi-Interface kost ja nicht die Welt. Gibt ja auch günstige USB Kabel mit einem Midi In/Out, zum testen ideal.

Falls mir noch was einfällt, melde ich mich.
 
D
Despistado
|
Naja, so preiswert sind die gar nicht. Vor allem gibt es heutzutage die Unart keine Treiber mehr mitzuliefern, was im Normalfall dann heißt, das die Interfaces nicht multiclientfähig sind und auch sonst nur eingeschränkt laufen. Brauch ich nicht.
Mit den Midisports bin ich bislang eigentlich recht gut gefahren.

Ich hab vermutet, dass es möglicherweise an Windows 7 liegt aber ich hab das ganze jetzt auch (am selben Rechner) unter Windows Server 2003 ausprobiert. Selbes Problem.

Seltsam.
 
G
Glgralkhges23535615573
Guest
Win 7 könnte Probleme mit Asio haben, dafür gab es mal ein Fix. Was Midi angeht ist mir nichts bekannt.

Wie gesagt. Deine Probleme kommen mir bekannt vor und ich meine mich daran zu erinnern, dass es am Interface lag und teilw. auch an den seltsam Einstellungen von Cubase SX.

Vlt mal als Demo Cubase 10 probieren ?
 
D
Despistado
|
Hm, vielleicht mach ich das mal.
Cubase 10 will ich eigentlich nicht, aber mit der Lizenz hat man dann ja immerhin auch Lizenzen für ältere Versionen.

Hoffentlich zerschießt mir die Lizenzierung dann nicht den SX2 Dongle...
 
G
Glgralkhges23535615573
Guest
Das würde ich abklären, aber eigtl sollte da nix passieren, weil du ja zunächst nur ne Demo aufspielst und die, davon gehe ich aus, als seperate Lizenz geführt werden sollte ?
 
D
Despistado
|
Ach Mist. Jetzt fällt mir gerade ein/auf, dass es ja nur mehr 64Bit versionen gibt.
Damit funktionieren ja die 32Bit VSTis nicht mehr.
Damit funktioniert dann auch Battery (1) nicht und damit kann ich dann den Versatz zwischen VSTi und Midi-Hardware ja gar nicht hören.

P.S: Das hätte ich vielleicht erwähnen sollen: Das VSTi ist vom Midi Timing her in Ordnung, aber die Midi-Hardware macht die Probleme.
Spricht vllt. wirklich fürs Midi Interface (oder dagegen) aber so viele brauchbare Alternativen gibt es da ja gar nicht.
 
G
Glgralkhges23535615573
Guest

Unter 20€ zum testen oder Upgrade zu einem neuen ? Vlt tuts auch nen Treiber Update ?
 
K
Klangbasis
|||
Gabs da nicht irgenwo ein Häkchen bei "Windows Sytemzeit nutzen" in den MIDI-Optionen? Das hatte damals bei SX3 mein ähnliches Problem gelöst - glaube das Häkchen gibts bei meinem aktuellen Cubase 10 immer noch...
 
D
Despistado
|
Cubase 10 funktioniert nicht.
Die Trial Lizenz ist zwar auf dem Dongle aber der Lizenzierungszeitraum kann nicht begonnen werden...

Tja.
 
D
Despistado
|
Hab jetzt eine ältere Version von Cubase Elements 7 gefunden.
Selbes Problem.
Also an Cubase an sich scheint's nicht zu liegen.
 
D
Despistado
|
Hab jetzt verschiedene Treiber für das Midi-Interface auch schon durch, ändert nichts.

Tja, muss wohl damit leben, dass irgendjemand Mist gebaut hat.
 
D
Despistado
|
Danke für deinen Tipp, aber das mit den emulierten Midi-Ports usw. hab ich schon alles durch.

Mittlerweile hat sich auch herausgestellt, dass das Problem (zumindest eines davon) nicht auftritt, wenn ich statt Battery z.B. Drums von einem externen Midi-Instrument verwende.
Es wird aber wohl nicht so einfach sein, dass das VSTi schuld ist, denn warum sollte das VSTi bewirken, dass Midispuren von externen Instrumenten verzögert werden und Timing-Probleme haben, und das aber auch nur eine gewisse Zeit lang?
Wenn man 30 Sekunden wartet wird alles korrekt abgespielt.

Sinn ergibt das für mich alles nicht unbedingt.
 
fanwander
fanwander
*****
denn warum sollte das VSTi bewirken, dass Midispuren von externen Instrumenten verzögert werden und Timing-Probleme haben, und das aber auch nur eine gewisse Zeit lang?
Du weißt doch garnicht, ob die Events verzögert werden. Vermutlich ist einfach die Klangerzeugung zu dem Zeitpunkt lahm. Stell Dir vor Du klingelst bei jemandem, und der hat einen kaputten Fuß und braucht fünf Minuten bis zur Türe um Dir dann aufzumachen. Da ist ja auch nicht die Klingel kaputt...


Und dass die Sachen irgendwann tight kommen, könnte daran liegen, dass da was "mühsam" berechnet wird, was dann irgendwann in einem Cache liegt. Ab dem Moment wo es im Cache liegt, geht alles flott.
 
D
Despistado
|
Ich vermute, dass die Midi-Events verzögert rausgeschickt werden. Die externe Klangerzeugung bekommt ja von dem VSTi nichts mit, die wird also nicht langsamer "in Fahrt" kommen immer rein zufällig dann wenn die Drumspur von einem VSTi abgespielt wird.

Die Frage ist also (unter anderem, denn das ist ja nicht das einzige Timing Problem) was Cubase so sehr belastet wenn ein VSTi Drums abspielt dass dadurch andere Midi-Spuren (zu externen Geräten) ins Straucheln geraten.
Ich hab mal testweise ein anderes VSTi verwendet (LM9) und nach zwei Takten schmiert Cubase komplett ab.
Daraufhin hab ich Cubase quasi zurückgesetzt (den Teil in der Registry gelöscht der alle Einstellungen beinhaltet) aber immer noch dasselbe Problem.

Ist alles recht seltsam und unerklärlich hier.
 
Summa
Summa
hate is always foolish…and love, is always wise...
Du hast den PC schon entsprechend konfiguriert, was die Energieoptionen betrifft? Ansonsten braucht er vielleicht nen Moment um aus dem Energiesparmodus rauszukommen.
 
D
Despistado
|
Das Problem besteht übrigens immer noch, also falls zwischenzeitlich irgendjemandem etwas eingefallen ist, nur raus damit.

Was ich mittlerweile sagen kann ist, dass es weder mit der verwendeten Cubase-Version zusammenhängt und auch nicht damit ob Windows vllt. zugemüllt ist o.ä.

Du hast den PC schon entsprechend konfiguriert, was die Energieoptionen betrifft? Ansonsten braucht er vielleicht nen Moment um aus dem Energiesparmodus rauszukommen.
Steht auf Höchstleistung und ausschalten "nie".
 
 


Neueste Beiträge

News

Oben