PMM-88E schafft mich!

Miks

|||||
Schön, dann werde ich mich zunächst mal um Datensicherung kümmern und dann weitersehen. Als nächstes muß erst mal 'n Schlachtplan her: wer - wie - wodurch - mit wem - warum - und ob überhaupt... dann geht's in die Details. Ich hoffe, ich darf Dich auch weiterhin mit doofen Fragen belästigen, falls es irgendwo mal wieder hakt... ;-)
 

microbug

*****
Klar, aber dann am Besten hier im Thread, dann ist alles beisammen. Den Editor hab ich übrigens unter Win7/64 ans Laufen bekommen, sag Bescheid wenn Du die Datei mitsamt Anleitung drin brauchen solltest. Muckt zwar manchmal bissl rum, läuft aber meist problemlos.

Zur Planung am besten auch mal meinen Artikel mit der MP44 anschauen, siehe Signatur, da sind die Basics und die Vorüberlegungen beschrieben.

Falls Du zufällig auch auf facebook sein solltest: Dort hab ich eine MIDITemp Usergruppe am Laufen, und die hier erstellte Anleitung ist dort bereits als Datei hochgeladen worden.
 

Miks

|||||
Super. Ich werde schon versuchen, so weit es geht mir mein(e) Setup(s) selbst zu erstellen/erarbeiten - soll ja angeblich auch 'n Lerneffekt haben... ;-)

Den Editor (nebst deutscher Hilfe-Datei) habe ich hier unter Win7 Pro SP1 32Bit am Start - läuft bisher, soweit ich das beurteilen kann, fehlerfrei.

Nee, Batzefuck - ääähh - Fazebuck habe ich nicht - brauch ich auch nicht, ich bin zu alt für so'n Scheiß :mrgreen:

Ich habe mir mal erlaubt, diese unsere Konversation (Hüüülfeee...) als PDF zu erstellen - sozusagen als 'Gedächtnisstütze' für mich...
 

Miks

|||||
Ich kann Dir das pdf des Artikels mit den Bildchen auch gerne hier anhängen.
Ja, gerne.

Wenn Du magst, auch gern mal den Link zu Deiner Facebook MIDITemp Usergruppe - zumindest reinschauen kann man ja meist, ohne einen eigenen Account zu haben. Kenne ich zumindest so von vielen Facebook-Seiten, z.B. auch der von unserer Band.
 

Miks

|||||
Bin heute seit einiger Zeit dabei, die PMM-8E einzurichten - aber immer schön langsam, eins nach'm annern. Erste kleine Erfolge sind zu verzeichnen. Aber, Dietmar, Du hast Recht: der MIOC-Editor scheint einige Bugs zu haben. Wenn ich z.B. im Editor in der Bank M1A die Programmnamen ändere (auf 'Patch 1' bis sonstwo) und diese Bank dann speichere & anschließend wieder einlade, werden einige Patches wieder 'standard-mäßig' in 'Program xx' umbenannt.

Auch beim Kopieren von Programmen geht was schief - ich kopiere z.Z. immer Patch 1 auf andere Programmplätze, um meine 'Grundeinstellung' von FCB1010 & GX700 weiter zu verwenden - brauche ich in vielen Songs - speichere ich diese Bank über den 'Save Bank'-Befehl im Program-Menü (wo ich auch kopieren kann), und lade diese Bank dann wieder, fehlen etliche 'Patches' bzw. sind nicht korrekt :shock: Wähle ich jedoch im Hauptbildschirm jedoch im Drop-Down-Menü (oben Mitte) ein Program aus und sende dieses 'händisch', d.h. mit der 'Transmit Program'-Schaltfläche klappt es, auch eine dann auf Festplatte abgespeicherte Bank ist, soweit ich das bis jetzt überblicke, in Ordnung... man man man.
 
Zuletzt bearbeitet:

Miks

|||||
Kleine Zwischenbilanz: mein Boss GX700 läßt sich bereits wie gewünscht per PMM-88E steuern - Patches umschalten geht, ebenso das Ein- und Ausschalten des Tuners auf jeweils erneute Betätigung desselben Foot-Switches hin.

Ein auf Midi-Kanal 14 eingestelltes Lehle D.Loop ließ sich (nach vorübergehender Umstellung des 1. Ausganges der PMM ebenfalls auf Kanal 14) einwandfrei mit gesendeten PC-Befehlen programmieren:

PC#001 schaltet Loop A ein - falls B = an wird B ausgeschaltet.
PC#002 schaltet Loop B ein - falls A = an wird A ausgeschaltet.
PC#003 schaltet Loop A und B ein - falls A oder B = an wird die jeweils andere Loop dazugeschaltet
PC#004 schaltet Loop A und B aus (quasi ein general-OFF)

Es geht voran - slowly but surely :mrgreen:

Die beiden Lehle 3AT1 sind auch noch dran - die sind jedoch noch im Ü-Raum...
 
Zuletzt bearbeitet:

microbug

*****
Auch beim Kopieren von Programmen geht was schief
Denk dran, daß das bei den MIDITemps am Gerät umgekehrt funktioniert, also Du wählst erst das Zielprogramm an und dann die Quelle.

Wenn der Editor Mist baut, kann das aber auch am Interface liegen, denn besonders die Billigen können mit Sysex nicht umgehen, weil da kein Speicher eingebaut wurde, und wenn dann eh immer zuwenig.
 

Miks

|||||
Ja nee - is' klar! Ich hänge mal wieder bei der Programmierung der PMM-88E!

Achtung: ist momentan alles testhalber, damit ich die Kiste verstehen lerne...

Ich möchte im Patch 34 einen ProgramChange 1 an Ausgang 8 auf Midi-Kanal 14 senden können (D.Loop soll mir Loop A einschalten) und im Patch 35 einen ProgramChange 4 an Ausgang 8 auf Midi-Kanal 14 senden (D.Loop soll mir Loop A ausschalten). Krieg' ich nicht hin...

So sieht das zur Zeit im MIOC-Editor für Patch 34 aus:
Patch34-1.jpg Patch34-2.jpg Patch34-3.jpg Patch34-4.jpg Patch34-5.jpg
Was mache ich wo falsch?

Und mal 'ne grundsätzliche Frage: ist das Routing auch abhängig von den angewählten Patches? Ich denke ja - man korrigiere mich, sollte ich falsch liegen.

Bin für zweckdienliche Hinweise echt dankbar, egal, ob direkt über die Fernbedienung der Matrix oder (noch lieber) per MIOC-Editor.

Falls jemand noch Fragen zu irgendwelchen anderen Einstellungen hat, einfach fragen.

Ich kann auch bald nich mehr...!
 
Zuletzt bearbeitet:

microbug

*****
Program Changes am Besten am Gerät direkt eingeben, da ist der Editor doof. Ist dort viel einfacher, probier es aus. Dort kannst dann nämlich direkt durch drehen am Encoder sehen, ob das Zielgerät drauf reagiert. Tut es das nicht, gibt es mehrere Möglichkeiten:

1. Am Gerät ist der Empfang von Program Change ausgeschaltet
2. es muß immer ein Bankselect dabei sein

Das Routing ist von dem Patch abhängig, welches am Gerät gerade aktiv ist.
 

Miks

|||||
Danke für's Antworten

1. Am Gerät ist der Empfang von Program Change ausgeschaltet
Kann man am D.Loop nicht generell ausschalten.
2. es muß immer ein Bankselect dabei sein
Würde mich wundern, denn es ging ja schon mal:
Ein auf Midi-Kanal 14 eingestelltes Lehle D.Loop ließ sich (nach vorübergehender Umstellung des 1. Ausganges der PMM ebenfalls auf Kanal 14) einwandfrei mit gesendeten PC-Befehlen programmieren:

PC#001 schaltet Loop A ein - falls B = an wird B ausgeschaltet.
PC#002 schaltet Loop B ein - falls A = an wird A ausgeschaltet.
PC#003 schaltet Loop A und B ein - falls A oder B = an wird die jeweils andere Loop dazugeschaltet
PC#004 schaltet Loop A und B aus (quasi ein general-OFF)
Da hatte ich nur das GX-700 vom Ausgang 1 der PMM-88E abgezogen, dem Ausgang die Midi-Adresse 14 zugewiesen und dann den Lehle D.Loop angesteckt - funktionierte sofort mit den PC's 001 - 004, die das FCB1010 sonst unverändert an das GX-700 sendet...
 

microbug

*****
Was mache ich wo falsch?
Ich sehe gerade, Du hast im Routingfenster Kanäle umdefiniert - warum das? Zur Erinnerung: im Editor fürs reine Routing den Kanal rechts oben IMMER auf OMNI stellen, an dieser Stelle KEINE Kanäle einstellen, denn diese dienen zum Multiconverting, also wenn Du zB den Kanal für ein Zielgerät verbiegen willst, um dort selbst leine Einstellung treffen zu müssen.

Reines Routing IMMER erstmal 1:1 machen, also links oben den Port auswählen und dann in der Mitte das Ziel, die Kanäle links erstmal links liegen lassen.

Geht übrigens noch einfacher: Im Startfenster des Editors auf das Symbol eines Eingangs klicken, dann invertiert es sich, dann kannst die dazu passenden Ausgänge anklicken und wenn fertig nochmal auf den zuerst gewählten Eingang klicken - fertig.
Ich empfehle auch mal die Anleitung zum Editor zu lesen :)
 

Miks

|||||
Ich sehe gerade, Du hast im Routingfenster Kanäle umdefiniert
Was heißt das? Stehe wie der Ochs' vor'm Berge...
im Editor fürs reine Routing den Kanal rechts oben IMMER auf OMNI stellen
Wenn ich irgendwo OMNI einstelle, das zur Matrix schicke (oder auch nicht), aus dem Routing rausgehe und es wieder aufrufe, ist nie das OMNI geblieben, es ist (scheinbar) immer Kanal 1 aktiviert - die Kiste treibt mich noch in den Wahnsinn!
Ich empfehle auch mal die Anleitung zum Editor zu lesen
Super Idee - zumal ich sie (falls Du die Hilfe-Datei meinst) ja selber ins Deutsche übersetzt habe ;-)
Aber auch die finde ich recht dürftig - ein paar Beispiele, wie man wann wo was macht, wären darin sicher von Vorteil gewesen...
 
Zuletzt bearbeitet:

microbug

*****
Was heißt das? Stehe wie der Ochs' vor'm Berge...
Das heißt, das Du Kanäle nicht 1:1 durchleitest, sondern umbelegst, also 1 auf 2 oder so. Das, was Du oben so schön bunt gemacht hast, sind die Eingangs (Quell)kanäle, unten drunter in den 8 Reihen dann die Zielkanäle. Im Bild oben hast Du beim ersten Gerät 1 auf 1 gemappt, was ja nicht nötig ist weil 1:1 das eh macht, beim Gerät in Reihe 8 kann ich nicht sehen, welchen Kanal Du da auf 14 gemappt hast, weil das nicht ausgewählt ist.

Wenn ich irgendwo OMNI einstelle, das zur Matrix schicke (oder auch nicht), aus dem Routing rausgehe und es wieder aufrufe, ist nie das OMNI geblieben, es ist (scheinbar) immer Kanal 1 aktiviert - die Kiste treibt mich noch in den Wahnsinn!
Ich müßte das nochmal nachschauen, aber solange man es nicht abspeichert, fängt der immer bei Kanal 1 an.

Daher: Die Kanäle ignorieren und erstmal immer mit 1:1 arbeiten, und dazu brauchst Du nicht in dieses Fenster zu gehen. Vielleicht mach ich ja mal ein Video zum Editor.
 

Miks

|||||
Das, was Du oben so schön bunt gemacht hast, sind die Eingangs (Quell)kanäle, unten drunter in den 8 Reihen dann die Zielkanäle.
Das ist soweit klar - steht ja auch dran.
Im Bild oben hast Du beim ersten Gerät 1 auf 1 gemappt
Daher wohl auch der 'Eintrag' 1:1 im 3. Feld der Ein- und Ausgänge.
Reihe 8 kann ich nicht sehen, welchen Kanal Du da auf 14 gemappt hast, weil das nicht ausgewählt ist.
:?: - meinst Du mit Kanal jetzt einen Ein- oder Ausgang? Die 14 ist ja (m)ein (Midi)Kanal. Ich möchte erreichen, daß bei Aufruf von Patch 34 an Ausgang 8 ein ProgramChange auf Midi-Kanal 14 (auf den das Lehle D.Loop eingestellt ist) gesendet wird. Diesen soll die Matrix erzeugen - kann sie ja auch. Mit SysEx kann ich hier nicht arbeiten weil das die Lehles nicht können - man kann den Midi-Kanal (1-16) einstellen, die 3 Tastenfunktionen (Reaktion auf eingehende ProgramChanges (001-127) durch 'scharfschalten' mit anschließendem Senden des gewünschten PCs programmieren... das war's schon.
Ich müßte das nochmal nachschauen, aber solange man es nicht abspeichert, fängt der immer bei Kanal 1 an.
Abspeichern wohin - in die Matrix oder auf Datenträger (hier also auf Festplatte des Computers)?
Daher: Die Kanäle ignorieren und erstmal immer mit 1:1 arbeiten, und dazu brauchst Du nicht in dieses Fenster zu gehen. Vielleicht mach ich ja mal ein Video zum Editor.
Au ja - 'n Video wäre schön - oder 'n Text nach dem Schema:
Matrix einschalten, Patch anwählen, ENTER. 1 (RTG) drücken - oder 7 (PRG) drücken... usw. Kurz & knapp. Ich mache auch gern mal die Matrix 'leer' und fange frisch an - einfach um mir eine funktionierende Konstellation mal im Editor anzusehen, was dann wo wie eingestellt ist - vielleicht erschließt sich mir diese Einstellung dann besser und ich kann darauf weiter aufbauen.
 

Miks

|||||
So sieht meine ProgramChange-Einstellung (PC 1/01/001 wie auch immer) auf Midi-Kanal 14 für Ausgang 8 momentan im Display der PMM aus...
PrgChng 1.jpg
 

microbug

*****
und genau so sollte sie auch funktionieren, wenn Du keine Kanäle umgebogen hast, kann man ja am Gerät direkt testen, wenn man den Encoder dreht schaltet das angeschlossene Gerät um.

Mach Dir außerdem das Leben leichter und benenne die Ein/Ausgänge.
 

Miks

|||||
und genau so sollte sie auch funktionieren, wenn Du keine Kanäle umgebogen hast, kann man ja am Gerät direkt testen, wenn man den Encoder dreht schaltet das angeschlossene Gerät um.
Was genau heißt umgebogen - wo & wie sehe ich das? Bzgl. Encoder drehen - an welcher Stelle? 'Normales' Umschalten von z.B. Patch 33 auf 34 mit anschließendem Druck auf ENTER (Drehrad), so daß der Patch an/ausgewählt ist? Oder meinst Du an anderer Stelle - falls ja, wo genau?

Ich hatte gestern mal meinen Studiomaster MA36 Midi-Analyzer an Ausgang 8 gesteckt und geschaut, was dort ankommt - seltsamer Weise haben alle 16 LEDs für die Kanäle beim Senden kurz aufgleuchtet, dazu noch die LED für ProgramChange (!) und für All Notes Off (!). Aber das Lehle D.Loop hat sich gepflegt mit irgendwelchen Erekt - ääh - Reaktionen zurückgehalten...

Mach Dir außerdem das Leben leichter und benenne die Ein/Ausgänge.
Hab' ich doch - siehe meine obigen 5 Bilder...
 

microbug

*****
Was genau heißt umgebogen - wo & wie sehe ich das?
Im Routingfenster des Editors oben, wie schon erklärt. Am Gerät sieht man es auch, aber erst wenn man in eine gesetzte Verbindung reingeht und dann READ drückt. Wenn da nicht links omi und rechts org steht, wurden Kanäle gemappt.

Encoder drehen - an welcher Stelle? 'Normales' Umschalten von z.B. Patch 33 auf 34 mit anschließendem Druck auf ENTER (Drehrad), so daß der Patch an/ausgewählt ist?
Cursor muß auf dem Program Change stehen, dann sollte man durch drehen des Encoders die Program Changes direkt auslösen, ich habs grad nicht auswendig im Kopf, muß selbst probieren, da ich das nicht ständig benutze.

Bei Programmwechsel der PMM wird immer ein AllNotesOff gesendet, kann man aber mit Menupunkt ANO im Config-Modus (doppelklick auf MATR) abschalten. Hab ich bei meinem Demovideo fürs Nerdlich so gemacht, damit die Noten beim Umschalten nicht abreißen.

Die benannten Portnamen hast Du aber offenbar nicht ans Gerät gesendet, denn im Beispielbild oben steht nichts hintet der 8 - oder ist das nur eine nachgetippte Grafik?
 
Zuletzt bearbeitet:

Miks

|||||
Im Routingfenster des Editors oben, wie schon erklärt. Am Gerät sieht man es auch, aber erst wenn man in eine gesetzte Verbindung reingeht und dann READ drückt. Wenn da nicht links omi und rechts org steht, wurden Kanäle gemappt.
Ok - schau ich mir noch mal an.

Cursor muß auf dem Program Change stehen, dann sollte man durch drehen des Encoders die Program Changes direkt auslösen, ich habs grad nicht auswendig im Kopf, muß selbst probieren, da ich das nicht ständig benutze.
Probiere ich aus - hatte ich gestern auch schon getestet, keinerlei Reaktion. Lag/liegt aber bestimmt an (einer) noch nicht korrekten Einstellung(en).

Bei Programmwechsel der PMM wird immer ein AllNotesOff gesendet, kann man aber mit Menupunkt ANO im Config-Modus (doppelklick auf MATR) abschalten. Hab ich bei meinem Demovideo fürs Nerdlich so gemacht, damit die Noten beim Umschalten nicht abreißen.
Ah ok - dann war die Anzeige schon richtig so. Kann ich (vermutlich) so lassen, weil ich nichts so umschalte(n werde), daß gespielte Noten noch weiter klingen müssen.

Die benannten Portnamen hast Du aber offenbar nicht ans Gerät gesendet, denn im Beispielbild oben steht nichts hinter der 8 - oder ist das nur eine nachgetippte Grafik?
Die Grafik ist aus der PDF-Bedienungsanleitung rauskopiert und von mir so 'gepimpt' worden, daß es optisch passt - den/die Namen allerdings nicht. Ist also nur ein 'kosmetischer Fehler' ;-) Normalerweise sehe ich sie im 'echten' Display.
 

microbug

*****
Program Changes am Gerät testen: cursor auf # setzen, Encoder drehen und drücken, das sendet den eingestellten Program Change und den evtl eingestellten Bank Select.
Wenn das Gerät nicht reagiert:
- Kanal prüfen
- Einstellungen checken, ob Program Change Empfang eingeschaltet

Das kann man auch in einem leeren Programm, also wo keine Routings drinsind, probieren, bleibt halt danach dort solange gespeichert, bis man das Programm wieder löscht.

IMG_4752.JPG
So sieht das hier aus, wenn ich den JD-Xi auf Bank E umschalten will, der braucht immer einen Bank Select und der Kanal ist auf 16 eingestellt.
 
Zuletzt bearbeitet:

Miks

|||||
Isch werd' noh bleede! Nu gäähts!

Ich habe eben, ohne zuvor Deine letzten beiden Beiträge gesehen zu haben, noch mal rumprobiert. In meiner Verzweifelung habe ich dann mal mit den Midi-Kanälen gespielt - und als ich auf Kanal 15 statt auf 14 mal den ProgramChange 1 eingestellt & aktiviert habe, reagiert der D.Loop so wie er soll :shock:

Und ich war mir so sicher, daß der Midi-Kanal am D.Loop auf 14 eingestellt ist und er ja auch schon am Output 2 testhalber drauf reagiert hat...

Das wird überprüft! Jedenfalls dann (alles noch Testphase) Patch 34 nach 35 kopiert, den PC für Out 8 von 1 auf 4 abgeändert (alle Loops aus) - haut hin! Oh man...

Danke für das Video, muß ich mir noch ansehen, und für:
Program Changes am Gerät testen: cursor auf # setzen, Encoder drehen und drücken, das sendet den eingestellten Program Change und den evtl eingestellten Bank Select.
Wenn das Gerät nicht reagiert:
- Kanal prüfen
- Einstellungen checken, ob Program Change Empfang eingeschaltet

Das kann man auch in einem leeren Programm, also wo keine Routings drinsind, probieren, bleibt halt danach dort solange gespeichert, bis man das Programm wieder löscht.
Diese Bank ist erstmal gespeichert - und jetzt sehe ich mal weiter. Aber ich denke, der Nebel des Grauens lichtet sich so langsam... (hoff) ;-)
 
Zuletzt bearbeitet:

Miks

|||||
So sieht das Patch 34 momentan aus:
Patch34-6.jpg
Nicht verwirren lassen - ich habe inzwischen den D.Loop auf Midi-Kanal 14 umgestellt, so wie's eigentlich vorgesehen war...
 
Zuletzt bearbeitet:

microbug

*****
Du hast immer noch ein Channelmapping drin, das hat da nichts verloren, wie ich schon mehrfach sagte (Fenster links unten) und im Video erklärte.
 

Miks

|||||
So sieht jetzt Patch 1 aus:
Patch1 - 1.jpg
Die Patches 1 - 4 machen jetzt genau das, was sie sollen - GX700 umschalten und die beiden Lehles so ein/umschalten wie der Pappa das möchte... ;-) ist noch immer 'Test-Modus' - die nächste Aufgabe wird die Umschaltung von Synths sein...
 


Neueste Beiträge

News

Oben