VCF mit dem CA3140; Eklärung zum Schaltplan gesucht...

Dieses Thema im Forum "Lötkunst" wurde erstellt von zeiner-rider, 20. Dezember 2008.

  1. Also ich habe hier den VCF aus dem ASM-1 Projekt. Der Link dazu: http://www.elby-designs.com/asm-1/asm1.htm

    Irgendwie verstehe ich die Funktion der CA3140 in der Schaltung nicht. Vielleicht findet sich jemand, der mit die Schaltung etwas erklären kann.

    Hier die Schaltung: http://www.elby-designs.com/asm-1/vcf/vcf-asm1-cct.pdf
    Ich denke so funktioniert es:
    Über die oberen CV-Eingänge bildet sich ein Steuerstrom an dem Stromspiegel Q2, Q3. Dieser Strom bestimmt die Trennfrequenz der Filter (CA3140).

    Bei meiner DIY Platine funktionieren die Ausgänge nicht wie sie sollten und desshalb suche ich hier um Rat.

    So ein OTA hat ja einen Stromquellenausgang was ich im Netz rausgefunden habe. Aber wieso so kompliziert? Warum nicht ein gewöhnlicher OPV?

    Vielen Dank!
     
  2. Anonymous

    Anonymous Guest

    Q202, 203 sind die Stromquellen (und Exponentiatoren) für den Steuerstrom der OTAs CA3080.
    Der OTA Ausgangs*strom* geht in die mit FET-OPs aufgebauten Integratoren CA3140.
    Den CA3140 kannst du gedanklich fast weglassen: der Ausgangsstrom des OTAs geht dann direkt auf einen 330pF Kondensator gegen Masse und der 3140 Ausgang stellt die Spannung an dem gepuffert bereit. (Der Vorteil ist hier, das der Spannungspegel am OTA-Ausgang = Minus-Eingang vom OP auf 0 volt liegt, das macht die Schaltung schön linear, weil der Arbeitspunkt konstant ist. )

    (Warum das eine ein CA3140 und das andere CA3130 ist weiß ich nicht. Prinzipiell machen die das gleiche - das sind normale Operationsverstärker.)
     
  3. Vielen Dank für deine schnelle Hilfe!

    Aber warum 2 Integratoren? Das verstehe ich nicht. Immerhin muss ja ein Tiefpass rauskommen?

    Und die Diodenschaltung die zum Bandpass führen sollte ist auch unklar.
     
  4. 2 Integratoren weil es ein 12dB/Okt Filter ist. Jeder Pol hat dabei 6dB/Okt.

    Das Bandpassignal wird über die Dioden negativ rückgekoppelt und erzeugt damit die Resonanz. Die Dioden bilden hier ein nicht-lineares Netzwerk welches dem Filter eine bestimmte Charakteristik verleihen soll.
    Anleihe an das Oberheim SEM-Filter.

    CA3140/3130 waren zur damaligen Zeit (Anfang 80'er) die einzigsten OpAmps mit sehr hoher Eingangsimpedanz. Die gerade erschienenen TLxxx haben gegenüber den CA3140 den Nachteil, daß sie an einer der Versorgungsspannungen unter gewissen Umständen hängen bleiben können, die Gefahr ist bei Filtern durch hohe Pegelspitzen durch Resonanz vorhanden. (siehe phase reversal).
    .
     
  5. Die Stufen verstärken irgenwie zu gering. Nur Millivolt sind mit dem Oszi messbar.

    Dieses Offset 1 und 2 ist auch sehr merkwürdig, besonder diese MOhm Widerstände in Serie...

    An U203 Pin 6 (Ausgang) ist das Signal im Millivolt bereich. Muss eigentlich, da der U204 Eingang an Masse zieht (Ud=0). Erst an diesenm U204 Ausgang müsste man doch das Bandpass Signal ordentlich messen können. Ich messe da nur mist.
     
  6. Anonymous

    Anonymous Guest

    Am Ausgang der OTAs kannst du nix (sinnvoll) Messen - erst am Ausgang der folgenden OPs.
    Am Eingang der OTAs ist das Signal sehr klein.
    Der Offset ist erstmal egal - wenn alles geht wird damit wohl am Ausgang der 'zugehörigen' 3140/3130 auf Null Volt DC abgeglichen.
     
  7. Die Widerstände R221 und R226 sind etwas sehr klein. Vermutlich ein Druckfehler.
    Normalerweise sind sie genauso groß wie die entsprechenden Widerstände an den nicht-invertierenden Eingängen, also 220 Ohm statt 22 Ohm.
    .
     
  8. Ist das leicht gar kein Integrator, sondern durch die C203 R225 und R226 ein Tiefpass mit -6dB ? Also ein PT2?

    Werd mal diesen Teil durchsimulieren.

    Verglichen mit einem Schaltplan von 1996, hat der ältere Plan nur anstatt des 33pF, einen 30pF Kondensator. Also müsste das mit den 22Ohm stimmen!

    Vieviel Strom liefert der Pin5 des CA3080? der Strom fließt ja von -15V im IC, über den 18k (R224) über Q202 nach GND. Wenn ich den 18k nämlich veringere müsste ja mehr fließen. :roll:
     
  9. Also diese (für mich) komische Filterschaltung im unteren Bereich des Schaltplanes funktioniert soweit mal.
    Wird nämlich der Stromeingang (Pin5) des CA3080 mit einem anderen Strom versorgt, als wie es über den obrigen Stromspiegel vorgesehen ist, so funktioniert die Schaltung.

    Versorgt über die Transistoren, geht nichts. Also ist hier irgendwo mein Fehler.
    Der erste OPV links oben wird ziemlich warm. Bei den 490Ohm wundert mich das auch nicht weiters... :?

    Nach meinem Verständis nach (also ggf. korrigieren) hat dieser eine Verstärkung von -1/50, da 2k/100k. Bei einem Eingang von 10V hat der Ausgang des ersten OPVs ein Potential von -1/50*10V= -0,2Volt.

    Irgendwo gibts noch einen kurzen, denn wenn ich den 2N3904 hineingebe, blitzt es und mein NT schaltet bei ca 1A ab.

    Also bitte helft mir, ich werde da noch verrückt!
    Dass ich an der BE Strecke des 2N3904 immer 8Volt messe, sage ich am besten gar nicht! :shock:

    Zusammengefasst:
    Meiner Meinung nach hackt es an der Belastung des ersten OPVs.
    10V am Eingang ergeben -160mV an seinem Ausgang(nur ohne der 490Ohm Last). Das stimmt in etwa mit der Berechnung. Mit den 490Ohm (Also 100Ohm Poti+390Ohm R210) steigt die Ausgangsspannung des OPVs auf 6 Volt und er wird heisssss..

    Ist etwas lang geworden, trotzdem habe ich mich bemüht alles Verständlich rüberzubringen!
     
  10. C0r€

    C0r€ -

    also bei U201A sollen bestimmt 20k in die rückkopplung, nicht 2k (ausserdem machen die 20k gegen masse bei 2k in der Rückkopplung keinen sinn) Und 460R als Last für den OPV ist auch etwas wenig, eher 3,9k. und wenn du einmal nen CA3080 überlastet hast kannst du den so gut wie immer vergessen, die sind nicht besonders kurzschlussfest. Die schaltung scheint total verbuggt zu sein. Normalerweise gabs bei EFM immer viele bugs, die man im Forum abklären bzw. finden konnte.

    Die Spannung am Emitter von Q201 muss bei etwa -0.6V liegen, an der Basis (da Emitterfolger) etwa Diodenabfall höher.
     
  11. Genau! Daraus habe ich auch geschlossen, dass an dieser Basis ein Potential von 0V liegen muss.

    Ja wenn die Schaltung schon mal nicht stimmt...
    Werde noch mal ein bisschen daran rumprobieren.
     
  12. Ich habe mal simuliert. Die Schaltung mit PSpice:
    [​IMG]

    Man sieht dass die 490Ohm gar kein Problem sind, da ja auch nur unter 1V ausgegeben wird.

    Folgendes Bild zeigt oben einen Sinus am Eingang:
    [​IMG]
    2ter Verlauf zeigt den ersten Emitter und der untere Verlauf zeigt den Strom am OPV Ausgang!

    Doch eines macht mich sehr stutzig: lt simulation fallen an der ersten BE-Strecke (2N3904) 0,7V ab. (Was den sonst?)
    Aber messen tue ich 6Volt :shock: :shock:

    edit:
    Aber was solls. Wenn ich statt der Kollektoren der 2ten Transistoren ein Poti reinhäng (+ und - 15V; Schleifer ist Ausgang)funktioniert die Schaltung auch!
     
  13. boerge

    boerge -

    Dann ist der Transistor kapott :)
    Hast Du direkt zwischen B und E gemessen, oder B gegen GND oder V-?

    Grüße vom Senfsee!
     
  14. genau auf den Beinchen. B und E.

    er schaltet sehr gut durch. Also CE ist 50mV oder so etwa. B liegt nach der Messung nach ziemlich genau auf 6Volt. Aber jetzt egal.


    Für beide OTAs habe ich jetzt einen Steuereingang mit einem einfachen Poti realisiert. Das funktioniert prima!

    Ich lass den oberen Teil einfach weg!
     
  15. Die beiden Offset-Trimmer weiß ich nicht einzustellen...

    Übrigens schwingt mein VCF auch ohne Signal-input, also schließe ich daraus dass noch irgendetwas nicht passt. Oder gehört das so?
    Also bei rechteckförmigen Eingangssignal fügt die Schaltung noch höherfrequente Signalanteile hinzu. Sieht ziemlich toll aus am Oszi. :roll:
     
  16. Ich spreche von so einem Bild am Oszi:
    [​IMG]

    Habe ich gerade irgendwo gefunden. Wird also normal sein. Und ich dachte das fängt zum schwingen an oder so... :roll: :roll:
     

Diese Seite empfehlen