Verständnisfrage zu OR-Gattern (4071)

Dieses Thema im Forum "Lötkunst" wurde erstellt von changeling, 23. Februar 2013.

  1. Ich bin seit fast einer Woche dabei meinen inSEQt zu debuggen und habe im Schaltplan den Weg vom nicht funktionierenden Gate Bus vom Schalter bis zum Ausgang verfolgt, dabei ist als letzte Instanz vor dem Ausgang ein 4071 OR-Gatter mit folgendem 22K Widerstand von wo der Ausgang abgeht und noch ein 10K Widerstand gen Masse geht.

    Das OR-Gatter wird vom Clock Signal des Sequencers auf einem Eingang und dem Bus Signal nach den Schalter gefüttert. Ein OR Gatter gibt aber doch 1 aus, wenn mindestens ein Eingang 1 ist. Also müsste der doch schon den Clock Rhythmus ausgeben, was ja aber nicht sein kann und bei den anderen Bussen auch nicht so ist.

    Was ich meine sieht man im Schaltplan http://www.retrosynth.com/docs/1601/1601_15b.gif rechts oben in der Gate Output Processor Box. Das Bus Signal nach den Schalter kommt bei R142/R143 rein, geht in den Transistor des CA3086 (Z4D) und von da in den 4071 (Z17C). M² ist das Clock Signal aus dem Mask Circuit (http://www.retrosynth.com/docs/1601/1601_14b.gif unten rechts).

    Wäre toll, wenn mir jemand den Schaltungsteil erklären könnte und wie ich überprüfen kann, ob da was kaputt ist. Ich habe den 4071 in Verdacht, was aber nur ins Blaue geraten ist, weil es ein CMOS IC und deswegen anfälliger gegen statische Aufladung ist. Einen Ersatz 4071 habe ich leider nicht da, somit kann ich nicht einfach schauen, ob es mìt einem Neuen funktioniert.
     
  2. Skwit

    Skwit -

    Sehe ich auch so. Legst Du eine Clock an ein ODER-Gatter, so hast Du mindestens die Clock wieder am Ausgang.

    Dein Problem sind also die Pins 8/9/10 des Z17C. Auf Pin 8 ist direkt die Clock M² geklemmt. Auf Pin 9 wird ein Transistor von "Etwas" geschaltet. Solange der Transistor Z4D durch das "Etwas" nicht eingeschaltet ist, ist er "offen", d.h. Eingang 9 wird über den 22k PullUp R144 auf HIGH gezogen. Wird der Transistor nun durch das "Etwas" eingeschaltet, d.h. es fließt ein Strom über den Vorwiderstand R22 in seine Basis, werden die Pins 11-10 des Transistors kurzgeschlossen. Dadurch wird der PullUp R144 auf Masse gezogen. Am Eingang 9 des 4071 liegt nun ein LOW an.

    Was ist M²? Das mit dem "Mask Circuit" sagt mir nichts, da mir da wieder das F² fehlt. Ich würde mir den 4071 bestellen und sehen, was das Ersatzteil macht.

    Christian
     
  3. Danke für die Antwort.

    F² kommt vom Randomizer/Skip/Reset Teil: http://www.retrosynth.com/docs/1601/1601_14a.gif
    Das ist Pin 9 vom CD4520 mit der Bezeichnung Z7B.

    Wenn der CA3086 Transistor bei anliegendem Signal auf Low schaltet ist das OR-Gatter eventuell ein "invertiertes" AND-Gatter, was passen würde, wenn der Transistor Q32 bei anliegendem Signal auf High schaltet, das Ganze also wieder umdreht.
     
  4. Wenn ich mir den Artikel zu analogen Schaltern im Elektronik Kompendium anschaue, sehen Q32, der vorherige R145 mit 22K und der nachfolgende R156 mit 10K gegen Massen genau wie die PNP-Transistor-Schaltung hier aus:

    [​IMG]
    (Bild zu Teil 7)

    Nur R155 mit 1K passt da so direkt nicht rein. Meine Vermutung ins Blaue ist, dass der einfach die Ausgangsspannung auf etwa 10 Volt reduziert.

    Auf jeden Fall invertiert Q32 das Signal wieder. M² wird daher auch ein invertiertes Clock-Signal liefern und der 4071 arbeitet somit als AND-Gatter.

    Ich bestelle mir dann mal bei Reichelt einen 4071 und schaue, ob es wirklich daran liegt. Ansonsten können ja noch der CA3086 oder Q32 kaputt sein.
     
  5. Skwit

    Skwit -

    Ja, das ist dasselbe.

    Da ist noch ein Spannungsteiler nachgeschaltet, http://www.elektronik-kompendium.de/sit ... 201111.htm

    Die Ausgangsspannung am J12 beträgt:

    Vin / Vout = (R147+R14:cool: / R148. Umgestellt: Vout = Vin * R148 / (R147 + R14:cool: = Vin * 10k / 11k. Vin ist dabei die Spannung, die am Emitter von Q32 anliegt.

    Q32 sperrt, wenn an seiner Basis ein HIGH anliegt und leitet, wenn an seiner Basis ein LOW anliegt. Der 4071 ist in Verbindung mit dem Q32 trotzdem kein AND, sondern ein invertiertes OR, also ein NOR.

    Christian
     
  6. Auf jeden Fall werden Clock und Gate Bus 2 zusammen geführt, also hinten kommt nur eine 1 raus, wenn sowohl ein Clock Puls läuft als auch ein Schalter in Position für den Gate Bus 2 steht. So meinte ich das.

    Wäre mal interessant zu wissen, warum die Gate- bzw. Clock-Signale in der Schaltung so oft invertiert werden.
     
  7. Heute kam der 4071 von Reichelt an, leider war das Tütchen aufgeschnitten und der 4071 flog auf dem schwarzen IC-"Kissen" in der Tüte drum rum herum.

    Naja, ausgetauscht und leider keine Änderung. :sad:

    Also entweder ist der Austauch 4071 auch kaputt oder der Fehler liegt woanders.
     
  8. Skwit

    Skwit -

    Schade.

    Kannst Du noch mal schreiben, was am inseqt eigentlich kaputt ist?

    Christian
     
  9. In Mittelstellung der Gate-Schalter (also der Position für Gate Bus 2) leuchtet weder die Positions LED, noch kommt ein Signal aus der Buchse für den Gate Bus 2.

    Das ist passiert nachdem ich versucht habe die hier beschriebene Modifikation zum Gate-Schalter der einzelnen Steps umzusetzen (Diode zum Gate Bus 2 und bei Gate Bus 3 die andere Schalterseite benutzen):
    viewtopic.php?p=521490#p521490

    Testweise hatte ich auch mal die Diode von Step 1 wieder raus gelötet und einen Jumper rein gemacht, dann bekomme ich zwar wieder das übersprechen während des Umschaltens, das die Modifikation beseitigen soll, aber der Gate Bus 2 bleibt dann geschaltet immer noch aus. Ich hatte zuerst auch den Verdacht, dass ich da irgendwo versehentlich eine Brücke eingebaut habe, aber optisch habe ich nichts gesehen und dann sollte ja auch das Übersprechen nicht kommen. Daher hatte ich mich auf die Ausgangsstufe vom Gate Bus 2 versteift.
     
  10. Hatte mich bisher gedrückt an der Ausgangsschaltung zu messen, weil es sich um drei übereinander gestapelte Platinen handelt, es jetzt aber doch mal gemacht, da mir nichts anderes mehr einfiel:

    Ergebnis: An der Ausgangsschaltung scheint es nicht zu liegen, weil da schon nichts ankommt.

    Ich hatte bei Step 3 den Gate Bus 3 auf Reset gestellt und somit die Sequenz auf 2 Schritte beschränkt, einer stand auf Gate Bus 1, der andere auf Gate Bus 2.

    Messungen:

    Gate Bus 1:
    Basis CA3086 (also direkt vom Gate-Schalter kommend): 0,1 - 0,65 V
    Kollektor CA3086 (Ausgang): ca. 2 bis ca. 12 V
    Ausgang 4071: ca. 2 bis ca. 12 V
    Ausgang zur direkt zur Buchse: 0 bis 3 V

    Gate Bus 2:

    Basis CA3086 (also direkt vom Gate-Schalter kommend): 0 bis 0,01 V
    Kollektor CA3086 (Ausgang): 12,82 - 13,15 V
    Ausgang 4071: 13,10 - 13,48 V
    Ausgang zur direkt zur Buchse: 0 V

    Dann habe ich ne Weile auf die unterste Platine gestarrt und mich gefragt wo ich da einen Fehler gemacht habe und bei ein paar Kurzschlussverdachtsfällen durchgepiepst, allerdings wieder ohne Ergebnis.

    Ergo bin ich völlig ratlos.

    Mir fällt jetzt nur noch ein mal Gate Bus 1 mit Gate Bus 2 kurz zu schließen um zu schauen, ob der dann auch nicht mehr funktioniert. Falls ja: Doch irgendwo ein Kurzschluss (Masse auf Gate Bus 2 durchgepiepst ergibt jedenfalls nichts). Falls nein: Liegt es doch an den Dioden? Warum hat es dann mit der Brücke auf Step 1 statt der Diode auch nicht geklappt?

    Hier mal ein schematisches Bild von der Modifikation (ist nicht von meinem inSEQt, sondern von Tomcats, ich habe nur die Leiterbahnunterbrechungen [rot] und Brücken [blau] deutlicher gemacht und beschriftet, was zu welchem Gate Bus gehört, die gelben Pfeile sind Brücken zu den nächsten Schaltern):

    [​IMG]

    Die Schalterpositionen sehen so aus:

    Oben:
    Gate Bus 1 an

    Mitte:
    Gate Bus 2 an

    Unten:
    Gate Bus 3 an

    An heißt jeweils, dass der Gate Bus mit dem Strang an dem die Diode hängt verbunden ist. Die Diode gehört zur Modifikation. Wenn links oben bei Gate Bus 1 der Pin 1 vom Schalter ist, dann nach unten und dann rechts oben wieder nach unten nummeriert wird, ergibt sich folgendes Schaltungsschema:

    Oben:
    Pin 1 mit Pin 2 und Pin 5 mit Pin 6

    Mitte:
    Pin 2 mit Pin 3 und Pin 6 mit Pin 7

    Unten:
    Pin 2 mit Pin 4 und Pin 6 mit Pin 8

    Vor der Modifikation hing der Strang von den LEDs also direkt an den Pins 2 und 7. An der Oben Stellung ändert die Modifikation gar nichts, da Pin 5 in der Luft hängt (NC).

    In der Mitte Stellung waren vor der Modifikation der LED-Strang an Pin 2 über Pin 3 mit dem Gate Bus 2 verbunden. Pin 7 war zwar mit Pin 6 verbunden, der hing aber auch in der Luft (NC). Nach der Modifikation hängt Pin 3 in der Luft (NC) und der Gate Bus 2 ist nur über Pin 7 mit Pin 6 und über die Diode mit Pin 2 verbunden. Der nächste Schalter rechts ist per Brücke von Pin 6 aus angebunden.

    In der Unten Stellung waren vor der Modifikation der LED-Strang an Pin 2 über Pin 4 mit dem Gate Bus 3 verbunden. Die Pins 4 und 7 waren kurz geschlossen (warum auch immer, vermutlich nur wegen der Brücke zum nächsten Schalter). Nach der Modifikation sind die Pins 4 und 7 voneinander getrennt und Pin 4 hängt per Brücke an der Brücke zum nächsten Schalter rechts.

    Die Schalter machen beim Schalten einen Kurzschluss zwischen der vorherigen und der nächsten Stellung, deswegen die Modifikation um das Übersprechen dadurch zu vermeiden. Ohne Diode gibt es wie mein Test mit Step 1 und der Brücke statt der Diode ergab allerdings auch Übersprechen. Die Leiterbahn von Pin 2 nach Pin 7 ergibt ohne Modifikation für mich überhaupt keinen Sinn. Ich vermute die wurde stumpf aus dem Arp 1601 Schaltplan kopiert, wo vermutlich andere Schalter benutzt wurden und die Schalterpositionen 1:1 so sind wie man es im Schaltplan auf den ersten Blick vermuten würde. Sonst würde die Verbindung dort auch keinen Sinn machen.
     
  11. Das Problem ist gelöst!

    Nachdem ich heute nochmal drauf geschaut habe und nicht nur dort wo ich mit der Modifikation was geändert habe, ging mein Augenmerk Richtung Flachbandkabel. Da ich noch zweireihige 90 Grad SIL Reihen hatte, habe ich einfach eine passend abgezwickt und dran gehängt, zum Gate Bus 2 auf der Frontplattenplatine durchgepiepst und nüscht. Zuerst dachte ich das Flachbandkabel wäre durch das viele raus und rein kaputt, dann ist mir aufgefallen, dass die Leiterbahn zu dem Stecker fürs Flachbandkabel arg komisch aussah und Lötzinn drauf war. Also zwischen Steckerlötungen und Gate Bus 2 gepiepst: Nüscht.
    Dann habe ich einfach ein Stück Draht über die komische Stelle gespannt und mit dem Stecker und dem funktionierenden Leiterbahnstück verlötet. Alles wieder eingebaut und: Et funzt! :frolic: :frolic: :frolic:

    Von Anyware kommt mir aber kein Gerät mehr ins Haus, da ist soviel rum gefrickelt worden. :roll: Der Tommy hat sich an dem Teil total übernommen.
     
  12. Skwit

    Skwit -

    :phat:

    Christian
     

Diese Seite empfehlen