class compliant

khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Ich habe hier ein class compliant USB Gerät welches nur nach erneutem
rein/raus stecken des USB Kabels erkannt wird, nicht beim einschalten des Gerätes selbst.
Wie kann ich ohne ziehen des USB Kabels das Gerät erkennen lassen?

EDIT:
Automatisch erkannt wird es von Linux
dmesg
Code:
23176.673135] usb 2-1: Product: Cirklon
[23176.768634] input: Sequentix Cirklon as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.1/input/input7[
usb-devices
Code:
T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1234 ProdID=0001 Rev=01.00
S:  Manufacturer=Sequentix
S:  Product=Cirklon
C:  #Ifs= 2 Cfg#= 1 Atr=40 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=snd-usb-audio
I:  If#= 1 Alt= 0 #EPs= 2 Cls=01(audio) Sub=03 Prot=00 Driver=usbtouchscreen
lsusb


aber qjackctl erkennt es nicht sofort.
Habe ALSA-Sequencer als auch "sleep 5 && a2jmidid -e &" versucht.
 
dbra

dbra

Ehrenpräsident des Technofreunde Ohlenburg e.V.
Das hatte ich früher mit meinem Interface auch. Durch ein Upgrade auf eine neuere Fedora-Version verschwand das dann.
 
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Sry, hatte nicht alles gepostet bzw. Missverständlich.
Hmm der Atom hat Debian stable ... dann also so in 2-3 Jahren ... ;-)
 
DrFreq

DrFreq

|
So etwas kenne ich eigentlich nur von Audio Interfaces, hier ist es aber ein reines MIDI Gerät, Jackd hat hiermit nichts zu tun, weil MIDI Geräte über Alsa zuverlässig funktionieren. Eventuell hilft es wenn man zuerst USB einsteckt, den Sequencer einschaltet und erst dann den Rechner einschaltet... Ich hatte es auch schon mal das man ein Gerät einsteckt aber der Treiber nicht sofrt geladen wird und man zuerst den Rechner neu starten muss...

Alternativ, wenn du weisst welches Modul verwendet wird kannst du auch versuchen während der Laufzeit das entsprechende Modul in den Kernel zu laden... Ich glaube mit modprobe usw. habe mir sowas mal angeschaut aber nie gebraucht weil alles soweit sehr gut funktioniert hat.

Die Buben machen sehr gute Arbeit... Man mus sich ja mal überlegen das die ganzen Hersteller kein Linux unterstützen und da verdient es doch einiges an Respekt wenn jemand trotzem in der Lage ist einen Treiber zu entwickeln damit man die Hardware in ihren mindestens Grundzügen verwenden kann, meistens scheitert es dann eh nur an den zusätzlichen Features die kein Mensch braucht, aber es unter Windows in der GUI schön anzusehen ist...
 
dbra

dbra

Ehrenpräsident des Technofreunde Ohlenburg e.V.
Audio-Interfaces werden auch über ALSA angesteuert, egal ob nun JACK oder nicht. Denke eher, es ist ein Bug in dem Treibercode für die Class-Compliant-MIDI-Interfaces.
 
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Eventuell hilft es wenn man zuerst USB einsteckt, den Sequencer einschaltet und erst dann den Rechner einschaltet...
Hatte ich auch mal gestestet LOL ja dann war meine SC 9632 wech (absolut wech) und nur Sequencer vorhanden (Alsa/jackd) als audio Interface :D
ja modprobe ist der Befehl,
laut usb-devices
Driver=snd-usb-audio
Driver=usbtouchscreen

Ja und nach erneutem rein/raus stecken des USB Kabels wird er erkannt. Nervt halt nur bissel. Bin extrem faul!

Hab btw mal parallel post gestartet. Nur mein .en ist noch kaputter wie mein .de oder so. ;-)
 
dbra

dbra

Ehrenpräsident des Technofreunde Ohlenburg e.V.
Probier mal, die Wartezeit in QJackCtl von 5 auf 10s hochzusetzen.
 
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
?
Timeout
oder
sleep 5 && a2jmidid -e &
auf 10 (denke das meinst du?)

Müsste ich aber rebooten (mach ich nachher evt mal, morgen bestimmt), wenn er 1 mal erkannt wurde funkt es dann ganz normal (power on ==> Cirklon da (im qjackctl).
 
dbra

dbra

Ehrenpräsident des Technofreunde Ohlenburg e.V.
Kannste auch in den QJackCtl-Settings einstellen. Probier halt beides aus... :)
 
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
OMG welch grausamer Anblick! /Reboot ;-)
Nö Timeout im SetUp als auch sleep 10 ... - hat keine Besserung gebracht :-/
 
dbra

dbra

Ehrenpräsident des Technofreunde Ohlenburg e.V.
Ja, meine mich jetzt zu erinnern, daß das damals bei mir auch nicht geholfen hat. Ausprobiert hatte ich es aber... :)

Nimm halt Fedora, dann brauchst du auch Wir-nehmen-nur-alte-Soft-und-haben-trotzdem-nicht-weniger-Bugs-Debian nicht mehr. :)
 
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Gentoo Gentoo über alles \o
Der Atom machts halt nicht so mit mergen, deswegen .deb.
(Btw Debian erkennt MIDI Keyboard automatisch, Gentoo nicht, dafür Sequencer Debian nicht aber Gentoo)
Fedora :doof: :P
 
DrFreq

DrFreq

|
Bei Linux ist es immer besser auf eine ältere Version zu setzen ausserdem sollte man darauf achten das es lightweight ist. Gentoo? Respekt, wäre mir zu langwierig, ich wollte auch mal T2 und Linux from scratch ausprobieren aber bin dan über Tinycore doch zu Crunchbang gekommen
 
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Ja damit fahre ich auch sehr gut: Alte Hardware und uralte Software - WM fluxbox! ;-)
 
DrFreq

DrFreq

|
khz schrieb:
Ja damit fahre ich auch sehr gut: Alte Hardware und uralte Software - WM fluxbox! ;-)

Ich habe die letzte Woche ein Buch gelesen, Sampling, von 1988... Ich war erstaunt wie aktuell der fachliche Inhalt gewesen ist.
 
 


Neueste Beiträge

News

Oben