Cubase: Unregelmässige Verzögerung bei MIDI

Dieses Thema im Forum "DAW, Softsequencer" wurde erstellt von Tax-5, 15. Dezember 2015.

  1. Tax-5

    Tax-5 |||||

    Ich versuchs mal hier, auch auf Gefahr hin dass der Thread mit 0 Antworten im Nirvana verschwindet.

    Ich habe letzens festgestellt, dass ich bei Cubase 6.5 (aktuellste Version) einige Probleme beim MIDI Timing habe.
    Die allerdings nur wenn ich gleichzeitig Audio aufnehme. (MIDI Spur dudeln lassen, externe Synths ansteuern und in Cubase als Audio Spur (1x Stereo bzw Mono) aufnehmen.

    Ich habe schon mehrere Experimente gemacht um herauszufinden was das Problem sein könnte. MIDI Interface kann man komplett ausschliessen, da ich unterschiedliche verwende.
    Auch bei den Synths habe ich verschiedene angesteuert (n paar 80er, 90er und aktuelle Kisten)

    Eine kleine Verzögerung ist zwar üblich, jedoch wäre diese dann konstant (zb. 1/256 Takt)
    Bei mir tritt das Problem auf, dass die Verzögerung der Audiospur (also das Audio Signal) unregelmässig erscheint. Das ganze sieht aus (und klingt wie) ein schlecht eingespielter Part ohen Quantisierung. Wenn man da noch Sounds layern will (zb zwei Drum/Percussionssounds) dann sind beide Spuren total aus dem Lot. Herrlich dies manual nachbearbeiten :opa:

    Das Problem tritt aber nur auf, wenn ich eine MIDI Spur laufen lasse und gleichzeitig eine Audiospure recorde.
    Lasse ich zb. ein komplette Arrangement via MIDI laufen und zeichne das Stereo auf, dann ist das Problem nicht vorhanden oder nicht merkbar. Da sitzen alle MIDI Parts auf der eins.

    Nun die 100'000 Euro Frage: Wie kann man das beheben, woran liegt das?
    Ich gehe mal davon aus, dass Cubase einfach Dreck ist und die MIDI Spuren unregelmässig "abfeuert"

    Noch technisches am Rande: Computer ist ein Intel I5 mit 16 GB Ram, Win 7 64 Bit. Cubase 6.5.
    MIDI Interfaces sind Motu Midi Express 128 und Focusrite Scarlett 18I6 (Audio Interface mit MIDI Schnittstelle)
     
  2. Klangbasis

    Klangbasis ....

    Hast du in den Midieinstellungen "Windowssystemzeit verwenden" (oder so ähnlich) aktiviert?
     
  3. mink99

    mink99 ..

    Lass mal den latencymon laufen.

    Wenn cubase 6.5 was kann, dann ist das Midi , das sollte laufen. Und deine Hardware scheint ok. :agent:
     
  4. virtualant

    virtualant eigener Benutzertitel

    Nun, es gibt anscheinend durchaus Probleme mit MIDI, hatte mich da vor kurzem mit beschäftigt, weil ich festgestellt habe dass MIDI vorgerückt aufgenommen wird, also immer etwas früher als gespielt. Sehr seltsam dachte ich, habe ich da irgendwas mit dem Latenzausgleich falsch eingestellt?
    Ich benutze auch nachwievor Cubase 6.5.
    Habe dann etwas recherchiert und bin auf diese Threads gestossen:
    http://www.steinberg.net/forums/viewtop ... &start=325
    http://www.steinberg.net/forums/viewtopic.php?t=72585
    http://www.steinberg.net/forums/viewtopic.php?t=75233
    http://www.steinberg.de/forums/viewtopi ... 96&t=60365
    http://www.steinberg.net/forums/viewtop ... 46&t=22939
    Muss wohl irgendwie mit Latenzausgleich zu tun haben.

    Die Aussagen sind aber auch nicht einheitlich, mal heisst es es ist mit Cubase 7 behoben, dann heisst es wieder es ist immer noch mit Cubase 8 da. Dann gilt es auch noch zu unterscheiden Windows oder OS X, denn die Einstellmöglichkeiten unterscheiden sich da leicht.

    Ich blick da nicht so ganz durch und habe das Problem auch noch nicht beheben können.
     
  5. virtualant

    virtualant eigener Benutzertitel

  6. Tax-5

    Tax-5 |||||

    Das Problem ist ja nicht die Latenz (bis das Midi Signal beim Synth ankommt, dort in Ton gearbeitet wird und anschliessend digital den PC erreicht) an sich, sondern die Tatsache dass die Latenz unregelmässig ist. Das klingt bei Schlagzeug und Percussionssounds dann immer so als würde man unquantisiert Fingerschlagzeug spielen.... Groove und genauer Takt kommt da nicht rein.

    Werde heute Abend mal probieren obs an der Systemzeit (erste Antwort hier) liegt....

    Ich kann mir gut vorstellen dass Cubase selbst das Problem ist. Mit MIDI Clock läufts ja auch nicht so rund....ist aber eher zweitrangig
     
  7. tichoid

    tichoid Maschinist

    Läuft vielleicht ein Echtzeit-Virenscanner auf dem System? Irgendwelche Prozesse im Hintergrund
    (Programm-Updates, Aktualisierungen)?
     
  8. suche den Ordner (midi port enabler) in Cubase In dem Ordner sind 2 Dateien verschieb die mal da raus aber lösche sie nicht.

    Starte mal ein neues Projekt. gehe in die Synchronisationseinstellung und deaktiviere ausnahmslos alles. Ziele usw.

    Ist das Problem dann immer noch da?
     
  9. Tax-5

    Tax-5 |||||

    Habe ich mal gemacht... jetzt ist zwar das Timing besser aber immer noch genauso unregelmässig.

    Ich gehe schwer davon aus, dass das Problem bei Cubase selber liegt. Kann mich aber nicht erinnern auch solche Probleme früher (Cubase SX und so n Schotter) gehabt zu haben....

    Weiss noch jemand Rat? Werde mal versuchen ne andere DAW auszuprobieren.... muss aber erstmal ne Demo von Sonar ziehen.
     
  10. mink99

    mink99 ..

    Hast du jetzt ein jitter Problem oder nur die falsche latenzkompemsation ?
     
  11. Tax-5

    Tax-5 |||||

    Jitter?
    Ich hatte eben grad die Idee, mal das ganze Arrangement per MIDI laufen zu lassen und nur eine Spur als Audio aufzuzeichnen (Kanäle am Mischpult/Wandler muten) - Entweder ich mache irgendwo einen Denkfehler oder da ist wirklich irgendwie der Wurm drin.
     
  12. mink99

    mink99 ..

    Jitter : es eiert
    Latency compensation : er kommt zu früh/spät , aber immer (in der jeweiligen Sitzung ) um die gleiche Zeit .
     
  13. Tax-5

    Tax-5 |||||

    Dann ja... es eiert... resp. es läuft unregelmässig.
     
  14. Zolo

    Zolo ..

    Midi eiert immer und hat Schwankungen ;-)

    Wenn man erstmal genau hinzoomed bekommt man immer einen Schreck :mrgreen:
    Ist aber ganz normal und ist bei jeder DAW / Midianbindung so.

    Außer es geht hier nicht nur um ein paar ms
     
  15. Klangbasis

    Klangbasis ....

    Ich stelle aber in meinem Systemen ebenfalls fest, dass MIDI über eine USB-Schnittstelle wesentlich schwammiger ist. Wenn ich am Läppi Musik mache, läuft MIDI meist irgendwie über USB. In meinem Standrechner werkelt eine EMU1616m über PCIe bei der ich das Empfinden nicht habe.

    Der Vorgänger meiner EMU war eine Terratec 88MT, die Gebraucht günstig zu bekommen ist - jedoch nur PCI - eine Option zum Ausprobieren?
     
  16. intercorni

    intercorni |||||||

    Die Frage ist doch: wackelt MIDI nur, wenn du nach außen gehst oder wackelt es auch schon bei DAW internen MIDI Instrumenten in Cubase?
     
  17. Tax-5

    Tax-5 |||||

    Das ist eine gute Frage... das habe ich noch nicht probiert.

    Ich werde mal versuchen die MIDI Parts von VST Instrumenten aufzunehmen und einmal zu bouncen. Mal sehen ob es da dann einen Unterschied gibt.
    Meine Vermutung ist, dass das Problem bei USB generell liegt. Zusammen mit Cubase etc. sind dass dann schon alles kleine Faktoren die in der Summe das ausmachen.

    Habe mir auch schon Gedanken gemacht, die MIDI Interfaces durch Ethernet-Lösungen zu ersetzen. Ist natürlich eine Kostenfrage
     
  18. intercorni

    intercorni |||||||

    Wenn ich per USB an mein MIDI Interface sende, dann habe ich auch kleine Wackler. Ich recorde dann das externe Instrument und quantisiere danach das Audio. Das mache ich immer.
    MIDI wackelt halt doch ziemlich stark.
     
  19. für jitterfreies midi kann ich expert sleepers empfehlen
     
  20. fanwander

    fanwander ||||||||||

    Der eigentliche Test ist: gleicher Song. Einmal alle Spuren an, und ein MIDI-Instrument auf eine Audiospur aufnehmen. Dann alles bis auf diese eine MIDI-Spur muten, und das Instrument auf eine weitere Audiospur aufnehmen. Dann die beiden Audiospuren hart gepanned laufen lassen und miteinander vergleichen.

    Wenn es da hörbare Unterschiede gibt, dann eine nach der anderen Spur wieder aufmachen, und immer wieder abgleichen. Dann sollte man rauskriegen, wo der Datenmüll auf USB her kommt.

    Das ist meines Erachtens Unsinn. MIDI-Timing hängt zuvorderst an sauberer Kontrolle der wiedergegebenen Daten. Kuck zB ob eventuelle Spurautomationsdaten für den Cubaseinternen Mischer ggf auch auf MIDI ausgegeben werden (alles schon erlebt).
     
  21. Mr. Roboto

    Mr. Roboto positiv eingestellt

    Oder sogar noch Midi-Clock und/oder MTC dazu.
     
  22. Zolo

    Zolo ..

    Da man sowas gar nicht so gut über Ohren beurteilen kann, würde ich nicht auf Empfinden setzten sondern nur auf Messungen...

    Aber wie gesagt - wir leben alle mit eierenden Midi. Auch wenn es viele total verrückt macht wenn sie es sehen.

    Seht es mal so: viele Producer machen sich die Mühe in der DAW jede Note leicht per Hand zu verschieben damit es nicht mehr so ultratight klingt ;-)
     
  23. mink99

    mink99 ..

    Frage an den te:

    Eiert nur die midiclock , oder Eiern auch sequenzierte Noten ?
     
  24. microbug

    microbug |||||||||

    MIDI selbst nicht, nur MIDI über USB. Himmelweiter Unterschied.
     
  25. Zolo

    Zolo ..

    Oh das ist mir neu. Aber stimmt ich bin auch über USB...
    Wobei damals war ich eigentlich nicht über USB ?

    Müsste ich mal testen. Obwohl es ging ja auch so die ganzen Jahre :mrgreen:
     
  26. Tax-5

    Tax-5 |||||

    An Mink:

    Es eiert die MIDI Sequenz (Bassverlauf, Schlagzeugpattern, whatever) UND MIDI Clock. Habe oftmals Mühe Geräte mit der MIDI Clock zu synchronisieren. Daher laufen die meisten Clock-gesteuerten Synths über das Focusrite MIDI Interface. Das ist passabel.

    Ich habe heute mal die Einstellungen überprüft und siehe da: Wir sind der Lösung ein Stück näher.
    Bei MIDI Filter war SysEx aktiv und ein NoteOff-Befehl (kein Plan in welchem Takt der gesandt wird).. habe den Quatsch mal deaktiviert und hoppla: Das Timing ist mittlerweile ziemlich genau. Das fehlende Quäntchen Genauigkeit kommt warscheinlich nun mal vom Signalweg MIDI->Synth->Wandler->PC/Cubase aber das ist vom Timing her schon ziemlich gut.

    ABER! Die Unregelmässigkeiten sind nach wie vor da. Zb die Bassdrum auf der 1 ist gut ein 256tel Takt verzögert. Die Offbeat Hihats sitzen allerdings fast gerade und auch die Snaredrum ist ziemlich am Platz wo sie hingehört.

    Versuche morgen noch die Tests zu machen, ob das Problem auch bei VSTi besteht. Kam heute nicht dazu... musste noch n paar Sachen abmischen (und dann hat mich der Jupiter angelächelt.. Jamsession.. und hoppla wars nach 23 Uhr )
     
  27. mink99

    mink99 ..

    Wenn die Sequenz (die von cubase gelieferten Noten ) eiert, was tust du dann mit der clock synchronisieren.

    Also nochmal
    Eiert die clock ?
    Eiern die von cubase gesendeten Noten ?
     
  28. Zolo

    Zolo ..

    Hab ich noch nie gehört dass bei VSTs intern auch Midi ungenau wird. Wie soll das gehen ? Würde ich ausschlessen.

    Ich vermute die Clock eiert nicht sondern ist verzögert. Selbst bei Latanz-Ausgleich muss die Soundkarte von Latenzwerten ausgehen die eher geschätzt sind und in wirklichkeit um ein ms verschoben sind.

    In Ableton ist da ein ganzes Kapitel in der Hilfe und eine Anleitung wie man das selbst einmessen kann. Also man recorded quasi und misst die Latenz ganz genau statt sie vom System vorgeben zu lassen.
     
  29. Anonymous

    Anonymous Guest

    Es geht hier wohl nicht um eine statische Latenzzeit, sondern die Latenz zeigt sich dynamisch. Sie kann also nicht als Konstante ermittelt werden. Die Ursache muss gefunden werden.
     
  30. mink99

    mink99 ..

    =jitter