Eagan Matrix – programmieren

Evtl..gibt's ja auch schon darin sehr erfahrene User an Board, die evtl. ein paar Fragen dazu beantworten können/wollen.

Aus dem Stehgreif fiele mir ein:

- wie kann ich die Macros mit anderen Parametern belegen?
- kann ich, und wenn ja, wie, die Controller mit anderen Parametern belegen? Den Glide/Pitch der auf den seitlichen Tasten liegt z.b. , könnte ich stattdessen auch z.b. wenn vorhanden den Cutoff eines Filters oder die rhythmische Struktur eines Layers damit beeinflussen? Mit dem Aftertouch einen anderen Parameter als voreingestellt? Kann ich eventuell sogar mehrere Parameter für einen Controller definieren? Oder für einen Macro mehrere Parameter einstellen?
- ist es sehr umständlich in die vorhandene Struktur eines Sounds neue Dinge einzufügen? Wenn ich jetzt mal modular denke...z.b. einen sehr langsamen LFO mit Wellenform Rauschen/Random z.b. die Lautstärke eines weiteren OSC's steuern lassen....etc.pp...

Also, ja ich merke schon, das ist wahrscheinlich alles nicht so einfach und sehr tiefgehend, und wahrscheinlich wird mir jemand der es weiss, sagen - ey Alter, arbeite dich da Mal n paar Monate ein...oder so...
 
Also Erfahrung hab ich keine, hab heut aber einfach mal losprobiert :)

@freidimensional Prinzipiell ist das alles möglich was du vorhast, nur ganz ohne ist das alles nicht.

Zum besseren Verständnis mal anbei ein mega simpler Beispielpatch.
Laden geht oben rechts über "preset from disk".

Anstatt Pitchbend verändert man in dem Beispielpatch die Harmonie des Oscilators1. (Formel B "killt" quasi im ersten Schritt den Pitchbend, indem man nur die Initialen X-Wert nimmt; Formel A ändert dann relativ zum Initialwert die Harmonics vom Osc1).



Macros zuweisen geht prinzipiell auch über die Formeln. Und zwar bei der Formel über dem W der dritte Punkt>linksklick und dann je nachdem Macro i bis vi auswählen.
Das W dann noch auf einen Wert grö0er 0 stellen, damit das einen Effekt zeigt. Die Formel kann man beliebig dann auf der Matrix verteilen und die jeweiligen Parameter steuern. Man kann auch ein Macro in mehrere unterschiedliche Formeln einbauen. (In meinen Beispielpatch Formel D & Formel E).

Um die Bezeichnung für die Macros zu ändern muss man unten den "Control Text" bearbeiten.

Shape Generator 1 (Modus ContinousCycle = LFO), welcher der Formel D zugewiesen wurde bewirkt das im Aftertouch die Harmonics von OSC2 zyklisch verändert werden.

Formel E ist einfach nur Noise als Beispiel.

Funktion C sagt nur, dass der Patch nur das nur die halbe Lautstärke vom Osc2 auf den Output geschickt werden soll.


Die richtigen Presets sind allerdings nochmal eine ganz andere Nummer, da muss man erstmal durchblicken, was da wo gemacht wird.
 

Anhänge

  • EM_Beispiel.mid
    325 Bytes · Aufrufe: 1
Zum Austausch von Patches wurde jetzt eine neue Kategorie auf patchstorage.com ins Leben gerufen: https://patchstorage.com/platform/eagan-matrix/

Ein paar neue Patches gibt es schon :)

Wird detailliert im neuen Video von EaganMatrix Programming vorgestellt:
https://youtu.be/7qeejT57PQ0



Übrigens, wer schon alle Osmose Presets erkundet hat kann im Ordner des Haken Editors im Unterordner „HE\Firmware\SysPresets“ alle Presets der anderen EaganMatrix Geräte zugreifen (Continuum, ContinuuMini, EaganMatrix Module, Osmose). Funktioniert bei vielen Presets überraschend gut, nur bei manchen kommt gar kein Sound. Gerade beim Continuum gibt es noch viel Neues. So kommt man schon von 529 auf insgesamt 1033 Presets).

Das Laden der Presets über den Haken Editor ist leider etwas mühsam, aber zumindest kann man einzelne Presets per drag&drop in die Freien Speicherplätze laden.
 
In Ergaenzung zu Bernies post:
Laut Expressive E (online manual) sollen folgende Pedale problemlos mit dem Osmose funktionieren:

Clavia Nord Single Sustain
Dunlop Volume X Mini
Lead Foot LFD-2
Moog EP-3 [mode: other, knob at max.]
M-AUDIO SP-2
M-AUDIO EX-P [mode: other, knob set low]
Roland DP-10 [Switch]
Yamaha FC3A
Yamaha FC4A
Yamaha FC7

Wobei z.B. das Yamaha FC4A keinen TRS Stecker hat... Hier ist das FC3A (half pedalling) sicher besser geeignet.
 
In Ergaenzung zu Bernies post:
Laut Expressive E (online manual) sollen folgende Pedale problemlos mit dem Osmose funktionieren:

Clavia Nord Single Sustain
Dunlop Volume X Mini
Lead Foot LFD-2
Moog EP-3 [mode: other, knob at max.]
M-AUDIO SP-2
M-AUDIO EX-P [mode: other, knob set low]
Roland DP-10 [Switch]
Yamaha FC3A
Yamaha FC4A
Yamaha FC7

Wobei z.B. das Yamaha FC4A keinen TRS Stecker hat... Hier ist das FC3A (half pedalling) sicher besser geeignet.
Das Moog EP-3 hab ich mehrfach für Voyager usw. hier, das war allerdings nicht so dolle am Continuum, daher hab ich mir trotzdem die Yamahas gekauft.
Die Pedale FC3A und FC7 funktionieren perfekt, sind mechanisch solide und sehr gefühlvoll zu bedienen.
 

Anhänge

  • Update File2 1009 Continuum.txt
    38,2 KB · Aufrufe: 5
  • Update File2 1009 ContinuuMini.txt
    34,7 KB · Aufrufe: 5
  • Update File2 1009 EaganMatrixModule.txt
    37,8 KB · Aufrufe: 6
  • Update File2 1009 Osmose.txt
    26,3 KB · Aufrufe: 7
Auweia...

1702586264452.png

Das geht ja schon mal gut los.

Also man benötigt Max (oder man hat Ableton inklusive Max for Live). Das musste ich erstmal kapieren. Der Editor wird auch kurz angezeigt, stürzt dann aber ohne jeden weiteren Kommentar ab. Ursache wird wohl Fehler 7 sein.

Mal schauen wie das weitergeht...
 
cant open midi device ist ein eher seltener fehler und du solltest mal checken, ob das gerät von anderen host programmen aus gefunden werden kann.

was passiert denn, wenn du "midi setup" in der menuzeile öffnest?
 
Ich habe mich mal an die Anleitung von Haken bis zum Löschen von MidiPorts.txt gehalten. Vorher habe ich mal alles andere was am Rechner hing entfernt. MIDI-OX kann Osmose MIDI empfangen und senden.

Ebenso wie Ableton:
1702588300628.png

Eingestellt ist der Osmose auch im Haken Editor:

1702588413866.png

Output Port blinkt, Input Port blinkt auch wenn ich am Osmose eine Taste drücke. Osmose Port 2 blinkt nur Output aber nicht Input.

Jetzt bin ich ein wenig ratlos. Mit MIDI hatte ich noch nie Probleme.

wenn du "midi setup" in der menuzeile öffnest
Was meinst du damit?
 
alles klar, also woanders isses schon mal da.

Was meinst du damit?

in der max runtime. falls der menueintrag in der windows version in diesem speziellen patch nicht absichltich ausgeblendet wurde, hat jede max runtime (und auch jedes max programm) diverse voreinstellungsgeschichten, die immer gleich aussehen.
 
Da war jetzt nichts in der Richtung. Aber dann werde ich das mal checken bevor ich den Haken Editor starte. Mal sehen was das bringt.
 
Bringt alles nichts. In Ableton funktioniert alles, im Max-Haken Editor nicht so viel. Schade schade. Ich habe mich darauf gefreut ein wenig in der Matrix zu stöbern. Jetzt bin ich wohl erstmal auf die Presets angewiesen. Wobei da viele coole Sachen dabei sind. Wird schon irgendwie gehen.

Wenn man schnell ist kann man kurz das Fenster sehen und screenshoten bevor es dann größtenteils geleert wird.

1702647364093.png

Die Anweisung bringt aber auch nichts. Ich denke, dass ich Haken mal anschreiben werden.
 
Bringt alles nichts. In Ableton funktioniert alles, im Max-Haken Editor nicht so viel. Schade schade. Ich habe mich darauf gefreut ein wenig in der Matrix zu stöbern. Jetzt bin ich wohl erstmal auf die Presets angewiesen. Wobei da viele coole Sachen dabei sind. Wird schon irgendwie gehen.

Wenn man schnell ist kann man kurz das Fenster sehen und screenshoten bevor es dann größtenteils geleert wird.

Anhang anzeigen 197493

Die Anweisung bringt aber auch nichts. Ich denke, dass ich Haken mal anschreiben werden.
Man muss erstmal dahinter steigen, aber es muss jeweils Osmose (Port 2) für Input und Output ausgewählt werden, dann funktioniert es (zu sehen das die Verbindung blau wird).

Die normalen einser Ports sind für normales Midi bzw MPE (je nach einstellung). Die 2er Ports für Haken Audios MPE+.

Achso und in Osmose muss noch unter Global Settings -> midi i/o -> haken usb mode aktiviert sein. Dadurch kann es dann aber sein, dass wenn man in der DAW nicht den einzelnen in port anwählt die noten doppelt gespielt werden. Da muss man ein bisschen aufpassen.

Und beim experimentieren in der eagan Matrix lieber die Lautstärke runter regeln. Ich hatte auch schon des öfteren, das wenn man was falsch patched es kurz ploppt und dann gar kein sound mehr kommt. dann muss man noch mal osmose aus und nochmal anschalten und eagan matrix neu starten 🙈
 
Zuletzt bearbeitet:
Die 2er Ports für Haken Audios MPE+
Die 2er-Ports habe ich auch schon getestet. Ich teste es aber auch nochmals:

1702672005662.png

Bleibt rot. Auch nach einem Neustart von Max, EaganMatrix und Osmose. Interessant ist ja, dass das Gerät zumindest mal gefunden und auch irgendwie ausgewertet werden kann. Aber das war's dann auch.

Schade, schade...
 
Die 2er-Ports habe ich auch schon getestet. Ich teste es aber auch nochmals:

Anhang anzeigen 197564

Bleibt rot. Auch nach einem Neustart von Max, EaganMatrix und Osmose. Interessant ist ja, dass das Gerät zumindest mal gefunden und auch irgendwie ausgewertet werden kann. Aber das war's dann auch.

Schade, schade...

Hattest du auf dem Osmose muss unter Global Settings -> midi i/o -> haken usb mode aktiviert? (Dadurch kann es dann aber sein, dass wenn man in der DAW nicht den einzelnen in port anwählt die noten doppelt gespielt werden. Da muss man ein bisschen aufpassen.)
 
+Hattest du das aktuelle Firmware Update schon installiert. Ich glaube, das war für die Eagan Matrix notwendig (kann mich aber auch irren 🙈)
 
Um ganz genau zu sein: "haken usb mode" muss auf "note & matrix" eingestellt werden.

Falls mal noch jemand über dieses Problem stolpern sollte. Ausgerechnet im midi-Menü war ich noch nicht.
 
Das ist schon alles etwas sperrig. Auch wenn ich das Konzept der Eaganmatrix gar nicht so schlecht finde. Die Verwaltung der MPE Verhaltensweisen ist schon klug gelöst. Es ist zwar ein wenig mathematisch, aber die Grundrechenarten reichen ja eigentlich.

Aus ergonomischer Sicht ist der Matrix-Editor für mich allerdings eine echte Katastrophe. Was ich z. B. immer noch nicht herausfinden konnte ist, wie ich einen Patch dauerhaft auf den Osmose schiebe. Wahrscheinlich ist das irgendwo im Handbuch oder im Preset Cook Book kurz erwähnt. Das GUI hilft mir da aber nicht. Ich kann per Drag&Drop einen vorher auf die Festplatte gespeicherten Patch in einen Speicherplatz legen:

1702998696014.png

Was ich übrigens den Short Cuts entnommen habe. Im Handbuch ist dazu nichts zu finden.

Jetzt erwarte ich eigentlich, dass mein Patch auf dem Osmose auf Platz 1 der User-Patches zur Verfügung steht.

3. Exploring the EaganMatrix
[...]
When you work on a User Preset of your own, you should not only store it as a User Preset inside the Continuum, but
also use “Save” to store it to your computer’s file system. When you use “Save”, you will have the opportunity to choose
a name for your preset. You can also store the current preset to a User Preset position.

8.6. Save your Work
Your EaganMatrix designs can be saved to Preset files and opened at a later time (see the Open and Save topic in the
Continuum User Guide). When you save your Preset, you will have the opportunity to name it. Save your work often and
remember to back up your computer’s file system

Ähh ja. Das war's zum Thema im Handbuch. Stimmt nicht ganz. Es gibt noch zwei weitere Einträge die aber noch nichtssagender sind. Und wenn ich meinen Osmose ausschalte ist alles weg. Oder auch nur mal einen anderen Speicherplatz anklicke.

Ah ok. Ich muss den Patch anscheinend nach jedem Speichern auf Disk in den User-Slot schieben. Und keine Ahnung wie ich zum Beispiel Character und Category angeben kann obwohl mir das auf dem Osmose auch hier angeboten wird.

Jetzt verstehe ich auch warum es nur so wenige Patches auf Patch Storage gibt. ;-) Das System ist einfach ziemlich unzugänglich.

Wie ist da euer Workflow? Mache ich was falsch? Habe ich vielleicht einfach nur Tomaten auf den Ohren?
 
Das ist schon alles etwas sperrig. Auch wenn ich das Konzept der Eaganmatrix gar nicht so schlecht finde. Die Verwaltung der MPE Verhaltensweisen ist schon klug gelöst. Es ist zwar ein wenig mathematisch, aber die Grundrechenarten reichen ja eigentlich.

Aus ergonomischer Sicht ist der Matrix-Editor für mich allerdings eine echte Katastrophe. Was ich z. B. immer noch nicht herausfinden konnte ist, wie ich einen Patch dauerhaft auf den Osmose schiebe. Wahrscheinlich ist das irgendwo im Handbuch oder im Preset Cook Book kurz erwähnt. Das GUI hilft mir da aber nicht. Ich kann per Drag&Drop einen vorher auf die Festplatte gespeicherten Patch in einen Speicherplatz legen:

Anhang anzeigen 198040

Was ich übrigens den Short Cuts entnommen habe. Im Handbuch ist dazu nichts zu finden.

Jetzt erwarte ich eigentlich, dass mein Patch auf dem Osmose auf Platz 1 der User-Patches zur Verfügung steht.

3. Exploring the EaganMatrix
[...]
When you work on a User Preset of your own, you should not only store it as a User Preset inside the Continuum, but
also use “Save” to store it to your computer’s file system. When you use “Save”, you will have the opportunity to choose
a name for your preset. You can also store the current preset to a User Preset position.

8.6. Save your Work
Your EaganMatrix designs can be saved to Preset files and opened at a later time (see the Open and Save topic in the
Continuum User Guide). When you save your Preset, you will have the opportunity to name it. Save your work often and
remember to back up your computer’s file system

Ähh ja. Das war's zum Thema im Handbuch. Stimmt nicht ganz. Es gibt noch zwei weitere Einträge die aber noch nichtssagender sind. Und wenn ich meinen Osmose ausschalte ist alles weg. Oder auch nur mal einen anderen Speicherplatz anklicke.

Ah ok. Ich muss den Patch anscheinend nach jedem Speichern auf Disk in den User-Slot schieben. Und keine Ahnung wie ich zum Beispiel Character und Category angeben kann obwohl mir das auf dem Osmose auch hier angeboten wird.

Jetzt verstehe ich auch warum es nur so wenige Patches auf Patch Storage gibt. ;-) Das System ist einfach ziemlich unzugänglich.

Wie ist da euer Workflow? Mache ich was falsch? Habe ich vielleicht einfach nur Tomaten auf den Ohren?
Ich habe so den Eindruck, dass die EaganMatrix noch nicht so 100% auf Osmose angepasst ist. Aus der EaganMatirx ins Gerät speichern habe ich auch noch nicht gefunden und ich speichere momentan einfach am Gerät in den User-Bereich, wenn ich was gemacht habe. Danach erscheint das Preset dann auch widerum bei diesen 16 Slots oben. Ansonsten bin ich ganz Deiner Meinung - intuitiv ist echt anders. Oft erkennt man nicht mal, dass sich hinter irgendeinem Text noch ein Auswahl-Menu befindet. Ich finde übrigens die helle Oberfläche angenehmer - rot auf dunkelgrau liest sich eher unangenehm.

Ein guter Rat ist, immer den Lautstärke-Regler griffbereit zu haben ;-) (bei Fehl-Patches die dann irgendeinen Burst-Ton erzeugen)
Insgesamt bin ich aber noch nicht sonderlich weit gekommen, habe aber auch so viel Spaß an dem Teil 👍
 
Zuletzt bearbeitet:


Neueste Beiträge

News

Zurück
Oben