Latenz mit Emagic AMT8

Hallo

Ich habe 2 AMT 8 und ein Unitor8 zusammengehängt. Funktioniert eigentlich problemlos - ich habe 24 Midi Ports. Das erste AMT8 hängt mit kurzem USB Kabel am Mac. Die beiden anderen hängen dann aber an einem doch etwas längerem RS Kabel. Könnte das der Grund sein?
 

vogel

Lebensform, fortgeschritten
Wo meinst du denn die Latenz zu haben? Schon am ersten Gerät oder erst am dritten?
Latenz von DAW zu AMT/Unitor oder auch Latenzen der AMT/Unitor untereinander?

Ich hab zig Jahre bis zu 4 AMT/Unitors gestackt und hatte keine spürbaren Latenzen....
 
Also wenn ich über logic 10.4.1 spiele und "Port ALLE" anwähle, dann ich habe ich eine spürbare Latenz - auf jedem Interface. Wenn ich dort aber nur einen Port anwähle - dann nicht. Spiele ich aber ohne Logic, dann habe ich keine Latenz - auch wenn ich über alle Ports gehe.

Die Latenz die ich oben angesprochen habe, war nach einem Reset des ersten AMT8 wieder weg. Nur wenn ich über Logic spiele (External Midi) dann ist sie bei "Alle Ports" da.
 

vogel

Lebensform, fortgeschritten
OK, wichtige Zusatzinfo.
Ich kann da nur orakeln, dass Logic ggf. auf 48 losballert, und das wird dann halt seriell gemacht und dann kann es an den hinteren Ports schon zu spürbaren Latenzen kommen. Ich hab irgendwas von 2ms pro Kanal im Hinterkopf. Ich hab selbst noch nie alle Ports für eine Spur ausgewählt (warum eigentlich auch?).

Da können dir aber Spezis wie @microbug sicher mehr zu sagen.
 
@vogel
Ich habe auch daran gedacht, dass Midi ja nur seriell raus gibt.
Aber nachdem du geschrieben hast, dass du mit 4 AMT kein Problem hast, dachte ich, das kann es nicht sein.
 

microbug

*****
@organisch ich fürchte, Du hast da etwas Grundlegendes nicht verstanden.

Zuerst mal: warum benutzt Du die parallel? Das ist Käse. Wenn, dann gehören alle zusammen verkettet, wie im Handbuch beschrieben, dann werden sie auch als eine Einheit betrachtet. Einschaltreihenfolge betrachten, der Master wird zuletzt geschaltet, das ist der, der per USB am Rechner hängt.

Die Einstellung "alle" ist im Übrigen Unsinn, wenn man so viele Interfaces zusammengeschaltet hat, so benutzt man die nicht. Gezielten Port auswählen, fertig.
 

microbug

*****
@vogel
Ich habe auch daran gedacht, dass Midi ja nur seriell raus gibt.
Aber nachdem du geschrieben hast, dass du mit 4 AMT kein Problem hast, dachte ich, das kann es nicht sein.
Die Emagics benutzen Timestamping per Hardware, AMT genannt. Die Daten werden mit einem Zeitstempel vorher übertragen und im Interface dann zum richtigen Zeitpunkt ausgegeben.
Ohne diese Technik würden Interfaces mit so vielen Ports nicht gescheit funktionieren.
 

xtortion

|||||||
Ich hatte diese Probleme auch immer wenn die Teile über USB angebunden waren. Hatte dann extra nochmal eine serielle (?)Schnittstellenkarte in den PC geschraubt. Damit war das Problem dann erledigt. Versuche mal das erste Gerät mit der Mac Schnittstelle zu betreiben.
 
@organisch ich fürchte, Du hast da etwas Grundlegendes nicht verstanden.

Zuerst mal: warum benutzt Du die parallel? Das ist Käse. Wenn, dann gehören alle zusammen verkettet, wie im Handbuch beschrieben, dann werden sie auch als eine Einheit betrachtet. Einschaltreihenfolge betrachten, der Master wird zuletzt geschaltet, das ist der, der per USB am Rechner hängt.
Ich hab sie schon hintereinander gehängt. Das erste via USB und dann mit diesen RS 422 und dann RS 232. Sie erscheinen auch als eine Einheit.

Ich habe nur das Gefühl - wenn ich eines meiner Soundmodule direkt ans Keyboard hänge - dann hab ich weniger Latenz.

Ich habe das weiter oben event. nicht richtig beschrieben.

Die Latenz die unbrauchbar wäre habe ich nur, wenn ich in Logic "Alle Ports" anwähle.
Anscheinend ist das einfach so - lässt sich aber ja umgehen.

Aber:
Mein Rack mit den Soundmodulen steht etwas weiter weg - das RS 422 Kabel ist sicher 5 Meter lang.

Könnte es da Probleme geben oder ist das durch das AMT Protokoll nicht möglich?
 

microbug

*****
RS423 ist wie MIDI und RS232 eine Stromschleifenschnittstelle, die problemlos mehr als 5m Kabel abkönnen, und das haben beide Schnittstellen über Jahrzehnte hinweg auch bewiesen.

Mit dem Protokoll hat das nichts zu tun.

Ein Soundmodul direkt ans Keyboard hat keinerlei Latenz, außer die Firmware ist mies, was bei manchen Rolands der Fall wäre.

Die größte Verzögerung entsteht, wenn Du Deine Soundmodule über die DAW ansteuerst, gerade bei USB macht man sowas nicht, weil die Daten dann zweimal durch due USB Hölle müssen.
Wenn Du das Ganze Standalone nutzt und mit dem Unitor8 Control Panel Routings einstellst (Patch Mode), gibt es keinerlei Verzögerungen.

Und nochmal: "Alle Ports" ist Blödsinn. Nicht machen.
 

xtortion

|||||||
Zuletzt bearbeitet:

microbug

*****
Doch doch, ich habe einen Imac von 2017 aber ich dachte es gäbe sowas evtl. für die Thunderbolt Schnittstelle
Es gibt den zweifach seriell Adapter Keyspan USA-28x, liegt hier noch rum, aber der geht mit den Interfaces nicht, weil der aktuelle Treiber offenbar nur noch USB unterstützt.

Vergiß das also.
 
RS423 ist wie MIDI und RS232 eine Stromschleifenschnittstelle, die problemlos mehr als 5m Kabel abkönnen, und das haben beide Schnittstellen über Jahrzehnte hinweg auch bewiesen.

Die größte Verzögerung entsteht, wenn Du Deine Soundmodule über die DAW ansteuerst, gerade bei USB macht man sowas nicht, weil die Daten dann zweimal durch due USB Hölle müssen.
Wenn Du das Ganze Standalone nutzt und mit dem Unitor8 Control Panel Routings einstellst (Patch Mode), gibt es keinerlei Verzögerungen.
Nachdem die erste Leitung nach dem USB AMT ja RS423 ist und RS423 wie Midi "ist", kann also ein längeres Kabel schon Latenzen machen. Tut es ja bei Midi auch.
Allerdings funktioniert die AMT/Unitor Kette aber - laut Anleitung - nur so.
Gibt es hier event. eine andere Lösung?

Stand Alone nutze ich das ganz nur zum Jammen für mich. Großteils werden die Soundmodule schon über die DAW angesprochen.
 

Summa

hate is always foolish…and love, is always wise...
MIDI hat 'ne feste Geschwindigkeit, entweder es funktioniert oder funktioniert nicht, kann sich also nicht an die Qualität der Kabel anpassen und einfach langsamer werden. Ein Timelord würde vielleicht die Driftgeschwindigkeit der Elektronen bemerken ;-)
 

microbug

*****
Nachdem die erste Leitung nach dem USB AMT ja RS423 ist und RS423 wie Midi "ist", kann also ein längeres Kabel schon Latenzen machen. Tut es ja bei Midi auch.
Tut es definitiv nicht. Stromschleifenschnittstellen sind selbst bei längeren Kabeln unempfindlich, da würden im Zweifel eher Mülldaten rauskommen als Verzögerungen entstehen.

Die Kabellänge ist offiziell auf max. 15m für zuverlässige Funktion spezifiziert.

Die analoge Telefonleitung funktioniert übrigens nach dem gleichen Prinzip, und das über noch längere Strecken, und das seit sehr langer Zeit.


Großteils werden die Soundmodule schon über die DAW angesprochen.
Und genau DA entstehen die Verzögerungen, nicht durch das Kabel.
Die Emagics sind USB1.1
Der Weg geht über den USB Stack zum Treiber und durch diverse Hintergrunddienste in die DAW und den gleichen Weg wieder zurück, und USB ist nicht echtzeitfähig, zB werden einzelne Bytes nicht wie bei MIDI sofort gesendet, sondern erst, wenn der Sendeblock voll ist.

Beim Atari oder Mac/PC mit seriellen Schnittstellen konnte man sowas noch machen, bei USB Interfaces sollte man das unterlassen.

Die Alternative wäre, die Emagics im Patchmode zu benutzen, wie ich schon schrieb, oder eine echte MIDI Patchbay bzw mehrere anzuschaffen.

Meist braucht man ja nur die Ports und nicht alle Kanäle.
 
Zuletzt bearbeitet:

swissdoc

back on duty
MIDI over USB ist ja ganz nett, aber eigentlich die Vorstufe zur Hölle. MIDI an sich ist ja schon recht doof, aber MIDI over USB ist eben so richtig doof, in allen denkbaren Dimensionen.

Was denke ich da sehnsüchtig an so Sachen wie Atari ST, Commodore C64 oder gar MIDI via Gameport auf einer Soundblaster SB16 zurück. Lustig war auch das auf Lochraster-ISA-Karte mit vielen Litzen hinten drauf selber gebaute MIDI Interface nach einer Idee in der Byte. Hach, da war die Welt noch schön und Magazine haben so richtig sinnvolle Artikel publiziert.

Mit diesem Interface habe ich damals mal so richtig standard-konform den Microwave bei einem Full Dump in die Knie gezwungen. Das ist mir sonst mit nichts anderem gelungen.
 
Tut es definitiv nicht. Stromschleifenschnittstellen sind selbst bei längeren Kabeln unempfindlich, da würden im Zweifel eher Mülldaten rauskommen als Verzögerungen entstehen.


Und genau DA entstehen die Verzögerungen, nicht durch das Kabel.
Die Emagics sind USB1.1
Der Weg geht über den USB Stack zum Treiber und durch diverse Hintergrunddienste in die DAW und den gleichen Weg wieder zurück, und USB ist nicht echtzeitfähig, zB werden einzelne Bytes nicht wie bei MIDI sofort gesendet, sondern erst, wenn der Sendeblock voll ist.

Beim Atari oder Mac/PC mit seriellen Schnittstellen konnte man sowas noch machen, bei USB Interfaces sollte man das unterlassen.

Die Alternative wäre, die Emagics im Patchmode zu benutzen, wie ich schon schrieb, oder eine echte MIDI Patchbay bzw mehrere anzuschaffen.

Meist braucht man ja nur die Ports und nicht alle Kanäle.
Ich habe 22 Module und die möchte ich mit 22 Ports von meinem Mac bzw. auch von einem Keyboard ohne Mac ansprechen können.

Was bestelle ich mir also damit ich glücklich bin?
 

microbug

*****
Ich habe 22 Module und die möchte ich mit 22 Ports von meinem Mac bzw. auch von einem Keyboard ohne Mac ansprechen können.

Was bestelle ich mir also damit ich glücklich bin?
Das ist nicht so ganz einfach. Meine MIDITemps sind 8x8, da bräuchtest Du aber 3 davon und eine Zentrale zum Verbinden, zB das MIO4. Ist vielleicht aber für Deine Zwecke Overkill, wenn nur eine einspielquelle vorhanden ist.

Alternativ mach großen MIDI Patchbays wie Waldorf MIDIBay oder KMX16 schauen, es gibt auch die Akai ME-80P, die ist 8x10, wird nur selten angeboten. Davon zwei Stück und mit einem MIO4 kombiniert ginge auch.

Du könntest zwei MIO10 und ein MIO4 nehmen und die kaskadieren. Die können auch routen, aber halt nur ein festes Setup, welches man am Rechner erstellen muß.
Kaskadieren geht über USB Host oder Netzwerk, Anschließen kann man die übrigens auch über Netzwerk an den Rechner, dürfte wahrscheinlich sogar besser als USB sein, jedenfalls hatte ich hier meine beiden räumlich getrennten Setups schon via Netzwerk miteinander verbunden und Sequenzen zum jeweils anderen Set geschickt, ohne daß es da hörbare Verzögerungen gegeben hätte. Zum Einstellen nimmt man iConfig, fürs Netzwerken braucht man allerdings die neue Software Auracle, siehe Thread zu den Iconnectivity Interfaces.
Über USB kaskadierte MIOs kann man seit der Firmware 2.0 leider immer noch nicht kaskadiert ansprechen, vorher ging das, und dieser Bug ist schon länger gemeldet. Hat man die im Netzwerk hängen, werden sie von der Software problemlos gefunden.
Den RTP MIDI Treiber dafür gibts sowohl vom Hersteller selbst als auch von Tobias Erichsen.

Du kannst ja mal ein MIO4 holen und schauen, ob es das ist, was Du möchtest.
 

Summa

hate is always foolish…and love, is always wise...
Das hängt aber nicht mit der Länge des Kabels zusammen, die Latenz hast du im Klangerzeuger.
 
Das ist nicht so ganz einfach. Meine MIDITemps sind 8x8, da bräuchtest Du aber 3 davon und eine Zentrale zum Verbinden, zB das MIO4. Ist vielleicht aber für Deine Zwecke Overkill, wenn nur eine einspielquelle vorhanden ist.

Alternativ mach großen MIDI Patchbays wie Waldorf MIDIBay oder KMX16 schauen, es gibt auch die Akai ME-80P, die ist 8x10, wird nur selten angeboten. Davon zwei Stück und mit einem MIO4 kombiniert ginge auch.

Du könntest zwei MIO10 und ein MIO4 nehmen und die kaskadieren. Die können auch routen, aber halt nur ein festes Setup, welches man am Rechner erstellen muß.
Kaskadieren geht über USB Host oder Netzwerk, Anschließen kann man die übrigens auch über Netzwerk an den Rechner, dürfte wahrscheinlich sogar besser als USB sein, jedenfalls hatte ich hier meine beiden räumlich getrennten Setups schon via Netzwerk miteinander verbunden und Sequenzen zum jeweils anderen Set geschickt, ohne daß es da hörbare Verzögerungen gegeben hätte. Zum Einstellen nimmt man iConfig, fürs Netzwerken braucht man allerdings die neue Software Auracle, siehe Thread zu den Iconnectivity Interfaces.
Über USB kaskadierte MIOs kann man seit der Firmware 2.0 leider immer noch nicht kaskadiert ansprechen, vorher ging das, und dieser Bug ist schon länger gemeldet. Hat man die im Netzwerk hängen, werden sie von der Software problemlos gefunden.
Den RTP MIDI Treiber dafür gibts sowohl vom Hersteller selbst als auch von Tobias Erichsen.

Du kannst ja mal ein MIO4 holen und schauen, ob es das ist, was Du möchtest.
Miditemp gibt es ja auch nicht mehr oder?

Das MIO4 scheint es auch nicht mehr zu geben. Nur 10 oder 2.

Ob es dann wirklich tigther ist oder nicht werde ich wohl nur mit einem Test und viel Zeit rausfinden können.


Als ich mir die Emagics zugelegt habe dachte ich, hier ein auch noch in Jahren zuverlässiges Produkt zu haben.
 

vogel

Lebensform, fortgeschritten
Als ich mir die Emagics zugelegt habe dachte ich, hier ein auch noch in Jahren zuverlässiges Produkt zu haben.
Hast du auch.
Zumindest solange Apple noch den Treiber pflegt.
Ich fahre hier eine Mischung aus AMT8 + MIDITemps, und das wird wohl noch ein paar Jährchen halten, auch wenn es die Geräte schon lange nicht mehr zu kaufen gibt.
Du kannst mit deinem Unitor und den AMT8 auch ohne Neuinvestition glücklich werden; baller halt nur nicht alles über alle Ports aus der DAW raus.
 

swissdoc

back on duty
Mir fällt gerade das hier ein:

Dumm halt die Sache mit Apple und Emagic:
- Logic nur auf Mac
- SoundDiver ist tot
- Emagic Treiber nur noch für Mac (und Linux - angeblich)
 


Neueste Beiträge

News

Oben