MIDI/DAW-Setup???

N

noisegate

.
Hallo alle zusammen,

ich schlage mich seit einigen Tagen mit dem gleichen Problem herum und habe es hier schon mit einem Eintrag versucht. Da ich das Problem trotzdem noch nicht lösen konnte, ich mittlerweile meine Versuche von Reason auf Logic Pro erweitert habe und ich das Problem möglicherweise eingrenzen kann, versuche ich es erneut:

Ich möchte einen alten Roland Alpha Juno 2 Synthesizer (ohne USB) und einen Behringer Crave (mit USB) aus einer der beiden oben genannten DAWs mit einem USB-/Midi Keyboard steuern. Ziel ist am Ende auch beide Synthesizer parallel über einprogrammierte MIDI-Signale aus den DAWs anspielen zu können. In erster Linie geht es hier aber um den Roland.

Mein Hardware-Setup habe ich als Grafik unten angehängt.

In den DAWs lege ich eine MIDI-Spur an, die ich dem Interface zuordne. Dazu eine Audiospur, der ich die beiden Stereo Inputs vom Synthesizer zuordne, und die ich auf "Live-Monitoring" stelle.

Bevor ich anfange den Fehler im Detail zu suchen: Ist das die grundsätzliche der richtige Aufbau und die richtige Konfiguration?

Nun zum "Trouble-Shooting", bzw. meinen Tests (alles gilt für beide DAWs, Logic und Reason):
  • Crave, USB-Keyboard und Interface werden erkannt, ich habe aber keine Ahnung über diverse MIDI Settings in den Einstellungen der Programme
  • Treiber für das Interface ist installiert
  • Wenn ich das USB-Keyboard anspiele, erkennt die MIDI-Spur zwar einen Anschlag, aber es ertönt kein Sound
  • Stecke ich das USB-Keyboard über (5-Pin-) MIDI in den Roland, kann ich ihn anspielen (ich möchte aber Töne in den DAWs programmieren und bearbeiten können)
  • Spiele ich den Roland über die eigenen Tasten an, höre ich ebenfalls Sound über die Audiospur
Wo ist der Fehler?? :cry:
Über eure Hilfe wäre ich sehr dankbar!

Liebe Grüße
Nick

67144-bf8a769f176885e9aa7d5a07e4103fec.jpg
 
Cosso

Cosso

||
Könnte mich jetzt irren- aber weswegen machst du den Umweg via deiner DAW über das Focusrite ?
Wenn es dir primär um den Roland geht, würde ich doch "einfach" eine Direktverbindung (USB2Midi-Adapter) von deinem Mac aus in den Alpha gehen (er soll ja, wenn ich es richtig verstanden habe, auch nur empfangen ?)
 
N

noisegate

.
...weil ich so einen Adapter nicht habe.
Aber ist das Interface nicht genau das? Ich schließe es per USB an den Rechner an und habe dann MIDI in und out?
 
Tom Noise

Tom Noise

|
In den DAWs lege ich eine MIDI-Spur an, die ich dem Interface zuordne. Dazu eine Audiospur, der ich die beiden Stereo Inputs vom Synthesizer zuordne, und die ich auf "Live-Monitoring" stelle.

Bevor ich anfange den Fehler im Detail zu suchen: Ist das die grundsätzliche der richtige Aufbau und die richtige Konfiguration?
Ja, grundsätzlich ist das so korrekt. Alternativ könntest in Logic auch eine Audio Instrument Spur anlegen und in diese das External Instrument Plugin laden (unter "Utility") und innerhalb des Plugins Midi Output und Audio Input zuweisen.

Wenn ich das USB-Keyboard anspiele, erkennt die MIDI-Spur zwar einen Anschlag, aber es ertönt kein Sound
Okay, wenn Du den Alpha Juno per Kopfhörer abhörst, ertönt denn dort was? Stimmen die Midi Kanal Settings des Juno mit denen der Midispur im Sequencer überein?
 
Cosso

Cosso

||
Ich glaube du hattest- oder hast schon einen Thread zu deiner Problematik mit der Ansteuerung (mit Reason?) offen ?
Ich fürchte, ich kann da leider keine explizite Antwort auf genau jene spezifische Problematik geben und würde an dieser Stelle Pi*Daumen sagen, dass es im wesentlichen ein Konfigurationsproblem wäre, wenn es nicht klappt (in der DAW/Midi Thru etc).
Auch ich habe ja noch einiges an V-Gear in meinem Setup, was ich aber, wenn ich es nicht Live via Audiorecording zu/einspiele und mal wirklich Midi-Kontrolle brauche (Midi-Receive), einfach mit einem simplen PC/Midi-Converter (In/Out/Thru) löse (ist imgrunde nur ein Kabel mit USB- auf 5PolBuchse, weil ich dann direkt vom PC im Keyboard drin bin.
Es hilft dir vielleicht gerade an dieser Stelle nicht wirklich weiter- und ja, eigentlich sollte das Focusrite nach meiner Vorstellung diese Funktion auch erfüllen können (wie gesagt, mal schauen was die DAW an Kofinguration hergibt), aber bei V-Gear würde ich zumeist zuimmerst versuchen, direkt ohne Umwege über andere Audio-Units, ins Keyboard (sofern es nur ein einziges ist) über ein etwaiges USB2Midi-Cable zu gehen (kostet um die 15 Euro). In der DAW auf dem Track nur den Midi-Ausgang /Midi-Gerät eingestellt, fix.
Ich hoffe, es ist vielleicht ein kleiner Anhaltspunkt für dich dabei.
 
GeoTeknique

GeoTeknique

|||||
Ja, sieht nach einem Konfigurationsproblem aus.
Hab hier Presonus Studio One, da ist es so dass ein Instrument wie der Juno gegenüber dem System als zwei Geräte auftaucht. Ein Gerät ist zum Abspielen von Noten und Aufzeichnen von Reglerbewegungen gedacht, um jedoch Noten in den PC zu kriegen, muss das Gerät zusätzlich als 'Keyboard' angegeben werden. Mit diesem Keyboard kann ich alle Instrumente aus der DAW heraus steuern - auch zeitgleich. Ich kann auch zwischen mehreren Keyboards on the fly wechseln.
Das Problem liegt wohl darin, dass der PC nicht weiß wo er sein Notensignal hinschicken soll. In der Konfiguration der DAW sollte es ein MIDI-Setup geben in dem du die zur Verfügung stehenden MIDI-IN und MIDI-OUT-Leitungen angibst, an der der Synthesizer hängt. Du musst der DAW also mitteilen, schicke das Notensignal an DEN Midi-Port. Helfen tut da immer eine DAW in der man den MIDI-Datenstrom auch textlich verfolgen kann.

MIDI und Audio über ein und das selbe USB-Gerät ist eh nicht optimal. Drum würde ich, je nachdem wie deine längerfristigen Ambitionen aussehen, früher oder später zu einem MIDI-Interface raten, das sich NUR mit MIDI beschäftigt.
 
N

noisegate

.
Liebe Leute,

bisher schon mal ein Danke für eure Hilfe!

Ja, grundsätzlich ist das so korrekt. Alternativ könntest in Logic auch eine Audio Instrument Spur anlegen und in diese das External Instrument Plugin laden (unter "Utility") und innerhalb des Plugins Midi Output und Audio Input zuweisen.
Das funktioniert! "Problem" hier: Der Roland lässt sich so bestens anspielen. Der "neue" Crave über USB ertönt doppelt. Ich muss die Lautstärke der Spur in Logic herunterdrehen und dann höre ich nur noch ein Signal. Lautstärke kann ich dann nur an dem Gerät selbst regeln. Bei dem Roland ist das nicht das Problem. Ich kann ihn anspielen und auch die Lautstärke über die Logic-Spur regeln. Kann das schon ein Hinweis sein?

In Reason verhält es sich quasi genau umgekehrt: Der Crave ist über die MIDI-Spur problemlos einspielbar, beim Roland erklingt nichts.

Okay, wenn Du den Alpha Juno per Kopfhörer abhörst, ertönt denn dort was? Stimmen die Midi Kanal Settings des Juno mit denen der Midispur im Sequencer überein?
Ja, Kopfhörer am Juno spuckt Sound aus! Das MIDI Signal aus Reason über das Interface kommt also an. Genauso kann ich den Juno über MIDI-Kabel ja auch mit dem USB-Keyboard ansteuern.


Ich habe das Gefühl ich stehe kurz davor, nur irgendwo ist ein Denkfehler, bzw. irgendwelche "Detaileinstellungen" sind mir nicht bekannt... :denk:
Ich wundere mich, dass meine Vorstellungen so kompliziert umzusetzen sind - ich möchte einen Synthesizer über MIDI aus einer DAW aus steuern und aufnehmen. Ich würde vermuten das ist eine "Standard-Anforderung"? Wenn ein USB-zu-MIDI-Kabel die Lösung ist, dann ist das natürlich sofort gekauft!
 
N

noisegate

.
Ja, sieht nach einem Konfigurationsproblem aus.
Hab hier Presonus Studio One, da ist es so dass ein Instrument wie der Juno gegenüber dem System als zwei Geräte auftaucht. Ein Gerät ist zum Abspielen von Noten und Aufzeichnen von Reglerbewegungen gedacht, um jedoch Noten in den PC zu kriegen, muss das Gerät zusätzlich als 'Keyboard' angegeben werden. Mit diesem Keyboard kann ich alle Instrumente aus der DAW heraus steuern - auch zeitgleich. Ich kann auch zwischen mehreren Keyboards on the fly wechseln.
Das Problem liegt wohl darin, dass der PC nicht weiß wo er sein Notensignal hinschicken soll. In der Konfiguration der DAW sollte es ein MIDI-Setup geben in dem du die zur Verfügung stehenden MIDI-IN und MIDI-OUT-Leitungen angibst, an der der Synthesizer hängt. Du musst der DAW also mitteilen, schicke das Notensignal an DEN Midi-Port. Helfen tut da immer eine DAW in der man den MIDI-Datenstrom auch textlich verfolgen kann.

MIDI und Audio über ein und das selbe USB-Gerät ist eh nicht optimal. Drum würde ich, je nachdem wie deine längerfristigen Ambitionen aussehen, früher oder später zu einem MIDI-Interface raten, das sich NUR mit MIDI beschäftigt.
Ich bin mir nicht sicher ob ich alles richtig verstanden habe...
Ich möchte den "alten" Roland ja nur als Soundquelle nutzen. Einspielen möchte ich über das zweite Keyboard, bzw. eben über MIDI-Signale aus der DAW (damit ich Noten auch händisch programmieren kann), das per USB am Rechner hängt. Der Roland kann so gesehen ja nur über "Umweg" in den Programmen auftauchen. Nämlich in Form meines Interfaces, wo er per MIDI angestöpselt ist.

Bei dem Setup, das ich am ersten Beitrag angehängt habe, tauchen der Behringer Crave Synthesizer, mein Focusrite Secarlett Interface und Das M-Audio Keyboard als externe Steuergeräte in den Einstellungen beider Programme auf.
 
Horn

Horn

|||||||||||
Weise dem Crave in der DAW einen anderen MIDI-Kanal zu als dem Juno (die Einstellungen an den Geräten selbst müssen dem ensprechen).

Deine Verkabelung ist richtig so, wie Du sie gemacht hast, alles andere musst Du in Logic konfigurieren.
 
Labsounds

Labsounds

|
Hi,

Da du sagtest du hörst den Synthie doppelt.

Ich hab das unter Logic am Anfang mit meinem Deepmind auch gehabt. Da lags aber an der Focusrite Software. Der entsprechende Eingang den ich für den Deepmind benutzt hab war direkt zum Ausgang geroutet. In Logic gibts ja die direct monitor Funktion, die ja normalerweise auch an ist für den jeweiligen Audiokanal der aufgenommen werden soll, ergo hört man den dann doppelt.
Ich weiß jetzt nicht welche Focusrite du hast, die kleinen haben für das direct monitoring nen Knopf vorne bzw einen Schalter oben rechts. Bei den großen Focusrite kann man in der Software die Sachen einstellen
 
 


News

Oben