Keystep Midi-Clock Probleme

Dieses Thema im Forum "Hardware Sequencer" wurde erstellt von Kolli64, 31. Mai 2017.

  1. Hi, ich habe mal ein neues Thema aufgemacht, da ich keine Antwort auf mein Problem gefunden habe...

    Neuerdings (?) gibt mein Keystep (fungiert als slave) das Midi-Clock-Signal nur über Midi weiter, wenn die Starttaste gedrückt wurde (über Sync wird es normal durchgeschliffen). Das ist sehr störend, denn angeschlossene Geräte sollten auch synchron laufen, wenn der Keystep gerade kein Arpeggio oder eine Sequenz erzeugt. Ja, Midi-Thru ist auf on.

    Ich finde keine Lösung, weiß jemand Rat?
     
  2. verstaerker

    verstaerker ||||||||||

    ich hab hier ein anderes Problem:

    und zwar wenn ich eine z.B. ein simple seq im Keystep auf 1 und 8 habe, jedes Mal wenn ich die Midi-Clock stoppe und wieder starte ist die Sequenz versetzt ..
    drücke ich zwischendurch noch Stop am Keystep, sitzt die Seq wieder richtig.
    Gibt es eine Einstellung die das automatisch richtig macht?
     
  3. verstaerker

    verstaerker ||||||||||

    hat niemand sonst das Problem?
     
  4. fanwander

    fanwander |||||||||||

    Vorbermerk: Ich hab keinen Keystep.

    Ich verstehe nicht ganz was Du beschreibst: ist tatsächlich die Programmierung von der 1 auf die 2 verschoben, wenn Du einzeln durch stepst, oder startet nur der Keystep um einen Schritt zu spät.

    Letzters könnte (muss aber nicht!) durchaus auch am Sender von Clock und Start/Stop-Befehl liegen, wenn das Timing der Befehle nicht koordiniert ist.
    Leider macht die MIDI-Spezifikation hier keine Vorschriften. Bei DIN-Sync hat Roland eindeutig vorgeschrieben, dass das Senden des Start-Befehls einen eventuell gleichzeitig laufen Clock abbrechen soll und der nächste Clock-Tick erst 9ms nach der Start-Flanke kommen darf.
     
  5. verstaerker

    verstaerker ||||||||||

    es scheint so als würde der Keystep , wenn ich stopp sende , die Sequence pausieren wo er gerade steht und bei einem erneuten Start Befehl nicht von vorn starten sondern dort weiterspielen wo er pausierte
    um das zu korrigieren bräuchte er einen Stop Befehl (ist ein bestimmter MidiCC oder MMC - wie ich den elegant sende , weiß ich noch nicht )

    und wer bitte hat sich das mit den DIP Schaltern zum umstellen der ClockQuelle ausgedacht ...
     
    Zuletzt bearbeitet: 4. Januar 2019
  6. verstaerker

    verstaerker ||||||||||

    nein, das ist es nciht, die Sequence fängt immer auf der 1 an .. aber irgendwie gibts einen Offset ... noch nicht klar woher der resultiert

    auf die eingestellten MidiCC für Start/Stop reagiert er auch nciht
     
    Zuletzt bearbeitet: 4. Januar 2019
  7. Niki

    Niki ||||||||

    also ich habe auch probleme mit der Synchronisation von meinem Keystep.

    1. Midisync:
    Digitakt ist mein master Clock. Vom Digitakt Out gehe ich mit dem midi kabel direkt in den Keystep IN. Von Keystep gehe ich direkt mit dem Gate/CV in die Mother32
    Wenn ich bei dem Digitakt auf Play drücke, dann geht der KeystepSeq zwar an aber nicht sofort, sondern irgendwann wann der Lust hat (1 bis 3 sec. Versatz)
    Das ganze läuft zwar stabil, aber komplett im offbeat.



    2. Sync In:
    Gleiches Setup wie oben nur der Keystep kriegt statt MidiIn, den Clock von der qMi2. Die Mother32 wird über gate/Cv direkt aus dem Keystep angesteuert.
    Zum Starten muss ich den Play am Keystep drücken. Die Sequence läuft zwar stabil aber davon abhängig wann ich die starte. Wenn ich bei 1,5 Play drücke dann läuft es halt offbeat.

    Jetzt ist die Frage:

    Wie kriege ich den Keystep dazu über midikabel im Takt mit dem Digitakt paralel zu starten bzw zu laufen, so das es mir syncron läuft?
     
  8. fairplay

    fairplay |||

    ...brute-force mit sowas:

    B1B46B3E-168D-4A7F-8560-05466DF6F39C.jpeg
     
    audiowerkstatt und Niki gefällt das.
  9. Niki

    Niki ||||||||

    Juhuuuu, vielen dank für den Tip. Die seite kannte ich noch gar nicht, scheinen aber echt hilfreiche dinge zu geben.

    "Mit dem audiowerkstatt midi-restarter v2 kannst Du Deinen MIDI-Slave ohne Neustart des MIDI-Masters synchronisiert starten und stoppen." DAs hört sich sehr gut und passend zu meinem Problem an.
     
  10. verstaerker

    verstaerker ||||||||||

    was sollte das helfen? er reagiert schon auf die stop&start commands der mainclock nicht richtig - oder macht das Teil was besonderes ?
     
  11. verstaerker

    verstaerker ||||||||||

    hier mal eine Darstellung des Problems
    Keystep_offset_AbletonLive_new.png
     
  12. verstaerker

    verstaerker ||||||||||

    naja ich hab das mal an Arturia reported ...vielleicht erkennen sie ja das Problem und Könnens fixen.
    Wenn wenigstens die Midi-CCs tun würden ... :evil:
     
  13. Niki

    Niki ||||||||

    Ich hatte das so verstanden, das das teil den Keystep erst dann startet wenn es denn clock 'fängt'. Dann zwar mit verspätung aber im takt. Oder wie funktioniert das genau @fairplay?
     
  14. fairplay

    fairplay |||

    ...bietet die Möglichkeit den Keystep getrennt einzustarten, bzw. bei laufender clock neu zu starten. Das Kistchen kennt (aus dem Kopf mindestens 3) unterschiedliche Modi des Stoppen und Startens - in der Anleitung ist ganz gut beschrieben, dass es Geräte/Synths/Sequencer usw. gibt, die bestimmte Zeit-abstände zwischen dem Stop- und dem Start-Signal benötigen, und das kann man damit realisieren...

    ...bei mir hat es die Trennung zwischen Stop und Start gebracht...
     
    Niki gefällt das.
  15. verstaerker

    verstaerker ||||||||||

    aus der Anleitung:
    genau daher kommt das Problem und weil der Keystep kein Stop erkennt wenn man stoppt (zumindest die Stop-kommandos meiner Multiclocks nicht)

    der Keystep nutzt MMC... keine Ahnung welches Gerät das nutzt, zumindest keines das ich habe
     
  16. verstaerker

    verstaerker ||||||||||

    ich hab mal die Anleitung des Audiowerkstatt-Teils studiert... also eigentlich sollte das gar nichts ändern, weil der Keystep eben diese MMC Befehle erwartet und der Midi-restarter ja auch nur Start/stop benutzt
    wenn der Keystep mal ge-offsettet ist, dürfte das pausieren und weiterspielen nicht wirklich helfen
     
  17. fairplay

    fairplay |||

    ...hmmm...bei mir setzt er auf die erste Position zurück und startet dann ein...ich kann es aber leider im Moment (die nächsten Tage) nicht nochmal ausprobieren...bin gespannt was Arturia sagt...
     
  18. fanwander

    fanwander |||||||||||

    Üblicherweise können DAWs MIDI Machine Control (zumindest Logic kanns, muss man aber extra aktivieren).
    Letztlich ist das aber ein riesen Scheiss; Arturia sollte dringlich einen Patch liefern, der auf Standard Realtime Messages Start/Stop/Continue umstellt.
     
    Niki, Audiohead und verstaerker gefällt das.
  19. verstaerker

    verstaerker ||||||||||

    das geht bei mir nicht. schickst du evtl solche MMC commands von einer DAW?
     
  20. verstaerker

    verstaerker ||||||||||

    ja sehe ich genauso ... optional zumindest

    so ist das für mich nicht sinnvoll benutzbar
     
  21. fairplay

    fairplay |||

    ...nicht bewusst (aus Ableton), nein - aber vielleicht habe ich das Problem bisher einfach noch nicht gehabt/bemerkt?!...
     
  22. Fr@nk

    Fr@nk ||

    Schau doch mal nach, ob Deine Firmware auf dem aktuellen Stand ist:

    V1.0.1.15

    Improvements

    • Factory reset implemented
    • When in external sync, pressing play from pause starts in the beat

    Bugfixes

    • Arpeggiator now properly plays when synchronized from 1 step (Gate)
    • Proper CV output when in Seq mode while the sequencer is paused
    • ...
     
  23. verstaerker

    verstaerker ||||||||||

    ich bin mir sicher die aktuelle firmware draufzuhaben ... hatte ich gleich als erstes nach dem auspacken geupdated

    der erwähnte fix "When in external sync, pressing play from pause starts in the beat" sollte aber eigentlich genau das machen was ich will.. aber es geht nicht
     
  24. Nimm mal die 1.0.0.5 statt der aktuellen ver.
     
  25. Fr@nk

    Fr@nk ||

    Das ist doch quatsch ... die 1.0.1.15 ist seit 2016 online und seit dem sind zehntausende KeySteps damit ausgeliefert worden ... was soll da ein Downgrade bringen?
     
  26. Niki

    Niki ||||||||

    Ich habe jetzt guguckt, bei mir ist auch das aktuelle Firmware drauf.
    Das Problem ist glaube ich generell nur mit Elektron Geräten wegen dem anderem Midi.

    Vielleicht kann man da was im Midi Control Center einstellen?
     
  27. Niki

    Niki ||||||||

    upload_2019-1-7_12-48-17.png

    ich verstehe nicht ganz was das da alles bedeutet aber ich glaube das die rot angekreuzte felder was damit zu tun haben können

    bei sync clock In/Out kann man was auf (Korg) umschalten - was bedeutet das?
    und bei Transport Mode kann man auf mmc oder off umschalten - vll würde das was bringen?
     
  28. verstaerker

    verstaerker ||||||||||

    ich habe alle relevanten settings im Midi-Center getestet

    was hat das mit den Elektrons zu tun? der OT war nur ein Beispiel von diversen Maschinen die ich als Vergleich benutzt habe... hab z.B. auch ne acidlab Miami benutzt ... spielt auch keine rolle, die Steps aus dem Keystep sitzen jedes mal an anderer Stelle , das mit der anderen Maschine ist nur ne Referenz um es leichter zu erkennen
     
  29. Niki

    Niki ||||||||

    Hatte die Vermutung weil ich damals schon probleme hatte den Votageblock über den Resetout von qmi2 mit dem Digitakt zusammen zu syncen.
    Das hat nicht geklappt weil die Elektron Geräte ihre Start/stop Befehle anders rum senden als der Rest der Welt. Was dann im nachhinein für schlechte Kompatibilität zu anderen Geräten sorgt.

    Ich dachte, vll hat dieses Phänomen einen ähnlichen Ursprung.
     
  30. verstaerker

    verstaerker ||||||||||

    Das ist mir noch nicht aufgefallen. Wie sollte das auch gehen? Zuerst start dann stop ?
    Wie dem auch sei, meine Masterclock ist ne e-rm Multiclock.