Win 7 64 / Probleme bei mehreren Synths mit MIDI über USB

FunKeyLicious

FunKeyLicious

|
Hallo!

Ich habe mehrere meiner Synths statt wie früher über DIN MIDI direkt über USB Kabel via MIDI steuern. Betriebssystem am Musikrechner ist Windows 7 64bit. Es handelt sich derzeit unter anderem um Geräte wie Mopho X4, Little Phatty, Bass Station 2, Nord Electro 4 und John Bowen Solaris. Die meisten Synths sind class compliant und brauchen keinen eigenen Treiber, für den Nord Electro z.B. ist der proprietäre Clavia Treiber installiert.

Leider habe ich derzeit das Problem, dass nicht alle Geräte gleichzeitig erkannt werden. Manche werden erkannt, aber nur wenn ich sie einmal auf einen anderen USB Port umstecke. Ich bekomme es aber nicht hin, dass Windows eben alle gleichzeitig registriert. Alle Kabel hängen direkt am Rechner, kein USB Hub dazwischen.

Unter Windows XP war mir das Limit der MIDI Ports bekannt, das sollte aber unter Windows 7 nicht mehr existieren, oder?

Hat jemand vielleicht eine Idee, woran das liegen könnte?

Danke im Voraus!
 
B

Bragi Vän

......
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

Wann schaltest Du die Geräte ein, vor oder nach dem hochfahren des Betriebsystems?
 
FunKeyLicious

FunKeyLicious

|
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

Hab beides probiert, leider selbes Ergebnis...
 
B

Bragi Vän

......
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

Ich denke das Problem ist eher beim Mainboard und dem BIOS zu suchen. Windows ist da eigentlich großzügig. Ich hatte da noch nie Probleme. Eventuelle könnte eine über SATA angeschlossene zusätzliche USB Schnittstelle bzw. noch besser eine PCI auf USB Karte helfen.
 
BBC

BBC

...
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

Alle Kabel hängen direkt am Rechner, kein USB Hub dazwischen

soweit ich mal irgendwo gelesen habe ist nicht jede USB Buchse am Rechner auch ein eigener Port. Die werden teilweise auch als HUB erkannt habe ich mal gelesen in irgendeiner PC Zeitschrift...vielleicht liegts daran ...

der Access Virus zb. funktionierte bei mir auch NUR an dem Port/Anschluss am Rechner an dem ich ihn bei der Installation der software hatte. An einem anderen Port wurde er nach umstecken nicht mehr erkannt.
 
B

Bragi Vän

......
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

BBC schrieb:
Alle Kabel hängen direkt am Rechner, kein USB Hub dazwischen

soweit ich mal irgendwo gelesen habe ist nicht jede USB Buchse am Rechner auch ein eigener Port. Die werden teilweise auch als HUB erkannt habe ich mal gelesen in irgendeiner PC Zeitschrift...vielleicht liegts daran ...

der Access Virus zb. funktionierte bei mir auch NUR an dem Port/Anschluss am Rechner an dem ich ihn bei der Installation der software hatte. An einem anderen Port wurde er nach umstecken nicht mehr erkannt.

Da hat der Kollege vollkommen recht. Insofern sollte man die Buchsen testen oder die Anleitung des Mainboards befragen.
 
FunKeyLicious

FunKeyLicious

|
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

Vielen Dank schon mal für die Tipps, ich werde mal Stück für Stück probieren, ob sich das Problem auf bestimmte USB Buchsen eingrenzen lässt. Mal sehen...
 
mink99

mink99

......
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

Auch wenn es bei win7 etwas besser geworden ist, wann immer möglich, class compliant Treiber vermeiden ....
 
FunKeyLicious

FunKeyLicious

|
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

So, ich hab's jetzt lösen können.

Ich habe jedes Gerät (jeden Synth) einzeln an den verschiedenen USB Buchsen beim Rechner getestet. Interessanterweise hat das z.B. gezeigt, dass die Novation BassStation 2 als einzige nicht mit USB3 Buchsen kommunizieren wollte, egal ob es die bereits im Rechner eingebauten oder jene auf den zwei USB Erweiterungssteckkarten waren. Zwar kein Synth aber ebenso USB3 "bockig" gibt sich übrigens der Synchrosoft Licenser USB Dongle für Cubase und andere.... Der wird dann auf einem anderen Steckplatz einfach nicht richtig erkannt. Finde ich etwas seltsam.

Jedenfalls habe ich immer einzeln geprüft, ob Windows 7 das Gerät auch korrekt im Gerätemanager anzeigt bzw. die richtigen Treiber installiert (bis auf den Nord Electro 4 begnügten sich alle anderen Synths mit den Windows Treibern). Weiters dann via MIDI-Ox geprüft, ob die jeweiligen MIDI Ports auch funktionieren. Manchmal war ein Neustart des Rechners notwendig, meistens war es doch positiverweise echtes Plug'n'Play im laufenden Betrieb.

Also im Enderfolg hat alles geklappt und es war zumindest die Mühe wert, alles nochmals einzeln zu testen und neu zu verkabeln. Warum das Ganze nicht auf Anhieb geklappt hat, weiß ich nicht. Aber Ende gut alles gut udn danke nochmals für eure Hilfe :phat:
 
A

Anonymous

Guest
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

FunKeyLicious schrieb:
So, ich hab's jetzt lösen können.

Ich habe jedes Gerät (jeden Synth) einzeln an den verschiedenen USB Buchsen beim Rechner getestet. Interessanterweise hat das z.B. gezeigt, dass die Novation BassStation 2 als einzige nicht mit USB3 Buchsen kommunizieren wollte, egal ob es die bereits im Rechner eingebauten oder jene auf den zwei USB Erweiterungssteckkarten waren. Zwar kein Synth aber ebenso USB3 "bockig" gibt sich übrigens der Synchrosoft Licenser USB Dongle für Cubase und andere.... Der wird dann auf einem anderen Steckplatz einfach nicht richtig erkannt. Finde ich etwas seltsam.

Jedenfalls habe ich immer einzeln geprüft, ob Windows 7 das Gerät auch korrekt im Gerätemanager anzeigt bzw. die richtigen Treiber installiert (bis auf den Nord Electro 4 begnügten sich alle anderen Synths mit den Windows Treibern). Weiters dann via MIDI-Ox geprüft, ob die jeweiligen MIDI Ports auch funktionieren. Manchmal war ein Neustart des Rechners notwendig, meistens war es doch positiverweise echtes Plug'n'Play im laufenden Betrieb.

Also im Enderfolg hat alles geklappt und es war zumindest die Mühe wert, alles nochmals einzeln zu testen und neu zu verkabeln. Warum das Ganze nicht auf Anhieb geklappt hat, weiß ich nicht. Aber Ende gut alles gut udn danke nochmals für eure Hilfe :phat:

vielen leiben Dank... also erstmal Vorsicht mit USB 3 !???!?
 
FunKeyLicious

FunKeyLicious

|
Re: Win 7 64 / Probleme bei mehreren Synths mit MIDI über US

vielen leiben Dank... also erstmal Vorsicht mit USB 3 !???!?

Naja, im Grunde sollte das ja kein Thema sein, die meisten Geräte hatten auch kein Problem mit USB 3. Insbesondere bei der BassStation 2 war ich verwundert, weil ja ganz neu... Vielleicht hilft später mal ein Firmware Update? Und wie immer: Probieren geht halt leider über Studieren ;-)
 
 


Neueste Beiträge

News

Oben