16 Step CV Sequenzer

Beitrag Nr. 18 wurde als beste Antwort markiert.

Hallo zusammen,

mein nächstes Löt-vorhaben ist ein CV Sequenzer mit 2 CD4015.
Der Plan bisher:

Seq16.png

Könnt ihr irgendwelche Fehler entdecken? Verbesserungsvorschläge?
Freue mich auf eure Tipps und Anregungen...
 
Schade das es hier niemanden zu interessieren scheint.
Die Idee des Sequenzers stammt von hier .
Ich habe es soweit fertig gebaut und es funktioniert noch nicht 100%.
Der Stepp 6 kommt nicht, 4 und 5 dafür gemeinsam. Das durchlaufende Hoch verliert sich dann auch nach 2-3 Durchgängen.
Ich bleibe dran....
 

fanwander

*****
Ich verstehe den Unterschied zwischen OPulsOut und PulsOut nicht. Was macht diese Verbindung von Pin6 U6 zu R.28? Warum gibts Du da nochmal die Gate rein?

Außerdem vergibt man sehr sehr viele Möglichkeiten wenn man die Poti-Reihe von einem Zähler ansteuern lässt, statt klassisch von einem DeMultiplexer (4051 oder DG408 oder ähnliches). Beim DeMultiplexer kannst Du im simplesten Fall eine konstante Spannung in den Common-in des DeMultiplexers reingeben, dann hast Du das gleiche Ergebnis wie bei Deiner Schaltung.
Du kannst aber eben auch andere sich ändernde Spannungen rein geben oder Audio. Oder zB das Gate/Pulse-Signal des jeweiligen Steps, dann bekommst Du dynamische Trigger, etc etc. pp.....
 
Zuletzt bearbeitet:
Ich verstehe den Unterschied zwischen OPulsOut und PulsOut nicht. Was macht diese Verbindung von Pin6 U6 zu R.28? Warum gibts Du da nochmal die Gate rein?
Ich wollte erst einen 3-Wege-Schalter um einen alternativen PulsOut zu haben. aber OPulsOut ist jetzt AUS also C/D am 4081 (und nachfolgendes) ohne Funktion.
Der GateMixOut soll Pulse und Gate mischen um längere Gates als 1Step zu erhalten.
Also ich hab je Step 1 3fach Schalter der Puls / Aus / GateMix wählt.

Leider klappt etwas noch nicht ganz, der je 4. Step macht gleichzeitig den nächsten hoch. Das sollte eigentlich nicht sein.

Einen "klassischen" Sequenzer mit De-multiplexer werde ich bestimmt auch nochmal basteln. Gibt es da ein Simples Schema?
Der Klee erscheint mir doch schon zu komplex.
 

fanwander

*****
Der GateMixOut soll Pulse und Gate mischen um längere Gates als 1Step zu erhalten.
Ah, ok.
Leider klappt etwas noch nicht ganz, der je 4. Step macht gleichzeitig den nächsten hoch. Das sollte eigentlich nicht sein.
Kuck Dir mal das Datenblatt des 4015 an:
1596556221845.png

Der Dateneingang jeder Stufe wird vom invertierten Datenausgang der vorigen Stufe gesetzt.
Jetzt schau Dir Deine Schaltung an. Da setzt Du den Dateneingang der fünften Stufe mit dem nicht-invertierten Datenausgang der vierten Stufe. Du brauchst also zwischen jedem Viererblock bei der Verbindung von Q4 zum D des nächsten Blocks einen Inverter.
 
Du brauchst also zwischen jedem Viererblock bei der Verbindung von Q4 zum D des nächsten Blocks einen Inverter.
Hm ok, aber in der kleinen Tabelle siehts anders aus und in der Schaltung vom Original ist auch nix invertiert.

Bildschirmfoto_2020-08-04_19-01-39.png

Beim einschalten sind erstmal alle Stepps hoch, muss erstmal reseten um einen Stepp setzen zu können und das tue ich doch auch nicht invertiert. ???
 

fanwander

*****
Argh, der Data-in (Pin15 und 7) invertiert ja selbst. Sorry!

Vielleicht probierst Du mal die Dämpfung mit dem RC-Glied, das die Turing-Maschine zwischen Q4 und nächsten Data-In hängt
 
Vielleicht probierst Du mal die Dämpfung mit dem RC-Glied, das die Turing-Maschine zwischen Q4 und nächsten Data-In hängt
Bildschirmfoto_2020-08-05_07-57-25.png

Genauso habe ich es jetzt, aber leider bessert das nix.
Die aktiven Stepps verlieren sich nach ein paar Durchgängen, immer bei Q4 zu Q1 sind beide hoch und dann nix mehr.
Das ist aber unregelmäßig, manchmal wird 1 Stepp auch übersprungen. Das ganze passiert unabhängig von Poti- und Schalter-Stellung.
Bin echt ratlos.
 
Die Kondensatoren an den Data in Eingängen ergeben keinen Sinn für mich, beide Pins liegen auf Gnd.
bei Digital Schaltungen sollte man -Tiefpass Filter wie R43/C14 vermeiden da diese die Schaltvorgänge
verzögern.
 
Ein D-Flipflop übernimmt bei steigender Flanke den Pegel am D-Eingang.
Wenn der Pegel am D-Eingang durch das RC-Glied "analog" und zeitverzögert wird, wird Q bei steigender Flanke diesen, möglicherweise falschen Pegel, annehmen.
 
Zuletzt bearbeitet:
Hier ist noch ein Plan in dem ein RC-Glied vor dem D-Eingang ist.
Allerdings scheint es in meinem Fall keine Rolle zu spielen, ohne RC funktioniert die Schaltung ja genauso schlecht wie mit.
Was könnte also noch eine Rolle spielen?
 
Schade das es hier niemanden zu interessieren scheint.
Mich interessiert es definitiv, aber leider bin ich noch lange nicht so weit ! Ich bastel seit 2 Tagen an nem Rauschgenerator mit 13 einfachen Bauteilen rum und bekomme keinen Ton raus...bis ich sowas checke, vergehen noch ein paar Monde... Ich wünsche dir aber viel Erfolg und dass es balde richtig funktioniert!
 
Bau dir doch mal eine Step Taste auf mit der du schritt für schritt mit dem Messgerät
alles überprüfen kannst,
statt 74HC14 nimmst du dann den CD40106 damit die Schaltung auch mit +12V läuft.
Taster-entprellt-Schmitt-Trigger.png
 
Ich habe den 4015 gewechselt und es schien gut zu laufen mit kurzen schnellen Puls am Clock In.
Dann mit relativ langsamen Divider als Clock verloren sich die gesetzten Bits wieder.
Ich trennte dann die 1N Kondensatoren (Widerstände sind geblieben) und nun ist jeder gesetzte Bit am 4 zum 5 Takt weg auch mit schnellem Puls am Clock In.
Mehrere Bits hintereinander gesetzt - verlieren sich alle 4 Takte je immer 1 Bit.

Mit messen Takt für Takt werde ich auch nicht schlauer.
Die Spannungen sind knapp 12 V an Q oder ebend 0 so wie es sein soll.
Q4 gibt korrekt die Spannung an den nächsten D Eingang aber der nächste Q1 bleibt beim nächsten Takt 0 V.

Was mich irritiert ist das beim Einschalten des Systems alle Bits gesetzt sind. Das bleibt dann auch mit Clock IN so.
 
Ich kenne Deinen Aufbau nicht, deshalb gehe ich davon aus, dass er dem Schaltplan entspricht.
Aber wie ich schon andeutete, ist die Taktansteueurung "nicht digital". Getaktete Schaltkreise erfordern bestimmte Flankenanstiegszeiten und Datenvor- und -nachhaltezeiten, siehe Datenblatt.
Um einen definierten Einschaltzustand zu erreichen, muss der 4015 mit einem Einschaltresetimpuls zurück gesetzt werden.
 
besser wären Schmitt-Trigger Gatter/Inverter vom typ 40106 oder 4093.
mit denen kannst du auch Reset On Power realisieren. Google doch mal.
Für weitere IC ist kein Platz, ich wollte die Schaltung auch einfach halten.
Mir ist echt unklar was weitere Logik IC bringen sollten damit die Sequenz ordnungsgemäß durchläuft.
Das alle Stepps On sind nach dem Einschalten damit könnte ich leben.
 
Die Turing-Maschine hängt auch manchmal.
Bei der Turing Maschine hatte ich auch Probleme aber mit einem Trimmer für den Rauschpegel läuft es wunderbar.
Das hatte allerdings nix mit dem Clocksignal zu tun.

Zu meinem Sequenzer:

Er läuft jetzt gut. :huepfling:
Ich habe die 10k Widerstände (R40, 41, 43) entfernt, R44 (14) wieder auf 4k7.
Von R13 bin ich zu U8D Pin 12+13 und dann von Pin 11 direkt zu den ClockIn der 4015 (Pin 1+9).

Ich danke euch für die Hinweise die mich zum Ziel führten.
Ein sauberes digitales Hoch ist also erforderlich damit der 4015 sauber läuft.

Der Clock-Ausgang am TL074 zeigte eine Anstiegs-kurve im Millisekunden-bereich.
Laut Datenblatt 4015 : "Clock Rise and Fall Time" - Vdd 10V - 15 Mikrosekunden
beim 4081 ist es noch weniger: "LOW-to-HIGH Level" - Vdd 10V - 100 Nanosekunden (0,1 Mikrosek.)

Nochmal der funktionierende (berichtigte) Schaltplan:

Bildschirmfoto_2020-08-07_16-18-13.png
 

Anhänge

Zuletzt bearbeitet:

fanwander

*****
Eeehm, warum geht R44 an CP und nicht an D wie im UrSchaltplan? Und wenn es dann an D ist, warum ist da ein Widerstand? Ich hätte eine Diode erwartet (das muss ja ein OR mit dem SetIn sein)
 
D5/R37 ergeben auch keinen Sinn für mich, oder soll damit
minus Volt Clock abgeblockt werden?
die Diode direkt am Clock in (Pin 3) wäre dann doch Logischer Oder?
 
warum geht R44 an CP und nicht an D wie im UrSchaltplan? ....
Ja genau, habe das falsch aber nur im Plan. :iPC:
Der eigentliche UrSchaltplan gibt mir den Widerstand (R44) vor. Eine Diode wäre also besster?

D5/R37 ergeben auch keinen Sinn für mich, oder soll damit
minus Volt Clock abgeblockt werden?
die Diode direkt am Clock in (Pin 3) wäre dann doch Logischer Oder?
Ich hatte den ClockIn Teil von der Turingmaschine übernommen. Das Teil funktioniert und gut, so dachte ich.

Trotz das ich nun schon ne Menge Module (nach Plänen aus dem WWW) gebaut habe, verstehe ich wohl noch recht wenig von diesen Schaltungen.
 
 


News

Oben