Firefox mit jackdbus

khz

EAT THE RICH
Seit dem Prozessorbug habe ich vorübergenehnd immer den offiziellen, aktuellen Kernel und keinen Realtime Kernel mehr installiert.
Keine Ahnung ob dass damit zusammenhängt, es ist nur in etwa zeitgleich damit eingetreten.
Problem ist das weder Firefox noch Seamonkey Audio über Jackdbus hörbar übertragen. Die Audio connection verbindet sich immer automatisch in z.B. qjackctl. Sprich es funkt eigentlich.
Nur den Ton höre ich nicht.
Nach
Code:
killall -9 jackdbus && killall -9 qjackctl
geht der Ton über ALSA.

Hat jemand einen Tipp?

Code:
[ebuild   R    ] www-client/firefox-59.0.1::jorgicio  USE="dbus gmp-autoupdate jack screenshot startup-notification -bindist -custom-cflags -custom-optimization -debug -eme-free -hardened -hwaccel (-neon) -pulseaudio (-selinux) -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite {-test} -wifi" L10N="de -ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -dsb -el -en-GB -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW" 0 KiB
Code:
[ebuild   R    ] www-client/seamonkey-2.49.7.0_p0::gentoo  USE="calendar chatzilla crypt dbus gmp-autoupdate ipc jack jemalloc roaming startup-notification -custom-cflags -custom-optimization -debug -force-gtk3 -minimal (-neon) -pulseaudio (-selinux) (-system-cairo) -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite {-test} -wifi" L10N="de -cs -en-GB -es-AR -es-ES -fr -hu -it -ja -lt -nl -pl -pt-PT -ru -sk -sv -zh-CN -zh-TW" 0 KiB
Code:
[ebuild   R    ] sys-kernel/gentoo-sources-4.15.13:4.15.13::gentoo  USE="-build -experimental -symlink" 0 KiB
Code:
[ebuild   R   *] media-sound/jack-audio-connection-kit-2.9999:0/2::bar  USE="alsa dbus pam -celt -debug -doc -ieee1394 -opus" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
Code:
[ebuild   R    ] media-sound/qjackctl-0.4.5::gentoo  USE="alsa dbus -debug -portaudio" 0 KiB

Grade alte Einstellungen in "/home/.asoundrc" gefunden. Braucht man die noch? Habe sie ja "#".
Code:
#pcm.!default {
#    type plug
#    slave { pcm "jack" }
#}

#pcm.jack {
#    type jack
#    playback_ports {
#        0 system:playback_1
#        1 system:playback_2
#    }
#    capture_ports {
#        0 system:capture_1
#        1 system:capture_2
#    }
#}

#ctl.mixer0 {
#    type hw
#    card 0
#}

Ich will das lieber über Jack(d/sbus) qjackctl laufen lassen.
Muss ich da im /home Verzeichn
 
Zuletzt bearbeitet:
@End war ein vergessener Satz, bezog sich auf .asoundrc.
Was war/ist das noch einmal?
Evt. habe ich es vergessen, habe grade kein Plan. Ah lese grade Pulseaudio und jack-sink?
Wenn das zusammenhängt: Ich baue meine Programme ohne Pulseaudio (
-pulseaudio), in der make.conf so festgelegt.
Pulseaudio ist $böse IMHO.
 
Da kann man so virtuelles jack in Pulse oder umgekehrt einrichten und dann dahin routen. Hab ich aber irgendwie nie geschafft.

ich baue nix im Linux, von daher muss ich das so nehmen wie es kommt
 
wie bindest du denn ohne pulse audio firefox überhaupt in jack ein?
FF unterstützt das doch offiziell gar nicht afaik.
 
Code:
[ebuild R ] www-client/firefox-59.0.1::jorgicio USE="dbus gmp-autoupdate jack screenshot startup-notification -bindist -custom-cflags -custom-optimization -debug -eme-free -hardened -hwaccel (-neon) -pulseaudio (-selinux) -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite {-test} -wifi" L10N="de -ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -dsb -el -en-GB -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW" 0 KiB
Code:
[ebuild R ] www-client/seamonkey-2.49.7.0_p0::gentoo USE="calendar chatzilla crypt dbus gmp-autoupdate ipc jack jemalloc roaming startup-notification -custom-cflags -custom-optimization -debug -force-gtk3 -minimal (-neon) -pulseaudio (-selinux) (-system-cairo) -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite {-test} -wifi" L10N="de -cs -en-GB -es-AR -es-ES -fr -hu -it -ja -lt -nl -pl -pt-PT -ru -sk -sv -zh-CN -zh-TW" 0 KiB
siehe USE="jack -pulseaudio", geht seit keine Ahnung Version Nummer kA 0.5/1 Jahr.
Als Firefox noch kein jack unterstützt hatte habe ich in der ".asoundrc" das oben gepostete (ohne "#") eingetragen. Glaub ich zumindest oder war es ... .
Seit Firefox aber jack unterstützte ging es ohne den Eintrag.
Hmmm Debian
 
hmm bei mir läuft seamonkey incl. jacksupport problemlos. Hab nirgens gedreht einfach nur emerged.
 
Seitdem ist auch Firefox/Seamonkey in englisch obwohl ich in deutsch baue (L10N="de").
Frickeln bis zum umfallen. ;-)
Ich baue wie gesagt das ganze System ohne Pulsaudio (Gentoo make.conf >> "-pulseaudio"). Da geht es entweder direkt über Jack. Seamonkey/Firefox haben ein "jack" USE-flag, also sie unterstützen Jack.
Wenn Jack aus ist läuft es hier über ALSA.
Pulseaudio will ich so lange es geht vermeiden. 2 Soundsysteme (Jack/Pulseaudio) und noch ALSA ist mir persönlich zu viel/verwirrend.
Klug wie ich bin habe ich Firefox mal in der Konsole gestartet und habe auf ein YT Video geklickt.
Jack ist eingeschaltet:
Code:
[Child 29705, MediaPlayback #1] WARNING: 7f74ee9a3400 OpenCubeb() failed to init cubeb: file /tmp/portage/www-client/firefox-59.0.2/work/mozilla-release-239e434d6d2b8e1e2b697c3416d1e96d48fe98e5/dom/media/AudioStream.cpp, line 387
[Child 29705, MediaPlayback #1] WARNING: Decoder=7f74ee509e20 [OnMediaSinkAudioError]: file /tmp/portage/www-client/firefox-59.0.2/work/mozilla-release-239e434d6d2b8e1e2b697c3416d1e96d48fe98e5/dom/media/MediaDecoderStateMachine.cpp, line 3755
JavaScript error: chrome://browser/content/preferences/languages.xul, line 1: ReferenceError: gLanguagesDialog is not defined
Jack ist ausgeschaltet:
Code:
- Keine Fehlermeldung und erfolgreiche Soundausgabe über ALSA -
Und dadurch bin ich u.a. dahin gekommen: https://www.linuxquestions.org/questions/slackware-14/firefox-in-current-alsa-sound-4175622116/
was ich jetzt noch verstehen muss.
4 --help >> beer
 
Zuletzt bearbeitet:
Gelöst.
Grund: Wenn man "jack-audio-connection-kit" neu baut muss man danach auch immer den "qjackctl" erneut bauen. Das (qjackctl) neu bauen hatte ich vergessen.
Seamonkey geht wieder mit Jack, Firefox momentan immer noch nicht, evt. Bug, keine Ahnung.
THX@telefonhoerer.net
 
Zuletzt bearbeitet:
Mit Mozilla Firefox 60.0 geht es wieder über qjackctl.
Aber will ich noch Firefox?
 
Mit Mozilla Firefox 60.0 geht es wieder über qjackctl.
Aber will ich noch Firefox?

Nachdem ich rausgefunden habe, wie ich auch bei 60.0 die Tableiste verschwinden lassen kann, wenn nur ein einziges Tab da ist: ja.

chrome/userChrome.css:

#tabbrowser-tabs, #tabbrowser-tabs arrowscrollbox { min-height: 0 !important; }
#tabbrowser-tabs tab { height: var(--tab-min-height); }
#tabbrowser-tabs tab:first-child:last-child { display: none !important; }

Danach nur noch im Hamburger-Menü->Anpassen das +-Icon zum Anlegen neuer
Tabs entfernen, und schon ist die Tableiste so lange weg, bis ein
zweites Tab angelegt wird.
 


News

Zurück
Oben