GNU/Linux Debian Installieren >> Linux Audio Workstation LAW

marco93

marco93

Moderator
Qtractor kackt immer noch ab beim Reinladen von Calf Analyzer ... LOL ...
Aber Waveform kann ohnehin MEHR!!!, hoffe es läuft stabil.

So, Alsa loop funzt, habe das KX Settings Packet (siehe oben) installiert.
Jetzt check ich das Config Script ...
 
Zuletzt bearbeitet:
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Liegt wohl an der installierten Calf-Version. Wäre mir egal.

Hat KXStudio eigene/andere Calf-Versions Paket?
(Oder: Die Backports nutzen und aus dem Debian-testing Zweig das Calf Paket installieren. Würde ich nur wenn unbedingt sein muss machen. (-Auflösen von Abhängigkeiten können Probleme bereiten. -Wenn man nicht vorher alle aus den Backports installierte Programme wieder auf die Original "stable" Zweig ge'"downgrade"'et hat und "apt-get dist-upgrade" ausführt kann dieser dist-upgrade mit "error" Meldungen abbrechen.)
 
Zuletzt bearbeitet:
marco93

marco93

Moderator
marco@fox:~/realtimeconfigquickscan$ perl ./realTimeConfigQuickScan.pl
Can't locate QuickScanEngine.pm in @INC (you may need to install the QuickScanEngine module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at ./realTimeConfigQuickScan.pl line 21.
BEGIN failed--compilation aborted at ./realTimeConfigQuickScan.pl line 21.


Abhilfe mit:

perl -I ./ ./realTimeConfigQuickScan.pl

->https://github.com/raboof/realtimeconfigquickscan/issues/8
----------------------
Output:
marco@fox:~/realtimeconfigquickscan$ perl -I ./ ./realTimeConfigQuickScan.pl
== GUI-enabled checks ==
Checking if you are root... no - good
Checking filesystem 'noatime' parameter... 4.9.0 kernel - good
(relatime is default since 2.6.30)
Checking CPU Governors... CPU 0: 'powersave' CPU 1: 'powersave' CPU 2: 'powersave' CPU 3: 'powersave' - not good
Set CPU Governors to 'performance' with 'cpufreq-set -c <cpunr> -g performance'
See also: http://linuxmusicians.com/viewtopic.php?f=27&t=844
Checking swappiness... 10 - good
Checking for resource-intensive background processes... none found - good
Checking checking sysctl inotify max_user_watches... < 524288 - not good
increase max_user_watches by adding 'fs.inotify.max_user_watches = 524288' to /etc/sysctl.conf and rebooting
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#sysctlconf
Checking access to the high precision event timer... readable - good
Checking access to the real-time clock... readable - good
Checking whether you're in the 'audio' group... yes - good
Checking for multiple 'audio' groups... no - good
Checking the ability to prioritize processes with chrt... yes - good
Checking kernel support for high resolution timers... found - good
Kernel with Real-Time Preemption... found - good
Checking if kernel system timer is high-resolution... found - good
Checking kernel support for tickless timer... found - good
== Other checks ==
Checking filesystem types... ok.
not found.
** Warning: no tmpfs partition mounted on /tmp
For more information, see:
- http://wiki.linuxaudio.org/wiki/system_configuration#tmpfs
- http://lowlatency.linuxaudio.org
** Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks.
Find your sound card's IRQ by looking at '/proc/interrupts' and lspci.
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
~Alles mit "not good" lesen was da steht und machen wenn du willst bzw. Link anklicken.
Must!have: Die Anpassung der "limits.conf" ist das wichtigste.
Nice2have: Alles was du willst von "realTimeConfigQuickScan.pl" anpassen wie da beschrieben.
Damit erreichst du sehr viel im Bereich Realtime Audio. Und verlierst sehr viel im Bereich Sicherheit. ;-)
Keine Panik.

*
Code:
cpufreq-set -c <cpunr> -g performance
<cpunr> == wie soviel Prozessoren bei dir vorhanden. "cpufreq-set -c 0 -g performance" (0/1/2/...)
Oder BESSER https://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin
https://packages.debian.org/stretch/xfce4-cpufreq-plugin

* max_user_watches https://wiki.linuxaudio.org/wiki/system_configuration#sysctlconf
Best is to not touch the default settings as setting this parameter is unrelated to performance in an audio context.
Machst/Brauchst du nicht!

* ** Warning: no tmpfs partition mounted on /tmp
Als "root" in der Konsole "nano /etc/fstab" und das hinzufügen:
Code:
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
speichern ("F2" "ja" "enter") und Computer "reboot".
https://www.spinics.net/lists/linux-audio-users/msg29784.html
http://debiananwenderhandbuch.de/mobile/content/ch03s20s02s01.html

##

Du hast das Paket jackd2(-firewire) installiert und in z. B. "qjackctl" Einstellungen > Advanced: "Server Präfix" "jackdmp" ausgewählt?
 
Zuletzt bearbeitet:
marco93

marco93

Moderator
Die Punkte schau ich mir später noch an.

2 Dinge, die nerven

1. Ich hab das whiskers menu installiert, find ich aber furchtbar
Standard ist besser. Ich schaff es aber nicht den Anwendungsstarter auf die linke Seite zu setzen. Entweder springt er wieder nach rechts oder neue symbole werden auf der linken Seite eingefügt und das Mäuschen rutscht immer weiter nach rechts.

2. Die Mauszeigergeschwindigkeit lässt sich nicht einstellen. Die acceleration Parameter haben keinen Einfluss. Wohl ein Bug ...

In Cadenece wird beim Kernel auch noch ein Warnsymbol statt Häkchen angezeigt ... und das Theme ist nicht so schön dunkel ... ok ... Erstesweltproblem... kann ich falkTX fragen....

Schriften sehen besser aus... hab an der Kantenglättung rumgespielt... läuft bis jetzt alles schnell und stabil.
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
@Grafik: Dein AMD/Nvidia/.. "non-free" Grafiktreiber (unfreien Firmware) über den Paketmanager installieren.
 
marco93

marco93

Moderator
@Grafik: Dein AMD/Nvidia/.. "non-free" Grafiktreiber (unfreien Firmware) über den Paketmanager installieren.

root@fox:/home/marco# lspci -nnk | grep -i VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
Subsystem: Micro-Star International Co., Ltd. [MSI] Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1462:7817]
Kernel driver in use: i915

Ist eine simple onboard Graphik. Gibt es dafür bessere Treiber?
 
  • Daumen hoch
Reaktionen: khz
marco93

marco93

Moderator
* ** Warning: no tmpfs partition mounted on /tmp
Als "root" in der Konsole "nano /etc/fstab" und das hinzufügen:
Code:
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
speichern ("F2" "ja" "enter") und Computer "reboot".
https://www.spinics.net/lists/linux-audio-users/msg29784.html
http://debiananwenderhandbuch.de/mobile/content/ch03s20s02s01.html
Du hast das Paket jackd2(-firewire) installiert und in z. B. "qjackctl" Einstellungen > Advanced: "Server Präfix" "jackdmp" ausgewählt?

Die Zeile habe ich eingetragen (s.u.), aber die Meldung kommt immer noch, wenn ich das script ausführe. Ist da eventuell ein Syntaxfehler?

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda1 during installation
UUID=8ea536dc-6928-4da9-a747-2fa60cf3d097 / ext4 errors=remount-ro 0 1
# /home was on /dev/sda6 during installation
UUID=2f1dc8ca-1bdd-4feb-964f-de1213159542 /home ext4 defaults 0 2
# swap was on /dev/sda5 during installation
UUID=7504a9ac-53f6-49e3-a25d-1a764a8babc7 none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
jackd2 statt jackd1.
FAQ: what are the differences between JACK 1 and JACK2 >> https://github.com/jackaudio/jackaudio.github.com/wiki/Q_difference_jack1_jack2


Code:
apt-get install intel-microcode firmware-linux-nonfree alsa-firmware-loaders
https://wiki.debian.org/Microcode
https://packages.debian.org/de/stretch/firmware-linux-nonfree
Oder was du noch findest.


Mit <TAB> Taste dazwischen ist es lesbarer, Fehlererkennung.
Code:
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
Das ist erst nach einem Reboot wirksam da "tmpfs".
 
Zuletzt bearbeitet:
marco93

marco93

Moderator
Das ist erst nach einem Reboot wirksam da "tmpfs".

Hab ich gemacht (Neustart). Und jetzt nochmal ganz runter und wieder ein... immer noch da.

marco@fox:~/realtimeconfigquickscan$ perl -I ./ ./realTimeConfigQuickScan.pl
== GUI-enabled checks ==
Checking if you are root... no - good
Checking filesystem 'noatime' parameter... 4.9.0 kernel - good
(relatime is default since 2.6.30)
Checking CPU Governors... CPU 0: 'performance' CPU 1: 'performance' CPU 2: 'performance' CPU 3: 'performance' - good
Checking swappiness... 10 - good
Checking for resource-intensive background processes... none found - good
Checking checking sysctl inotify max_user_watches... < 524288 - not good
increase max_user_watches by adding 'fs.inotify.max_user_watches = 524288' to /etc/sysctl.conf and rebooting
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#sysctlconf
Checking access to the high precision event timer... readable - good
Checking access to the real-time clock... readable - good
Checking whether you're in the 'audio' group... yes - good
Checking for multiple 'audio' groups... no - good
Checking the ability to prioritize processes with chrt... yes - good
Checking kernel support for high resolution timers... found - good
Kernel with Real-Time Preemption... found - good
Checking if kernel system timer is high-resolution... found - good
Checking kernel support for tickless timer... found - good
== Other checks ==
Checking filesystem types... ok.
not found.
** Warning: no tmpfs partition mounted on /tmp
For more information, see:
- http://wiki.linuxaudio.org/wiki/system_configuration#tmpfs
- http://lowlatency.linuxaudio.org
** Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks.
Find your sound card's IRQ by looking at '/proc/interrupts' and lspci.
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Dann noch das in die "/etc/fstab" eintragen.
Code:
tmpfs            /tmp        tmpfs        defaults,size=7500M,mode=1777    0 0
"size=7500M" <-- angepasst an deinen tatsächlich verbauten RAM, size=weniger als tatsächlich verbauten RAM.

Hatte es eben hier grade getestet mit nur
"shm /dev/shm tmpfs nodev,nosuid,noexec 0 0"
in der fstab, das
"tmpfs /tmp tmpfs defaults,size=7500M,mode=1777 0 0"
mit "#" rausgenommen und bekam auch "Warning"," tmpfs /tmp ..." wieder rein in die fstab und das Script hat mich nicht mehr angeschrienen. \o/
Also nimm mal beides dazu:
Code:
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0
tmpfs           /tmp       tmpfs       defaults,size=7500M,mode=1777   0 0


Wenn das dann noch drin ist hast du generell eine ~100% Realtime Linux Audio Workstation LAW.
Fehlen nur noch Programme. install --all ;-)

@telefonhoerer du hast doch ein Intel Prozessor. Was hast du diesbezüglich alles installiert (firmware/nonfree/...)? und alle anderen: Falls da was fehlerhaft/falsch ist bitte korrigiert mich. Danke
Struktur ist ugly, sry.
 
Zuletzt bearbeitet:
marco93

marco93

Moderator
Check ich, danke. Was heißt eigentlich real time? Mit dem real time kernel habe ich die gleiche Latenz wie vorher mit dem Standarddebiankernel (10ms). 0 Latenz geht ja wohl nicht.
 
  • Daumen hoch
Reaktionen: khz
dbra

dbra

Ehrenpräsident des Technofreunde Ohlenburg e.V.
Du musst natürlich auch die Puffer Größe von Jack verringern...
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
Das ist ja das schlimme! ;-)

Keine Panik! Das ist ja auch schon das ganze Geheimnis an Linux && Audio. Keine Panik!
 
marco93

marco93

Moderator
Das mit der fstab hat nun geklappt.

In die limits.conf habe ich

@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -10

eingetragen. Irgendwo habe ich gelesen, dass man das noch aktivieren muß bevor die Änderungen übernommen werden?
Zum Mausproblem hab ich hier mal einen Thread eröffnet: http://forums.debian.net/viewtopic.php?f=5&t=137309

Ich hatte gestern mal aus Spaß auf Desable Device im Mausmenu gedrückt. Hahaaha... dann ging natürlich die Maus nicht mehr. Stand ja auch da. Zweite Maus geholt und irgendwie die auch disabled.... Zwei Mäuse dran und keine ging, auch abstecken und anstecken hat nix gebracht. Reboot ... immer noch alles tot.... Dritte Maus geholt .... Im Menü war dann aber teilweise nur eine sichtbar ... ich habe es dann mit xinput set-prop irgendwie wieder hinbekommen, dass meine Hauptmaus am alten Port wieder ging, denn teilweise ging sie dann nur an bestimmten Ports des Hubs.
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
"@audio - nice -10" <--- kann raus, bringt nichts. Siehe:
Änderung nach "reboot" wirksam.

Linux lässt sich auch ~gut alleine mit der Tastatur bedienen ("Windows Taste" öffnet z.B. "Whisker Menu" >> Pfeil, TAB, enter, ... -tasten zum Steuern, <ALT> & <TAB> zum geöffnete Fenster wechseln, ... .)

Code:
apt-get install intel-microcode firmware-linux-nonfree alsa-firmware-loaders
alsa-firmware-loaders <--- hast du schon?
Der "intel-microcode" ist für Prozessor &
die "firmware-linux-nonfree" für unfreien Treiber/Firmware/Grafik/... wichtig.
 
Zuletzt bearbeitet:
marco93

marco93

Moderator
apt-get install intel-microcode firmware-linux-nonfree alsa-firmware-loaders

Hab auch ausgeführt. Scheint ja ziemlich wichtig zu sein.
 
  • Daumen hoch
Reaktionen: khz
marco93

marco93

Moderator
Welche version--0.0.0.1.5.345?

foobar-microcode brauch ich wofür? Stehen die ganzen Punkte irgendwo oder sind das Erfahrungswerte?
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run
marco93

marco93

Moderator
foobar-microcode findet er nicht:

root@fox:/home/marco# apt-get install foobar-microcode
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket foobar-microcode kann nicht gefunden werden.

Wenn ich in der Debian wiki suche finde ich keinen Eintrag. Ist das eventuell für Gentoo?

Muss man so Dinge unter Ubuntu auch nachinstallieren oder gibt es das dort gar nicht?
 
Zuletzt bearbeitet:
  • Daumen hoch
Reaktionen: khz
marco93

marco93

Moderator
scheint ok zu sein, oder?

root@fox:/proc# dmesg | grep "microcode updated early to"
[ 0.000000] microcode: microcode updated early to revision 0x22, date = 2017-01-27

Spezielle Graphiktreiber habe ich noch nicht installiert, schaut aber alles ok aus.
 
  • Daumen hoch
Reaktionen: khz
khz

khz

D@AU ~/Opportunist/Orwell # ./.cris/pr.run

Similar threads

khz
Antworten
81
Aufrufe
3K
_wolle_
_wolle_
khz
Antworten
48
Aufrufe
8K
khz
 


Neueste Beiträge

News

Oben