"meModular" Modularer DIY Synth

rolfdegen

|||||
Hallöchen..

Auf der diesjährigen "Happy Knobbing 2019" hab ich mich mit einem gefährlichen Virus infiziert.. dem "Modular Virus".
Da ich noch kein eigenes Modular System habe, hatte ich auf der Happy Knobbing ein Virtuelles Modular System in Form
einer Software namens "VCV Rack" mitgebracht und mit vielen Modulen experimentiert. Hat tierisch viel Spaß gemacht.
Für den Einstieg ins Modular System und wer es mal ausprobieren möchte kann ich das kostenlose "VCV Rack" nur empfehlen.
Die Software ist Open source und kann man sich hier downloaden: https://vcvrack.com/

VCV Rack
VCV_HK[1].jpg

Hier einen kleinen Eindruck von der "Happy Knobbing 2019" in Fischbach.
Die Hintergrundmusik entstand live beim drehen an den vielen Knöpfchen im VCV Rack.
View: https://youtu.be/s4wbrQq7Q1Q


Meinen Desktop Computer hielt man auf der "Happy Knobbing" irrtümlich für eine Heizung. Gute Tarnung ist halt alles :kaffee:

IMG_20151009_161623[1].jpg

Angesteckt durch die vielen Möglichkeiten und Freude an der elektronischen Musik, habe ich mich entschlossen einen eigenen Modularen Synth zu bauen.
Anfangen werde ich mit einem Midi to CV Interface. Ein Midi to CV Interface liefert die Steuerspannung und Steuersignale um zB einen Spannungsgesteuerter Oszillator (VCO)
und Filter (VCF) zu steuern.

Gruß Rolf
 
Zuletzt bearbeitet:

rolfdegen

|||||
Was braucht man für den Anfang..

Ein gutes Netzteil mit verschiedenen Spannungen zB +12V -12V +5V und genügend Strom auf jeder Leitung zB. 500mA.
Ein preisgünstiges und gutes Netzteil habe ich hier bei Voelkner gefunden.

Schaltnetzteil: Mean Well RT65B
53671

:connect:
Aber Achtung ! Die Stromführenden 230 Volt Anschlüsse sind bei diesem Netzteil nicht abgedeckt und können bei Berührung tödlich sein.
Aus diesem Grund würde ich vorschlagen den 230V Anschluss nach dem Anschluss eines Kabels mit Heißkleber einfach zu verkleben.



Ein Midi to CV Modul

Einen VCO Modul

Einen VCF Modul

Einen VCA Modul

Einen Hüllkurvengenerator (ADSR)

Und zu guter letzt schönes Gehäuse

Das alles werde ich zum Teil selber bauen und hier beschreiben.

Gruß Rolf
 
Zuletzt bearbeitet:

Niki

|||||||||||
Wenn das Ergebniss so ausgefuchst und simple wie der TubeOhm Filter sein wird und gute Sounds liefern wird, dann wäre es schon ziehmlich interessant.
Ich finde aber den Ansatz mit einem vco, vcf, env und vca ziehmlich langweilig. Interessanter wäre eher die richtung:
- Tongeber (was auch immer, ein osc oder iwas sample basiertes oder physical modeling)
- mixer, am besten 2 oder sub out bei tongeber
- Tonverbieger (waveshaping oder foding, crushing usw. Like a gigercounter)
- geiles modulationsshinken like a voltageblock, vll mit integration von sehr knackicken und percusiven env. Bzw gate signalen like a varigate 4+ und pamelas new workout.
- eine reudige fikterbank mit cv steuerbaren Bändern die einen eigenen und geilen klang hat. Von mir aus digital wie der Ohm Filter.

Bitte so viel wie möglich modulierbar.

Das ist aber nur meine Eigene Meinung. Das jemand seinen eigenen modularsynth bauen will, feiere ich so oder so :)
 

rolfdegen

|||||
Viel Spaß,
willst Du Bausätze verwenden oder das Rad neu erfinden?
Ich fange erst mal klein und einfach mit selbstgebauten Modulen an. Das wird sich dann nach und nach entwickeln.
Andre von Tubeohm.com ist natürlich mit im Boot. Macht zusammen noch mehr Spaß wie ich finde.

Ich baue gerade das Oszillator Modul auf Basis zweier AS3340 Chip's.
Das sind Clone der legendären CEM3340 VCO Chip's.
20190616_171025.jpg

Gruß Rolf
 
Zuletzt bearbeitet:

telefonhoerer

||||||||
ich hatte mir zuerst eine Synth-Stimme (pittsburgh synth block) gekauft um eine Referenz zum testen der eigenen Module parat zu haben, dann hab ich mit ADSR's angefangen.
Filter und VCO's hab ich bisher wenn überhaupt als Bausätze gebaut und zum Teil modifiziert, da mir die Entwicklung eiines eigenen VCF/VCO-Modules zu zeitaufwendig ist (zumindest wenn ein klanglich Konkurenzfähiges Ergebnis erwünscht ist).
Allerdings machen es einem z.B. die AS3**** sowie die ElectricDruid Chips schon leicht ein gutes eigenes Modul zu entwickeln.
als Midi-Interface hab ich mal den Bausatz von Erica-Synth gebaut da eine komplette Eigenentwicklung doch Aufwendig erschien
 

rolfdegen

|||||
Habe heute noch ein paar Kleinteile zum 1V/Oct Abgleichen der Oszillatoren bestellt. Denn die Standartbeschaltung ist bei hohen Frequenzen (ab C6) zu ungenau. Die Töne liegen dann um 2-4 Hz daneben.

Gruß Rolf
 

rolfdegen

|||||
Hallöchen..

Haben die Oszillator Chips AS3340 und CEM3340 nach dem Einschalten eine Aufwärmzeit bis die eingestellte Tonfrequenz stabiel bleibt ?

In meiner Oszillatorschaltung benötigt der AS3340 ca. 20-30min bis die eingestellte Frequenz zB C6 (1046Hz) dauerhaft stabiel (+-1Hz) stehen bleibt.
 
Zuletzt bearbeitet:
Im Pro One sind auch 3340 enthalten und es ist mir oft passiert, dass nach einem anschalten nach einem Tag immer noch exaktes Tuning vorhanden war und ich nichts nachregeln musste. Die sind also eher sehr stimmstabil.
 

rolfdegen

|||||
Ok. Danke für deinen Hinweis. Schon beim Einschalten ist die Frequenz um ca. 30Hz niedriger und klettert dann innerhalb von ca. 20min auf die Soll Frequenz.

Stimmt vlt etwas mit meiner Schaltung nicht. Auch beim berühren des Chips sinkt die Frequenz um ein paar Herz und steigt dann wieder. Trotz eingebauten Tempco-Regelung im Chip. Versteht ich nicht ?
 
Zuletzt bearbeitet:

Jenzz

||||||||||
Aloha .-)

Kontrollier mal, ob die Betriebsspannungen Temperaturgang haben. Dies ist beim 3340 eher ein Thema als der Tk vom Chip selber...

Jenzz
 

Jenzz

||||||||||
Habe heute noch ein paar Kleinteile zum 1V/Oct Abgleichen der Oszillatoren bestellt. Denn die Standartbeschaltung ist bei hohen Frequenzen (ab C6) zu ungenau. Die Töne liegen dann um 2-4 Hz daneben.

Gruß Rolf

Hast Du auch den High Freq Track (Pin 7) beschaltet? Der gleicht solche Sachen ja aus...

Jenzz
 

rolfdegen

|||||
Die Betriebsspannung für den AS3340 wird über einzelne Festspannungsregler mit +10V (LM2940-10) und -5V (79L05) gemacht. Der Cap an Pin 11 ist ein 1000pF teures "Luxus" Teil. Fast 2 Euro hats gekostet. Was tut man nicht alles für die Qualität :xencool:

High Track ist wie im AS3340 Manual beschrieben beschaltet.

Etwas merkwürdig ist die Tatsache, dass nach dem Einschalten der Stromversorgung, die aktuelle Frequenz 20-30Hz niedriger ist als der eingestellte Sollwert und erst mit der Zeit (ca. 10-20min) auf den vorgegebenen Sollwert zB 1000Hz klettert.
Danach bleibt die Frequenz sehr konstant und stabil. Die Soll-Frequenz habe ich mit Hilfe eines 100K Prä. Trimmer und 100K (0,1%) Widerstand in Reihe direkt an Pin 14 des AS3340 eingestellt.

Hab jetzt testweise einen 100nF parallel zum 1.8K Widerstand an Pin 14 geschaltet und teste gerade.. Hab ich in einem anderen Schaltbild gesehen.

Nachtrag: 100nF hat nichts gepracht. Das gleiche Problem.

Gruß Rolf
 
Zuletzt bearbeitet:

Jenzz

||||||||||
Die Betriebsspannung für den AS3340 wird über einzelne Festspannungsregler mit +10V (LM2940-10) und -5V (79L05) gemacht.
Die meisten Hersteller lassen sich heutzutage über Temperaturgänge nicht mehr aus.... Schaut man aber in Datenblätter (für das gleiche Bauteil) von vor 10 Jahren, dann steht da meist was von 'Output Voltage drift = -0,8mV / C°'. Dies ist meist schon genug, um diese Unterschiede zu erzeugen. Nach dem Einschalten muss man also warten, bis sich sowohl Regler als auch der 3340 entsprechend erwärmt haben, erst ab dann ist es stabil.

Jenzz
 
Die Betriebsspannung für den AS3340 wird über einzelne Festspannungsregler mit +10V (LM2940-10) und -5V (79L05) gemacht. Der Cap an Pin 11 ist ein 1000pF teures "Luxus" Teil. Fast 2 Euro hats gekostet. Was tut man nicht alles für die Qualität :xencool:

High Track ist wie im AS3340 Manual beschrieben beschaltet.

Etwas merkwürdig ist die Tatsache, dass nach dem Einschalten der Stromversorgung, die aktuelle Frequenz 20-30Hz niedriger ist als der eingestellte Sollwert und erst mit der Zeit (ca. 10-20min) auf den vorgegebenen Sollwert zB 1000Hz klettert.
Danach bleibt die Frequenz sehr konstant und stabil. Die Soll-Frequenz habe ich mit Hilfe eines 100K Prä. Trimmer und 100K (0,1%) Widerstand in Reihe direkt an Pin 14 des AS3340 eingestellt.

Hab jetzt testweise einen 100nF parallel zum 1.8K Widerstand an Pin 14 geschaltet und teste gerade.. Hab ich in einem anderen Schaltbild gesehen.

Nachtrag: 100nF hat nichts gepracht. Das gleiche Problem.

Gruß Rolf
Meine 3340 laufen mit 12V!
 

rolfdegen

|||||
Merkwürdig. Was hab ich da für CEM3340 Clone bekommen :shock:

+12Volt habe ich auch getestet. Das gleiche Problem.

Das ist mein Testaufbau mit AS3340
53962

Power on frequency ist 700Hz. The stabel frequency after 20min is 800Hz.

I have test with two AS3340 Typ Nr. is AS3340 1808

Rt is normal metall resistor with 5,6k 1%

Gruß Rolf
 
Zuletzt bearbeitet:

rolfdegen

|||||
Habe die Spannung mit zwei Nachkommastellen gemessen (9.84V). Alles stabil. Ich hab jetzt gerade mein kleines Eurorack Case A-100LC1 von Doepfer bekommen. Das hat ein +-12V Netzteil. Werde es jetzt damit versuchen.
 

rolfdegen

|||||
Ok. Hab jetzt noch mal die Standartschaltung für den 3340 nachgebaut und das Eurorack Netzteil verwendet . Gleiche Problem. Was mich etwas wundert ist die Änderung der Z-Diode im Chip. Alfa gibt im AS3340 eine Zener Spannung von 7.4V an. Im Original sind es aber 6.5V. Also kein 100% Clone.
 

Jenzz

||||||||||
Moin .-)

Am Anschluss der internen Z-Diode (Pin3) fehlt noch ein Widerstand. Im CEM 3340 Datenblatt werden die -15V über einen 820 R Widerstand eingespeisst. Auf Deiner Zeichnung gehen die -5V (warum eigentlich nur -5? Woher kommt dieser Wert? Im ALFA-Datenblatt stehen auch -15V drin und den 820R gibt es dort auch...) direkt drauf ?? Da wird die Z-Diode doch (zumindest bei -15V) gegrillt....

CEM3340_int.jpg


Jenzz
 
Zuletzt bearbeitet:

rolfdegen

|||||
Hi Jenzz. Wenn die Spannung am VEE Anschluss (Pin3) nicht höher ist als -6.5 Volt kann die Einspeisung direkt erfolgen. So stehts in beiden Datenblättern (AS3340 u. CEM3340)

CEM3340_VEE[1].jpg

AS3340_VEE[1].jpg

Zum Versuch hatte ich den Pin 3 auch über einen Vorwiderstand an -12 Volt angeschlossen. Aber ich konnte nach dem Einschalten der Betriebsspannung die gleiche Frequenzdrift beobachten wie mit -5 Volt.

Ich hab die ganze Schaltung noch einmal sauber aufgebaut um Fehler auszuschließen. Leider ohne Erfolg.

Hier meine aktuelle Messungen von heute Morgen (Stabile Soll- und Ist-Frequenz von Gestern Abend war 800Hz)

t0 : 670 Hz - 0 min
t1 : 780 Hz - 12 min
t2 : 785 Hz - 21 min
t3 : 791 Hz - 40 min
t4 : 797 Hz - 60 min

Ich werde jetzt eine Änderung an den TEMPCOGEN Anschlüssen Pin1+2 nach den Tuning Vorgaben von Rob Hordijk durchführen (siehe unten) und dann Frequenzmessungen machen.

AS3340_tuning[1].jpg
AS3340-VEE-03[1].jpg

Link: http://www.alfarzpp.lv/eng/sc/Tuning the AS3340.pdf

Aktueller Testaufbau
AS3340_Testboard[1].jpg

Gruß Rolf
 
Zuletzt bearbeitet:


News

Oben