Problem mit Yamaha AN1x

D
DIGITAL MIND
..
Hallo zusammen,

ich habe mir kürzlich einen gebrauchten Yamaha AN1x zugelegt.
Nun habe ich mir ein Soundset dafür zugelegt und wollte es auf den Synthesizer übertragen. In dem Download war eine MIDI-Datei, und eine AN1-Datei für den Editor.
Wenn ich die MIDI-Datei versuche zu übertragen (mit dem SysEX Librarian oder Cubase), bekomme ich sofort die Fehlermeldung "SysEx Size Error".
Wenn ich die AN1-Datei in den Editor lade, alles markiere und auf "Send" klicke, kommt beim Synthie zwar der Dump an, aber die Patches werden nicht gespeichert. Auch nicht, wenn ich danach auf "Store" drücke.
Ich bin einigermaßen ratlos. Hat jemand eine Idee?

Gruß

Alex
 
recliq
recliq
¯\_(ツ)_/¯
Was für ein Midi-Interface benutzt du?
Zeigt der AN1x "Receiving Dump" an?

Bei mir funktioniert der Editor recht gut, aber mein Midi Interface hat große Buffer und es sendet noch eine ganze Weile Daten an den AN1x nachdem der Editor schon meint fertig zu sein, leider kann man das nicht beeinflussen.
Es kann sein das die Daten zu schnell beim AN1x ankommen. In diesem Fall würde ich das .MID File in Sysex wandeln (https://www.sequencer.de/synthesizer/threads/mid-to-syx-conversion.100660/) und mit MIDI-OX (http://www.midiox.com/?http://www.midiox.com/moxdown.htm) übertragen.
Dort kannst du die Anzahl der Buffer einstellen und Pausen nach den einzelnen Sysex-Blöcken definieren.
Ein weiteres etwas einfacheres Tool ist C6 Sysex Manager (https://www.elektron.se/support/?connection=analog-drive#downloads).
 
Zuletzt bearbeitet:
D
DIGITAL MIND
..
Was für ein Midi-Interface benutzt du?
Zeigt der AN1x "Receiving Dump" an?

Bei mir funktioniert der Editor recht gut, aber mein Midi Interface hat große Buffer und es sendet noch eine ganze Weile Daten an den AN1x nachdem der Editor schon meint fertig zu sein, leider kann man das nicht beeinflussen.
Es kann sein das die Daten zu schnell beim AN1x ankommen. In diesem Fall würde ich das .MID File in Sysex wandeln (https://www.sequencer.de/synthesizer/threads/mid-to-syx-conversion.100660/) und mit MIDI-OX (http://www.midiox.com/?http://www.midiox.com/moxdown.htm) übertragen.
Dort kannst du die Anzahl der Buffer einstellen und Pausen nach den einzelnen Sysex-Blöcken definieren.
Ein weiteres etwas einfacheres Tool ist C6 Sysex Manager (https://www.elektron.se/support/?connection=analog-drive#downloads).
Ich habe das Miditech Midiface 2x2.
Ja, der AN1x zeigt das an. Wenn der Dump "durch" ist, zeigt er auch ganz kurz den Namen des ersten neuen Sounds an, aber das ist sofort wieder weg und er zeigt den Namen des Werkssounds an.
Der AN1x ist fertig, sobald der Editor fertig ist (Received Bulk im Display).
 
Knastkaffee_309
Knastkaffee_309
|||||||
Besteht der Dump nicht aus meheren Sysex-Strängen?

Vlt hilft es das Midi mal langsamer abzuspielen?
 
recliq
recliq
¯\_(ツ)_/¯
Hm, also bei mir sehe ich die neuen Namen erst nachdem ich einmal das Programm geändert habe, wenn ich einen kompletten Dump einspiele.
Funktioniert es im Editor mit einzelnen Programmen (die werden nicht automatisch gespeichert!)

Ich würde auch wirklich mal das Midi File in reines Sysex wandeln und mit Midi-Ox oder C6 langsamer einspielen.

PS: Ich kenne das Miditech Midiface 2x2 nicht, habe aber mit anderen Miditech nicht unbedingt die besten Erfahrungen gemacht... wenn das Ding zu kleine oder keine Buffer hat wird es dir bei einem großen Dump das Sysex zerstören (Datenverlust).
 
Zuletzt bearbeitet:
D
DIGITAL MIND
..
Hat auch mit 20 bpm nicht geklappt. Versuche es demnächst mal mit dem von Dir vorgeschlagenen Weg.
 
Synthwaver
Synthwaver
Synthiepopper
Zuletzt bearbeitet:
D
DIGITAL MIND
..
F
fraanck
..
Moin, hattest du das Problem für dich gelöst? Ich habe es mit SysEx Librarian (OSX) und dem AN1XEditor (Windows) probiert und bin bisher gescheitert etwas zu senden. Einen Dump empfangen mit Librarian hat funktioniert, das dann aber wieder an den AN1X zu senden ergab immer einen SysEs Fehler im AN1X. Mit unterschiedlichen Geschwindigkeiten und Pausen habe ich experimentiert - gleiches Ergebnis.
 
Zuletzt bearbeitet:
D
DIGITAL MIND
..
Noch nicht. Habe mir über eine Kleinanzeige ein anderes MIDI-Interface gekauft, das ist aber noch auf dem Postweg.
 
subsoniq
subsoniq
|||||
also midiman 2x4 mit midiox geht bei mir
kannste mit an1xedit nen singlesound rüberschicken/editieren?
midiloop sollte man vermeiden
 
D
DIGITAL MIND
..
Das "neue" Interface ist von MOTU, das sollte eigentlich was vernünftiges sein.
Das rüberschicken eines einzelnen Sounds hat nicht funktioniert, die Anzeige "receiving Dump" im Display geht nicht weg. Wenn ich dann mit plus oder minus den Speicherplatz wechsle, ist alles wie vorher.
 
D
DIGITAL MIND
..
Der umgekehrte Weg, also eine selbst erstellte Voice in den Editor übertragen, hat anscheinend funktioniert.
 
Summa
Summa
hate is always foolish…and love, is always wise...
Vom An1x angestoßen? Edit: Dann könnte es sein dass die Device ID nicht stimmt, das wird dem Editor egal sein, dem Synth aber nicht.
 
Zuletzt bearbeitet:
Cello
Cello
||||
Der Midiempfang ist meiner Erinnerung nach in diverse Pakete unterteilt damit Presets unabhängig von Sequencen ausgetauscht werden können. Wenn du auf Werkseinstellung zurücksetzten willst sollten zumindest alle Werkpresets inkl. Seq. wieder drin sein. Danach mit dump all alles rausspielen und sehen wie gross das Datenpaket ist. Dann hast du einen Vergleich mit dem Paket das du ursprünglich senden wolltest.
 
Summa
Summa
hate is always foolish…and love, is always wise...
Welche Windows Version? Hab' den Editor bisher nur unter XP und Vista laufen gehabt und im Moment auf keinem meiner aktuellen PCs installiert.
 
D
DIGITAL MIND
..
Ich habe Windows 11.
Das mit der Device-ID kann es eigentlich nicht sein, ich habe im Editor keine Möglichkeit, da was einzustellen, und der AN1x ist auf "all" eingestellt.
 
Zuletzt bearbeitet:
Tax-5
Tax-5
||||||||||
Diese Miditech Sachen sind der letzte Müll. Hab mir auch schon Zeug von denen geholt (und kenne Leute, die sich auch Interfaces gekauft haben) und war so enttäuscht.
Dachte erst es wären DOA oder Montagsgeräte, aber deren Produkte sind wirklich einfach nur Ramsch.

Das Problem bei dir ist auf jeden Fall das MIDI Interface. Versuch auch mal die Sounds via Bome SendSX an den AN1x zu senden.
Sysex im Sequencer ist auch immer so ein bisschen eine Glückssache.
Wichtig sind jedoch folgende (und eigentlich auch klare) Punkte:

-Midi Kanal ist immer 1 für Sysex
-Sysex muss vom Synth akzeptiert werden
-Memory Protect auf Off
-Gutes Interface und entsprechende Software verwenden.
 
subsoniq
subsoniq
|||||
Also wenn der editor ein request schickt und bekommt nen patch zurück is da nicht das interface fast ausgeschlossen?
Für mich wär dann die speicherbatterie eher wahrscheinlich
 
fanwander
fanwander
*****
-Midi Kanal ist immer 1 für Sysex
Sorry, aber SysEx kennt keinen MIDI-Kanal. SysEx läuft komplett außerhalb der MIDI-Standarddatenstruktur Kanal/Typ/Wert.

-Gutes Interface und entsprechende Software verwenden.
Üblicherweise ist nicht(!) das Interface oder die Übertragungssoftware relevant, sondern die Art wie der Rechner USB beschickt ist entscheidend.

SysEx-Implementierungen in Synths sind leider oft ziemlich abhängig vom Timing der Übertragung (das ist der eigentliche Fehler!). USB per se kennt aber kein vorgeschriebenes Timing. Wenn da der Treiber des Interfaces nicht massiv in die USB-Kommunikation des Rechners eingreift (und die ClassCompliant-Treiber tun das nicht), dann hängt das alles komplett vom "Goodwill" des Rechners und der USB-Konstellation ab. ZB eine Maus oder ähnliches am gleichen internen USB-Bus/Hub kann das ganze USB-Timing killen. Wenn ein Rechner zwei verschiedene USB-Ports hat (einen für USB3, einen für USB2), dann hängt man das Interface für die Sysex-Übertragung bitte immer an den einen Port und alles andere an den anderen Port.
 
MacroDX
MacroDX
Hat ein Bild mit Robotern wo aufm Mond rumlaufen
Üblicherweise ist nicht(!) das Interface oder die Übertragungssoftware relevant, sondern die Art wie der Rechner USB beschickt ist entscheidend.
Auch das ist natürlich nicht von der Hand zu weisen. Allerdings habe ich, wie oben schon beschrieben, gerade mit dem genannten Hersteller und SysEx keine guten Erfahrungen gemacht und diecRecherche dazu hat mich auch einiges an Zeit gekostet.
Aber im hier vorliegenden Fall könnte man ja mal mit MIDIOX prüfen, was da passiert. MIDI OUT mit MIDI IN verbinden, darauf achten, dass man mit MIDIOX keine Loopback Connection herstellt und dann den SysEx abschicken. Wenn in MIDIOX dann nicht das ankommt, was rausging, hat man einen Anhaltspunkt.
 
Jörg
Jörg
||||||||||||
Sorry, aber SysEx kennt keinen MIDI-Kanal. SysEx läuft komplett außerhalb der MIDI-Standarddatenstruktur Kanal/Typ/Wert.

Es gibt Geräte wo der Kanal tatsächlich übereinstimmen muss.
Ich glaube es liegt daran (korrigiere mich bitte ggf.), dass in diesen Fällen der Midi Kanal als Device ID in den Sysex Daten gespeichert ist.
Entspricht sicher nicht der Midi-Spezifikation, und ist natürlich doof, wenn man nicht weiß, welchen Kanal man beim Empfänger einstellen muss.
 
Miks
Miks
Mir will los...
Ein Problem mit vielen 'Billich-Dingern' (= 'El Cheapos') ist oft ein zu kleiner oder gar nicht vorhandener interner Puffer-Speicher - da SysEx-Daten gerne mal 'etwas umfangreicher' sind, werden diese dann leider nur unvollständig oder verstümmelt übertragen, was beim empfangenden Gerät selten gut ankommt...
 
fanwander
fanwander
*****
Es gibt Geräte wo der Kanal tatsächlich übereinstimmen muss.
Ich glaube es liegt daran (korrigiere mich bitte ggf.), dass in diesen Fällen der Midi Kanal als Device ID in den Sysex Daten gespeichert ist.
Entspricht sicher nicht der Midi-Spezifikation, und ist natürlich doof,
Naja, der MIDI-Spezifikation ist schnurz, wie sich das Gerät seine Device-ID bastelt. Hauptsache es hört auf eine.

Aber wo Du es jetzt sagst, erinnere ich mich auch wieder daran.
wenn man nicht weiß, welchen Kanal man beim Empfänger einstellen muss.
Jepp, das ist wirklich doof, wenn man die Daten nicht selbst erzeugt hat.
 
 


News

Oben