Diskettenlaufwerk beim Yamaha DX7iiFD defekt

Dieses Thema im Forum "Digital" wurde erstellt von crincy, 16. März 2014.

  1. crincy

    crincy -

    Hallo an alle,
    bei meinem DX7IIFD hat sich wohl das Diskettenlaufwerk verabschiedet. Es ließt auf einmal keine Disketten mehr. :roll:

    Weiß hier zufällig jemand, was man da als Ersatz nehmen kann.


    Hatte bei Google schonmals gesucht und mitbekommen , das es DD 720 KB Laufwerke mit D0 - Drive Select 0 sein muß.
    Kann man auch ein 1,44 MB mit Drive Drive Select 0 nehmen ??


    Besten dank schonmals im vorraus
     
  2. crincy

    crincy -

  3. crincy

    crincy -

    Hallo nochmals,

    habe also ein Teac HD Laufwerk auf DS0 umgelötet und eingebaut .....

    ABER: LED brennt durchgehend , Formatieren funzt, Diskette wechseln erkennt er nicht --> erst nach aus und einschalten ließt er die Diskette neu ein. :cry:

    außerdem läd er irgendwie nicht alle abgespeicherte Files / mal ja mal nicht. Irgendwie ist da noch was nicht klar.

    gruß chris
     
  4. microbug

    microbug |||

    Da stimmen irgendwelche Jumpereinstellungen nicht, offenbar wird der Diskettenwechsel nicht an den Synth weitergeleitet. Müßte nochmal im Servicemanual schauen, ob sich da was dazu findet.

    Ich glaube mal, daß ein neues Laufwerk garnicht nötig gewesen wäre, meistens sind einfach nur die Köpfe verdreckt und wenn man die mit einem Q-Tip säubert, geht alles wieder.

    Das Laufwerk ist MSX-Standard und hat auch die Jumpereinstellungen entsprechend, müßte man im Netz nachlesen können.

    Idealerweise nimmt man für sowas DD-Laufwerke vom Atari ST oder baut gleich den HxC-Floppyemulaor rein.
     
  5. microbug

    microbug |||

    Achja, das alte Problem, jetzt weiß ichs wieder. Pin 2 des Steckers ist beim Yamaha mit dem Diskchange-Signal belegt, bei einem HD-Laufwerk aber wird an diesem Pin signalisiert, daß eine HD-Diskette eingelegt wurde. Dieses Signal liegt durch einen Mikroschalter dauerhaft an, während Disk Change iirc ein Impulssignal ist, was nur kurz anliegt, das müßte ich aber nochmal in meinen alten Unterlagen nachschauen.

    Mit einem HD-Laufwerk gibts daher also ein Grundsatzproblem, außer das Laufwerk läßt sich an dieser Stelle umjumpern, was bei früheren Laufwerken durchaus möglich war. Dazu mußte man aber dem Laufwerk auch sagen, daß es sich wie ein DD verhalten soll, ebenfalls per Jumper, denn HD-Laufwerke haben im HD-Modus eine andere Umdrehungsgeschwindigkeit.

    Außerdem bin ich mir gerade ziemlich sicher, daß der DX7II auch ein Ready-Signal haben will, und das liefern die wenigsten neueren Laufwerke.

    Ich muß mir den Schaltplan anschauen, dann weiß ich mehr.

    Hast Du eine Typbezeichnung des HD-Laufwerks?
     
  6. crincy

    crincy -

    hi microbug,
    danke erstmal für deine ausfühlichen Antworten, das macht das ganze schon ein wenig klarer.

    Das alte Laufwerk im DX7 funktionierte beim Kauf nicht.
    -> Komischerweise ging es zwischendurch und nun wieder das gleiche
    -> findet wohl spur 0 nicht "rödelt" und macht err. -> formatieren geht noch bis er spur 0 sucht dann wieder err.

    Vielleicht eventl doch mal sauber machen ?

    Das mit dem HD Laufwerk werde ich heute abend nachschauen -> ist ein TEAC soweit ich weiß



    gruß chris
     
  7. mink99

    mink99 aktiviert

    Meist du das floppy Laufwerk aus nem akai s2k tuts hier ?
     
  8. microbug

    microbug |||

    Das Floppy aus dem s2k ist ebenfalls ein HD, nutzt also nix.

    @crincy: guck bitte mal nach beiden Bezeichnungen, also der vom Teac und nach der des im DX7 eingebauten Laufwerks. Die Bezeichnungen stehen entweder oben auf dem Laufwerk oder hinten neben dem Anschlußstecker.

    Sollte das Teac ein FD-235HF sein, bitte auch mit der Zahl nach dem HF, denn davon gibts etliche Versionen mit unterschiedlichen Jumpersettings.

    So ein FD-235HF hat prinzipiell schonmal das Problem, daß es kein RDY-Signal mehr liefert und Diskchange auf Pin 34 sitzt statt auf Pin 2, wo der Yamaha ihn haben will (MSX-Belegung). Es gibt aber offenbar Varianten des Laufwerks, die das können, so muß zB ein solches Teac für den Einsatz im Roland MT-80 umgejumpert werden.

    Spur 0 nicht finden könnte je nach Laufwerk auf eine verdreckte Lichtschranke hindeuten, manche haben da aber auch Mikroschalter (selten). Ich würde das alte Laufwerk erstmal säubern, aber vorsichtig. Oft muß man das Blechkleid entfernen, um an die Einzelteile ranzukommen. Der Kopfschlitten ist nicht per Hand verschiebbar, aber die Bauteile sind alle sehr filigran, also vorsichtig damit umgehen. Säubern der Köpfe mit Wattestäbchen und Isopropanol (nix Anderes nehmen!), ebenfalls vorsichtig und dabei den Kopfträger nicht verbiegen oder gar schnappen lassen. Manchmal reicht es schon, die Frontblende abzunehmen, dann kann man die Köpfe von vorn säubern.

    Die Mechanik der Laufwerke ist so gebaut, daß erst ein Einschieben der Diskette bis nach hinten die Köpfe auf die Magnetscheibe parkt, ohne Diskette drin sind sie abgehoben und gut zugänglich, dadurch aber auch leider anfällig für Staub. Früher gabs für solche Zwecke immer sogenannte Schutzdisketten, das ist aber lange her ...

    Die Lichtschranke für das Erkennen der Spur 0 findest Du auf der Platine am hinteren Ende des Kopfschlittens, dieser hat dazu ein Plastikteil dran, der die Lichtschranke unterbricht. Oft sitzt diese auch auf der Unterseite, dazu muß dann aber wirklich das Blechkleid abgemacht werden.

    Wenn das Laufwerk nach dem Säubern immer noch nicht tut, ist es wahrscheinlich dejustiert, und das bekommt man nur mit Spezialdiskette und einem Oszilloskop wieder hin.
     
  9. crincy

    crincy -

    Hallo microbug,

    anbei die gewünschten Daten

    1. Teac FD-235HF -D291 /BT1 SMT JS ( Hat eine Platine von Soni)

    2. DX orig. Matsushita DDF3-1

    noch ne Möglichkeit, habe noch -> ALPS DF354H090F
    oder kann bei Ebay noch ein DD Laufwerk ersteigen , welches D0 gejumpert ist und in einem Amiga 2000 lief ??

    http://www.ebay.de/itm/321353038848?ssP ... 1423.l2649

    nochmals besten Dank für deine hilfe

    gruß Chris
     
  10. microbug

    microbug |||

    Ok, da muß ich schauen.

    Das Alps könnte gehen, muß aber auch umgebaut werden. Dazu hier etwas, zwar für den Amiga, der will die gleiche Signalbelegung haben wie der DX7II:

    http://www.pitsch.de/stuff/amiga/floppy.htm

    Dort wird auch das Alps genannt.

    Ein Amiga-Laufwerk wäre sogar ideal, wenn ich das richtig sehe, denn das hat die Signale an den passenden Stellen, also RDY auf 34 und DCH auf Pin 2.
     
  11. crincy

    crincy -

    wenns am einfachsten ist so werde ich es mal versuchen zu bekommen -> mal sehen

    gruß chris
     
  12. microbug

    microbug |||

    Zu Deinem Teac finde ich leider gerade keine Belegung der Lötjumper.

    Wenn die aber beschriftet sind, sollte sich die Anleitung auf der Amigaseite übertragen lassen.

    Es muß auf jeden Fall RDY auf PIN34 und DCH auf Pin 2 gelegt werden, außerdem muß das Laufwerk in den DD-Modus mit 300U/min versetzt werden (bei Teac heißt der oft 1M-Modus).
     
  13. crincy

    crincy -

    Hallo

    habe mal auf das " Amiga" Laufwerk geboten -> abwarten

    Aber wegen dem Tatendrang und der Neugier obs geht werde ich mir mal das ALPS vornehmen und nach beschriebener Anleitung umbauen,
    entweder heute abend oder morgen. :nihao:
    ->>hoffe, ich spiele mir nicht noch den Floppycontroller vom DX7 hinüber :floet:

    ich melde mich wegen dem ergebniss.

    gruß chris
     
  14. crincy

    crincy -

    moin moin

    Also , was soll ich sagen --->>> :cry:

    ich habe beide Laufwerke umgebaut

    das ALPS nach diesem Plan:
    http://www.pitsch.de/stuff/amiga/floppy.htm#A3

    das Teac passte hiernach:
    http://www.pitsch.de/stuff/amiga/SONY%20MPF920.pdf

    aber, endweder habe ich was falsch gemacht oder beide Laufwerke wollen nicht mehr.
    Das einzige , die LED brennt dauernd --> sonst tut sich nichts mehr ->>> :heul:

    beim teac habe ich dann mal das rechte Kabel vom SH1 --> http://www.pitsch.de/stuff/amiga/obr.03.jpg abgemacht
    nun verhält es sich wieder wie oben beschrieben .
    irgendwas gefällt dem DX7 nicht an dieser Lösung

    habe noch dashier gefunden, das zu meinem problem haargenau passt-> leider fehlt wie meistens die Auflösung

    http://www.computerbase.de/forum/showth ... p?t=574428



    gruß chris
     
  15. microbug

    microbug |||

    Der ist da im falschen Forum, das sind PC-User. Zu solchen Laufwerken hätte man in einem MSX-Forum mehr Erfolg, denn da steckt ein MSX-Laufwerk drin und muß genau so angeschlossen werden.

    Immerhin kann man diese Amiga-Laufwerke sogar neu kaufen.

    Muß da selbst nochmal schauen, wird mich auch treffen, wenn ich demnächst meinen DX7II verkaufen will.
     
  16. crincy

    crincy -

    mit den Umbauten komme ich nu nicht weiter, oder hast du da noch eine Idea ?

    --->werde mal auf das Amiga Laufwerk warten und dann sehen wir weiter

    gru0 chris
     
  17. crincy

    crincy -

    scheint aber trotzdem nicht gelaufen zu sein, es gibt ja nur zwei möglichkeiten -> den Netzstecker mal aussenvor gelassen !

    gruß chris
     
  18. crincy

    crincy -

    hi microbug,

    welchen standart hat denn der DX7 II Floppyinterface , ich lese beim Atari immer "Standard Shugart Interface" -> passt das denn ??
    --------------------------------------------------------
    und hier habe ich dann das noch gefunden

    http://www.ebay.de/itm/720KB-3-5-USB-SS ... 1089434644


    edit: beim "alten" Laufwerk hat sich der Schrittmotor für den Schlitten verabschiedet , bewgt sich keinen meter mehr -> :cry:

    gruß chris
     
  19. microbug

    microbug |||

    Schrieb ich bereits: Shugartbus, aber mit MSX-Belegung. MSX war ein in Japan erdachter Standard für Heimcomputersysteme, der sich aber nicht durchsetzen konnte, siehe Wikipedia.

    Der Motor für den Schlitten geht normal selten kaputt, eher mal die Ansteuerung durch Überlastung.
     
  20. crincy

    crincy -

    Habe heute nochmals ein Atari st 1024 DD Laufwerk drangehabt -> aber ebenso erkennt dieses nicht den Diskettenwechsel
    und die LED brennt auch dauernd.

    wo ist da noch was zu machen ? -> ich komm hier einfach nicht weiter !

    Formatieren Save u. Load bis jetzt einwandfrei

    PS: Amigalaufwerk ist auch schon unterwegs........
     
  21. Rupertt

    Rupertt aktiviert

    Wen die led dauerleuchtet ist oft das Flachbandkabel falschrum dran.
     
  22. crincy

    crincy -


    Danke Rupertt für den hinweiß ,
    leider ist das hier nicht der Fall -> wäre dann auch zu einfach gewesen ..

    hat warscheinlich nochwas hiermit zutun "" Shugartbus, aber mit MSX-Belegung""

    aber da finde ich keine Belegung oder ich bin zu blöd dazu :?

    gruß chis
     
  23. microbug

    microbug |||

    Die Belegung hatte ich doch oben schon gepostet?

    Ich guck mal ins Servicemanual.

    Bitte bei Laufwerken immer die Bezeichnung angeben, "Atari-Lauwerk" nützt nichts, da beim Atari im Laufe der Jahr mindestens 10 verschiene Laufwerkstypen zum Einsatz kamen.

    Mit der Bezeichnung kannst Du nämlich auch selbst nach einer Jumperbelegung googlen :)
     
  24. microbug

    microbug |||

    So, ich glaub ich hab das Problem entdeckt:

    Auf Pin 1 des Floppyanschlusses liegt ein Signal, daß sich DCR nennt und lowaktiv ist. Dort hat aber normal ein Signal nichts zu suchen, denn alle ungeraden Pins des Shugartbusses liegen auf Masse.

    Der Floppycontroller ist der u.A. auch beim Atari eingesetzte WD1772, allerdings ist das DCR-Signal keines von Diesem, sondern das kommt aus einem Port des Yamaha, ebenso wie die Driveselects. Der DX7IIFD ist übrigens für 2 Laufwerke vorgesehen, denn es sind sowohl DS0 als auch DS1 an einen Port angechlossen - ob DS1 auch angesteuert wird, kann ich nicht sagen, das müßte man probieren.

    Die Zeichnung auf der Laufwerkseite weist leider auch einen Fehler in der Bezeichnung auf, was es schwerer macht, da sind jemandem wohl die Pins verrutscht.

    Pin 34 (ready) scheint nicht angeschlossen zu sein.

    Ich poste mal einen Bildauschnitt:


    Es gibt eine Anleitung im Netz, mit der man einen DX7IID zu einem DX7IIFD aufrüsten kann, indem man die fehlenden Bauteile nachbestückt und die Firnware (EPROM) austauscht:

    http://www.cloudswalker.com/files/upgradedx7ii.pdf

    Den Herren würde ich mal anschreiben, denn der hat offenbar ein normales Laufwerk drangeklemmt und scheint sich mit solchen Basteleien auszukennen.
     

    Anhänge:

  25. crincy

    crincy -

  26. crincy

    crincy -

    Hallo , wollte mal einen ( zwischenstand durchgeben) :sad:(

    habe mir von dieser Seite mal ein Disklaufwerk kommen lassen
    http://floppy.shugart.free.fr/page.php? ... /index.htm

    leider funktionierte dieses nicht , noch keine Ahnung woran es liegen könnte ( macht keinen muks)-> Eventuell am diskchain auf pin 2
    Er wird mir noch ein neues zusenden.

    Das Amiga Laufwerk habe ich durchs jumpern soweit zum Laufen bekommen ( LED geht aus, Load, Save, Format ok) aber wie bei allen kein diskchain.
    Diskchain jumper auf 34 -> Laufwerk läuft aber kein Diskettenwechsel
    Diskchain jumper auf 2 -> Laufwerk geht nicht mehr an -> keine LED Motor dreht nicht ( DX7 macht beim einlesen error )

    werde noch kirre -> aber es geht erstmal zur not.

    PS: @ microbug , hast du zufällig noch einen dx7IIFD bei dir rumstehen ? Hatte sowas beim forum " durchlesen" gelesen . -> :))

    gruß chris
     
  27. microbug

    microbug |||

    Ich hab meinen DX7IIFD noch hier und muß den auch demnächst nochmal zwecks Verkauf durchchecken, incl. Floppylaufwerk.

    Das Signal heißt "Diskchange", mit Chain (Kette) hat das nichts zu tun.

    Ich hätte da wahrscheinlich längst den HxC-Floppyemulator reingebaut, statt mich mit den ollen Laufwerken und den blöden unterschiedlichen Belegungen rumzuärgern. Diese Abweichungen haben mich früher schon reichlich Nerven gekostet.
     
  28. Hallo

    ich warne auch davor, über USA ein Refurbished Disk-Laufwerk zu kaufen. Nannte sich Route 66 Studios, grottenschlecht, teuer, war als Geschenk deklariert, das Ganze ist natürlich aufgeflogen, so mußte ich hier beim Zoll nachzahlen, Wechselkurs war damals recht hoch. Das Innenleben ist völlig schief - die Disketten passen nicht hinein

    Angeblich gibt es HxC Laufwerke, wobei man die Jumper noch stecken kann f. div. Geräte

    2 HD kann man abkleben mit lichtundurchlässigem Gaffa (Lichtschranke) für ältere 2DD Laufwerke
     
  29. crincy

    crincy -

    sah mir doch gleich irgendwie falsch aus :selfhammer: -> funktioniert warscheinlich deswegen nicht ;-)

    gruß chris
     
  30. crincy

    crincy -


    Habe ich auch schon ins Auge gefasst, bin aber noch nicht sicher ob da nicht auch die gleichen probleme auftauchen können ??????
    muß mich da noch ein wenig reinlesen.

    eben deswegen, muß warscheinlich auch wieder umgeändert werden ............... :? :?

    Wäre eine obercool Sache , wenn sowas am DX7 laufen würde !!

    gruß chris
     

Diese Seite empfehlen