Ableton Midi Transport start Offset Problem

verstaerker
verstaerker
*****
Cool danke für die Analyse :) Ich hätte mir gewünscht dass man im Sync Standard noch einen Modus hätte der ohne das zeitkrittische aufeinander folgen von den CLock-Bytes auskommt und dafür jeweils autarke genomte interne Clocks verwendet. Dann hätte man nur die latenz des Start-Bytes als Problem.

Praktisch gesehen finde ich die Lösung die Live suggeriert (wenn sie denn funktionieren würde) die Beste. Also es sieht ejedenfalls so aus als ob das die Intention von Ableton wäre im Hinblick auf Midi Sync.
1) Man schaut in die Timeline wie der Versatz in ms ist
2) trägt den Wert ein in den presfs
3) Live oder die jeweilige DAW startet um diesen Offset die Midiclock früher und alles andere (DAW itmeline, Recording Punch In dies-das) folgt dann nach dem Offset "pünktliuch"

es funktioniert ja, man muss nur rausfinden warum es das bei dir nicht tut... ich hab das hier mit diversen Geräten und Midiinterfaces ausprobiert. Alle reagieren genau wie man sich das vorstellt.

Hast du noch andere Synths mit denen man das testen könnte?

Ich würde dir auch raten mal den Ableton Support zu kontaktieren.
 
P
ppp
....
Sorry lange Rede @ppp wie würdest du es machen mit dem einen Takt vorlauf? Aktuell startet die clock ja direkt mit..

Die Midi Clock startet immer sobald du Live startest. Das kannst du nicht ändern.

Du suchst dir die Audio Latenz vom M:S so raus wie dus beschrieben hast und stellst entsprechend den negativen Midi Clock Delay ein.

Dann machst du ein leeres Pattern am M:S

Das Internet sagt: "MIDI program change messages 0–95 selects pattern 1–96 (A01–F16) on the Model:Samples."
Man kann beim M:S die Patterns also via Program Change wechseln. Also zwei Clips anlegen:
Clip 1: Program Change Nr des leeren Patterns
Clip 2: Program Change Nr des aufzunehmenden Patterns
Du startest Clip 1 und einen Takt später wechselst du auf Clip 2 - manuell oder via Follow Action (achte darauf, dass die Quantisierungen auf beiden Geräten zueinander passen. zB beide auf "1 bar")
 
verstaerker
verstaerker
*****
Die Midi Clock startet immer sobald du Live startest. Das kannst du nicht ändern.

Du suchst dir die Audio Latenz vom M:S so raus wie dus beschrieben hast und stellst entsprechend den negativen Midi Clock Delay ein.

Dann machst du ein leeres Pattern am M:S

Das Internet sagt: "MIDI program change messages 0–95 selects pattern 1–96 (A01–F16) on the Model:Samples."
Man kann beim M:S die Patterns also via Program Change wechseln. Also zwei Clips anlegen:
Clip 1: Program Change Nr des leeren Patterns
Clip 2: Program Change Nr des aufzunehmenden Patterns
Du startest Clip 1 und einen Takt später wechselst du auf Clip 2 - manuell oder via Follow Action (achte darauf, dass die Quantisierungen auf beiden Geräten zueinander passen. zB beide auf "1 bar")
und was sollte das ändern? Es klappt doch hier auch ohne solche Spielchen. Bei nem Program change wird doch keine Timing verändert.
Es sei denn der M:S hat irgendeine Besonderheit bei der Midiclock-verarbeitung . Den hab ich aber nicht hier, nur 5 andere Elektron Geräte mit denen das tadellos klappt.

Sehr Interessant:

ohne clock offset
1638144495024.png

mit -20 ms offset
1638144563792.png

mit +20ms offset
1638144625304.png

das kann ich wiederholen, jedes Mal mit negativem offset verzögert Live die Ausgabe des ersten clock-Singals nach dem Start etwas.. ich kann leider


hier nochmal - jetzt starte ich Live mit einer Midinote
clockoffset -300ms
1638144893046.png

clockoffset 0
1638144974522.png

clockoffset -10ms
1638145078096.png

clockoffset -10ms, aber audio-Latenz auf 512 samples erhöht
1638145169810.png

clockoffset -5ms, audio Latenz 512 samples
1638145249547.png


es scheint es gibt einen Zusammenhang zwischen Audio-Latenz und den Möglichkeiten der negativen Midilatenz. Vielleicht das mal noch testen @systemexklusiv
 
P
ppp
....
Ich verstehe @systemexklusiv so, daß nur der erste Beat das Problem ist, da bei dem der negative Delay noch nicht angewendet wird. Das bestätigt sich für mich auch, nachdem ichs mit meiner TR-8 getestet hab.
Ich hab die Audio Clips in der Session View aufgenommen und zur Veranschaulichng im Arrangement untereinandergestellt.
Oben: der erste Beat ist nicht Negativ-Delay-korrigiert
Unten: der erste Beat passt bereits, weil die Midi Clock bereits einen Takt vorher gestartet wurde. (Ich mußte manuell umschalten, weil die Tr-8 kein Pattern change via Program Change hat).
Screenshot 2021-11-29 at 08.53.20.png

Noch ein Beispiel mit den selben Live Einstellungen mit kurzen 16tel kicks: Erste 16tel ist nicht korrigiert. Bereits aber der zweiten 16tel passt alles.

Screenshot 2021-11-29 at 09.04.00.png
 
verstaerker
verstaerker
*****
das mit dem ersten beat, das ist eben so ...
man startet Ableton einfach vorher und drückt dann auf Aufnahme oder schneidet den ersten Beat eben weg

oder nimmt ne E-RM Multiclock. die macht das automatisch

Wenn ich die videos so anschaue, sieht es doch sehr danach aus das es um den ersten beat geht. Das hab ich völlig übersehen.
 
Zuletzt bearbeitet:
systemexklusiv
systemexklusiv
..
@verstaerker und @ppp mega! Vielen Danke für die Analysen. Ich war etwas out of order die letzten Tage, werde mich dran setzen folgendes checken:
a) Zusammenhang zwischen Audio-Latenz und den Möglichkeiten der negativen Midilatenz
b) "Der erste Beat ist das Problem"
Ich mach mal ne Tabelle und vergleiche PC/Mac und vielleicht Clock vom A4 mk II vs M:S.

@verstaerker Interessant, dass der eingestellte offset sich nicht zu in den gemessenen Daten so richtig wieder findet. Man sieht zwar (auch nicht immer) das Live jedes Mal mit negativem offset die Ausgabe des ersten clock-Singals nach dem Start heraus zögert, aber zB bei "-20 ms offset" ist der Offset nur 1 ms, also wenn man Clock - Start rechnet. Das könnte dann mit dem Buffer/Latenz-Wert korrelieren vielleicht?

@ppp ich glaube ich habe mich so auf die "1" fixiert, dass ich gar nicht die folgenden Takte angeschaut habe .. ich teste es bei mir und halte euch auf den Laufenden!

Geil danke euch!

Offtopic: Spielt jemand live von euch mit Ableton gesequenzten Audio/Midi und den Elektron-Kisten. Ich benutzte Live hauptsächlich als einen Komfortablen Looper für Gitarre und für Send-Fx. LOL und leider auch als Clock Master :guckstdu:. Interessanter Weise hat der Octatrack nicht das Problem. Mit dem OT sind takes von der M:S tight. Leider leider stehe ich etwas mit den Pickup-Machines auf Kriegsfuss
 
dubsetter
dubsetter
|||||
moin,

ich hatte bei früheren versionen (live 8 ) ne mpc mit dranhängen..
lief ohne "schwere" hörbare probleme im sync zu ableton
(live)

(andersrum ging gar nicht)

später dann hatte ich nur noch nen evolver dranhängen dessen eigener sequencer mitlief.
da musste ich etwas justieren am offset, da die die sequenzen etwas "off " waren.

hängt evlt. auch mit dem verwendeten midi interface zusammen,
bei dem alten rme multiface gabs kaum versatz.


das ist allerdings ein anderes szenario, als zurück in ableton aufzunehmen.
ich habe ableton immer nur als clip /pattern schleuder benutzt für live.


aber wenn "nur " der erste takt off ist, dann kann man ja hinterher
einfach am anfang was wegschneiden. :denk:
 
Zuletzt bearbeitet:
systemexklusiv
systemexklusiv
..
@ppp Ich mache momentan ein Tabelle und vorweg, am PC mit RME Fireface USB, 256kb Buffer, 12,9 OverallLatency, ist es so dass es sich einpendelt nach ca 1 Take um die anvisierte "1" mit einer Varianz von ca. 0.5-1ms. In meinem Fall war bei diesem Test der Offest von den 1sen ab dem 2. Takt ca. 4ms und die habe ich eingetragen mit -4 ms bei MidiCLockDelayCompansation. Mhh..

@verstaerker Wenn ich die Buffersize auf 2048 erhöhe und sonst die Parameter unverändert lasse, dann ist die Aufnahme etwas später aber im Frame Bereich. Diese Tests sind mit einem PC, Midi over USB an den Model Samples.

Sorry ich dachte ich poste mal ein Zwischenergebnis.. muss das am Mac nochmal checken.

@dubsetter In meinen Fall habe ich 2 Probleme,
1) Aufnehmen von Patterns des M:S, so dass ich hinterher die einzelnen Tracks layern kann. Wenn alle einen komischen Offset habe bekomme ich sie in Ableton nicht mehr so geschnitten, dass sie den groove noch so wieder geben. besonders bei unterschiedlichen Shuffel und rasterfernen Trigger sind leichte Unterschiede im millis liegende schon so gravierend dass es nicht mehr so anfühlt wie vorher
2) Wenn ich live looping zu ner Elektron Kiste mache und zB den M:S absample damit ich ihn am Rechner live verändern möchte und vielleicht das Pattern im M:S wechseln und dann mir der agesampelten Version layern möchte, dann sollte es möglichst genau sein. Das nur ein Beispiel.

Allgmein ist es so wie @ppp in einem Post oben dargestellt hat, nach dem Start holpern die Tocks ein bissl und das höre zB auch wenn ich eine 16tel hh in einem pattern starte. Man hört richtig wie die ersten schläge zu schnell sind und dann versuchen auf zu holen.

Leider manchmel klappt auch das Aufholen nicht mehr.. arg Midiclock :mauer:
 
verstaerker
verstaerker
*****
Leider manchmel klappt auch das Aufholen nicht mehr.. arg Midiclock :mauer:
das ist doch aber wieder ein anderes Problem

Problem 1 ... der erste Beat hat nen offset
Problem 2 ... Midiclock ist holprig

Problem 1 würde ich als gelöst ansehen. Weil das ist eben so.
Problem 2 passiert das auch wenn du den M:S via USB verbindest und er clock ausschließlich über USB bekommt? Ich habs hier mit dem DT und dem M:C probiert .. beide absolut tight. Ich glaube das KÖNNTE ein Problem der Midiinterfaces sein

Wenn du unbedingt die einzelnen Spuren in der DAW layern willst, wäre es da nicht praktischer nen DT via OB zu benutzen?
 
Zuletzt bearbeitet:
systemexklusiv
systemexklusiv
..
das ist doch aber wieder ein anderes Problem

Problem 1 ... der erste Beat hat nen offset
Problem 2 ... Midiclock ist holprig

Problem 1 würde ich als gelöst ansehen. Weil das ist eben so.
Problem 2 passiert das auch wenn du den M:S via USB verbindest und er clock ausschließlich über USB bekommt? Ich habs hier mit dem DT und dem M:C probiert .. beide absolut tight. Ich glaube das KÖNNTE ein Problem der Midiinterfaces sein

Wenn du unbedingt die einzelnen Spuren in der DAW layern willst, wäre es da nicht praktischer nen DT via OB zu benutzen?
ad 1) ja OK, das wäre verschmerzbar da man die clock ja nicht soo häufig restartetund zum Absamplenauch etwas unpraktisch da man dann immer die doppelte Patternlänge aufnehmen muss pro Layer
ad 2) Direkt via USB. Bei mir ist es so dass ich in Ableton und beim M:S transport stop mache. Dann starte ich den Clock Master (live) dann holpert es los und fängt sich. Manchmal wenn ich oft Stop/Start mache, dann fängt es sich nicht mehr. Es läuft auf keinen Fall so dass ich sagen würde "tight"

Bei Dem DT, AR, A4 ist das alles kein Problem mit dem Layern da ich alles enzeoln aber gleichzeit recorde. Beim OT und auch M:S ist blöd da weniger Ausgänge als Tracks.

Abgesehen von dem Recorden von Layern - Problem ist es so, dass ich mich gerne mit Ableton loope und schneide live die Summe vom M:S mit in einen Audioclip um diesen in die Performance ein zu bauen (oder auch nur um im Hintergrund ein neues Pattern zu Suchen ), dass eben dieser Clip einen Versatz hat. Also echt leider daneben liegt.
 
verstaerker
verstaerker
*****
Abgesehen von dem Recorden von Layern - Problem ist es so, dass ich mich gerne mit Ableton loope und schneide live die Summe vom M:S mit in einen Audioclip um diesen in die Performance ein zu bauen (oder auch nur um im Hintergrund ein neues Pattern zu Suchen ), dass eben dieser Clip einen Versatz hat. Also echt leider daneben liegt.
ich glaub ich verstehe deine Arbeitsweise nicht. Wieso ist das denn ein Problem? (also ich gehe davon aus das nur der erste Beat n Versatz hat)

ich starte hier irgendwann die Midiclock, dann tuckern die Maschinen allerspätestens nach dem ersten Takt sauber ... ab da drücktste Aufnahme in den Slots und erhälst so saubere loops. Dann Variation am M:S bauen, dann wieder kurz Aufnahme drücken für für nächsten loop usw und so fort

Wo genau entsteht das Problem?

Also wenn die clock natürlich holpert geht das nicht. Aber das sollte sich lösen lassen.
 
verstaerker
verstaerker
*****
das ist echt schräg... länger als einen Takt darf das auf keinen Fall dauern
ich mach mal Werbung
Multi_multiclock_750_397.png

weil gutes Produkt und unterstützenswerte kleine Firma aus D - ich hab gleich 2 davon
 
einseinsnull
einseinsnull
[nur noch musik]
Eigentlich müsste Live seinen interne Aktivität verspätet starten. Tut es aber nicht.

dabei könnte es so einfach sein: man muss einfach nur "start" anders behandeln, als die daten, die 70ms nach "start" kommen.

ich persönlich halte kurze latenzen nicht für eine supertolle problemlösung.

denn auch kurze muss man für die ein oder anwendung kompensieren, und auch das geht nur, wenn ich im setup keine "loops" habe sondern alle geräte, die irgendwie miteinander verbunden sind, in einer art graphen miteinander verbunden sind.

so etwas wie "mit dem gleichen keyboard virtuelle instrument und hardware abwechelnd anspielen" oder das einfügen einer DAW in ein inline mischpult sind auch mit sehr kurzen latenzen immer nur ein kompromiss, und tauchen probleme damit auf, checkt man erst mal gar niht, was man jetzt machen kann und wie dabei das audio und das midi zusammenhängen.

ich habe mich inzwischen daran gewöhnt, u.a. auch autonome computerbasierte klangerzeuger und effekte zu benutzen, und dann kann ich die eben immer nur so benutzen, dass ich schon die steuerdaten der instrumente mit predelay versehe. würde ich eine klassische DAW benutzen, was ich nicht tue, müsste man dann noch die audiospuren mitverzögern, und dann wird es schon sehr, sehr unübersichtlich.

und wer kennt es nicht, dass man so wie in diesem thread schon mit dem bloßen "syncen" von nur 2 geräten an den rande des wahnsinns kommt, weil irgendwas nicht besonders toll implementiert, undokumentiert ist oder man selbst etwas falsch macht.
 
Zuletzt bearbeitet:
einseinsnull
einseinsnull
[nur noch musik]
Das bestätigt sich für mich auch, nachdem ichs mit meiner TR-8 getestet hab.

sofern du diese bilder nicht selbst gephotoshoppt hast, scheint alles so zu funktionieren, wie es soll.

die verzögerung des ersten dingsda ist nicht zu vermeiden - außer du beginnst jedes projekt mit einem leeren takt. (habe ich persönlich niemals anders gemacht, egal mit welcher hard- oder software.)
 
verstaerker
verstaerker
*****
die verzögerung des ersten dingsda ist nicht zu vermeiden
ja, es ist eben so ... ich hatte das schon so verinnerlicht, das ich das schon gar nicht mehr wusste

also zum einem weil ich die Multiclock benutze und zum anderen , weil ich immer die clock schon ewig laufen lasse bis ich mal auf Aufnahme drücke
 
fairplay
fairplay
|||||||
…nein, also: ja - Du hast ja recht…nur hat mich die Erlangung dieser Erkenntnis damals einige graue Haare gekostet…und hier war es jetzt so trocken präsentiert - da blieb nur Lachen…
 
systemexklusiv
systemexklusiv
..
ich glaub ich verstehe deine Arbeitsweise nicht. Wieso ist das denn ein Problem? (also ich gehe davon aus das nur der erste Beat n Versatz hat)

ich starte hier irgendwann die Midiclock, dann tuckern die Maschinen allerspätestens nach dem ersten Takt sauber ... ab da drücktste Aufnahme in den Slots und erhälst so saubere loops. Dann Variation am M:S bauen, dann wieder kurz Aufnahme drücken für für nächsten loop usw und so fort

Wo genau entsteht das Problem?
Bzgl. Aufnahme: Also es ist kein Problem mehr seitdem ich akzptiere dass der erste Takt schrott ist. Ein kleines Problem ist, dass ich so die doppelte Pattern-Länge aufnehmen muss um dann den ersten Durchlauf wegen versemmelter "1" wegschmeißen muss. Sonst ist es OK.

Bei Geräten mit Einzelausgängen oder Overbridge wäre es nicht so schlimm, da man dann ja den gleichen Offset über alle Spuren hat. Bei M:S der 6 Tracks hat aber man nur 2 gleichzeitig ohne Stereo Effekte absamplen kann ist eine konsistente "1" wichtig da sonst beim zusammenbauen hinterher die Layer nicht mehr so sind wie sie mal waren in der Kiste. Aber für dieses Problem habe ich dank dir und @ppp nun verstanden dass es nur der erste Takt ist. Habe mich einfach zu sehr auf die erste "1" konzentriert.

Bzgl Live-Looping mit Ableton gesync'ed zu outboard-Sequencern: Aktuell geht es gut aber es ist nicht richtig deterministisch. Hier wäre die ERM Multiclock vielleicht eine gute lösung, da ich dann nur die Clock vom M:S retarten kann zur nächsten 1 von, in meinem Fall, der Live und dabei nicht alle Sequencer stoppe.
naja es gibt keine Lösung dafür. Entweder ärgert man sich bis zum Sangt-Nimmerleinstag darüber oder lebt eben damit
Haha das stimmt aber danke um mal eine Übersicht zu bekommen wie es bei Euch aka anderen läuft. Dachte ich höre mich um bevor ich vielleicht arbeit mache die dann für die Tonne ist.
 
systemexklusiv
systemexklusiv
..
Also danke euch allen!!! Ihr habt mir Gewissheit gegeben dass ich einen allg. partizipierten Midi-Sync-Stand habe mit allen "features" included yay :selfhammer:
 
 


News

Oben